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SHIPCONSTRUCTOR LICENSE AGREEMENT

BEFORE PROCEEDING WITH THE INSTALLATION, YOU MUST ACCEPT THE TERMS OF THIS 
AGREEMENT. INDICATE YOUR ACCEPTANCE OR REJECTION OF THIS AGREEMENT BY CLICKING ON THE 
APPROPRIATE BUTTON. IF YOU CLICK ON “REJECT,” INSTALLATION WILL ABORT.

1. License Grant.  ShipConstructor Software Inc., #304 – 3960 Quadra Street, 
Victoria, B.C. Canada, V8X 4A3 (“SSI”) grants to the person accepting this 
Agreement (the “Licensee”) a non-exclusive, non-transferable right to use (the 
“License”) in object code form those program modules, application programming 
interface (“API”), any other materials provided by SSI under this Agreement, and all 
upgrades, revisions, fixes, updates or enhancements to any of the foregoing 
(“Licensed Materials”) specified in the Licensee’s purchase order or request 
(“Invoice) solely on the software and hardware listed in the Licensed Materials 
manual (“System Configuration”).  

2. Academic Institutions/Trial Versions.

A. In the event that the Licensee qualifies as an academic institution user in 
accordance with SSI’s specifications (an “Academic Licensee”), the Academic 
Licensee and its faculty, employees and students may use the Licensed Materials 
for the singular purpose of either teaching, training users or undertaking 
research provided that the Licensed Materials, and all copies of the Licensed 
Materials, remain at all times at the Academic Licensee’s premises and the 
Licensed Materials are used for no other purpose than that set forth above. The 
above restrictions are in addition to the restrictions on use set out in Section 5 
below.

B. In the event that the Licensee receives a trial version of the Licensed Materials 
for evaluation purposes, the terms and conditions of this Agreement, excluding 
Sections 15-19, shall continue to apply subject to the following provisions:

(a)    the License pursuant to Section 1 above shall terminate at the end of 
the specified trial period;

(b)    the Licensee shall return the Hardware Key to SSI immediately upon 
expiry of the specified trial period and in any event within 28 days of 
the expiry of the specified trial period;

(c)    in the event that the Licensee does not return the Hardware Key in 
accordance with Section 2B.(b) above, SSI shall be entitled to invoice 
the Licensee for and the Licensee shall pay for the costs of the 
Hardware Key plus all shipping and handling expenses and SSI 
administrative charges; and

(d)    in the event that the Licensee elects to and does acquire a License, the 
terms and conditions of this Agreement, excluding Section 2B herein, 
shall continue on and apply.



3. Ownership.  All rights, title and interests in and to the Licensed Materials and related 
documentation shall remain the sole property of SSI.  Licensee shall not remove or 
alter any proprietary rights notices on the Licensed Materials and the 
documentation, and shall reproduce such notices on any copies that it makes.  
Licensee shall be liable for the security of the Licensed Materials and the
documentation in its possession.

4. Expertise Required.  Licensee is responsible for evaluating whether the Licensed 
Materials meets Licensee’s requirements, and for operating the Licensed Materials 
and the results obtained.  The Licensed Materials are intended for ship modeling and 
construction purposes only, and must be used by a person who has expertise and 
knowledge in this field.  The Licensed Materials requires independent confirmation of 
the reliability and accuracy of all designs, drawings and other Licensed Materials 
output. An SSI representative may be made available under a separate consulting 
agreement, at the Licensee’s request to provide training and consultation on the 
operation or integration of licensed materials.

5. Limitations on Use.  

Licensee shall:

(a)    not make more copies of the Licensed Materials than are necessary for the 
Licensee’s installation of the Licensed Materials and shall only create 
backup copies for archival or emergency restart purposes;

(b)    maintain a log of the number of and location of all originals and copies of 
the Licensed Materials;

(c)    include SSI’s copyright, trademark and proprietary notices on any 
complete or partial copies of the Licensed Materials in the same form and 
location as the notice on any original work;

(d)    not attempt to defeat any copy protection;

(e)    not modify, any documentation, including any user manuals;

(f)    not modify, translate, reverse engineer, decompile or disassemble the 
Licensed Materials;

(g)    not sublicense, transfer, assign, sell, loan, rent or lease the Licensed 
Materials other than as permitted in this Agreement;

(h)    use the Licensed Materials for its own internal use only;

(i)    not permit any third party to use the Licensed Materials; and

(j)    thoroughly test any and all custom interfaces in accordance with general 
engineering principles.

6. Delivery and Installation.  All Licensed Materials will be delivered in an electronic 
format by media or method as SSI may elect and will be sent to the Licensee’s 



designated email address or shipping address as specified in the Invoice.  Licensee 
agrees to be responsible for installation of the Licensed Materials.

7. Term of License.  The License term commences on the delivery of the Licensed 
Materials to the Licensee, and, subject to Section 2B above, is either perpetual if so 
requested on the Order, or on a month to month rental or lease basis. If Licensee 
chooses a lease option the license converts to a perpetual term on Licensee’s 
payment of the balance of the perpetual License fee (prior monthly payments 
receiving 80% credit).  All Licenses are subject to termination in accordance with 
this Agreement.

8. System Configuration.  Operation of the Licensed Materials requires use of the 
specified System Configuration, which Licensee shall acquire and implement.  SSI 
shall not be responsible for any operational problems caused by the System 
Configuration.

9. Security.  The Licensed Materials includes security elements which support the 
detection of unauthorized use or copying of the software and which may (a)report 
such unauthorized use or copying to the Licensee, and (b)if applicable based on 
Licensee’s configuration, may report back specific user information such as User 
name and email address.

10.Hardware Keys.  Licensed Materials use requires “Hardware Keys” supplied by SSI, 
which can be used only at the site(s) authorized by SSI.  In the event of a failure of 
the Licensee’s System Configuration, the Licensee may upon advising SSI use the 
Hardware Keys and Licensed Materials on another system and/or location.

11.License Fees.  Licensee shall pay to SSI the License fees applicable for the Licensed 
Materials as set out in and in accordance with SSI’s Invoice.  

12.Services.  Support services after the Warranty Period (as defined in Section 15 
below) are provided by SSI under the terms of the SSI Subscription Agreement.  
Installation, consulting, training and implementation services, if requested by the 
Licensee, shall be provided by separate agreement and at an additional charge.



13.Taxes.  All amounts payable by Licensee to SSI are exclusive of all commodity taxes, 
including but not limited to applicable sales, use, value added, custom duties, excise 
taxes and other similar government charges, all of which will be paid by Licensee.  If 
Licensee is required by law to withhold any taxes, then Licensee shall pay SSI a 
gross amount of money such that the net amount received by SSI after deducting or 
withholding the required taxes is equal to the amount of the fee originally charged 
by SSI.

14.Interest Charges.  If any amount payable under this Agreement is not paid within 30 
days of becoming due, SSI shall have the right to impose a charge of 2% per month 
(24% annually) on the unpaid balance of the amount, from the due date until the 
date of receipt of all amounts in arrears including interest.

15.Purchase Orders.  Any purchase order (an “Order”) delivered by Licensee shall at 
all times be deemed to incorporate this Agreement by reference and shall be subject 
to the applicable provisions of this Agreement.  Any provisions of an Order shall not 
apply and shall not be binding upon SSI unless they relate to information which was 
requested by SSI.  In the event of a conflict or an inconsistency between the 
provisions of an Order and the terms and conditions of this Agreement, this 
Agreement shall govern and supersede to the extent of such conflict or 
inconsistency.

16.Limited Warranty.  SSI warrants that during a period of 90 days from the date of 
delivery of the Licensed Materials to Licensee (the “Warranty Period”), the 
Licensed Materials will perform substantially in accordance with the Licensed 
Materials documentation specifications, when used in accordance with this 
Agreement on a properly operating System Configuration.  SSI’s sole obligation 
under this Warranty, and Licensee’s exclusive remedy, shall be to use reasonable 
commercial efforts to correct Errors (a bug, defect or other problem incurred by a 
user in operating the Software that prevents the Software from performing in a 
manner consistent with the applicable specifications set out in the User Manual) that 
the Licensee identifies to SSI through fixes or workarounds free of charge.  If SSI 
determines that it is unable to make the Licensed Materials perform substantially as 
warranted, Licensee may terminate the License and receive a refund of a portion of the 
License Fees paid to date.

17.WARRANTY EXCLUSIONS.  THE LIMITED WARRANTY CONTAINED IN SECTION 15 IS 
IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED.  ALL OTHER 
CONDITIONS, WARRANTIES, AND REPRESENTATIONS, EITHER EXPRESS OR 
IMPLIED, ARE EXCLUDED, INCLUDING BUT NOT LIMITED TO CONDITIONS, 
REPRESENTATIONS AND WARRANTIES RELATING TO MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE.  SSI DOES NOT WARRANT THAT THE 
LICENSED MATERIALS ARE COMPLETELY ERROR FREE OR THAT ITS OPERATION WILL 
BE CONTINUOUS AND UNINTERRUPTED. 



18.Maintenance Services.  Licensee may elect, to obtain maintenance, support and 
upgrade services from SSI in accordance with and subject to the terms of SSI’s 
standard Subscription Agreement.

19.Loss of Data.  SSI shall not be responsible for any loss of or damage to files or data 
caused by the Licensed Materials, or be required to restore or rebuild files or data.  
Licensee shall implementing adequate backup procedures to avoid any loss of files 
and data.

20.Modifications. SSI may, from time to time, provide the Licensee with revisions to 
the Licensed Materials (the “Revised Licensed Materials”).  The Licensee shall test 
any external applications using the revised API before implementing the new 
version. While it is SSI’s intention that the Revised Licensed Materials shall be 
backward-compatible with the immediately prior version of the Licensed Materials, 
SSI does not guarantee or warrant that this shall be so, and SSI shall have no 
liability whatsoever to the Licensee for any failure of the Revised Licensed Materials 
to be backward compatible with any prior version of the Licensed Materials.  
Modifications requested by the Licensee shall be subject to prior written agreement 
as to scope and fees payable.  Ownership of all Licensed Materials modifications 
shall vest in SSI.  SSI does not warrant, guarantee or otherwise commit to 
supporting Licensed Materials that has been superseded by Revised Licensed 
Materials.

21.Confidential Information.  Each party will not use the confidential information of the 
other party for any purpose except for the purpose described in this Agreement, and 
shall not disclose it to any other person except on a confidential basis to its 
employees and representatives who have a need-to-know the confidential 
information for such purposes.  This Section 23 shall not apply to confidential 
information which (a) is or has become readily available to the public in the same 
form other than by an act or omission of the receiving party, (b) was lawfully 
obtained in the same form by the receiving party from a third party not under an 
obligation of confidence to the disclosing party, (c) was in the receiving party’s 
possession in the same and material form prior to its receipt from the disclosing 
party and did not otherwise originate from the disclosing party, or (d) is required to 
be disclosed by operation of law.



22. Audit Rights. Upon reasonable notice by SSI, which shall be delivered on no more 
than an (annual?) basis, Licensee shall provide a signed statement verifying its 
compliance with the terms of this Agreement. SSI shall also have the right, upon 
reasonable notice and no more than on an annual basis, to inspect Licensee’s 
facilities to verify Licensee’s compliance with such terms. Any such inspection or
audit shall be conducted either by SSI or by representatives authorized by SSI to 
complete the inspection. If such inspections or audits disclose that the Licensee has 
installed, accessed or permitted access to the Licensed Materials in a manner that is 
not permitted under this Agreement, then Licensee shall be liable to pay for any 
unpaid license fees as well as the reasonable costs of the audit.

23.Termination.  This Agreement may be terminated by either party, immediately by 
written notice, if the other party commits a breach of any material provision of this 
Agreement, including a failure to make payment when due, and fails to correct or 
rectify such breach within 30 days of receipt of the notice requesting it to do so.  
SSI shall be entitled to place time-lock devices and other disabling features in the 
Licensed Materials that become effective in the event that the Licensee has failed to 
comply with its payment obligations hereunder and as set out in SSI Invoices.

24.Effect of Termination.  Upon termination of this Agreement Licensee shall 
immediately cease using the Licensed Materials, and within 14 days of termination 
return all Hardware Keys to SSI.

25.CONSEQUENTIAL DAMAGES.  IN NO EVENT SHALL SSI BE LIABLE FOR ANY LOSS 
OF DATA OR PROFITS, ECONOMIC LOSS OR SPECIAL, INDIRECT, INCIDENTAL, 
CONSEQUENTIAL OR PUNITIVE DAMAGES WITH RESPECT TO THIS AGREEMENT 
OR THE LICENSED MATERIALS, HOWEVER CAUSED, EVEN IF SSI HAD OR SHOULD 
HAVE HAD ANY KNOWLEDGE OF THE POSSIBILITY OF SUCH DAMAGES.

26.DAMAGES LIMITATION.  THE MAXIMUM LIABILITY OF SSI FOR ALL CLAIMS AND 
DAMAGES OF ANY KIND, WHETHER FOR FUNDAMENTAL BREACH OR ANY OTHER 
CAUSE UNDER THIS AGREEMENT, SHALL BE LIMITED IN THE AGGREGATE TO THE 
TOTAL OF ALL FEES PAID BY LICENSEE.

27.LIMITATION OF NON-APPLICABILITY.  IN SOME JURISDICTIONS THE EXCLUSION 
OR LIMITATION OF WARRANTIES OR LIABILITY MAY NOT BE APPLICABLE, AND IN 
SUCH JURISDICTIONS SSI HEREBY LIMITS ITS LIABILITY TO THE FULLEST EXTENT 
PERMITTED BY LAW.



28.Applicable Law.  This Agreement shall be subject to and construed in accordance 
with the laws of the Province of British Columbia, Canada, excluding its conflict of 
laws rules and the application of the UN Convention on Contracts for the 
International Sale of Goods.

29.References.  SSI shall be allowed to incorporate Licensee’s name in SSI’s customer 
reference list and to use it for marketing.

30.Dispute.  If any dispute arises under this Agreement, a good faith attempt to resolve 
the dispute will be made by senior management of both parties at a mutually 
agreeable site and time.  If the parties are unable to reach agreement within 30 
days after a request for such meeting, the dispute shall be referred to arbitration in 
English, before one arbitrator in Victoria, British Columbia, Canada, in accordance 
with the Commercial Arbitration Act of the British Columbia. 

31.Entire Agreement.  This Agreement contains the entire agreement between the 
parties and shall supersede all prior discussions and agreements between the parties 
regarding its subject matter.

32.Amendment.  Any amendment of this Agreement must be in writing and signed by 
duly authorized representatives of the parties.

33.Waiver.  The waiver by any party of a breach by the other party of this Agreement 
shall not be construed as a waiver by such party of any succeeding breach by the 
other party of the same or another provision.

34.Assignments.  Licensee may not assign or transfer the License or Licensee’s rights or 
obligations under this Agreement without SSI’s prior written consent, and any such 
assignment or transfer without consent shall be null and void. A transfer of all or 
substantially all of the voting stock of the Licensee shall constitute a transfer for 
these purposes and shall be subject to SSI’s prior written consent.

35.Successors and Assigns.  This Agreement will bind and enure to the benefit of the 
parties and their respective successors and permitted assigns.

36.Severability.  In the event that any provision of this Agreement is declared invalid, 
illegal or unenforceable by a court having jurisdiction, then the remaining provisions 
shall continue in full force and effect.

37.Force Majeure.  Except as related to Licensee’s obligation to make payments to SSI, 
neither party shall be liable for delays or non-performance if such delays or non-
performance are beyond such party's reasonable control.  A delayed party shall 
promptly notify the other party in writing stating the cause of the delay and its 
expected duration and shall use commercially reasonable efforts to remedy a delay 
or non-performance as soon as reasonably possible.



38.Survival.  The provisions of Sections 3, 5, 11, 13, 14, 17 and 20-30 shall survive the 
expiry or termination of this Agreement.

39.Language.  It is the express will of the parties that this Agreement and related 
documents have been prepared in English.  C’est la volonté expresse des parties que 
la présente Convention ainsi que les documents qui s’y rattachent soient rédiges en 
anglais.

#363338
28/05/2010





Contents

i

Contents

Pipe Library Setup 1

Standards .............................................................................................................................................................. 2
Create a Standard.....................................................................................................................................................................3
Edit a Standard .........................................................................................................................................................................4
Delete a Standard.....................................................................................................................................................................4
Create a Pressure Rating.........................................................................................................................................................4
Edit a Pressure Rating .............................................................................................................................................................4
Associate a Pressure Rating with a Geometric Standard ..................................................................................................5
Delete a Pressure Rating.........................................................................................................................................................5
Associate a Stock Type with a Geometric Standard ...........................................................................................................5

Nominal Sizes ....................................................................................................................................................... 5
Create a Nominal Size .............................................................................................................................................................6
Edit a Nominal Size ..................................................................................................................................................................6
Delete a Nominal Size..............................................................................................................................................................7

Size Definitions..................................................................................................................................................... 7
Create a Size Definition ...........................................................................................................................................................7
Create a ‘New Next Size’ Size Definition...............................................................................................................................7
Edit a Size Definition ................................................................................................................................................................8
Delete a Size Definition ...........................................................................................................................................................8
Filter Size Definitions ...............................................................................................................................................................8
Import Size Definitions ............................................................................................................................................................9
Export Size Definitions.............................................................................................................................................................9

End Treatments ..................................................................................................................................................10
Create an End Treatment Type............................................................................................................................................ 10
Edit an End Treatment Type................................................................................................................................................. 10
Delete an End Treatment Type............................................................................................................................................ 10
Create a LineMode Icon........................................................................................................................................................ 11
Edit a LineMode Icon............................................................................................................................................................. 11
Delete a LineMode Icon........................................................................................................................................................ 12
Set Up End Treatment Properties........................................................................................................................................ 12
Create an End Treatment ..................................................................................................................................................... 12
Edit an End Treatment .......................................................................................................................................................... 13
Delete an End Treatment ..................................................................................................................................................... 14
Usage Log................................................................................................................................................................................ 14
Filter End Treatments............................................................................................................................................................ 14
Import End Treatments......................................................................................................................................................... 15
Export End Treatments ......................................................................................................................................................... 15

Specifications......................................................................................................................................................16
Create a Spec ......................................................................................................................................................................... 16
Delete a Spec ......................................................................................................................................................................... 17



Contents

ii

Edit a Spec .............................................................................................................................................................................. 17

Catalogs...............................................................................................................................................................17
Create a Catalog .................................................................................................................................................................... 17
Delete a Catalog .................................................................................................................................................................... 18
Edit a Catalog ......................................................................................................................................................................... 18

Manufacturers.....................................................................................................................................................18

Materials..............................................................................................................................................................19

Pipe Stock ...........................................................................................................................................................19
Filter Pipe Stocks................................................................................................................................................................... 19
Create a Stock........................................................................................................................................................................ 19
Create a ‘New Next Size’ Stock ........................................................................................................................................... 30
Valve Handles......................................................................................................................................................................... 30
Add or Remove Pipe Stocks To or From a Spec ............................................................................................................... 33
Add or Remove Pipe Stocks To or From a Catalog .......................................................................................................... 33
Edit a Pipe Stock.................................................................................................................................................................... 33
Change Stock Subtype.......................................................................................................................................................... 34
Stock Usage............................................................................................................................................................................ 34
Import Pipe Stock.................................................................................................................................................................. 36
Export Pipe Stock................................................................................................................................................................... 37

Accessory Packages ..........................................................................................................................................37
Create an Accessory Type..................................................................................................................................................... 37
Create an Accessory Package ............................................................................................................................................. 38
Create an Accessory.............................................................................................................................................................. 38
Copy an Accessory Package ................................................................................................................................................ 38
Delete an Accessory Package ............................................................................................................................................. 39
Delete an Accessory or Accessory Type ............................................................................................................................. 39
Add or Remove an Accessory To or From an Accessory Package................................................................................. 39
Add or Remove an Accessory Package To or From a Spec ............................................................................................ 39
Import Accessory Packages................................................................................................................................................. 40
Export Accessory Packages ................................................................................................................................................. 40

Connections.........................................................................................................................................................40
Create a Connection Type..................................................................................................................................................... 41
Create a Connection.............................................................................................................................................................. 41
Create a ‘New Next Size’ Connection.................................................................................................................................. 42
Edit a Connection................................................................................................................................................................... 42
Delete a Connection or Connection Type........................................................................................................................... 42
Add an Accessory Package To a Connection .................................................................................................................... 43
Remove an Accessory Package From a Connection........................................................................................................ 43
Import Connections............................................................................................................................................................... 43
Export Connections................................................................................................................................................................ 44

Auto-Part Insertion Setup..................................................................................................................................44
Stock Setup ............................................................................................................................................................................ 44
Allowable Connection Setup................................................................................................................................................ 44

Pipe Bending Machines.....................................................................................................................................44
Create a Pipe Bending Machine.......................................................................................................................................... 44
Edit a Pipe Bending Machine............................................................................................................................................... 45
Delete a Pipe Bending Machine.......................................................................................................................................... 45



Contents

iii

Add a Size Definition to a Pipe Bending Machine’s Bender Information ..................................................................... 46
Edit Pipe Bending Machine’s Bender Information Size Definition Settings................................................................. 46
Remove a Size Definition Setting From a Pipe Bending Machine’s Bender Information .......................................... 46
Add a Size Definition to a Pipe Bending Machine’s Cutting Information ..................................................................... 47
Edit Pipe Bending Machine’s Cutting Information Size Definition Settings................................................................. 47
Remove a Size Definition Setting From a Pipe Bending Machine’s Cutting Information .......................................... 47
Delete a Pipe Bending Machine.......................................................................................................................................... 47
Import Pipe Bending Machines ........................................................................................................................................... 47
Export Pipe Bending Machines............................................................................................................................................ 48

User-Defined Attributes .....................................................................................................................................48

Excel Pipe Library Editor (“Flatsheet”) ............................................................................................................48
Overview.................................................................................................................................................................................. 48
Getting Started....................................................................................................................................................................... 49
The Help Tab........................................................................................................................................................................... 49
General Information.............................................................................................................................................................. 49

Pipe Hanger Stocks............................................................................................................................................50
Supported Hanger Types ...................................................................................................................................................... 50
Create a Hanger Stock.......................................................................................................................................................... 67
Edit a Hanger Stock............................................................................................................................................................... 68
Delete a Hanger Stock.......................................................................................................................................................... 68
Assign Allowable Nominal Sizes to a Hanger Stock......................................................................................................... 68
Assign Allowable Material Grades to a Hanger Stock ..................................................................................................... 69
Edit Hanger Stock Catalogs.................................................................................................................................................. 70
Assign Hanger Stocks to a Hanger Stock Catalog............................................................................................................ 70

Support Templates.............................................................................................................................................71
Support Template Types....................................................................................................................................................... 71
Create a Support Template.................................................................................................................................................. 76
Edit Support Template Tiers................................................................................................................................................. 77
Edit a Support Template....................................................................................................................................................... 78
Assign Allowable Hangers to a Support Template........................................................................................................... 78

Pipe Modeling 81

Pipe Drawings.....................................................................................................................................................81
Create a Pipe Drawing .......................................................................................................................................................... 81
Upon Opening a Pipe Drawing............................................................................................................................................. 81

Set Up Pipe Systems..........................................................................................................................................82
Create a System..................................................................................................................................................................... 82
Create a Branch ..................................................................................................................................................................... 83
Modify a System or Branch.................................................................................................................................................. 83
Delete a System or Branch .................................................................................................................................................. 83
Set the Current System for Pipes........................................................................................................................................ 83
Change the System for Pipes............................................................................................................................................... 84

Set Up Pipe Defaults, Display, and Performance..........................................................................................84
Display Options for Pipe ....................................................................................................................................................... 84
Change the NavAid Options ................................................................................................................................................. 85
Set the Transform Options ................................................................................................................................................... 86
Set the Routing Options........................................................................................................................................................ 87



Contents

iv

Set the Behavior Options...................................................................................................................................................... 88
Set the Constraints Options ................................................................................................................................................. 89

Insert Pipes..........................................................................................................................................................90
Selecting a Pipe Part to Insert............................................................................................................................................. 90
The NavAid.............................................................................................................................................................................. 91
Required Custom Attributes ................................................................................................................................................ 92
No Spool Parts........................................................................................................................................................................ 92
Straight Pipe........................................................................................................................................................................... 93
Bent Pipe................................................................................................................................................................................. 94
Generic Pipes ......................................................................................................................................................................... 96
Fittings..................................................................................................................................................................................... 96
Auto Part Insertion Mode ...................................................................................................................................................102
Inline Fitting Insert...............................................................................................................................................................102
Insert Connector Set Command........................................................................................................................................103
Routing Options ...................................................................................................................................................................103
Creating Connections While Routing In End Mode.........................................................................................................104
Create a Saddle....................................................................................................................................................................104
Offset Routing ......................................................................................................................................................................109
Object Snaps.........................................................................................................................................................................110
Custom Object Snaps..........................................................................................................................................................111

Modify Pipes..................................................................................................................................................... 113
Anchor Pipes.........................................................................................................................................................................113
Unanchor a Pipe...................................................................................................................................................................114
Lock a Pipe ...........................................................................................................................................................................114
Grip Points ............................................................................................................................................................................114
Toggle Transform Mode......................................................................................................................................................115
Toggle Constraining Mode..................................................................................................................................................124
Break a Pipe.........................................................................................................................................................................124
Disconnect Pipes .................................................................................................................................................................124
Connect Pipes.......................................................................................................................................................................124
Remove Saddle....................................................................................................................................................................125
Mark All Exceeding Maximum Length..............................................................................................................................125
Cut to Maximum Length .....................................................................................................................................................125
Extract Center Line ..............................................................................................................................................................125
Merge To Bent ......................................................................................................................................................................125
Change Connection Accessory Package..........................................................................................................................126
Transfer parts to another drawing / unit .........................................................................................................................127
Copy parts to another drawing / unit ...............................................................................................................................127

Pipe Spools....................................................................................................................................................... 127
Creating Spools....................................................................................................................................................................127

OPM................................................................................................................................................................... 140
Weight ...................................................................................................................................................................................142

Activate UCS from Parts................................................................................................................................. 142

Pipe-UCS Intersection ..................................................................................................................................... 143
Add Pipe-UCS Intersection..................................................................................................................................................143
Toggle UCS Intersection Line .............................................................................................................................................144
Erase Pipe-UCS Intersection...............................................................................................................................................144
Erase All Pipe-UCS Intersections.......................................................................................................................................144



Contents

v

Hanger Modeling 144

Hanger Drawings............................................................................................................................................. 144
Create an Hanger Drawing.................................................................................................................................................145
Upon Opening an Hanger Drawing....................................................................................................................................145

Set Up Hanger Defaults, Display, and Performance.................................................................................. 145
Display Options for Hangers...............................................................................................................................................145
NavAid Options.....................................................................................................................................................................146

Insert Hangers.................................................................................................................................................. 146
Selecting a Hanger Part to Place ......................................................................................................................................147
NavAid ...................................................................................................................................................................................148
Place Hanger ........................................................................................................................................................................148
Hanger Routing Options .....................................................................................................................................................150
Object Snaps.........................................................................................................................................................................150

Modify Hangers................................................................................................................................................ 153
Name Hangers .....................................................................................................................................................................153
Move Hangers to Drawing ..................................................................................................................................................154
Move Attached Hangers to Current Drawing...................................................................................................................154
Grip-points.............................................................................................................................................................................154

OPM................................................................................................................................................................... 155

Support Modeling 157

Support Drawings............................................................................................................................................ 157
Create a Support Drawing..................................................................................................................................................157
Upon Opening a Support Drawing.....................................................................................................................................157

Set Up Support Defaults, Display, and Performance................................................................................. 158
Display Options for Supports .............................................................................................................................................158
NavAid Options.....................................................................................................................................................................158

Insert Supports ................................................................................................................................................ 159
Bare Support.........................................................................................................................................................................159
Auto Support.........................................................................................................................................................................163

Modify Hangers................................................................................................................................................ 164
Name Supports ....................................................................................................................................................................164
Move Supports to Drawing.................................................................................................................................................164
Attach Pipes to Supports....................................................................................................................................................164
Copy Supports along Supported Objects..........................................................................................................................165
Grip Points ............................................................................................................................................................................165

OPM................................................................................................................................................................... 167

Distributed Systems Production Drawings 169

Creating a Spool Drawing .............................................................................................................................. 169
Set Up Spool Naming Convention .....................................................................................................................................169
Set an Active Naming Convention.....................................................................................................................................170



Contents

vi

Set Up a Spool Template Drawing ....................................................................................................................................170
Generate Spool Drawings...................................................................................................................................................176

Edit Spool Drawings........................................................................................................................................ 179
Rotate a Dimension ............................................................................................................................................................179
Align Dimension Text to View ............................................................................................................................................180
Re-dimension a Spool Drawing .........................................................................................................................................180
Label Connecting Spool/Assembly...................................................................................................................................181

Update Spool Drawings.................................................................................................................................. 181
Identifying Drawings that Require Updating ...................................................................................................................181
Updating an Existing Spool Drawing.................................................................................................................................182

Create Arrangement Drawings...................................................................................................................... 184
Set Up an Arrangement Drawing Template.....................................................................................................................184
Generate Arrangement Drawings .....................................................................................................................................187

Edit Arrangement Drawings........................................................................................................................... 193

Update Arrangement Drawings..................................................................................................................... 193
Identifying Drawings that Require Updating ...................................................................................................................193
Updating an Existing Arrangement Drawing ...................................................................................................................194

Labeling ............................................................................................................................................................ 198
Manual Labeling from BOM...............................................................................................................................................198
Copy Label from BOM .........................................................................................................................................................198
Relabel All.............................................................................................................................................................................198
Relabel from a selected BOM............................................................................................................................................198
Relabel from Parts ..............................................................................................................................................................199
Label to part edges..............................................................................................................................................................199

Common Production Drawing Functions..................................................................................................... 201
Insert an Orientation Icon...................................................................................................................................................201
Viewport Options..................................................................................................................................................................201
Update BOMs........................................................................................................................................................................201
Purge BOMs..........................................................................................................................................................................202
Clear All BOMs......................................................................................................................................................................202
Unlink All BOMS ...................................................................................................................................................................202
Edit BOM Collector Options................................................................................................................................................202
Update All Keywords ...........................................................................................................................................................202
Viewport Display Options....................................................................................................................................................202
List only Visible.....................................................................................................................................................................202
Viewport Clipping.................................................................................................................................................................203
Remove clip..........................................................................................................................................................................205

Support Construction Drawings 205

Set Up Support Construction Drawings........................................................................................................ 206
Set Up a Support Construction Drawing Template.........................................................................................................206
Set Up a Support Construction Drawing BOM Style .......................................................................................................208

Generate Support Construction Drawings................................................................................................... 209
Generating Support Construction Drawings....................................................................................................................209



Contents

vii

Edit Support Construction Drawings ............................................................................................................ 212

Update Support Construction Drawings....................................................................................................... 213
Identifying Drawings that Require Updating ...................................................................................................................213
Updating an Existing Support Construction Drawing .....................................................................................................214
Insert Keywords in a Support Construction Drawing......................................................................................................215

Plot Support Construction Drawings ............................................................................................................ 215
Plot a Support Construction Drawing ...............................................................................................................................215
Inspect a Plotted Support Construction Drawing............................................................................................................216

Appendix A: Pipe Command Reference 217

Manager Pipe Menu........................................................................................................................................ 217
Pipe > Pipe Benders............................................................................................................................................................217
Pipe > Stock Catalog...........................................................................................................................................................218

Toolbars ............................................................................................................................................................ 225
Pipe Toolbar..........................................................................................................................................................................225
Distributed Systems Utilities Toolbar ...............................................................................................................................227

ShipConstructor Menu.................................................................................................................................... 227
ShipConstructor > Navigator..............................................................................................................................................227
ShipConstructor > Export Pipe Bending Data .................................................................................................................228

SC Pipe Menu................................................................................................................................................... 228
SC Pipe > Straight Pipe.......................................................................................................................................................228
SC Pipe > Bent Pipe ............................................................................................................................................................228
SC Pipe > Elbow...................................................................................................................................................................229
SC Pipe > Reducer...............................................................................................................................................................229
SC Pipe > Caps.....................................................................................................................................................................229
SC Pipe > Cross....................................................................................................................................................................229
SC Pipe > Branches > Lateral............................................................................................................................................230
SC Pipe > Branches > Tee..................................................................................................................................................230
SC Pipe > Branches > Wye.................................................................................................................................................230
SC Pipe > Branches > Misc ................................................................................................................................................230
SC Pipe > Connectors > Union...........................................................................................................................................231
SC Pipe > Connectors > Flange.........................................................................................................................................231
SC Pipe > Connectors > Coupling......................................................................................................................................231
SC Pipe > Connectors > Weldolet .....................................................................................................................................231
SC Pipe > Connectors > Threadolet..................................................................................................................................232
SC Pipe > Connectors > Adapter.......................................................................................................................................232
SC Pipe > Connectors > Misc.............................................................................................................................................232
SC Pipe > Valves > Ball.......................................................................................................................................................232
SC Pipe > Valves > Butterfly...............................................................................................................................................233
SC Pipe > Valves > Check...................................................................................................................................................233
SC Pipe > Valves > Diaphragm..........................................................................................................................................233
SC Pipe > Valves > Gate .....................................................................................................................................................233
SC Pipe > Valves > Globe ...................................................................................................................................................234
SC Pipe > Valves > Plug......................................................................................................................................................234
SC Pipe > Valves > Relief ...................................................................................................................................................234
SC Pipe > Valves > SDNR...................................................................................................................................................234
SC Pipe > Valves > Misc......................................................................................................................................................235



Contents

viii

SC Pipe > Insert Connector Set .........................................................................................................................................235
SC Pipe > Equipment ..........................................................................................................................................................235
SC Pipe > Spools > Spool Manager ..................................................................................................................................235
SC Pipe > Spools > Set No-Spool ......................................................................................................................................236
SC Pipe > Spools > Remove No-Spool..............................................................................................................................236
SC Pipe > Spools > Add Spool Break................................................................................................................................236
SC Pipe > Spools > Remove Spool Break........................................................................................................................237
SC Pipe > System > System Manager…...........................................................................................................................237
SC Pipe > System > Set Current System From Pipe Part..............................................................................................237
SC Pipe > System > Set System….....................................................................................................................................237
SC Pipe > Saddles > Create Saddle..................................................................................................................................238
SC Pipe > Saddles > Remove Saddle...............................................................................................................................238
SC Pipe > Insulation and Finishes > Add Insulation ......................................................................................................238
SC Pipe > Insulation and Finishes > View Finishes........................................................................................................238
SC Pipe > Insulation and Finishes > Apply Finishes.......................................................................................................239
SC Pipe > Utilities > Merge To Bent..................................................................................................................................239
SC Pipe > Utilities > Route on Polyline.............................................................................................................................239
SC Pipe > Utilities > Cut to Max Length ...........................................................................................................................239
SC Pipe > Utilities > Extract Center Line..........................................................................................................................240
SC Pipe > Pipe-UCS Intersection > Add Pipe-UCS Intersection ....................................................................................240
SC Pipe > Pipe-UCS Intersection > Toggle Highlight on all HEP-UCS Intersection ....................................................241
SC Pipe > Pipe-UCS Intersection > Erase HEP-UCS Intersection..................................................................................241
SC Pipe > Pipe-UCS Intersection > Erase All HEP-UCS Intersection ............................................................................241
SC Pipe > Connect ...............................................................................................................................................................241
SC Pipe > Disconnect..........................................................................................................................................................242
SC Pipe > Break Pipe at Point ...........................................................................................................................................242
SC Pipe > Anchor Part.........................................................................................................................................................242
SC Pipe > Unanchor Part ....................................................................................................................................................242
SC Pipe > Lock Part.............................................................................................................................................................243
SC Pipe > Toggle Constrain Enforcement........................................................................................................................243
SC Pipe > Unlock Part .........................................................................................................................................................243
SC Pipe > Toggle Transform Mode....................................................................................................................................243
SC Pipe > Pipe Options.......................................................................................................................................................244
SC Pipe > Insert Penetration..............................................................................................................................................244
SC Pipe > Change Connection Accessory Package........................................................................................................244

Individual Drawing Display Settings Commands ....................................................................................... 245

Shared HEP Commands................................................................................................................................. 246
SCHEPTransferPartToDrawing...........................................................................................................................................246
SCHEPReplicateToDrawing................................................................................................................................................247

Supports & Hanger Commands.................................................................................................................... 247
SC Supports & Hangers > New Hanger ............................................................................................................................247
SC Supports & Hangers > Name Hangers .......................................................................................................................247
SC Supports & Hangers > Move Hanger to Drawing......................................................................................................247
SC Supports & Hangers > Move Attached Hanger to Drawing.....................................................................................248
SC Supports & Hangers > Insert Bare Support ...............................................................................................................248
SC Supports & Hangers > Insert Auto Support ...............................................................................................................248
SC Supports & Hangers > Insert LF Auto Support..........................................................................................................248
SC Supports & Hangers > Insert I Auto Support .............................................................................................................249
SC Supports & Hangers > Insert TN Auto Support .........................................................................................................249
SC Supports & Hangers > Insert MN Auto Support ........................................................................................................249
SC Supports & Hangers > Attach Pipes to Support........................................................................................................249



Contents

ix

SC Supports & Hangers > Transfer Supports to Drawing..............................................................................................250
SC Supports & Hangers > Name Supports In Order.......................................................................................................250
SC Supports & Hangers > Copy Supports Along Supported Parts...............................................................................250
SC Supports & Hangers > Hanger and Support Drawing Options................................................................................250

Appendix B: Pipe Modeling Reference 251

Pipe Navigator Page ....................................................................................................................................... 251

Pipe Spool Navigator Page ............................................................................................................................ 252

System Manager ............................................................................................................................................. 254

Pipe Options..................................................................................................................................................... 255
The Display Tab....................................................................................................................................................................255
The NavAid Tab ....................................................................................................................................................................261
The Transform Tab...............................................................................................................................................................262
The Routing Tab...................................................................................................................................................................264
The Behavior Tab .................................................................................................................................................................265
The Constraints Tab.............................................................................................................................................................266

Stock Selection Window Reference ............................................................................................................. 266
Required Custom Attributes Reference...........................................................................................................................267

Insulation Reference....................................................................................................................................... 268

Finishes Reference.......................................................................................................................................... 269

Pipe Part Right-Click Menu............................................................................................................................ 271

Select UCS Options Reference ...................................................................................................................... 272

Scenario Wizard Dialog .................................................................................................................................. 273

Hanger Stock Selection Window Reference ............................................................................................... 274

Hanger & Support Drawing Options ............................................................................................................. 275
Hangers .................................................................................................................................................................................275
Supports................................................................................................................................................................................276

Support Template Selection Window Reference ....................................................................................... 276

Appendix C: Pipe Production Command Reference 279

Toolbars ............................................................................................................................................................ 279
Spool Toolbar........................................................................................................................................................................279

SC Arrangement Menu ................................................................................................................................... 279
SC Arrangement > Update Drawing..................................................................................................................................279
SC Arrangement > Silent Update Drawing ......................................................................................................................279
SC Arrangement > Insert Keywords..................................................................................................................................280
SC Arrangement > Update All Keywords..........................................................................................................................280
SC Arrangement > Pipe Drawing Options........................................................................................................................280
SC Arrangement > HVAC Drawing Options......................................................................................................................280
SC Arrangement > Equipment Drawing Options ............................................................................................................280



Contents

x

SC Arrangement > Viewport Options................................................................................................................................281
SC Arrangement > Set Viewport Display Options...........................................................................................................281
SC Arrangement > Insert BOM Table................................................................................................................................281
SC Arrangement > Update BOMs......................................................................................................................................281
SC Arrangement > Edit Collector Options........................................................................................................................281
SC Arrangement > Toggle List Only Visible .....................................................................................................................282
SC Arrangement > Label > Manual Label from BOM ....................................................................................................282
SC Arrangement > Label > Copy Label from BOM.........................................................................................................282
SC Arrangement > Label > Relabel All.............................................................................................................................282
SC Arrangement > Label > Relabel from BOM...............................................................................................................283
SC Arrangement > Label > Relabel from Parts ..............................................................................................................283
SC Arrangement > Label > Label on Visible Edge On/Off.............................................................................................283
SC Arrangement > Label > Curved Plates in Visible Edge Detection On/Off.............................................................283
SC Arrangement > Label > Adjacent Part Edge Tolerance ...........................................................................................284
SC Arrangement > Label > Edge Length Filter................................................................................................................284
SC Arrangement > Label > Edge Determination Minimum Angle...............................................................................284
SC Arrangement > Label > Label Reset Automatic Settings........................................................................................284
SC Arrangement > BOM Revisions > New BOM Revision in Current Layout..............................................................285
SC Arrangement > BOM Revisions > New BOM Revision in All Layouts.....................................................................285
SC Arrangement > BOM Revisions > Delete BOM Revision in Current Layout..........................................................285
SC Arrangement > BOM Revisions > Delete BOM Revision in All Layouts.................................................................285
SC Arrangement > BOM Revisions > Delete All BOM Revision in Current Layout ....................................................286
SC Arrangement > BOM Revisions > Delete All BOM Revision in All Layouts ...........................................................286
SC Arrangement > BOM Revisions > List BOM Revisions.............................................................................................286
SC Arrangement > Global Dimension to Point................................................................................................................286

SC Spool Drawing Menu................................................................................................................................. 286
SC Spool Drawing > Update Spool Drawing ....................................................................................................................287
SC Spool Drawing > Rotate Dimension............................................................................................................................287
SC Spool Drawing > Align Dimension Text to Current View..........................................................................................287
SC Spool Drawing > Re-Dimension...................................................................................................................................287
SC Spool Drawing > CG Point ............................................................................................................................................287
SC Spool Drawing > Orientation Icon ...............................................................................................................................288
SC Spool Drawing > Label Connecting Spool/Assembly...............................................................................................288
SC Spool Drawing > Insert Keywords ...............................................................................................................................288
SC Spool Drawing > Update All Keywords .......................................................................................................................288
SC Spool Drawing > Drawing Options ..............................................................................................................................288
SC Spool Drawing > Viewport Options..............................................................................................................................289
SC Spool Drawing > Set Viewport Display Options.........................................................................................................289
SC Spool Drawing > Insert BOM Table .............................................................................................................................289
SC Spool Drawing > Update BOMs....................................................................................................................................289
SC Spool Drawing > Edit Collector Options......................................................................................................................289
SC Spool Drawing > Toggle List Only Visible ...................................................................................................................290
SC Spool Drawing > Label > Manual Label from BOM..................................................................................................290
SC Spool Drawing > Label > Copy Label from BOM.......................................................................................................290
SC Spool Drawing > Label > Relabel All ..........................................................................................................................290
SC Spool Drawing > Label > Relabel from BOM.............................................................................................................291
SC Spool Drawing > Label > Relabel from Parts............................................................................................................291
SC Spool Drawing > BOM Revisions > New BOM Revision in Current Layout............................................................291
SC Spool Drawing > BOM Revisions > New BOM Revision in All Layouts ..................................................................291
SC Spool Drawing > BOM Revisions > Delete BOM Revision in Current Layout........................................................292
SC Spool Drawing > BOM Revisions > Delete BOM Revision in All Layouts...............................................................292
SC Spool Drawing > BOM Revisions > Delete All BOM Revision in Current Layout ..................................................292



Contents

xi

SC Spool Drawing > BOM Revisions > Delete All BOM Revision in All Layouts.........................................................292
SC Spool Drawing > BOM Revisions > List BOM Revisions...........................................................................................293
SC Spool Drawing > Global Dimension to Point .............................................................................................................293

SC Arrangement Template Menu ................................................................................................................. 293
SC Arrangement Template > Orientation Icon................................................................................................................293
SC Arrangement Template > Insert Keywords................................................................................................................293
SC Arrangement Template > Pipe Drawing Options......................................................................................................294
SC Arrangement Template > HVAC Drawing Options....................................................................................................294
SC Arrangement Template > Equipment Drawing Options ..........................................................................................294
SC Arrangement Template > Viewport Options..............................................................................................................294
SC Arrangement Template > Set Viewport Display Options.........................................................................................294
SC Arrangement Template > Insert BOM Table..............................................................................................................295
SC Arrangement Template > Edit Collector Options......................................................................................................295
SC Arrangement Template > Toggle List Only Visible....................................................................................................295
SC Arrangement Template > Update from a Previous Version....................................................................................295

SC Spool Template Menu............................................................................................................................... 295
SC Spool Template > Orientation Icon .............................................................................................................................295
SC Spool Template > Insert Keywords .............................................................................................................................296
SC Spool Template > Drawing Options ............................................................................................................................296
SC Spool Template > Viewport Options ...........................................................................................................................296
SC Spool Template > Set Viewport Display Options ......................................................................................................296
SC Spool Template > Insert BOM Table ...........................................................................................................................296
SC Spool Template > Edit Collector Options ...................................................................................................................297
SC Spool Template > Toggle List Only Visible .................................................................................................................297
SC Spool Template > Update from a Previous Version..................................................................................................297

Appendix D: Distributed Systems Production Command Reference 299

SC Support Const Menu ................................................................................................................................. 299
SC Support Const > Update Drawing................................................................................................................................299
SC Support Const > Silent Update Drawing.....................................................................................................................299
SC Support Const > Insert Keywords................................................................................................................................299
SC Support Const > Update All Keywords........................................................................................................................299
SC Support Const > Re-Dimension ...................................................................................................................................300
SC Support Const > Structure Drawing Options..............................................................................................................302
SC Support Const > Hanger Drawing Options.................................................................................................................302
SC Support Const > Viewport Options ..............................................................................................................................302
SC Support Const > Set Viewport Display Options .........................................................................................................302
SC Support Const > Insert BOM Table..............................................................................................................................302
SC Support Const > Update BOMs....................................................................................................................................303
SC Support Const > Edit Collector Options ......................................................................................................................303
SC Support Const > Toggle list only visible......................................................................................................................303
SC Support Const > Label > Manual Label from BOM...................................................................................................303
SC Support Const > Label > Copy Label from BOM .......................................................................................................303
SC Support Const > Label > Relabel All...........................................................................................................................304
SC Support Const > Label > Relabel from BOM .............................................................................................................304
SC Support Const > Label > Relabel from Parts.............................................................................................................304
SC Support Const > Label > Label on Visible Edge On/Off...........................................................................................304
SC Support Const > Label > Curved Plates in Visible Edge Detection On/Off ...........................................................305
SC Support Const > Label > Adjacent Part Edge Tolerance..........................................................................................305
SC Support Const > Label > Edge Length Filter..............................................................................................................305



Contents

xii

SC Support Const > Label > Edge Determination Minimum Angle .............................................................................305
SC Support Const > Label > Label Reset Automatic Settings......................................................................................306
SC Support Const > BOM Revisions > New BOM Revision in Current Layout ............................................................306
SC Support Const > BOM Revisions > New BOM Revision in All Layouts...................................................................306
SC Support Const > BOM Revisions > Delete BOM Revision in Current Layout ........................................................306
SC Support Const > BOM Revisions > Delete BOM Revision in All Layouts ...............................................................307
SC Support Const > BOM Revisions > Delete All BOM Revision in Current Layout...................................................307
SC Support Const > BOM Revisions > Delete All BOM Revision in All Layouts..........................................................307
SC Support Const > BOM Revisions > List BOM Revisions ...........................................................................................307
SC Support Const > Global Dimension to Point..............................................................................................................308

SC Support Const Template Menu................................................................................................................ 308
SC Support Const Template > Insert Keywords..............................................................................................................308
SC Support Const Template > Structure Drawing Options............................................................................................308
SC Support Const Template > Hanger Drawing Options ...............................................................................................308
SC Support Const Template > Viewport Options ............................................................................................................308
SC Support Const Template > Set Viewport Display Options .......................................................................................309
SC Support Const Template > Insert BOM Table............................................................................................................309
SC Support Const Template > Edit Collector Options ....................................................................................................309
SC Support Const Template > Toggle list only visible....................................................................................................309

Appendix E: Distributed Systems Production Reference 311

Bill of Materials................................................................................................................................................ 311
BOM Functionality Overview ..............................................................................................................................................311

BOM Definitions Manager.............................................................................................................................. 313
Properties and Functions Explained ...............................................................................................................................313
BOM Fields............................................................................................................................................................................314
Merging Rows.......................................................................................................................................................................317
Merging Columns.................................................................................................................................................................317
Collectors ..............................................................................................................................................................................317

Creating a New BOM Definition .................................................................................................................... 319

Insert Empty BOM Wizard .............................................................................................................................. 320

Manual Label from BOM ................................................................................................................................ 322

Copy Label from BOM..................................................................................................................................... 322

Bending Data – XML Output.......................................................................................................................... 322
Raw........................................................................................................................................................................................322
Formatted .............................................................................................................................................................................324
Excel Import..........................................................................................................................................................................325
Choosing Pipes for XML Data Generation........................................................................................................................326

Bend Information and Location Tables........................................................................................................ 327
Corner Point..........................................................................................................................................................................327
Global Position .....................................................................................................................................................................328
Bending Tables.....................................................................................................................................................................328
Bending and Location Tables Example............................................................................................................................328

Spool Manager Reference ............................................................................................................................. 329



Contents

xiii

Right-Click Menu for the Spool Manager .........................................................................................................................332
Drag and Drop Feature for the Spool Manager...............................................................................................................333

Spool Properties Reference........................................................................................................................... 333

Keywords Reference....................................................................................................................................... 336

Create Spool Drawing Wizard Reference .................................................................................................... 339

Spool Styles Reference .................................................................................................................................. 341

Create Arrangement Drawing Wizard Reference....................................................................................... 344

Modified Part Information Reference.......................................................................................................... 349

Layer Conflict Resolution Reference............................................................................................................ 350

Update Arrangement Drawing Wizard Reference...................................................................................... 351

Label Styles...................................................................................................................................................... 354

BOM Revisions................................................................................................................................................. 355
New Revision ........................................................................................................................................................................356
Delete Revision ....................................................................................................................................................................356
Delete All Revisions.............................................................................................................................................................357
List Revisions........................................................................................................................................................................357

Global Dimension to Point............................................................................................................................. 357

Cut Length Dimensions .................................................................................................................................. 361

Elbow Radius Dimension ............................................................................................................................... 361

Flange Rotation Angles .................................................................................................................................. 362

Spool Drawings – Valves Icons ..................................................................................................................... 363

Spool Drawings – Penetrations..................................................................................................................... 364

Index 367





Pipe Library Setup

1

Pipe Library Setup
Each project contains various libraries that hold the stocks, materials, and other things you need to use in the project. 
Before you begin work on a project, you must set up these project libraries. You can also import project libraries from 
another project or from an XML file that you have exported from another project.

This manual describes how to set up pipe libraries, equipment libraries, and hanger libraries. See the Structure manual 
for details on setting up general and structural libraries. See the HVAC manual for details on setting up HVAC libraries.

Pipe stocks are managed through the Pipe Stock Catalog in Manager. The main interface for the Pipe Stock Catalog
involves four tabs; Size Definitions Tab (page 220), End Treatments Tab (page 221), Create/Edit Pipe Tab (page 222), and 
Connections Tab (page 223). Each tab, along with a number of sub-dialogs, helps you manage a different area of the pipe 
stocks catalog.

Hanger stocks are managed through the Hanger Stock Catalog in Manager. Stocks are managed through the main 
hangers grid and several smaller sub-dialogs.
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Standards
A standard is a combination of the following:

• An international standard (for example, ANSI) is the name of a governing international standard body.

• A geometric standard (for example, B16.9) is the section of the associated international standard.

• A pipe schedule or pressure rating (for example, 10S) represents the pipe’s wall thickness.

Examples of standards include:

• ANSI – B16.9 – 10S

• ASME – B36.19 – 40S

• ANSI – B16.5 – STD
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Create a Standard

To create a standard

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog. See Pipe > Stock Catalog (page 218) for details.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

Standards lists all international standards and geometric standards. (Each geometric standard is listed under its 
associated international standard.)

• To create an international standard, click New International and enter a Name and Description.

• To create a geometric standard, select an international standard, click New Geometric, and enter a Name and 
Description.

• To rename an international standard or geometric standard, double-click the standard name, enter a new name,
and press Enter.

• To delete an international standard or geometric standard, select the standard you want to delete and click 
Delete.

Pressure Ratings lists all pipe schedules.

• To create a pipe schedule, click New and enter a name (Pressure Rating).

• To associate a pressure rating with a standard, select the standard and then check the check box of the 
pressure ratings that will belong to the standard.

Pipe Stock Types lists all pipe stock types.

• To associate a standard with a specific stock type, select the standard and then check the check box of the pipe 
stock types you want to be available in the standard.

5. Click Apply to create the standard, click OK to create the standard and close the Standards window, or click Cancel
to close the window without saving any of your changes.
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Edit a Standard

To edit a standard

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select the international standard you want to edit and change its properties as needed, or select the geometric 
standard you want to edit and change its properties, the Stock Types it is associated with, or Pressure Ratings
assigned to it as needed.

6. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Delete a Standard

To delete a standard

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select the geometric or international standard you want to delete and click Delete Standard.

6. Click Apply to delete the standard, click OK to delete the standard and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Create a Pressure Rating

To create a pressure rating

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select the geometric standard you want to add a pressure rating for and click New under Pressure Ratings.

6. Enter a name for the pressure rating and check the Assigned check box to associate it with the currently selected 
geometric standard.

7. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Edit a Pressure Rating

To edit a pressure rating

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select a geometric standard under Standards and then select the pressure rating you want to edit under Pressure 
Ratings.

6. Edit the pressure rating’s name as necessary.
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7. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Associate a Pressure Rating with a Geometric Standard

To associate a pressure rating with a geometric standard

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select the geometric standard you want to associate the pressure rating with from the Standards list.

6. Select the pressure rating you want from the Pressure Ratings list.

7. Check the Assigned check box beside the pressure rating name.

8. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Delete a Pressure Rating

To delete a pressure rating

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select a geometric standard and then select the pressure rating you want to delete and click Delete.

6. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Associate a Stock Type with a Geometric Standard

To associate a stock type with a geometric standard

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Standards to open the Standards window.

5. Select a geometric standard from the Standards list.

6. Select a stock type from the Pipe Stock Types list and check the Assigned check box beside the stock type name.

7. Click Apply to save the changes, click OK to save the changes and close the Standards window, or click Cancel to 
close the window without saving any of your changes.

Nominal Sizes
The nominal size of a pipe is the name that it is identified by. Although the nominal size is a measurement, the 
measurement does not necessarily correspond exactly to the pipe’s actual inside or outside diameter.
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Create a Nominal Size

To create a nominal size

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Nominal Sizes to open the Nominal Sizes window. 

5. Click New.

6. Enter the Primary Size and Units.

You can also enter an Alternate Size and Units.

7. Click OK to close the Nominal Sizes window.

8. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog window.

Edit a Nominal Size

To edit a nominal size

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Nominal Sizes to open the Nominal Sizes window.

5. Double-click the field you want to edit and enter a new value.

6. Click OK to close the Nominal Sizes window.

7. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Note: A warning appears if the nominal size is currently in use. If you click OK, ShipConstructor will save the change to 
the nominal size and will automatically change all items based on the nominal size. If you click Cancel, 
ShipConstructor will not save the change to the nominal size.
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Delete a Nominal Size

To delete a nominal size

Note: You cannot delete a nominal size that is in use by a size definition or end treatment.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Edit Nominal Sizes to open the Nominal Sizes window.

5. Select the nominal size you want to delete.

6. Click Delete.

7. Click OK to close the Nominal Sizes window.

8. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Size Definitions
A size definition is a combination of a standard and a nominal size.

Create a Size Definition

To create a size definition

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click New to create a new size definition entry.

5. Set the values for the size definition:

• DN/ND (nominal size)

• Standard – Pressure Rating (standard)

• Outer Diameter

• Inner Diameter

• Wall Thickness

• 2nd Size in Name (if you want the secondary size used in the name)

6. Click Apply Changes to save the new size definition or click Done to save the new size definition and close the Pipe 
Stock Catalog.

Create a ‘New Next Size’ Size Definition

To create a ‘New Next Size’ size definition:

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Select an existing size definition to use as a base for the ‘new next size’ size definition.

5. Click New Next Size to create a new size definition with the next available nominal size greater than the nominal size 
of the currently selected size definition, and with the same standard, pressure rating, outer diameter, inner diameter, 
and wall thickness as the currently selected size definition. 
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6. Click Apply Changes to save the new size definition or click Done to save the new size definition and close the Pipe 
Stock Catalog.

Edit a Size Definition

To edit a size definition

Note: Changing a size definition’s outer diameter or wall thickness will automatically change all pipe using the size 
definition.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Select the size definition you want to edit.

5. Set the values for the size definition.

6. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Delete a Size Definition

To delete a size definition

Note: You cannot delete a size definition that is currently in use by a pipe stock or end treatment. You must delete the 
pipe stock or end treatment before deleting the size definition.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Select the size definition you want to delete.

5. Click Delete.

6. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Filter Size Definitions
At the top of the catalog size definition list is the yellow filter row. This filter row lets you filter by any property in the size 
definition list to narrow down the number of size definitions that appear.

To filter by a property

1. Click on the filter row cell in the column that the filter should be applied for.

2. Enter a number, string, or any other characters to filter by.

Note: The filter row executes a contains filter. This means that if you filter using the string 13, you get hits for 13, 
133, Stock13, and any other string containing 13. 

3. Repeat Steps 1 and 2 to add additional filters to other columns to further narrow down the number of size definitions 
displayed.

Note: The filter is applied only to expanded nodes in the tree. 

More filtering options

• Under Units, select whether to show size definitions that are measured in Metric units, size definitions that are 
measured in Imperial units, or size definitions measured in Both metric and imperial units.
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• To change the order that size definitions are listed in the size definition list, click a column heading to order the 
list by that setting. (For example, to order the size definition list by outer diameter, click the Outer Diameter
column heading.) To reverse the order, click the column heading again.

Import Size Definitions
When you import pipe stock from another project, the stock’s associated size definitions are automatically imported with 
them. See Import Pipe Stock (page 36).

To import size definitions

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Click Import to open a File Browser.

5. Select a project file (*.PRO) or XML file (*.XML).

6. Click Open.

7. The Import Pipe Size Definitions from XML window appears, letting you select the size definitions (from the project or 
XML file) you want to import.

8. Check the Import box for the size definitions you want to import.

9. Click OK.

Export Size Definitions
Size definitions are exported to an XML file.

To export size definitions

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Size Definitions tab.

4. Check the Export check boxes for the size definitions you want to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.
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End Treatments
An end treatment is a definition of the end of a pipe or fitting. An end treatment consists of a nominal size, a type, several 
properties, and some geometric information that describes the end treatment. There is also the option to use the 
Secondary size, if defined, in the name.

Create an End Treatment Type
To make it easier to create and edit end treatments, you can set up end treatment types. An end treatment type has a 
name and icon (for display in linemode drawings and spool drawings) and can either be used for saddle stitch connection 
or not.

To create an end treatment type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click Treatment Types to open the Treatment Types window.

5. Click New.

A new end treatment type appears in the list.

6. Enter a name for the end treatment type.

7. In the LineMode Icon column, click and choose an icon type to show in linemode drawings (for example, spool 
drawings).

To create a new LineMode Icon type, click LineMode Icons to open the LineMode Icon window and click New. (For 
more information, see End Treatments (page 10).)

8. If you want the end treatment type to be used for a saddle stitch, o-let, or stub-in connection, check the check box for 
Is Saddle.

9. Click OK to close the Treatment Types window.

10. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Edit an End Treatment Type
You can edit the name of an end treatment type, the icon type to show in linemode drawings, and whether the end 
treatment can be used for saddle stitch, o-let, or stub-in connections.

To edit an end treatment type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click Treatment Types to open the Treatment Types window.

5. Edit the values for an end treatment type.

6. Click OK to close the Treatment Types window.

7. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Delete an End Treatment Type

To delete an end treatment type

Note: You cannot delete an end treatment type that is in use.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.
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3. Select the End Treatments tab.

4. Click Treatment Types to open the Treatment Types window.

5. Select the end treatment type you want to delete.

6. Click Delete.

7. Click OK to close the Treatment Types window.

8. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Create a LineMode Icon
Linemode icons are used for displaying end treatments when only centerlines are being drawn (e.g. in spool drawings). 
Example icons are shown below. These are actually half-icons; when pipes are connected the two halves form a full icon. 
For example, the circle linemode icon shows up as a semicircle on one end of a pipe, but when that pipe is connected to 
another pipe that has the same end treatment, a full circle is shown. The two half-icons are drawn flush to each other 
even when the end treatment geometry is not exactly flush (i.e. when connections have gaps or the two ends only meet 
within an angular tolerance).

 

Linemode icons, left to right: Vertical line, Filled Rectangle, Rectangle, None, Cross, Filled Circle, Circle, and Socket.

To create a linemode icon

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click LineMode Icons… or click Treatment Types to open the Treatment Types window and then click LineMode 
Icons… in the Treatment Types window to open the LineMode Icon window.

5. Click New.

A new linemode icon appears in the list.

6. Enter a name for the linemode icon and set the Fill check box and LineMode Icon drop-down menu for the new 
linemode icon.

7. Under Scale, set options for fixed or relative scale.

8. Click Done to save your changes and close the LineMode Icon window.

Edit a LineMode Icon
You can edit the name of the linemode icon, whether or not it should be filled, the type of icon to display, and how the 
icon should be scaled.

To edit a linemode icon

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click LineMode Icons… or click Treatment Types to open the Treatment Types window and then click LineMode 
Icons… in the Treatment Types window to open the LineMode Icon window.

5. Select the linemode icon you want to edit and change its Name, Fill, or LindeMode Icon in the list or change its 
scaling properties under Scale.

6. Click Done to save your changes and close the LineMode Icon window.
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Delete a LineMode Icon

To delete a linemode icon

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click LineMode Icons… or click Treatment Types to open the Treatment Types window and then click LineMode 
Icons… in the Treatment Types window to open the LineMode Icon window.

5. Select the linemode icon you want to delete in the LineMode Icons list.

6. Click Delete.

7. Click Done to save your changes and close the LineMode Icon window.

Set Up End Treatment Properties
You can enter extended data for an end treatment, such as flange type, class, or facing property, using three settings: 
general property, descriptive property, and facing property. You can also use these properties to specify thread type, pitch, 
class, and any other information that is required but not contained in other fields. 

To set up end treatment properties

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click Edit Properties to open the End Treatment Properties window.

5. To create a new general property, under General Properties click New and enter a name for the property.

To create a new descriptive property, under Desc. Properties click New and enter a name for the property.

To create a new facing property, under Facing Properties click New and enter a name for the property.

6. Click OK to close the End Treatment Properties window.

7. Click Apply Changes to save the change or Done to save the change and close the Pipe Stock Catalog.

Create an End Treatment
When creating an end treatment, you define an end treatment type, a nominal size, and geometric information about the 
end treatment, the type of geometry (box, cylinder, or cone), and the dimensions of the geometry. You can also define 
general, facing, and descriptive properties to provide further information about the end treatment.

To create an end treatment

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.
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3. Select the End Treatments tab.

4. Do one of the following:

• To create one end treatment, click New. (If you do not see the New button, click the down arrow beside New –
All Sizes or New – From Range and select New.)

• To create end treatments for a range of nominal sizes, click New – From Range. (If you do not see the New –
From Range button, click the down arrow beside New or New – All Sizes and select New – From Range.) The 
End Treatment Range window appears. Set the Min and Max values to specify the range of nominal sizes and 
then click OK.

• To create end treatments for all nominal sizes, click New – All Sizes. (If you don’t see the New – All Sizes button, 
click the down arrow beside New or New – From Range and select New – All Sizes.)

Tip: You can also right-click and choose New, New – From Range, or New – All Sizes.

The Edit End Treatments window appears listing the end treatments that will be created.

5. Set the values for the End Treatment Type, the Geometry, and A, B, and C to specify the size of the geometry type for 
each end treatment. (The images along the top of the window indicate the meaning of each value.) These values 
have no effect on the length or diameter of pipes or fittings; they are for display and interference checking purposes 
only. The General Property, Desc. Property, Facing Property, and 2nd Size in Name can also be set now.

Tip: Click the Fill Down check box to enable the Edit Endtreatments dialog’s fill down functionality, when enabled 
any change made to an end treatment will change the same property in all end treatments below the selected 
end treatment to the same value. This allows for quickly changing a large number of end treatments to have the 
same values.

6. Click OK to close the New End Treatment window.

The new end treatments are listed in the Pipe Stock Catalog.

7. Click Apply Changes to save the change or click Done to save the change and close the Pipe Stock Catalog.

Edit an End Treatment

To edit an end treatment

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

End treatments are grouped by nominal size.
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To filter the list of end treatments, under Filter select Metric, Imperial, or Both.

4. Select the end treatment or end treatments to edit and click Edit. The Edit End Treatments window appears listing 
the end treatments to be edited.

5. Edit the values for the end treatments as desired.

6. Click OK to close the Edit End Treatment window.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Note: Editing the non-geometric properties of “In Use” stocks is now possible. To do this you require the Edit In-Use 
Stock Non-Geometric Properties permission under Pipe->Manager in the User Permissions dialog. Changes made to 
stocks that are in use in production drawings will cause the production drawings to be flagged as out of date.

Delete an End Treatment

To delete an end treatment

Note: You cannot delete an end treatment that is in use by a connection or stock item.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

End treatments are grouped by nominal size.

To filter the list of end treatments, under Filter select Metric, Imperial, or Both.

4. Select the end treatment you want to delete.

5. Click Delete.

6. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Usage Log
The Usage Log button on the End Treatments tab generates a log file detailing all of the different stocks using the 
selected end treatment.

To create a usage log

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Select the end treatment you want to create a usage log for.

5. Click Usage Log, a text file will be created, and displayed in your computer’s default .txt file editor, detailing which 
stocks are using the selected end treatment.

Filter End Treatments
At the top of the catalog end treatment list is the yellow filter row. This filter row lets you filter by any property in the end 
treatment list to narrow down the number of end treatments displayed.

To filter by a property

1. Click on the filter row cell in the column that the filter should be applied for.

2. Enter a number, string, or any other characters to filter by.

Note: The filter row executes a contains filter. This means if you filter using the string 13, you get hits for 13, 133, 
Stock13, and any other string containing 13. 
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3. Repeat Steps 1 and 2 to add additional filters to other columns to further narrow down the number of end 
treatments displayed.

Note: The filter is applied only to expanded nodes in the tree. 

More filtering options

• Under Units, select whether to show only end treatments that are measured in Metric units, end treatments that 
are measured in Imperial units, or end treatments measured in Both metric and imperial units.

• To change the order that end treatments are listed in the end treatment list, click a column heading to order the 
list by that setting. (For example, to order the end treatment list by geometry, click the Geometry column 
heading.) To reverse the order, click the column heading again.

Import End Treatments
When you import pipe stock from another project, the stock’s associated end treatments are automatically imported. See 
Import Pipe Stock (page 36).

To import end treatments

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the End Treatments tab.

4. Click Import to open a File Browser.

5. Select a project file (*.PRO) or XML file (*.XML).

6. Click Open.

7. The Import Pipe End Treatments from XML window appears, letting you select the end treatments you want to 
import.

8. Check the Import box for the end treatments you want to import.

9. Click OK.

Export End Treatments

To export end treatments

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.
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3. Select the End Treatments tab.

4. Check the Export check boxes for the end treatments you want to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.

Specifications
A specification, or spec, is a collection of stocks. You typically use specs as a way of limiting the stocks that designers can 
use. For example, you can create a spec for each pipe system. Each spec would contain only the stocks that you want 
used for that system. Whenever designers are working on that system, they can only choose stocks from the associated 
spec.

Create a Spec

To create a spec

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Specs to open the Pipe Specs window.

5. Click New.

6. Enter a name and, optionally, a description for the spec and then press Enter.

7. Click OK to close the Pipe Specs window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.
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Delete a Spec

To delete a spec

Note: You cannot delete a spec that contains catalog stocks.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Specs to open the Pipe Specs window.

5. Select the spec you want to delete.

6. Click Delete.

7. Click OK to close the Pipe Specs window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Spec

To edit a spec

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Specs to open the Pipe Specs window.

5. Double-click the name or description of the spec you want to edit and enter a new value.

6. Click OK to close the Pipe Specs window.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Catalogs
A catalog is a collection of pipe stocks, similar to the physical catalog of a supplier that you purchase pipe stock from. By 
setting up catalogs of pipe stock in ShipConstructor, you can reproduce your supplier’s physical catalogs or categorize 
pipe stock into logical groups, such as carbon steel.

Create a Catalog

To create a catalog

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Catalogs to open the Pipe Catalogs window.
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5. Click New.

6. Enter a name and, optionally, a description for the catalog and press Enter.

7. Click OK to close the Pipe Catalogs window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Delete a Catalog

Note: You cannot delete a catalog that contains stocks.

To delete a catalog

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Catalogs to open the Pipe Catalogs window.

5. Select the catalog you want to delete.

6. Click Delete.

7. Click OK to close the Pipe Catalogs window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Catalog

To edit a catalog

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Edit Catalogs to open the Pipe Catalogs window.

5. Double-click the name or description of the catalog you want to edit and enter a new value.

6. Click OK to close the Pipe Catalogs window.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Manufacturers
See Manufacturers in the Structure manual.
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Materials
See Materials in the Structure manual.

Pipe Stock
A pipe stock is a standard pipe or fitting that you are able to purchase or manufacture and that you want to use in your 
project.

Filter Pipe Stocks
At the top of the catalog stock list is the yellow filter row. This filter row lets you filter by any property in the stock list to 
narrow down the number of stocks displayed.

To filter by a property

1. Click on the filter row cell in the column that the filter should be applied for.

2. Enter a number, string, or any other characters to filter by.

Note: The filter row executes a contains filter. This means that if you filter using the string 13, you get hits for 13, 
133, Stock13, and any other string containing 13. 

3. Repeat Steps 1 and 2 to add additional filters to other columns to further narrow down the number of stocks 
displayed.

Note: The filter is applied only to expanded nodes in the tree. 

More filtering options

• Under Units, select whether to show only stocks that are measured in Metric units, stocks that are measured in 
Imperial units, or stocks measured in Both metric and imperial units.

• To change the order that stocks are listed in the stock list, click a column heading to order the list by that 
setting. (For example, to order the stock list by weight, click the Weight column heading.) To reverse the order, 
click the column heading again.

Create a Stock

To create a stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

Pipe stocks are grouped by type.

4. Select the type of pipe stock you want to create (for example, Pipe, Elbow, or Cross) or select a pipe stock of the type 
you want to create.

5. Click New.

6. Enter a name for the pipe stock and press Enter.

7. Set the pipe stock properties (see below).

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Common Properties

Stock Name
The name of the stock. You can enter any name you want. The name is what you will see most often when modeling and 
selecting items to add to the model and in your BOMs. When editing a stock in the Edit Stock window, you can click in the 
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name cell and bring up a list of the currently defined naming conventions that are valid for the stock type. Choosing one 
of the naming conventions in the list will generate a name for the stock based on the selected naming convention.

Schedule
The stock’s schedule or pressure rating.

Description
A full description of the stock.

Material
The material grade that the stock is made of.

Manufacturer
The manufacturer that produces the stock.

Additional Thickness
Adds external thickness to the pipes and fittings using the Outer Diameter as defined in the Size Definitions tab. In some 
cases this may not be the correct outside diameter for the fitting. For example, a coupling generally has an outside 
diameter greater than that of the pipe. To make sure the coupling is the right size, extra material thickness can be added.

Weight
The weight of the stock. For straight pipes the units are weight per foot and weight per meter, depending whether the 
stock is being viewed with metric or imperial properties.

Wet Weight
The weight of the stock when filled with fluid. Wet weight applies to all stock types except for straight pipes.

End N Treatment
The end treatment for the Nth end of the stock. When you select the end treatment for a given end, you will also be 
required to select an end treatment size definition for the end. Select the definition using the end treatment drop-down 
tree-control, which lists end treatments organized by end treatment type, nominal size, end treatment, and then size 
definitions. The listing of size definitions below the end treatment provides you with a method of setting a size definition 
for the end other than the size definition of the stock itself. This is necessary for representing some types of stocks. The 
end treatments and size definitions available to a given stock depend on the stock type and the size definition of the 
stock. You will find details of what end treatments are available for a given stock type under the Properties listing for the 
specific type.

Tip: End Treatments in the Pipe Stock Grid and Pipe Stock Edit dialogs now “Fill Down”, this means that when 
changing an end treatment all further ends of the stock are changed to the same value. For example if the 2nd end of 
a cross is changed to a PL 2” end treatment, the 3rd and 4th ends of the cross will also be changed to the same PL 2” 
end treatment, but the 1st end will be unchanged.

Custom Attributes
User defined attributes, set up in Manager, appear last in the stock edit dialog. User defined attributes also appear in the 
pipe stock grid at the end of the stock property columns, in the stock grid the properties are not editable but can be 
filtered or sorted against.

Tip: User defined attributes are also available in the Select Stock dialog when creating a pipe part, this allows for 
filtering and sorting based on the attributes, making finding the right stock easier.

Preview Control
The preview window will display the abbreviations of each end by the corresponding end. This allows the user to easily 
determine which ends need modifying and which end is being modified.
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Branch Properties

See Common Properties (page 19) for a description of properties common to all stock types.

End Treatments
Branch end treatments are constrained so that End 1 must have an end treatment with a nominal size equal to the 
nominal size of the schedule of the stock, and Ends 2 and 3 must have end treatments with nominal sizes equal to or 
less than the nominal size of the schedule of the stock.

End 1, 2, and 3 Length
The lengths measured from the intersection of the three centerline axes to the end faces.

End 1, 2, and 3 Trimmable
A flag indicating whether or not the given end can be trimmed back.

Angle A and Angle B
Angle A defines the total swept angle from End 1 to End 2, and Angle B defines the total swept angle from End 1 to End 
3.
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Cap Properties

See Common Properties (page 19) for a description of properties common to all stock types.

Cap Type
The cap type defines how the geometry, specifically the Flat Length, of the cap is interpreted. The available cap types are 
Round, Square Plug, and Recessed Square.

End Treatment
The end treatment of the cap must have the same nominal size as the schedule of the stock.

Length
The length of the cap from base to end, not including the flat length.

Flat Length
The flat length defines the height or depth, relative to the end of the cap, for the plug in square plug and recessed square 
caps.
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Connector Properties

See Common Properties (page 19) for a description of properties common to all stock types.

Length
The length is the overall length of the connector. The end treatments draw themselves inward.

End 1 and 2 Treatment
Connector end treatments are constrained so that the end treatments for both ends must have the same nominal size as 
the nominal size of the schedule of the stock. The only exception to this is the adapter connector type, which has no 
restrictions on which end treatments can be assigned to which ends.
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Cross Properties

See Common Properties (page 19) for a description of properties common to all stock types.

End Treatments
The end treatments for a cross are constrained so that End 1 must have an end treatment with the same nominal size as 
the nominal size of the schedule of the stock, while Ends 2, 3, and 4 can have end treatments with a nominal size less 
than or equal to that of the schedule of the stock.

End 1, 2, 3, and 4 Length
The lengths measure from the intersection of the four centerline axes to the end faces.

End 1, 2, 3, and 4 Trimmable
A flag indicating whether or not the given end can be trimmed back.
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Elbow Properties

See Common Properties (page 19) for a description of properties common to all stock types.

End Treatments
Elbow end treatments are constrained so that End 1 must have an end treatment with the same nominal size as the 
schedule of the stock, while End 2 can have a nominal size less than or equal to the nominal size of the schedule of the 
stock. Assigning End 2 an end treatment with a smaller nominal size than the schedule of the stock makes it possible to 
create reducing elbows.

End 1 and End 2 Total Length
Total length measures the length of the elbow from the intersection of the two centerline axes to the end of the elbow 
including any additional straight length.

Note: Since the intersection of the two centerline axes becomes much further away as the angle increases past 90 
degrees, when the angle of the corner is greater than 90 degrees then the end lengths are calculated as if the angle 
was 90 degrees.

Tip: Elbow geometry is linked, modifying one geometric property will cause changes in the other geometric properties 
of the elbow. Increasing total length results in gains to the straight length value of the given end, decreasing total 
length will result in decreases in the straight length and if necessary changes to the elbow’s radius, which will in turn 
result in changes to the other end’s total length and/or straight length as necessary to match the new radius. If you 
want increases in total length to affect the radius of the elbow instead of the straight length of the end, check the 
Minimize Straight Length check-box. Changes to the radius property will affect straight length of the ends first, and 
then if necessary it may also affect the total length values.
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End 1 and End 2 Straight Length
Straight length is the length that is added to the given end of the elbow, measured from the face of the end.

Radius
The radius of the elbow. The radius cannot exceed either of the end lengths.

Radius (x Nominal Size)
The radius defined as a multiple of the nominal size of the elbow.

Minimize Straight Length
Checking the Minimize Straight Length check-box changes the way geometric values react to each other when you make 
changes to them. The straight length values of the elbow will never be increased when this is checked, this means that 
you can change the angle or total end length values and the radius will be changed to automatically to match instead of 
the straight length being changed, this allows elbow geometry to be defined using just angle and end length values.

Angle
The total swept angle of the elbow. Valid angles are between 0° and 360°.

Number of Segments
The number of segments used for modeling the bent section of the elbow. You can create a mitered elbow by setting the 
number of segments to a value greater than one.

End 1 and End 2 Trimmable
A flag indicating whether or not the given end can be trimmed back.

Pipe Properties
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See Common Properties (page 19) for a description of properties common to all stock types.

End Treatments
Both ends of a pipe stock are constrained so that the nominal size of the end treatments must be equal to the nominal 
size of the stock’s schedule.

You can also specify generic end treatments for pipe stocks. To do this add allowable end treatments to existing stocks 
by clicking the End Types button and selecting end treatment types in the dialog that is shown. The end treatments that 
are then available to be applied to parts using this stock are any that are of a type that was added and that the nominal 
size matches the schedule of the stock. The End Types button is only enabled when a straight pipe stock is selected. The 
two figures below show how to add allowable end treatments to pipe stocks.
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Min and Max Length
The minimum and maximum length the stock can be purchased or handled. For straight pipe, the minimum length must 
be less than the maximum length. When you are placing pipes, ShipConstructor takes these lengths into account 
(preventing you from placing pipes that are less than the minimum length or greater than the maximum length).

Minimum Usable Remnant
This value is the minimum length that a piece of leftover pipe must be to be considered reusable.

Reducer Properties

See Common Properties (page 19) for a description of properties common to all stock types.

End Treatments
The ends of a reducer stock are constrained so that End 1 must have an end treatment with a nominal size equal to that 
of the stock’s schedule, and End 2 must have an end treatment with a nominal size less than the nominal size of the 
schedule of the stock.

Offset
The offset makes it possible for the user to create eccentric reducers. That is, reducers with the centerline of the pipe at 
one end offset from the centerline of the pipe at the other end.

Transition Length
The length of the body of the reducer or the length of the reducing section of the reducer. This does not include the 
lengths of the two ends.
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End 1 and End 2 Length
The length of the specified end of the reducer measured from the face of the end of the reducer corresponding to the end 
number.

Valve Properties

See Common Properties (page 19) for a description of properties common to all stock types.

A valve consists of two or three ends and a handle. Each end is defined by a cone where the base of the cone is the 
opening of the end and the tip of the cone is the start point of the end. Everything cons The opening of End 1 is 
considered the origin of all points in the valve. The start point of End 2 is always coincident with the start point of End 1. 

End 1, 2, and 3 Length
The length of each valve end from its opening to the center of the valve, where the ends meet.

End 2 and End 3 Theta
End 2 Theta is the angle between the centerline of End 1 and the centerline of End 2. If there is an End 3 in the valve, its 
centerline will also connect to the centerline of End 1 and provide End 3 Theta.

End 3 Phi
The angle for End 2 will always rotate in the plane of the valve. Because a third end can be in a different plane from the 
first two ends, End 3 must be defined by two angles. End 3 Phi is the angle that End 3 centreline rotates about the 
centerline of End 1. 
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End 3 Position
End 1 and End 2 will always have a coincident start point. End 3 is not as constrained. End 3 start point is measured 
along the centerline of End 1 a distance from the valve origin (the opening of End 1).

Handle Type
The handle types in ShipConstructor are defined by individual users. For each valve in a drawing, you pick a handle type 
from the drop-down menu.

Handle Position
To position the handle of the valve, you must enter a length that starts at the valve origin and runs along the centerline of
End 1.

Handle Theta
Like Ends 2 and 3 Theta, the centerline of the valve handle will form an angle with the centerline of End 1, rotating in the 
plane of the valve.

Handle Phi
Like End 3, the handle direction must be defined by two angles. Handle Phi is the angle formed between the centerline of 
the handle and the centerline of End 1 rotated about the centerline of End 1.

Handle Rotation
If the handle has more than a simple stem, it has a rotation. If the handle is not symmetrical about the stem, the handle 
rotation is defined as the handle’s rotation about handle axis or stem.

CG Point (X, Y, Z)
Each valve will have a different centre of gravity (CG) depending on the physical properties of the valve. The CG is 
measured from valve origin, and the information might be found in your parts catalog. If you cannot find a CG for your 
valve, create a value based on your valve’s density and weight.

Create a ‘New Next Size’ Stock

To create a ‘New Next Size’ stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Select the desired base stock from the Stocks Grid.

5. Click New Next Size to create a stock based on the currently selected stock but with the next available size definition 
and the next available sizes for each end of the stock. All other end treatment information (Treatment Type, General 
Prop., etc) are maintained as closely as possible, if they cannot be maintained no new stock will be created and an 
error will notify the user of the problem.

6. Enter a name for the new stock.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Valve Handles

Create a Valve Handle

To create a valve handle

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Valve Handles to open the Valve Handle Editor.

5. Select the desired valve handle type from the Valve Handles grid and click New.
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6. Enter a name for the valve handle and set the properties A – H and the angles A and B to values appropriate for the 
handle type you are creating.

7. Click OK to close the Valve Handles window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Valve Handle

To edit a valve handle

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Valve Handles to open the Valve Handle Editor.

5. Select the desired valve handle from the Valve Handles grid.

6. Modify the valve handle’s properties in the Handle Properties grid.

7. Click OK to close the Valve Handles window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Delete a Valve Handle

To delete a valve handle

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Valve Handles to open the Valve Handle Editor.

5. Select the desired valve handle from the Valve Handles grid.

6. Click Delete to delete the selected valve handle.

7. Click OK to close the Valve Handles window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Valve Type

To edit a valve type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Valve Types to open the Valve Types window.

5. Select a valve type you want to edit and change its draw icon using the drop-down list on the right.

6. Click OK to close the Valve Types window.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Create a Valve Handle 2D drawing

To create a valve handle 2D Drawing

1. Create a new AutoCAD drawing file.

2. Draw the geometry that will be used to represent the valve handle in a spool drawing.

a. The handle geometry starts at the origin.

b. The handle geometry must be drawn in the XY plane.
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c. The handle will be drawn in the Y direction.

d. When the geometry is inserted into a spool drawing it will be scaled based on the length of the handle.

3. Save the drawing file to a known location.

4. Choose ShipConstructor > Manager to open Manager.

5. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

6. Select the Create/Edit Pipe tab.

7. Click Valve Handles to open the Valve Handle Editor.

8. Select the desired valve handle type from the Valve Handles grid.

9. Select the 2D Geometry row.

10. Click the import button. 

11. Select the saved drawing file.

a. The 2D Geometry row will display <LOADED> to indicate that a drawing file has been loaded.

b. The drawing will be stored in the database. Changes to the drawing file will not affect the geometry of the 
icon unless the file is imported again.

c. All valve handles of the same type will use the same 2D geometry.

Edit a Valve Handle 2D Drawing

To edit a valve handle 2D drawing

1. Open a drawing file containing the geometry to use for the valve handle

2. Make the necessary changes to the geometry.

a. Must start at the origin, drawn in the XY plane, with the handle direction in the Y direction.

3. Save the drawing file to a known location.

4. Choose ShipConstructor > Manager to open Manager.

5. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

6. Select the Create/Edit Pipe tab.

7. Click Valve Handles to open the Valve Handle Editor.

8. Select the desired valve handle type from the Valve Handles grid.

9. Select the 2D Geometry row.

10. Click the import button.

11. Select the saved geometry file.

12. The handle icon will be updated in the drawings where it is used the next time the drawing is opened or when an 
update is performed on the drawing

Deleting a Valve Handle 2D Drawing

To delete a valve handle 2D drawing

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Valve Handles to open the Valve Handle Editor.

5. Select the desired valve handle type from the Valve Handles grid.

6. Select the 2D Geometry row.

7. Click the delete button. 
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a. The 2D Geometry row will display <NONE> to indicate that no valve handle drawing has been loaded.

Add or Remove Pipe Stocks To or From a Spec

To add or remove a stock to and from a spec

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Select the stocks you want to add or remove to or from a spec.

5. Click Assign To Spec to open the Assign To Spec window.

6. Under Assign, check the check box for the specs that you want to add the stocks to. Uncheck the check box for the 
specs to remove the stocks from.

7. Click OK to close the Assign To Spec window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Add or Remove Pipe Stocks To or From a Catalog

To add or remove a stock to and from a catalog

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Select the stocks you want to add or remove to or from a catalog.

5. Click Assign To Cat. to open the Assign To Catalog window.

6. Under Assign, check the check box for the catalogs that you want to add the stocks to. Uncheck the check box for the 
catalogs to remove the stocks from.

7. Click OK to close the Assign To Catalog window.

8. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Pipe Stock

To edit a pipe stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Edit the values of any stocks or select the desired stock and click Edit to bring up the Edit Stock window.

5. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Note: Stock end treatments now “fill over”, so changing an end treatment will change the stocks subsequent end 
treatments to match.

Note: Editing the non-geometric properties of “In Use” stocks is now possible. To do this you require the Edit In-Use 
Stock Non-Geometric Properties permission under Pipe->Manager in the User Permissions dialog. Changes made to 
stocks that are in use in production drawings will cause the production drawings to be flagged as out of date.
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Change Stock Subtype
This feature allows for stocks of a given sub-type to be changed to any other sub-type with the same parent type. This 
means any branch stock can be changed to any of the branch stock sub-types; Lateral, Misc, Tee, or Wye, this allow 
applies to Connector and Valve types.

To change a stock’s subtype

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Select the stock or stocks to have their subtype changed.

5. Click the right mouse button over one of the selected stocks to access the context menu.

6. Select the Change Subtype menu option and click on the subtype to change the stocks to.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Stock Usage
This powerful feature lets you easily find all part instances that are using a certain stock. In addition to creating a report 
where the stock is used, you can interactively open drawings and inspect the parts using the selected stock. 

To check stock usage

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab. 

4. Select a stock that is in use.

5. Click Stock Usage. The Drawings using stock window appears.
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6. All drawings that contain parts using this stock you selected are listed.

7. Select a drawing node and double-click or click the Open Drawing button to open the drawing. The Parts using stock
window appears.
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8. You can inspect the parts in the drawing by clicking on the part in the window. Click OK to close the drawing and 
return to the Drawings using stock window.

To create a stock usage log

1. Open the Drawings using stock window.

2. Click Create Log. A log file summarizing where the stock is used is created and displayed. The log file is stored in the 
LogFiles / Pipe / Stock Usage folder.

Import Pipe Stock
You can import pipe stock from another project. You can also set up pipe stock in an XML file (using Export XML) and 
import the XML file into ShipConstructor.

To import pipe stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Click Import to open a File Browser.

5. Select a project file (*.PRO) or XML file (*.XML).

6. Click Open.

7. The Import Pipe Stock from XML window appears, letting you select the pipe stocks you want to import.
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8. Check the Import check box for each stock that you want to import.

9. Click OK.

Set Up Pipe Stock in an XML File (Using XML)

To set up pipe stock in an XML file (using XML)

1. Use the schema http://www.shipconstructor.com/XMLSchemas/ARLLibraryV2.32.xsd and generate an XML file 
conforming to the schema containing the desired pipe stocks.

Export Pipe Stock

To export pipe stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Create/Edit Pipe tab.

4. Check the Export check boxes for the pipe stocks to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.

Accessory Packages
An accessory package is a collection of accessories (for example, nuts, bolts, gaskets, and washers) that accompany a 
penetration package, a pipe hanger, a pipe connection, or an HVAC connection. Accessory packages are not displayed in 
drawings but are listed in BOMs and reports.

When setting up accessory packages, you first define accessory types. Accessory types are groups or categories of similar 
types of accessories. For example, you can define an accessory type named bolts. After defining accessory types, you can 
then define specific accessories. Finally, you create accessory packages and add accessories to them.

Create an Accessory Type

To create an accessory type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, click New Type to create a new accessory type.

4. Enter a name for the accessory type (for example, Bolts, Gaskets, Nuts, or Washers) and press Enter.
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Create an Accessory Package

To create an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory package you want to create.

4. Click New to create a new accessory package.

5. Enter a name for the accessory package and press Enter.

Create an Accessory

To create an accessory

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, select the accessory type.

4. Click New Acces. to create a new accessory of the selected type.

Note: The New Access. button changes to the name of the selected accessory type.

5. Enter a name for the accessory and press Enter.

6. Enter a Description and Weight for the accessory.

Copy an Accessory Package

To copy an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.
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4. Select the accessory package you want to copy.

5. Click Copy to copy the accessory package.

6. Enter a name for the copied accessory package and press Enter.

Delete an Accessory Package

To delete an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to delete.

5. Click Delete to delete the accessory package.

Delete an Accessory or Accessory Type

To delete an accessory or accessory type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Under Accessories, select the accessory or accessory type that you want to delete.

4. Click Delete.

Add or Remove an Accessory To or From an Accessory Package

To add or remove an accessory to or from an accessory package

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to add or remove an accessory to or from.

Accessories that currently belong to the accessory package are listed under Spec Filter.

5. To add an accessory to the accessory package, under Accessories select the desired accessory and click Add.

Note: To add several of the same type of accessory, add the accessory once and set the Qty value.

To remove an accessory from the accessory package, under Spec Filter select the desired accessory and click 
Remove.

Add or Remove an Accessory Package To or From a Spec

To add or remove an accessory package to or from a spec

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.
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Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Select the accessory package you want to add or remove to or from a spec.

5. Click Assign Spec to open the Accessory Package Specs window.

6. Check the check box of the specs you want to add the accessory package to.

To remove an accessory package from a spec, uncheck its check box.

7. Click OK to close the Accessory Package Specs window.

Import Accessory Packages
You can import accessory packages from another project or from an XML file that was exported from another project.

To import accessory packages

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

6. Click OK to close the Accessory Packages window.

Export Accessory Packages
You can export accessory packages to an XML file (for example, to import into another project or to edit using other 
software).

To export accessory packages

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Accessory Packages to open the Accessory Packages window.

3. Set Type to the type of accessory packages you want to list.

Tip: Use the Spec Filter to filter the lists under Accessory Packages by spec.

4. Check the Export check boxes for the accessory packages you want to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.

8. Click OK to close the Accessory Packages window.

Connections
A pipe connection is a definition of how two end treatments from two different pipes can connect together. Pipe 
connections let you control the types of connections possible between pipe entities, making it faster for modelers to 
connect pipe and modify connected pipes with fewer errors.

A pipe connection consists of the following information:

• The type of end treatment for each connecting pipe

• Whether there is a gap or overlap between connecting pipes

• The display properties of the connection (how it appears in drawings)
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Physical Property -Gap

Connection Connection Accessory Package
Used for grouping related Accessories together.

End Treatment 2End Treatment 1

Display Properties
e.g. Connection Icon

Connection Accessories
e.g. Bolts and gaskets for flanged connections.

A connection can also have any number of accessory packages associated with it. See Accessory Packages (page 37) for 
details.

Create a Connection Type
Start by creating the connection types that will define your connections.

To create a connection type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Click the Connections tab.

4. Click New Type.

If you do not see the New Type button, click the down arrow beside the New Connection button and select New Type.

Tip: You can also create a new connection type by double-clicking * <New Type> in the list of connections.

5. Enter a name for the connection type and press Enter.

6. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Create a Connection

To create a connection

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Connections tab.

4. Select the type of connection you want to create or select a connection of the type you want to create.

5. Click New Connection.
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If you do not see the New Connection button, click the down arrow beside the New Type button and select New 
Connection.

Tip: You can also create a new connection by double-clicking * <New Connection> in the list of connections.

6. Set the connection properties:

• End Treatment 1, End Treatment 2 – The two end treatments required to make the connection.

• Gap – The distance between the ends of the two pipes or fittings. A positive value indicates a gap; a negative 
value indicates an overlap. For example, a butt weld connection might require a gap of 0.125” for welding, a 
flanged connection might require a gap of 0.25” to accommodate a gasket 0.25” in thickness, and a slip-on 
flange needs to slide over the plain end of a pipe by -1.25”.

• Angular Tolerance – The maximum allowable angle between the axes of the two pipes or fittings.

7. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Create a ‘New Next Size’ Connection

To create a ‘New Next Size’ connection

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Connections tab.

4. Select the connection you want to use as the base for the new connection.

5. Click New Next Size and a new connection with the next available end treatment sizes is created. The size difference 
between the end treatments, as well as the specific end treatment types, are maintained.

6. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Edit a Connection

To edit a connection

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Connections tab.

4. Select the connection you want to edit.

5. Change the desired values of the connection.

Note: changing End Treatment 1 in a connection will automatically change End Treatment 2 to match the new value 
of End Treatment 1.

6. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.

Delete a Connection or Connection Type

To delete a connection or connection type

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Select the Connections tab.

4. Select the connection or connection type you want to delete.

5. Click Delete.

6. Click Apply Changes to save the changes or Done to save the changes and close the Pipe Stock Catalog.
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Add an Accessory Package To a Connection
A connection can have any number of associated accessory packages. When modeling pipe and inserting a connection, 
ShipConstructor prompts you to select an accessory package from a list of possible accessory packages for that 
connection. For information on creating and editing accessory packages, see Accessory Packages (page 37).

To add an accessory package to a connection

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Click the Connections tab.

4. Select the connection you want.

5. Click Add to open the Select Accessory Packages window.

6. Check the check box for the accessory packages you want to add to the connection.

7. Click OK to close the Select Accessory Packages window.

The accessory packages are listed under Connection Accessories.

Note: You can add the same accessory package to a connection more than once, as long as each accessory 
package belongs to a different spec.

Remove an Accessory Package From a Connection

Note: You cannot remove an accessory package from a connection that is in use. If you try, a warning message and a 
report listing the drawings and pipe entities using the connection appear. Before you can remove the accessory 
package from the connection, you must first break the connection between the pipe entities. See Disconnect Pipes
(page 124).

To remove an accessory package from a connection

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Click the Connections tab.

4. Select the desired connection.

5. Under Connection Accessories, select the accessory package you want to remove.

6. Click Remove.

Import Connections

To import connections

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Click the Connections tab.

4. Click Import to open a File Browser.

5. Select a project file (*.PRO) or XML file (*.XML).

6. Click Open.

Note: When importing connections, you can optionally import their accessory packages and the package's related 
specs. When you choose this option, the accessory package is automatically reassigned to the related spec in the 
destination database.
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Export Connections

To export connections

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Stock Catalog to open the Pipe Stock Catalog.

3. Click the Connections tab.

4. Check the Export check boxes for the connections you want to export.

5. Click Export XML to open a File Browser.

6. Enter a name for the XML file.

7. Click Save.

Auto-Part Insertion Setup
To use the Auto Part Insertion Mode (page 102) (AP mode) tools to their full potential, several important 
considerations need to be made when setting up a projects catalog. The stocks and allowable connections need to be 
very well defined with no unnecessary allowable connections.

Stock Setup
When setting up stocks for the AP the main thing to consider is to keep ambiguities to a minimum. Ideally, there 
should be only one connector or reducer with a given pair of end treatments. Having more than one with a given pair 
leads to multiple solutions when the system is attempting to decide which parts to add to the model to facilitate 
connections. Also adding unneeded allowable end treatment types to generic pipes could potentially limit the AP’s 
usefulness.

Allowable Connection Setup
The most important part of catalog setup is the allowable connections. These should be kept to a minimum and be 
tightly constrained. For each end treatment, keep the number of allowable connections to a minimum to prevent 
multiple solutions. Every extra allowable connection using an end treatment adds another branch to possible 
solutions.

Pipe Bending Machines
You must create pipe bending machines to use for your project and give them capabilities. This is done in Manager. 
Creating and defining a pipe bending machine constrains what bending can be done for your projects. All limitations you 
want to impose are created here.

Create a Pipe Bending Machine

To create a pipe bending machine

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.
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3. Click New to open the Bending Machine window.

4. Enter a Name and Description for the pipe bending machine and set the Type and Units (the units you will use later 
to specify values for this pipe bending machine). See Pipe > Pipe Benders (page 217) for details.

5. Click OK to close the Bending Machine window.

Edit a Pipe Bending Machine

To edit a pipe bending machine

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine you want to edit.

4. Click the button to the right of the pipe bending machine name to open the Pipe Bending Machine window.

5. Edit the settings.

6. Click OK to close the Pipe Bending Machine window.

Delete a Pipe Bending Machine
You can remove a pipe bending maching from the list of options in the Pipe Bending Machines window.

To delete a pipe bending machine

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine you want to delete.

4. Click Delete.
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Add a Size Definition to a Pipe Bending Machine’s Bender Information

To add a size definition to a pipe bending machine’s bending information

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine from the Pipe Bending/Cutting Machines list.

4. Select a size definition from the Size Definitions list.

Click Add under Bending Information.

The Bender Size Definition Settings window appears.

5. Set the values for the size definition.

You can specify the Centerline Radius as a multiple of the nominal size (Size Multiplier) or as a fixed value (Fixed 
Radius).

6. Click OK to close the Bender Size Definition Settings window.

The size definition settings appear under Pipe Bender Schedule Settings.

Edit Pipe Bending Machine’s Bender Information Size Definition Settings

To edit a pipe bending machine’s bender information size definition settings

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine from the Pipe Bending/Cutting Machines list.

4. Select the size definition setting you want to edit under Bender Information.

5. Click Edit to open the Bender Size Definition Settings window.

6. Set the new values.

7. Click OK to close the Bender Size Definition Settings window.

Remove a Size Definition Setting From a Pipe Bending Machine’s Bender Information

To remove a size definition from a pipe bending machine’s cutting information

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.
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3. Select the pipe bending machine you want from the Pipe Bending Machines list.

4. Select the size definition setting you want to remove under Pipe Bender Schedule Settings.

5. Click Remove.

Add a Size Definition to a Pipe Bending Machine’s Cutting Information

To add a size definition to a pipe bending machine’s cutting information

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine you want from the Pipe Bending/Cutting Machines list.

4. Select a size definition you want to add from the Size Definitions list.

5. Click Add under Cutting Information.

6. Set the Kerf value.

7. Click OK to save your changes and close the Pipe Bending/Cutting Machines window.

Edit Pipe Bending Machine’s Cutting Information Size Definition Settings

To edit a pipe bending machine’s cutting information size definition settings

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine you want from the Pipe Bending/Cutting Machines list.

4. Select the cutting information entry you want to change from the Cutting Information list.

5. Change the Cutting Information values as desired.

6. Click OK to save your changes and close the Pipe Bending/Cutting Machines window.

Remove a Size Definition Setting From a Pipe Bending Machine’s Cutting Information

To remove a pipe bending machine’s cutting information size definition setting.

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine from the Pipe Bending/Cutting Machines list.

4. Select the cutting information entry you want to remove.

5. Click Remove under Cutting Information.

6. Click OK to save your changes and close the Pipe Bending/Cutting Machines window.

Delete a Pipe Bending Machine

To delete a pipe bending machine

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Select the pipe bending machine from the Pipe Bending/Cutting Machines list.

4. Click Delete.

Import Pipe Bending Machines
You can import pipe bending machines from another project or from an XML file exported from another project.
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To import pipe bending machines

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

Export Pipe Bending Machines
You can export pipe bending machines to an XML file (for example, to import into another project or to edit using other 
software).

To export pipe bending machines

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Pipe Benders to open the Pipe Bending/Cutting Machines window.

3. Check the Export check boxes for the pipe bending machines you want to export.

4. Click Export XML to open a File Browser.

5. Enter a name for the XML file.

6. Click Save.

User-Defined Attributes
See User-Defined Attributes in the Structure manual.

Excel Pipe Library Editor (“Flatsheet”)

Overview
Some users find it easiest to edit their pipe stock catalogs in Excel. To facilitate this, we provide an Excel document that 
will import and export XML files compatible with ShipConstructor’s Manager.

Excel is quite powerful and allows the user to define the stocks using formulae.
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Getting Started
To import a pipe stock library, select the Help tab and click on the Import XML File button. Then select the desired file. 
This file should have been created by ShipConstructor or the Excel sheet. Importing will overwrite the contents of the 
workbook. To get a feel for how this works, try loading one of the Pipe Catalogs that are installed with ShipConstructor.
They are located in C:\Program Files\ShipConstructor2009\ProjectTemplates\

To save the pipe stock library to XML, select the Help tab and click on the Export XML File button. Then select the desired 
location and file name. The resulting file can then be imported into ShipConstructor in Manager.

The Help Tab
The Import XML File button loads a dialog which allows you to select an XML file to load. Importing will overwrite the 
contents of the workbook.

The Export XML File button launches a dialog which allows you to select a location and name for the exported file. That 
file can then be imported into ShipConstructor using Manager.

When the Verify XML checkbox is enabled the validity of the XML files will be verified. This is generally recommended
however for very large files it can take a prohibitive amount of time.

The Clear All Worksheets button will clear the data from the workbook. It launches a verification dialog. In this dialog a 
checkbox allows you to clear hidden tabs (see below for details on hidden tabs).

The Revive Workbook button is sometimes necessary if an error occurs while importing or exporting. The most common 
symptom is that the generated and derived columns will cease updating. If this happens, click on the Revive Workbook
button and normal behavior should resume.

There is an option to hide the units in Size Definition names. ShipConstructor displays the units, so we default this to No. 
If you choose to change this to yes, it will not update the names currently in the workbook. Due to this, you should export 
any data you have, make the change, and then import it afterward.

The rest of the Help tab explains some of the basics necessary to use the Excel Pipe Library Editor.

General Information

Column Headers
Underlined columns are required fields. These cannot be left blank.
If the headers in a group are grey, then the whole group is optional. Required fields within the group cannot be blank 
if any entry in the group is non-blank.

Read-Only Columns
Columns that are generated will have an italicized header.

Columns with grey backgrounds are lookups to other worksheets. Usually the column to their left will reference another 
worksheet, and these lookup columns will show relevant information from the referenced column.

Columns with blue backgrounds are generated names. These are usually used to identify the entry on another worksheet
(eg. Referencing a Geometric Standard when making a Size Definition). These cannot be moved from the first column.

Attempting to modify a read-only item should have no effect. If it does change the entry, then the workbook is in a bad 
state. To fix this, select the Help tab and click on the Revive Workbook button.

Hidden Tabs
By default the End Treatment Type and Connection Display tabs are hidden. They can be edited by right-clicking on any of 
the tabs and selecting Unhide... Likewise any tab can be hidden using Hide. When Clearing All Worksheets hidden tabs 
will not be cleared by default.

User Defined Attributes
Columns can be added under the User Defined heading to create new User Defined Attributes.

Make sure that the User Defined cell stretches across all of the columns to be used. Inserting a column when selecting 
the last User Defined column should produce the correct results.
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Pipe Hanger Stocks
A pipe hanger stock is made up of several key parts; a hanger type that defines the geometric makeup of the stock, 
several geometric properties which define how the model of a given stock will look, a list of nominal sizes that the hanger 
is valid for, a list of material types that the hanger is valid for, and a list of allowable accessory packages that can be 
used with the hanger stock. The geometric properties required from the user will define the major pieces of the hanger 
stock, the goal being to ensure bolts, bolt holes, etc. are places properly in the model, some less critical geometry is 
determined by ShipConstructor based on the nominal size of the pipe connected to the hanger and the geometric 
properties defined for the hanger stock. The allowable nominal size and allowable material lists define what types of 
pipes are allowed to attach to a given hanger stock. Hanger stocks can belong to hanger stock catalogs and the stocks 
can also have user defined attributes associated with them.

Supported Hanger Types
ShipConstructor supports several different hanger types, these types and the geometric properties required to define 
them are listed below. There is also a set of properties common to all hanger types:

• Name

• Description

• Weight

• Manufacturer

• Allowable Accessory Packages

• Nominal Size(s) that the hanger is applicable for.

• Material(s) that the hanger is applicable for.
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U-Bolt

A – Rod Thickness

B – Edge to Pipe Center

C – Overall Width (rod center to rod center)
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Pipe Strap

H – Hole Diameter

G – Edge to Bolt Center

C – Overall Width

W – Stock Width

T – Stock Thickness
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Range with Elastic Insert

C – Overall Width

D – Overall Height

E – Overall Depth

I – Bolt Center to Bolt Center

H – Hole Diameter
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Pipe Clamp

H – Hole Diameter

B – Edge to Pipe Center

F – Center of Pipe to Center of Bolts

J – Distance between Clamps

W – Stock Width

T – Stock Thickness
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Offset Pipe Clamp

I – Bolt Center to Bolt Center

B – Edge to Pipe Center

G – Edge to Bolt Center

H – Hole Diameter

T – Stock Thickness

W – Stock Width
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Split Ring Extension

A – Rod Diameter

W – Split Ring Width

T – Split Ring Thickness
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Hinged Extension Split Pipe Clamp

A – Rod Thickness

T – Stock Thickness

W – Stock Width
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Adjustable Swivel Ring

A – Rod Thickness

B – Edge to Pipe Center

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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Adjustable J-Hanger

A – Rod Thickness

B – Edge to Pipe Center

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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Adjustable Clevis Hanger

A – Rod Thickness

B – Edge to Pipe Center

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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Flat Top Clevis Hanger

A – Rod Thickness

B – Edge to Pipe Center

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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Vee-Bottom Clevis Hanger

A – Rod Thickness

B – Edge to Pipe Center

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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J-Hook

D – Overall Height

F – Center of Pipe to Center of Bolts

H – Hole Diameter

T – Stock Thickness

W – Stock Width



Pipe Library Setup

64

Adjustable Roller Hanger

A – Rod Thickness

C – Overall Width

D – Overall Height

K – Center of Pipe to End of Rod

T – Stock Thickness

W – Stock Width
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Trapeze Roller Hanger

A – Rod Thickness

B – Edge to Pipe Center

C – Overall Width

D – Overall Height

I – Bolt Center to Bolt Center
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Roller Chair

B – Edge to Pipe Center

C – Overall Width

D – Overall Height

I – Bolt Center to Bolt Center

H – Hole Diameter

T – Stock Thickness

W – Stock Width
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Adjustable Roller Stand with Base

B – Edge to Pipe Center

C – Overall Width

E – Overall Depth

I – Bolt Center to Bolt Center

H – Hole Diameter

Create a Hanger Stock

To create a Hanger Stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.
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3. Select the type of hanger stock you want to create or select an existing hanger stock of the type you want to create.

4. Click New.

5. Enter a name for the hanger stock and press Enter.

6. Set the hanger stock properties required.

7. Click Apply to save changes, or OK to save changes and close the Hanger Stock Catalog.

Edit a Hanger Stock

To edit a Hanger Stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Select the hanger stock you want to change and edit the desired values in the Hanger Stocks grid.

4. Click Apply to save changed or OK to save changes and close the Hanger Stock Catalog.

Delete a Hanger Stock

To delete a Hanger Stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Select the hanger stock you want to delete and click Delete.

4. Click Apply to save changes or OK to save changes and close the Hanger Stock Catalog.

Assign Allowable Nominal Sizes to a Hanger Stock

To assign allowable Nominal Sizes to a Hanger Stock

1. Choose ShipConstructor > Manager to open Manager.
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2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Select the hanger stock you want to assign the allowable nominal sizes to.

4. Click Allowable Nominal Sizes to open the Allowable Nominal Sizes dialog.

5. Check the Selected check box for the nominal sizes you want to associate with the selected hanger stock.

6. Click OK to return to the Hanger Stock Catalog.

7. Click Apply to save changes or OK to save changes and close the Hanger Stock Catalog.

Assign Allowable Material Grades to a Hanger Stock

To assign allowable Material Grades to a Hanger Stock

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Select the hanger stock you want to assign the allowable material grades to.

4. Click Allowable Material Grades to open the Allowable Material Grades dialog.
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5. Check the Selected check box for the material grades you want to associate with the selected hanger stock.

6. Click OK to return to the Hanger Stock Catalog.

7. Click Apply to save changes or OK to save changes and close the Hanger Stock Catalog.

Edit Hanger Stock Catalogs

To edit Hanger Stock Catalogs

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Click Edit Catalogs to open the Hanger Catalogs dialog.

4. Click New to create a new hanger catalog, click Delete to delete the selected hanger catalog, to edit the name of an 
existing hanger catalog simply edit it in the Catalogs grid.

5. Click OK to return to the Hanger Stock Catalog.

6. Click Apply to save changes or OK to save changes and close the Hanger Stock Catalog.

Assign Hanger Stocks to a Hanger Stock Catalog

To assign Hanger Stocks to a Hanger Stock Catalog

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Hanger Stock Catalog to open the Hanger Stock Catalog.

3. Select the hanger stock you want to assign the hanger stock catalogs to.

4. Click Assign To Catalogs to open the Assign Hanger Catalogs dialog.
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5. Check the Selected check box for the hanger catalogs you want to associate with the selected hanger stock.

6. Click OK to return to the Hanger Stock Catalog.

7. Click Apply to save changed or OK to save changes and close the Hanger Stock Catalog.

Support Templates
A support template is made up of several key parts; a support type which defines the geometric makeup of the support, 
several geometric properties which define how the model of the template will look, and a list of supported hanger stocks.

The geometric properties required from the user will define the shape and size of the support, the goal being to ensure 
the correct structural stocks are used, the number of tiers is correct, and the maximum and minimum constraints of the 
support are met. The support hanger stocks will define what sizes and types of pipes will be allowed to connect to the 
support.

Support Template Types
ShipConstructor supports several different support types, these types the geometric properties required to define them 
are listed below. There is also a set of properties common to all support types.

• Name

• Min Overall Height

• Max Overall Height

• Min Distance To First Hanger

• Min Distance Between Hangers

• Max Distance Between Hangers

• Min Distance From Last Hanger

• Vertical Extrusion Stock

• Vertical Base End Extrusion Stock Endcut Standard

• Vertical Open End Extrusion Stock Endcut Standard

• Vertical Base Plate Stock

• Vertical Base Plate Type

• Vertical Base Plate Length

• Vertical Base Plate Width

• Vertical Base Plate Radius.

• Maximum Number of Hangers

I Type
The I Types can only have 1 vertical tier and no horizontal tiers.
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LF Type
The LF Type can only have 1 vertical tier and 1 or more horizontal tiers.
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• Cross Tier Extrusion Stock

• Cross Tier Start Extrusion Stock Endcut Standard

• Cross Tier End Extrusion Stock Endcut Standard

• Extrusion Direction Opposite

• Min Overall Width

• Max Overall Width

T Type
The T Type can only have 1 vertical tier and 1 or more horizontal tiers. The vertical tier will initially be in the center of the 
horizontal tiers.
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• Cross Tier Extrusion Stock

• Cross Tier Start Extrusion Stock Endcut Standard

• Cross Tier End Extrusion Stock Endcut Standard

• Min Overall Width

• Max Overall Width

Two by N Type
The Two by N Type will have 2 vertical tiers and 1 or more horizontal tiers.
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• Cross Tier Extrusion Stock

• Cross Tier Start Extrusion Stock Endcut Standard

• Cross Tier End Extrusion Stock Endcut Standard

• Extrusion Direction Opposite

• Min Overall Width

• Max Overall Width

• Angle

M by N Type
The M by N Type will have 2 or more vertical tiers and 1 or more horizontal tiers.
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• Cross Tier Extrusion Stock

• Cross Tier Start Extrusion Stock Endcut Standard

• Cross Tier End Extrusion Stock Endcut Standard

• Extrusion Direction Opposite

• Min Overall Width

• Max Overall Width

• Angle

Create a Support Template

To create a Support Template

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Support Template Catalog to open the Support Template Catalog.
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3. Select the type of support you would like to create or select an existing support template of the type you would like 
to create.

4. Click New Support.

5. Enter a name for the support template and press Enter.

6. Set the support template properties required.

7. Click Apply to save the changes, or click OK to save the changes and close the Support Template Catalog.

Edit Support Template Tiers

To edit Support Template Tiers

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Support Template Catalog to open the Support Template Catalog.

3. Select the support template that you would like to edit tiers.

4. Click Edit Tiers and select whether to edit horizontal tiers or edit vertical tiers to display the Tier Editor window.
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5. Click Add to add another tier to the support template or click Remove to remove a tier from the support template.

6. Click OK to return to the Support Template Catalog.

7. Click Apply to save changes or click OK to save changes and close the Support Template Catalog

Edit a Support Template

To edit a Support Template

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Support Template Catalog to open the Support Template Catalog.

3. Select the support template that you want to change and edit the desired values in the Support Template grid.

4. Click Apply to save changes or click OK to save changes and close the Support Template Catalog.

Delete a Support Template

To delete a Support Template

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Support Template Catalog to open the Support Template Catalog.

3. Select the support template you would like to delete and click Delete Support.

4. Click Apply to save changes or click OK to save changes and close the Support Template Catalog.

Assign Allowable Hangers to a Support Template

To assign Allowable Hangers to a Support Template

1. Choose ShipConstructor > Manager to open Manager.

2. Choose Piping > Support Template Catalog to open the Support Template Catalog.

3. Select the support template you would like to assign allowable hangers to.

4. Click Allowable Hangers to open the Allowable Hanger Stocks window.
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5. Click the Allowed check box for the hanger stocks you would like to be available for this support type.

Note: Only pipe strap and UBolt hanger types can be attached to a support.

6. Click OK to return to the Support Template Catalog.

7. Click Apply to save changes or click OK to save changes and close the Support Template Catalog.
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Pipe Modeling
All pipe modeling is done within system model drawings.

Pipe Drawings
You model pipe within pipe drawings. Because shipyards have different policies for organizing their projects, 
ShipConstructor does not have any constraints on pipe drawings. You can use either one drawing per system in a unit or 
multiple systems or branches in a drawing. You can also add equipment and model pipe in the same drawing.

For more information on drawings, see Drawings in the Structure manual.

Create a Pipe Drawing

To create a pipe drawing

1. Choose ShipConstructor > Navigator to open Navigator.

Note: To create a drawing for a unit other than the current unit, select the project at the top of the component list 
(for example, SC2009Demo) and then select the unit in the Unit list.

2. Select Pipe in the component list.

3. Select the Piping folder in the drawing list.

4. Click New Piping.

The New Drawing window appears.

5. Enter a File name for the drawing.

Note: To open the new drawing, check the Open new drawing check box.

6. Click OK.

Upon Opening a Pipe Drawing
When opening a Pipe drawing, if connected to the database, a synchronization occurs between the drawing and the 
database. If there are parts that are not in the database but are in the drawing, a window will appear asking if you would 
like to explode these parts.

If ‘Yes’ is clicked, the selected objects will be exploded. If ‘No’ is clicked, the selected objects will be erased.
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Set Up Pipe Systems
A pipe system is a collection of pipe parts that together fulfill a specific purpose (for example, the bilge system, the 
ballast system, or the fire main system). Each system is composed of one or more sections or branches. Before you can 
begin modeling pipe, you must set up systems and branches.

Each system or branch is part of a specification (spec). You must set up at least one spec before you can create a system 
or branch. To set up a spec, see Create A Spec (page 16).

Create a System

To create a system

1. Choose SC Pipe > System > System Manager (page 237) to open the System Manager. See System Manager (page 
254) for details.

2. Under Pipe System, select the spec, , that you want the new system to belong to. When you choose a spec, the 
New button at the bottom of the window is the New System button.

3. Click New System.

4. Enter a name for the new system and press Enter.

5. Set the system properties:

Finish – The finishes applied to pipes in the system. Click to open the Finishes window and use the left and right 
arrow buttons to select finishes from the list of Available Finishes. The order of Selected Finishes is the order that the 
finishes will be applied to the pipe.

Insulation – The insulation applied to pipes in the system. Click to open the Insulation window and use the left and 
right arrow buttons to select insulation from the list of Available Insulation. The order of Selected Insulation is the 
order that the insulation will be applied to the pipe.

Color – The color that ShipConstructor will display pipes in the system as.

Class – The class that pipes in the current system will be associated with.

Test Method – Enter a string field here based on what method you will use for testing.

Test Pressure – Enter a specific value in either pounds per square inch (psi) or kilopascals (kPa), depending on if you are 
in an imperial or metric project.

Density – The density of the pipe affects its wet weight (relative density multiplied by the weight of water). The density is 
entered based on each application and is entered on a branch or system level.
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6. Click OK to close the System Manager.

Create a Branch

To create a branch

1. Choose SC Pipe > System > System Manager (page 237) to open the System Manager. See System Manager (page 
254) for details.

2. Under Pipe System, select the system, , that you want the new branch to belong to. When you select a system, the 
New button at the bottom of the window becomes the New Branch button.

3. Click New Branch.

4. Enter a name for the new branch and press Enter. The name must be unique if the Pipe Unique Branch Name is set 
to ‘yes’ in Project Settings.

5. Set the branch properties (see Create a System (page 82)).

6. Click OK to close the System Manager.

Modify a System or Branch
You can modify a system or branch by modifying the properties of the system or branch, converting a branch to a system 
or a system to a branch, and re-assigning or deleting a system or branch.

To modify the properties of a system or branch

1. Choose SC Pipe > System > System Manager (page 237) to open the System Manager. See System Manager (page 
254) for details.

2. Under Pipe System, select the system or branch you want to modify.

3. Modify the system or branch properties.

See Create a System (page 82) for details on property fields.

4. Click OK to close the System Manager.

Delete a System or Branch

To delete a system or branch

Note: You cannot delete a system or branch if pipes have been assigned to that system or branch.

1. Choose SC Pipe > System > System Manager (page 237) to open the System Manager. See System Manager (page 
254) for details.

2. Select the system or branch you want to delete.

3. Click Delete.

4. Click OK to close the System Manager.

Set the Current System for Pipes

To set the current system for pipes

1. Choose SC Pipe > System > System Manager (page 237) to open the System Manager. See System Manager (page 
254) for details.

2. Select the branch, .

3. Click OK to close the System Manager.

-OR-

1. Choose SC Pipe > Systems > Set System From Pipe Part.
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2. Select an Pipe part from the current drawing.

3. The current system is now set to be the same as the system of the part selected in step 2. 

-OR-

1. Start routing a new Pipe part.

2. Place first end connected to an existing Pipe part that is in a different system.

3. You will be prompted to change the current system to that of the part you are connecting to.

4. Click Yes.

Change the System for Pipes

To change the system for pipes

1. Choose SC Pipe > System > Set System (page 237) to open the System Manager. See System Manager (page 254)
for details.

2. Select the branch, .

3. Click OK to close the System Manager.

4. A log file will be produced if any of the selected pipes cannot be set to the selected system.  The log file will display 
which pipes cannot have their system changed and why they cannot change systems.

Set Up Pipe Defaults, Display, and Performance

Display Options for Pipe

To change the display options

1. Choose SC Pipe > Pipe Options to open the Pipe Drawing Options window.

2. Click the Display tab.
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3. Set the display options. See The Display Tab (page 255) for a description of each option.

4. Click OK to close the Pipe Drawing Options window.

Change the NavAid Options
When you are placing pipes that require directional input, a visual aid called the NavAid appears, helping you to orient the 
component. You can adjust the size and snap behavior of the NavAid.

To change the NavAid options

1. Choose SC Pipe > Pipe Options to open the Pipe Drawing Options window.

2. Click the NavAid tab.
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3. Set the options. See The NavAid Tab (page 261) for details.

4. Click OK to save the changes and close the Pipe Options window.

Set the Transform Options
The transform options are the display options that are particularly relevant when transforming parts (moving, stretching, 
etc.).

To set the transform options

1. Choose SC Pipe > Pipe Options to open the Pipe Drawing Options window.

2. Click the Transform tab.
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3. Set the options. See The Transform Tab (page 262) for details.

4. Click OK to save your changes and close the Pipe Drawing Options window.

Set the Routing Options
The routing options allow you to control the visibility, color, and size of the flow direction arrow.

To set the routing options

1. Choose SC Pipe > Pipe Options to open the Pipe Drawing Options window.

2. Click the Routing tab.
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3. Set the options. See The Routing Tab (page 264) for details.

4. Click OK to save your changes and close the Pipe Drawing Options window.

Set the Behavior Options
The behavior options let you set up how the stock lengths are enforced.

To set the behavior options

1. Choose SC Pipe > Pipe Options (page 244) to open the Pipe Drawing Options window. 

2. Click the Behavior tab.
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3. Set the options. See The Behavior Tab (page 265) for details.

4. Click OK to save your changes and close the Pipe Drawing Options window.

Set the Constraints Options
The constraints options let you set up how ShipConstructor handles bent pipes when bender information is present.

To set the constraints options

1. Choose SC Pipe > Pipe Options (page 244) to open the Pipe Drawing Options window. 

2. Click the Constraints tab.
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3. Set the options. See The Constraints Tab (page 266) for details.

4. Click OK to save your changes and close the Pipe Drawing Options window.

Insert Pipes
You create a pipe model by inserting pipes into a pipe drawing.

Routing a pipe usually involves selecting a stock and providing geometric information that determines where the pipe is 
located and how it is oriented. You input geometric information through a combination of clicking points in the model and 
using command line options.

Selecting a Pipe Part to Insert
Before laying down any pipe, you must first select which pipe to use. By clicking on the type of part you want, the Select 
Stock window will appear letting you select a stock of that type from the stocks you made in the Pipe Stock (page 19)
Catalog for the current spec if there are any specs that meet these criteria.  If there are not, you will be notified to assign 
stocks of this type to the spec.



Pipe Modeling

91

To select a stock to insert

1. From the SC Pipe menu or the Pipe toolbar, choose the type of stock you would like to place in the drawing. The 
Stock Selection window will appear if there are any stocks of this type assigned to this spec. See Stock Selection
Window Reference (page 266) for more information.

Note: If there are no stocks shown, clear all the filters by selecting the Clear Filter button , and make sure 
that there are stocks of the type selected created and assigned to the spec where the current system is.

2. Select a stock and click OK.

The NavAid
The NavAid is a tool intended to help you with several aspects of pipe routing. It can be helpful for three things:

• Visualizing the current UCS

• Modifying the current UCS in a way convenient for routing pipes

• Snapping input points to fixed angles

When visible, the NavAid is located at the current UCS origin, aligned to the UCS XY plane. The angle displayed by the 
NavAid is the polar angle of the current input point. The center of the NavAid is indicated by a small cross, with the longer 
axis in the X direction (0° angle).
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Required Custom Attributes
After routing the pipe, if there are any required custom attributes or catalogs are assigned to the stock used, the catalog 
and custom attributes for this part must be set. ShipConstructor will attempt to do this automatically. If it cannot be done 
automatically the dialog below will be show. See Required Custom Attributes Reference (page 267).

No Spool Parts
If you are inserting a no spool part (Valve) and you have the Use Default Assembly project setting set to no, then you must 
select the assembly in which belongs. After selecting the hierarchy from the tree and pressing OK, you can then continue 
on to placing the part. 



Pipe Modeling

93

Straight Pipe
To route a straight pipe, you will select a stock and then provide two points indicating the start and end point of the pipe.

To insert a straight pipe

1. Choose SC Pipe > Straight.

A straight pipe appears with the first end at the cursor. Information about the pipe is shown on the command line.

2. You are prompted to pick the start point of the pipe or choose an option:
Please pick point : or  [Stock/Next end <1>/XOffset/YOffset/Choose offset <0,0> 
/Rotate/sAddle/Insulation]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):
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• Next end – Switches which end of the pipe will be placed at the picked point.

• Rotate – Rotates the pipe around its own centerline (the NavAid is not affected).

3. Click anywhere in the model to select the start point of the pipe. You can connect to an existing unconnected pipe 
end by clicking on its end point, indicated by an arrow (see Creating Connections While Routing In End Mode (page 
104)). The NavAid appears at the selected point and the end point of the pipe you are placing is anchored there.

4. You are prompted to pick the second point or choose an option:
Please pick point : or  [Forward/Aft/Port/Starboard/Up/Down/plaNE/XRotate/YRotate/ZRotate/ 
SNap<on>]:
See General Options (page 103) for explanation of the available options.

Note: If you created a connection to another pipe by clicking on a free end or by creating a saddle, several of the
options shown above do not apply (for example, the direction options) and are not available.

5. Click anywhere in the model to select the end point of the pipe. If you connected the pipe in step 3, any point you 
pick (including OSNAPs) is projected onto the axis of the end you connected to.

Bent Pipe

To insert a bent pipe by picking points

To route a bent pipe with this method, you will select a sequence of points that form the path to which the segments of 
the bent pipe will be aligned.

1. Choose SC Pipe > Bent.

The first segment of a bent pipe appears with the first end at the cursor. If there is only a single bender associated 
with the bent pipe, skip to Step 3. Information about the pipe is shown on the command line.

2. If the size definition of the bent pipe you are creating has a single set of pipe bender values associated with it, the 
bender values will automatically be applied to the bent pipe as you place it. If there is more than one set of bender
values associated with its size definition, you must select a pipe bender or a bend radius. The Select bend values
window appears and you are prompted to select which bender values to use. Your bent pipe will be restricted by the 
properties of that bender. If there is no bender data associated with the size definition, you will be prompted to enter 
a Bend Radius. This value will be used to restrict the bent pipe as you route it.
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Note: Information about the bend values can be seen in the OPM after the part has been placed.

3. You are prompted to pick the start point of the bent pipe or choose an option:
Please pick point : or  [Stock/Next end <1>/XOffset/YOffset/Choose offset <0,0>/Toggle 
mitered <rounded>/Rotate/sAddle/Insulation]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end – Switches which end of the bent pipe will be placed at the picked point.

• Toggle mitered – Switch between rounded corners and mitered corners. The current setting is shown in <angle 
brackets>. If you switch to mitered corners, you must specify the number of miter segments per corner.

• Rotate – Rotates the pipe around its own centerline (the NavAid is not affected).

4. Click anywhere in the model to select the start point of the pipe.

You may also connect to an existing unconnected pipe end by clicking on its end point, indicated by an arrow (see 
Creating Connections While Routing In End Mode (page 104)). The NavAid appears at the selected point and the end 
point of the pipe you are placing is anchored there.

If you click on a snap point of an existing AutoCAD polyline, you are given the option to automatically route the pipe 
along the path of that polyline. If you choose No, continue from Step 5. If you choose Yes, the bent pipe is routed 
along the polyline (if for any reason the pipe cannot be routed exactly along the polyline, an explanation will be 
printed to the AutoCAD console). The end of the pipe that you are routing by is placed at the end of the polyline 
closest to the snap point you selected. If the pipe is successfully routed, you are done routing the pipe, and are given 
the option to delete the polyline.

5. You are prompted to pick the second point or choose an option:
Please pick point : or  [Forward/Aft/Port/Starboard/Up/Down/plaNE/XRotate/YRotate/ZRotate/ 
SNap<on>]:
See General Options (page 103) for explanation of the available options.

Note: If you created a connection to another pipe by clicking on a free end or by creating a saddle connection, 
several of the options shown above do not apply (for example, the direction options) and will not be available.

6. Click anywhere in the model to select the second point of the pipe. If you connected the pipe in step 4, any point you 
pick (including OSNAPs) is projected onto the axis of the end you connected to.

To choose a point along the axis of an existing end, click the existing end. Your next input point will be restricted to 
the axis.

The NavAid appears at the selected point and the first pipe bend appears.

7. To create a bend in the pipe, repeat Steps 5 and 6 for the bend points. Note that he command prompt has extra 
options for further points :
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Please pick point : or  [XOffset/YOffset/Choose offset <0,0>/Radius<200>/World plane/Initial 
plane/paRT plane/Align to 
part/Forward/Aft/Port/Starboard/Up/Down/plaNE/XRotate/YRotate/ZRotate/ SNap<on>]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Radius – Changes the corner radius of the bend being manipulated. The current radius is shown in <angle 
brackets>.

• World plane – Aligns the NavAid to the world coordinates.

• Initial plane – Aligns the NavAid to the UCS that was active when the command started.

• Part plane – Aligns the NavAid to the plane of the most recently placed segment of bent.

• Align to part – Aligns the X-Axis of the NavAid (see The NavAid (page 91)) to the axis of the most recently placed 
segment of the bent. 

• Unlock – If you clicked on an existing end in step 6 to restrict your picked point to the axis of that end, this 
option will remove the restriction.

To finish a bent pipe, press Enter.

To automatically route a bent pipe along a polyline

1. Choose SC Pipe > Utilities > Route on Polyline (page 239). You are prompted to select a polyline:
Please select a polyline to route the pipe on. The pipe will be routed from the end of the 
polyline closest to the selected point. 

2. Select a polyline. If for any reason the pipe cannot be routed exactly along the polyline, an explanation will be printed 
to the AutoCAD console. You are asked if you would like to delete the polyline used to route along:
Delete source polyline? [Yes/No] <No> :

3. Enter a response. The pipe appears and routing is complete.

Generic Pipes
To apply one of the allowable ends to a generic pipe part, you must connect it. The allowable connections that can be 
used are the ones that match with the end treatments that are on the stock and those that are available to be applied to 
the stock. The following shows the Select Connection and Accessory Packages dialog when connecting two pipes of the 
stock that is shown in figure below. Whichever allowable connection is selected will apply the end treatment to the parts. 
For example, if the second allowable connection show below is chosen then the FL 1” – 150LB – FF end treatment will be 
applied to the two ends that are being connected. The ends of the pipe that are not being connected will not be affected.

Fittings
There are two means by which fittings can be placed. End Mode involves placing a fitting by specifying a location and 
orientation for one of its ends. Intersection Mode lets you place a fitting where two runs of pipe will meet.
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End Mode
When placing a fitting in end mode, you initially only need to consider which end you are placing (or connecting to 
another pipe).

To insert a fitting in end mode

1. Choose the desired fitting you want to insert from the SC Pipe menu. The fitting appears at the cursor and 
information about it is shown on the command line.

2. You are prompted to pick the first point or choose an option from the end mode command line:
Please pick the first point of the end axis : or  [Select stock/cOnnects To.../Next end 
<1>/inTersection mode/XOffset/YOffset/Choose offset <0,0>/sAddle/Insulation]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end – Switches which end of the fitting will be placed at the picked point.

• Intersection Mode – Switches the routing interface to intersection mode (see Intersection Mode (page 99)).

3. Click anywhere in the model to select the start point of the fitting. You can connect to an existing unconnected pipe 
end by clicking on its end point, indicated by an arrow (see Creating Connections While Routing In End Mode (page 
104)). The NavAid appears at the selected point and the end point of the fitting you are placing is anchored there.

4. If you connected the fitting to another pipe, continue from Step 6. Otherwise, you are prompted to pick a point 
indicating the direction of the end you just placed or choose an option:
Please pick the second point of the end axis : or  [plaNE/XRotate/YRotate/ZRotate/SNap<on>]:
See General Options (page 103) for explanation of the available options.

5. Click anywhere in the model to specify the direction of the current end’s axis (i.e. the end axis will be parallel to the 
line formed by this point and the point that you clicked in Step 3). The fitting is now restricted to rotation about this 
axis.
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Specifying the location and normal of End 1.

6. You are prompted to pick a point indicating the direction of an orienting end of the fitting or to choose an option:
Please pick a point indicating a rotation about the defined end axis : or  [Next end for 
orientation <1>/Forward/Aft/Port/Starboard/Up/Down/DEck align/FRame align/Long align/ALign to 
WCS/ZRotate/SNap<on>]:
Depending which end you placed in Step 3, not all ends will be available as an orienting end while cycling through 
ends with Next end for orientation. For example, if you placed a tee by one end of its trunk, the other end of the trunk 
is not useful to orient the tee with, but the branch is.

If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end for orientation – Switches the end governing the orientation of the fitting.

7. Click anywhere in the model to specify the direction of the orienting end.
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A cross that was placed by End 1 with points 1 and 2, and oriented with respect to End 3 with the 3rd input point.

Intersection mode
You will typically use intersection mode to place a fitting (or possibly multiple elbows) where two non-parallel pipe runs 
will meet (that is, where their centerlines will intersect). 
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If you are placing the fitting before the pipe runs on either side exist, you will directly specify the location of the 
intersection point and then set the orientation of the fitting. 

Intersection point on a tee.

If one of the other pipe runs exists already, you will align one end of your fitting with that run and then specify how far 
from that existing run the fitting is placed. If both of the other runs exist already, you will align one end of your fitting to 
one pipe run and a second end of your fitting to the other run.

To insert a fitting in intersection mode when the connecting runs do not exist yet

1. Choose the desired fitting you want to insert from the SC Pipe menu. The fitting appears at the cursor and 
information about it is shown on the command line.

2. If end mode is active, switch to intersection mode (see step 2 of End Mode (page 97)); otherwise continue with Step
3.

3. You are prompted to pick the location of the intersection point or choose an option:
Please pick the first point of the end axis : or  [Select stock/cOnnects To.../Next end 
<1>/neXt point <1>/End mode/Insulation]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end – Switches which end of the fitting will be aligned to the axis formed by the first two points you will 
choose in steps 4 and 6.

• Next point – Switches which intersection point of the fitting you want to place in step 4. You may not see this 
option if a fitting has only one intersection point (e.g. a non-offset elbow or basic tee).
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• End mode – Switches the routing interface to end mode (see End Mode (page 97)).

4. Click anywhere in the model (except a free end) to specify a location for the current intersection point. 

5. You are prompted to pick a second point defining the axis to which the current end of the fitting will be aligned or to 
choose an option. 
Please pick the second point of the end axis : or  [orieNting end <1>/plaNE/XRotate/YRotate/
ZRotate/SNap<on>]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Orienting end – Switches which end of the fitting will be aligned to the axis formed by the point you picked in 
step 4 and the point you will pick in step 7.

6. Click anywhere in the model to specify the direction of the current end’s axis (i.e. the end axis will be parallel to the 
line formed by this point and the point that you clicked in Step 3). The fitting is now restricted to rotation about this 
axis.

7. You are prompted to pick a point indicating the direction of an orienting end of the fitting or to choose an option:
Please pick a point indicating a rotation about the defined end axis : or  [Next end for 
orientation <1>/Forward/Aft/Port/Starboard/Up/Down/DEck align/FRame align/Long align/ALign to 
WCS/ZRotate/SNap<on>]:
Depending which end you placed in Step 3, not all ends will be available as an orienting end while cycling through 
ends with Next end for orientation. For example, if you placed a tee by one end of its trunk, the other end of the trunk 
is not useful to orient the tee with, but the branch is.

If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end for orientation – Switches the end governing the orientation of the fitting.

8. Click anywhere in the model to specify the direction of the orienting end.

To insert a fitting in intersection mode when one or both of the connecting runs already exist

1. Choose the desired fitting you want to insert from the SC Pipe menu. The fitting appears at the cursor and 
information about it is shown on the command line.

2. If end mode is active, switch to intersection mode (see step 2 of End Mode (page 97)); otherwise continue with Step
3.

3. You are prompted to pick the first point or choose an option from the Intersection Mode line:
Please pick the first point of the end axis : or  [Select stock/cOnnects To.../Next end 
<1>/neXt point <1>/End mode/Insulation]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end – Switches which end of the fitting will be aligned to the axis of the end you will select in step 4.
• Next point – You will be picking an existing end in step 4 (and not directly placing an intersection point); this 

option is not relevant to this routing method.

• End mode – Switches the routing interface to end mode (see End Mode (page 97)).

4. Click any free end in the model to indicate the end axis you want to place the fitting on. The fitting is now restricted 
such that its end is aligned with the end you clicked on.

5. You are prompted to pick a point indicating how far along the axis (chosen in step 4) the fitting should be placed. 
Please pick a point indicating distance from the existing end : or  [Next end for orientation 
<4>]: 
If more than one end is available for orientation, you can switch the end:

• Next end for orientation – Switches the end governing how far along the chosen end axis the fitting is placed.

6. Click anywhere in the model to fix the distance between the fitting and the end you clicked in step 4. 

If the second run you are looking to connect to already exists, you may click on its free end. Should the angle of the 
fitting differ from the angle between the two ends, a warning is printed. If you are routing an elbow, you may be given 
additional options to deal with the differing angle. If the elbow’s angle is too large (and its orienting end is 
trimmable), you will be asked if you would like to cutback the elbow to the correct angle. If the elbow’s angle is too 
small, you will be asked if you would like to insert multiple copies of the elbow (possibly trimming the last one) to fill 
the entire required angle.
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The points clicked when placing a lateral at the intersection of two free ends

If you clicked an existing free end you are finished; otherwise the fitting’s distance from the end you clicked in step 4 
is fixed; continue with step 7.

7. You are prompted to pick a point indicating the direction of an orienting end of the fitting or to choose an option:
Please pick a point indicating a rotation about the defined end axis : or  [Next end for 
orientation <1>/Forward/Aft/Port/Starboard/Up/Down /DEck align/FRame align/Long align/ALign 
to WCS/ZRotate/SNap<on>]:
Depending which end you placed in Step 3, not all ends will be available as an orienting end while cycling through 
ends with Next end for orientation. For example, if you placed a tee by one end of its trunk, the other end of the trunk 
is not useful to orient the tee with, but the branch is.

If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Next end for orientation – Switches the end governing the orientation of the fitting.

8. Click anywhere in the model to specify the direction of the orienting end.

Auto Part Insertion Mode
In Auto Part Insertion(AP) mode, when a user attempt to make a connection and there are no allowable connections 
for the end treatments of the parts, then instead of just failing or selecting a new stock in the case when the user is 
jigging, the Scenario Wizard attempts to add parts to make the connection work. The parts added will be one or two 
connectors if the ends to be connected are the same size or a reducer if they are not, and if there are multiple 
solutions at the simplest level that has a solution then the Scenario Wizard Dialog will be displayed.

Inline Fitting Insert
To insert a fitting into an existing run of pipe you first run the command for the type of part you want to insert. This 
starts the jig and where you select the command line option called INline Insert. At this stage you then pick a point. 
You can select a point in the middle of a straight section of a pipe, a point on a pipe end that is connected, a point on 
two coincident pipe ends. For each of the three cases the parts will be inserted differently. 
If you select a point in a straight section of pipe, that pipe will be broken and the parts will be inserted between the 
ends at the break. If you select a connected pipe end, the connection will be deleted and the parts will be inserted 
between the two previously connected parts. If you select two coincident pipe ends the parts will be inserted 
between them.
The parts inserted are determined by the Scenario Wizard.  It finds a solution from one of the end treatments that we 
are inserting into, to the fitting being inserted, to the other bounding end. It uses the solution with the least number 
of parts, and if there are multiple solutions at the simplest level that has a solution then the Scenario Wizard Dialog
(page 273) will be displayed.
After the parts have been inserted and connected then the fitting continues in jigging so you can orient it.
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Insert Connector Set Command
Running the SC Pipe > Insert Connector Set (page 235) command or using the toolbar button will start functionality 
to insert one or two connectors into existing pipe. The point to insert is the same for Inline Fitting Insert (page 102). 
After this is done the scenario wizard will select parts to insert in a similar fashion to what was described earlier, and 
if there are multiple solutions at the simplest level that has a solution then the Scenario Wizard Dialog (page 273)
will be displayed.

Routing Options
Several routing options are available in many different routing cases and serve more or less the same use in each case. 
To use the options, type their shortcuts (the letters that are capitalized when the options are displayed on the command 
line). Descriptions of each follow.

General options
• Select stock – Opens the Select Stock Pipe window, allowing you select a different stock pipe.

• Insulation – Displays the insulation window (see Insulation Reference (page 268)), allowing you to modify the 
insulation applied to the part you are routing.

• Saddle – Initiates the creation of a new saddle end on an existing pipe to which the pipe you are routing will be 
attached (see Create a Saddle (page 104)).

NavAid specific options
The following options affect the NavAid’s behavior or orientation (see The NavAid (page 91)).

• Snap – Toggles snapping of picked points to fixed angles (shown as spikes on the NavAid). The current setting is 
displayed in the command line in <angle brackets>.

• Plane – Changes the NavAid plane to a perpendicular one (the plane formed by the Z and X axes of the current UCS); 
effectively cycles the NavAid plane between the 3 axial planes of the current UCS.

• XRotate/YRotate/ZRotate – These options rotate the NavAid (or equivalently, the current UCS) about the respective 
axis according to the right-hand rule.

World coordinate alignment options
The following options are often available at times when you are prompted to pick a point specifying a direction or 
rotation. They are a convenient way to get diagonally oriented runs pointing back along world-coordinate axes and planes.

• Forward/Aft/Port/Starboard/Up/Down – These options automatically provide input equivalent to a point in the 
respective direction (or as close as possible to that direction, depending on the situation).

If you are routing a trimmable elbow, it is often the case that trimming it will allow alignment to directions not 
otherwise possible. In these cases, options for all possible directions will be available; choosing one that requires 
trimming will result in a prompt asking if you wish to trim the elbow to allow the alignment.

• Deck align/Frame align/Long align – These options will automatically provide you with an alignment such that the 
end you are orienting points in a direction lying parallel to the ship’s decks, frames, or longitudinal bulkheads, 
respectively. When there are 2 directions that result in the chosen alignment (which is usually the case), 
ShipConstructor will arbitrarily choose one of them and then ask you if you would like to use the other direction 
instead.

• Align to WCS – Aligns the NavAid such that its spikes are directed along world axes (only available in certain cases 
when the NavAid already lies in a world plane).

Offset routing options
These options affect your current routing offset (see Offset Routing (page 109)).

• XOffset/YOffset – Prompts you to type the new X or Y component of the routing offset, respectively.

• Choose offset – Allows you to choose a routing offset visually; you will type the letter corresponding to one of several 
named points on the bounding box of the pipe’s profile at the current end.
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Creating Connections While Routing In End Mode
Whether routing straights, bents, or fittings, connection creation is initiated by clicking an existing free pipe end when 
picking the first point. The choices you are prompted to make is dependent on whether or not the two ends can connect 
(that is, there are connections defined between the two involved end treatments).

If the end you are routing by cannot connect, but a different end on the part can, it is automatically used instead. If there 
is only one possible choice of connection and accessory package for the two involved end treatments, it is used 
automatically; otherwise the Select Connection and Accessory Package window will appear to allow you to choose which 
of each will be used. If no ends on the part you are routing can connect, the Stock Selection window will appear, allowing 
you to choose from a list of stocks that do have ends that can connect to the clicked end.

Special cases
It is possible to connect to a pipe that you have XRef’d in. This is called a remote connection and is always a spool break.
A second special case is connecting to a pipe from another system, which also automatically becomes a spool break (a 
warning that an inter-system connection has been created will be displayed).

Create a Saddle
A saddle connection is made between a normal end of a branch part, and a saddle end on a second header part. There 
are two ways to create a saddle.

• Choose the Saddle option when initially routing a pipe

• Route the two involved pipes independently and use the Saddle command to create the saddle connection.

Extra material
Both means of saddle creation allow you to adjust the amount of extra material. This is the minimum length of the 
branch part beyond the intersection between its surface and the header part’s surface.

Extra material applied to a branch part (branch part on the left, header part on the right, running into the page)

ShipConstructor can adjust the location of a branch part for a given amount of extra material only when the projection of 
the branch part’s end (along its end axis) falls entirely on the header part. If a situation in which this not the case is 
desired, you may place both parts manually, and use the Saddle command to create the saddle, in which specification of 
extra material is optional.
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Whether or not the end of a branch part projects entirely onto the header part

Create a saddle while routing a pipe

1. Choose the branch pipe that you want to route from a new saddle connection from the SC Pipe menu. The pipe 
appears at the cursor.

2. Type A (for sAddle) to begin creating the saddle and then press Enter. You are prompted to select the header part on 
which the saddle end will be created:
Please select a Header part:

3. Click on an existing header part on which the saddle will be created. You are prompted to pick a point on the header
part. This point is the intersection between the header part’s centerline and the connecting end axis of the branch
part, or closest point between those two lines in the case that offsets are applied in later steps.
Pick closest point on center line : or  [Point on OCS z-axis]:
Optionally, enter one of the keywords:

• Point on OCS z-axis – To specify a point relative to an object coordinate system on the header part, type O (for 
OCS) and press Enter. The object coordinate systems on the header part are displayed, with their z-axis’ tangent 
to the part’s centerline. Click the desired object coordinate system. You are prompted to enter a z-value in the 
selected object coordinate system; a positive or negative value is valid.
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2 object coordinate systems, and the z-axis of the selected one on which a point is specified

Or click on an end:

• Align to an existing free end – To set the saddles location, direction, and orientation to line up with those of an 
existing part’s end, click on the end. If it is not possible to create the saddle such that it is aligned with the 
existing end, an error is reported and saddle creation is aborted.
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A saddle aligned to an existing free end, created by clicking the free end right after picking the header part

4. Click a point to determine the direction, or if you selected an object coordinate system on the header part, enter a 
distance along its z-axis. If you clicked on an existing end, skip to step 6.
The branch part and NavAid appear at the selected point. You are prompted to pick a point indicating the direction of 
the saddle end.
Please pick point : or  [Center-offset<0>/Edge-offset/Flip-offset/Rotate90/World 
plane/Initial plane/paRt plane/Align to 
part/FOrward/AFt/Port/Starboard/Up/Down/plaNE/XRotate/YRotate/ZRotate/ SNap<on>]:
Optionally, enter one of the keywords:

• Center-offset – To set an offset between the end axis of the branch part and the centerline of the header part 
(the current offset is shown in <angle brackets>), type C (for Center-offset) and press Enter. Type an offset value 
and press Enter.

• Edge-offset – To set an offset between the edge of the branch part’s profile and the edge of the header part’s 
profile (the current offset is shown in <angle brackets>), type E (for Edge-offset) and press Enter. Type an offset 
value and press Enter. This option is only available when the header part has a consistent profile in the area 
local to the saddle end.

Edge and center offsets (branch part on the left, header part on the right, running into the page) 

• Flip-offset – To reverse the direction of the current center or edge offset, type FL (for FLip-offset).

• Rotate90 – To rotate the branch part about its own end axis by 90 degrees, type R (for Rotate90).

• World plane – To align the NavAid to the world coordinate axes, type W (for World plane) and press Enter.

• Initial plane – To align the NavAid to the UCS that was current when the command started, type I (for Initial 
plane) and press Enter.

• Part plane – To align the NavAid to the plane the header part lines in and the direction of its centerline closest 
to the saddle end, type RT (for paRT plane) and press Enter.

• Align to part – To rotate the NavAid within its own plane so that its zero angle is aligned with the nearest point 
on the header part’s center line, type A (for Align to part) and press Enter.

• Forward – To set the direction of the orienting end as close as possible to forward, type F (for Forward) and press 
Enter.

• Aft – To set the direction of the orienting end as close as possible to aft, type A (for Aft) and press Enter.

• Port – To set the direction of the orienting end as close as possible to port, type P (for Port) and press Enter.

• Starboard – To set the direction of the orienting end as close as possible to starboard, type S (for Starboard) and 
press Enter.
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• Up – To set the direction of the orienting end as close as possible to up, type U (for Up) and press Enter.

• Down – To set the direction of the orienting end as close as possible to down, type D (for Down) and press Enter.

• Snap – To turn on or off snapping of picked points to fixed angles (the current setting is displayed in the 
command line in <angle brackets>), type SN (for SNap) and press Enter.

Or click on an end:

• Align to an existing end – To set the saddles direction and orientation to match that of an existing part’s end, 
click that end.

A saddle with its direction aligned to an existing free end, created by clicking the free end after specifying a point on the 
header part 

5. Pick a point indicating the direction of the saddle end.  If you are routing a branch part that has a surface forged to 
fit the header part’s surface, you are prompted to enter the offset between it and the header pipe,
Enter the surface offset distance [Flush/Centerline] <Flush> :
or for a branch pipe that must be cut, the amount of extra material.
Enter the desired extra material length or extend to [Inner Diameter/Centerline] <0.0> :
Optionally, enter one of the keywords:

• Flush – Places the branch part such that its surface is flush to the surface of the header part.

• Centerline – Places the branch part such that its centerline begins at the centerline of the header part.

• Inner Diameter – Places the inner diameter of the branch part flush to the outer edge of the header part. The 
saddle hole cut in the header part is the same diameter as the inner diameter of the branch part.

6. Enter the surface offset (or extra material length). The branch part’s end placement is now fully determined. If there 
is more than one possible connection, you are prompted to select one. The branch part’s end treatment in 
combination with the selected connection determines the saddle’s end treatment, and you may only choose from 
connections such that the saddle’s end treatment is of the saddle type. If there is only one possible connection it is 
used automatically. If there are none, an error is reported and the saddle creation is aborted. 
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7. Unless only one possible connection exists (and was used automatically), select the desired connection and click OK. 
The saddle end and connection are created. If routing a fitting, continue from Step 6 of the To insert a fitting in end 
mode procedure (see End Mode (page 97)); otherwise continue from Step 4 of the To insert a straight pipe or To 
insert a bent pipe procedure (see Straight Pipe (page 93) or Bent Pipe (page 94)).

Create a saddle connection between existing pipes

1. Create both parts that will be involved in the saddle connection. They should be where you wish them to be after 
saddle creation with the exception of the branch’ parts end; you will have the option to move that end along its own 
axis to achieve a desired extra material length in steps 5 and 6.

2. Run the SCSADDLE command. You are prompted to select the branch part that will connect to the new saddle end.

3. Click on the branch part. You are prompted to select the header part on which the new saddle end will be created.

4. Click on the header part. You are prompted whether or not you wish to adjust the branch part’s end location to 
achieve a desired amount of extra material.

5. Enter Y or N for Yes or No, respectively. If you select No, skip entering the amount of extra material. If you select Yes, 
you are prompted to enter an amount of extra material.

6. Enter the extra material length. If the branch part’s end location needs to be adjusted to achieve the desired length, 
the branch part is moved using a multi-part transform on its end (see Multi-Part Transforms (page 117)). If there is 
more than one possible connection, you are prompted to select one. The branch part’s end treatment in combination 
with the selected connection determines the saddle’s end treatment, and you may only choose from connections 
such that the saddle’s end treatment is of the saddle type. If there is only one possible connection it is used 
automatically. If there are none, an error is reported and the saddle creation is aborted.

7. Unless only one possible connection exists (and was used automatically), select the desired connection and click OK. 
The saddle end and connection are created.

Offset Routing
Offset routing lets you route a pipe or fitting by specifying where it is relative to other geometry in the model. During 
typical use of offset routing, you specify offset values for a pipe, and then click on Object snap points of other geometry in 
the model (for example, structure parts, other pipes, or construction lines). A routing offset is specified as an X and Y 
value in a coordinate system perpendicular to the centerline of a pipe. 



Pipe Modeling

110

You can enter values separately for the X and Y offsets with the XOffset and YOffset options or choose an offset 
corresponding to a point on the bounding box of a pipe’s profile with the Choose offset option. An example of how an 
offset vector affects the routing of a pipe is shown below.

Pipe routed with four input points from several line segments with a left offset of 500 (offset vector <-500,0>).

Object Snaps
Pipes have several Object snap points that you might find useful when routing pipe or when transforming and existing 
pipe (see Multi-Part Transforms (page 117) or Single-Part Transforms (page 115)). The Object snaps can be enabled or 
disabled by clicking the OSNAP button on the AutoCAD status bar, by pressing F3, or by right clicking on the OSNAP 
button and click On or Off.  To enable or disable the Object snaps types, right click on the OSNAP button and click 
Settings.

Endpoint Object Snaps
AutoCAD Endpoint Object snaps can be found at the end points of pipes and at the end points of the sub-segments of a 
bent pipe.
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Midpoint Object Snaps
AutoCAD Midpoint Object snaps can be found on the midpoint of straight segments of pipe.

Nearest Object Snap
Pipes support AutoCAD’s nearest Object snap by snapping points to each pipe’s centerline.

Custom Object Snaps
In addition to the supported AutoCAD object snaps, several custom object snap types are supported. The custom Object 
snaps can be enabled or disabled by clicking the SCON OSNAP button (located beside the OSNAP button on the AutoCAD 
status bar), by pressing shift+F3, or by right clicking on the SCON OSNAP button and click On or Off.  To enable or disable 
the custom Object snaps types, right click on the SCON OSNAP button and click Settings. The custom Object snap 
settings will be saved between ShipConstructor sessions.
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All End Object Snaps
These are the points in the model where distributed systems ends exist.

Free End Object Snaps
These are the points in the model where unconnected distributed systems ends exist (a subset of the points provided by 
the EndPoint object snaps).

End Axis Intersections
End axis intersection snaps are points where end axes of a part meet. For branch fittings, you find these snaps where the 
centerline of a branch meets the centerline of the trunk. For an elbow, you find them where the two end axes meet (the 
intersection of the tangent lines defined by the centerline and the two end points of the elbow).
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Profile Corners Object Snaps
Profile corner snaps are located on distributed systems ends. These points are the corners of the bounding box of the 
profile (see the points labeled Top-Left, Top-Right, Bottom-Left, and Bottom-Right in Offset Routing (page 109)).

Profile Edges Object Snaps
Profile edge snaps are located on distributed systems ends. These points are the mid-points of the edges of the bounding 
box of the profile (see the points labeled Left, Right, Top, and Bottom in Offset Routing (page 109)).

Modify Pipes

Anchor Pipes
It is possible to anchor some pipes in a system so that they do not move when you are transforming the system.

To anchor a pipe 

1. Choose SC Pipe > Anchor Part (page 242).

2. Select all the pipes that you want to anchor.

3. Press Enter

The anchored pipes are marked with the anchor icon.

Note: An anchored pipe will not provide grips when selected.
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Unanchor a Pipe

To unanchor pipes

1. Choose SC Pipe > Unanchor Part (page 242).

2. Select all the pipes that you want to unanchor.

3. Press Enter.

Lock a Pipe
Locked pipes are similar to anchored pipes, but with even more restrictions. You cannot modify or erase a locked pipe. 
Locked pipes show a lock icon on them. Reasons for the pipe being locked can be seen in AutoCAD’s OPM (Object 
Property Manager). The most common locks in Pipe are a user lock and spool lock. The steps below describe the user 
lock.

To lock a pipe

1. Choose SC Pipe > Lock Part (page 243).

2. Select all pipes that you want to lock.

3. Press Enter.

To unlock a pipe

1. Choose SC Pipe > Unlock Part (page 243).

2. Select all pipes that you want to unlock.

3. Press Enter.

Grip Points
Grips are in the same locations regardless of which transform mode you are in, but they behave differently in each mode.

In single-part transform mode, there are three types of grips: end, corner, and middle grips. End grips are square, corner 
grips are round, and center grips are triangular. Their behavior is part-specific (see Single-Part Transforms (page 115)).
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In multi-part mode, all grips look and behave similarly.

Toggle Transform Mode
There are two modes in which you can transform existing pipes. Single-part transform mode lets you make specialized 
changes to individual parts. Multi-part transform mode lets you move larger sections of a pipe system simultaneously. 
You can toggle between single-part and multi-part transform modes.

To toggle the current transform mode

1. Click the transform mode icon, , on the transform toolbar.

Single-Part Transforms

Bent Pipes

The middle grips can be used to translate the entire bent pipe without changing its geometry.

End and corner grips behave similarly for bent pipes. The points you initially clicked when creating the bent pipe are 
actually the same points as the end and corner grips. Moving a grip to a different location can be thought of as moving 
one of the input points and recreating the bent pipe. You can only move a grip point so that the locations of the other 
grips are not changed.
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Fittings

With fittings, middle or center grips can be used for translations. Dragging an end grip point rotates a fitting about one of 
its connected ends, if possible.
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Multi-Part Transforms
Multi-part transforms let you manipulate large sections of a pipe system simultaneously. Typical uses of multi-part 
transforms are tasks like fine-tuning the location of large sections of a pipe system or adjusting the location of branches 
(fittings or saddles) in the system.
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Experimenting may be the most effective way to familiarize yourself with the behavior of these transforms, but it is also
helpful to understand some of logic ShipConstructor uses to help you in cases where a particular transform is not 
behaving the way you expect it to.

Helpful things to know about multi-part transforms

• The only changes a multi-part transform makes to a system are pipe translations and the shortening or lengthening 
of straight segments. Fittings are rigid in that they only translate (their geometry does not change).

• It is best to think of a system as several rigid sections connected by straight segments. The notion of these rigid 
sections is important to understanding how the set of selected grips determine the selected portion of the pipe
system.
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The thicker black lines indicate the rigid sections of this system. 

• Selecting a grip on a rigid section effectively selects the entire rigid section (that is, selecting more than one grip 
point on the same rigid section has no effect).
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Given that a fitting, transition, and offset are directly connected here, these are equivalent selections.

• Selecting more than one grip point selects all of the connected piping between the grips. More specifically, selecting 
a set of grips is equivalent to selecting all grips points along all possible paths from every selected grip point to every 
other selected grip point.
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Because of the connectivity between the parts with selected grip-points, these are equivalent selections.

• Anchored parts will not be moved. Free ends are treated similarly to anchors and will not move, unless they are part 
of the current selection.

An octagon with a cross is shown at points beyond which the system is constrained and cannot be moved.

• When multiple grips are dragged, the entire selected section will move by exactly the same amount and in the same 
direction. That is, the constraints governing how a set of grip points can move include the constraints imposed by 
each individual grip in the selected section.

• Within the above constraints, the primary goal of the multi-part transform solver is to determine a way to modify the 
system so that selected grips are moved as close as possible to where you drag them. The multi-part transform 
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engine will adjust as much of the system as necessary to accomplish this goal, which could mean transforming parts 
a significant distance away from the selected grips. Anchors are the best way to limit which portions of the system 
can be affected. 

• The transform solver’s secondary goal is to optimize the changes that are made to the system so that the changes to 
the system are as localized as possible. That is, changes to parts closer to the selected grips are preferred over 
changes to parts further away from the grips.

Toggle Constraining Mode
This option affects transforming bent pipes in both single-part and multi-part modes. If there is a bender associated with 
a pipe and constraining mode is on then you will be unable to modify a bent pipe in a way that would violate bender 
constraints. 

This option also enforces minimum stock length constraint for all pipes. When constraint enforcement is off, you will be 
able to modify a pipe so that its length is less than minimum stock length.

To toggle constraining mode

1. Click on the icon in the toolbar or choose SC Pipe > Toggle Constrain Enforcement (page 243).

Break a Pipe
Straight and bent pipes support the AutoCAD’s native break command. See AutoCAD documentation for further 
information. ShipConstructor registers a command, through LISP, called SCBAP that automatically splits a pipe object at 
a given point leaving two full length pieces.

The SCBAP command also allows for the Spacebar or Enter keys to repeat the command unlike the AutoCAD toolbar 
command.

To break pipes

1. Select the Pipe object that you want to split.

2. Run SC Pipe > Break Pipe at point (page 242).

3. Choose point to split pipe.

Disconnect Pipes

To disconnect pipes

1. Select the connection that is connecting the two pipes you want to disconnect.

2. Delete the selected connection by pressing the Delete key or using the AutoCAD delete command.

OR

1. Choose SC Pipe > Disconnect (page 242).

2. Select all the pipes that you want to remove connections from.

3. Press Enter.

Connect Pipes

To connect pipes

1. Choose SC Pipe > Connect (page 241).

2. Select the first free end to connect.

3. Select an end to connect to the first selected end. This is the part that will be moved by the multi-part transform 
engine to facilitate the desired connection if it is necessary.

OR

3. If you chose two coincident ends in step 2, choose the part you wish to be moved to make the connection if it is 
necessary.
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Remove Saddle

To remove a saddle

1. Choose SC Pipe > Saddles > Remove Saddle (page 238).

2. Click the saddle you want to remove.

Mark All Exceeding Maximum Length
The Behavior tab in the Pipe Options (page 255) window lets you choose whether or not to automatically cut pipes to the 
maximum allowable stock length. If you choose to not cut pipes to the maximum length, you have the option of labeling 
all pipes that exceed maximum length.

To label all pipes that are exceeding their maximum length

1. Choose SC Pipe > Pipe Options (page 244)

2. Select the Behaviour tab.

3. Check the Create warning labels for items exceeding stock length checkbox

Cut to Maximum Length
The Behavior tab in the Pipe Options (page 255) window lets you choose whether or not to automatically cut pipes to the 
maximum allowable stock length. If you choose to not cut pipes to the maximum length, you have the option of cutting 
pipes to their maximum length.

To cut a pipe to its maximum allowable length

1. Choose SC Pipe > Utilities > Cut to max length (page 239).

2. Select all pipes that you want to cut to their maximum allowable length. Press Enter.

3. ShipConstructor will attempt to cut each pipe to maximum stock length. For each selected pipe, you will be 
prompted to pick a connection to use to join the resulting segments. If the end treatments of a stock cannot be 
connected then pipes using that stock still split but the resulting segments will not be connected together.

Note: If the pipe that is cut contains green the End 1 Green will be applied to the first resulting cut pipe and the 
End 2 Green will be applied to the last resulting cut pipe. The green lengths will be included in the total length of 
the pipes.

Extract Center Line
Extracts the centerlines from a selection of pipe parts and places them as polylines on a centerline layer. The extracted 
centerlines can be used to create new pipe parts along the same path as the original parts.  On the corners of bents, 
dotted lines will be drawn to the corner position so that a new bent can be easily placed in the same position as the old 
bent by selecting the same start point, the corner points, and the same end point.

To extract centerlines

1. Choose SC Pipe > Utilities > Extract Center Line (page 240)

2. Select all the Pipe parts that you want to extract the centerline from.

3. Press Enter.

Merge To Bent
Merge to Bent is used to create a single bent pipe out of a selection of straight pipes, bent pipes, and pipe elbows.  The 
new bent pipe will follow the same route as the original selection of parts.

For a selection of pipe parts to be used to create the bent:

• They have to be connected to each other.

• They must not form a loop.

• They must not be anchored or locked.
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When creating the bent pipe:

• If all the parts have similar properties then those properties will be used to create the new bent pipe.  If the parts 
have different properties then the user will be asked to pick the appropriate property to use.

• If any of the pipes are spooled a message box will be displayed to ask to continue.  If yes, then the affected spools 
will be undefined and all the affected parts will be written out and displayed in a log file.

• If multiple benders exist for the pipe stock the bender selection dialog will appear to select the appropriate bender.  
If no benders exist the user must have permissions to enter a manual radius to use for bending.

• If connections existed between the end parts of the selected pipes and other pipes, these connections will attempt to 
be transferred to the new bent pipe.  If the connections cannot be transferred but valid connections exist between 
the new bent pipe and the other parts, the connection dialog will appear to select which connection to use.  If no 
valid connections exist then parts will remain unconnected.

To merge pipe parts to a single bent

1. Choose SC Pipe > Utilities > Merge To Bent (page 239)

2. Select the straight pipes, bent pipes, and elbows to merge to a single bent.

3. If pipes belong to different systems, select the system that the new bent pipe will belong to.

4. If any of the pipes belong to spools, click yes to undefined all the affected, a log file will be displayed containing all 
the parts affected from undefining the spools.

5. If selected straight and bent pipes are from different stocks the stock selection dialog will be displayed to select the 
stock of the new bent pipe.

6. If connections are to be created between the bent pipe and other parts and valid connections exist the connection 
dialog will be displayed for each connection to select the appropriate connection and accessory packages to use.

Change Connection Accessory Package
Connection accessory packages can be changed after you have placed the connection, provided there are accessory 
packages defined for the particular connection type, and the accessory package has the same spec as the pipes that are 
using the connection. If the connected pipes are from two different systems, connection accessory packages from both 
specs will be listed to select from. 

The accessory package that is assigned to a connection, can be seen at a quick glance in the OPM. Optionally from the 
steps described below, the accessory package can also be changed using the OPM.

To change a connection accessory package

1. Choose SC Pipe > Change Connection Accessory Package (page 244).

2. Select the connection you wish to change the package for.

3. Press Enter. 

If the connected pipes are from two different specs, you will be warned to select your accessory package carefully. 

The Select Accessory Package window will appear.
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4. Select a connection accessory package and click OK.

Transfer parts to another drawing / unit
The SCHEPTransferPartToDrawing command allows the moving of HEP parts from one drawing / unit to another drawing 
/ unit.

To transfer parts

1. Enter SCHEPTRANSFERPARTTODRAWING command. 

2. Select all pipes that you want transferred. Press Enter.

3. Choose a drawing / unit in the selection dialog, and press OK to transfer the parts.

Copy parts to another drawing / unit
The SCHEPReplicateToDrawing command allows the copying of HEP parts from one drawing / unit to another drawing / 
unit.

To copy parts

1. Enter SCHEPREPLICATETODRAWING command. 

2. Select all pipes that you want copied. Press Enter.

3. Choose a drawing / unit in the selection dialog, and press OK to copy the parts.

Pipe Spools

Creating Spools
To create a spool drawing, you must have at least one defined and approved spool. When finished modeling, it is easier 
to then start adding spool breaks, defining no-spool items, and define spools. 

The Spool Manager helps you do this. The Spool Manager is a ‘modeless’ window which allows changes in the model 
drawing while being open. In ShipConstructor, there is now no need to refresh the Spool Manager while modeling, as it is 
automatically refreshed to reflect the changes made. For instance, if a part is added to a run of ducts, it is automatically 
added to the correct grouping in the Spool Manager as soon as the part has finished being placed.
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To open the spool manager

1. Choose SC Pipe > Spools > Spool Manager (page 235) in Pipe drawings (See also Spool Manager Reference (page 
329).) 

Note: You must save your drawing to open the Spool Manager and undo will be disabled while it is open.
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No-Spool Items
A No-spool item is a part that is not going to be spooled. No-spool items are displayed with a cross icon.

To set no-spool items

There are six ways to set a part as a no-spool part:

1. In the Spool Manager (SC Pipe > Spools > Spool Manager (page 235)), drag and drop an undefined part to the No 
Spool Parts folder.

OR

2. In the model drawing, right-click on the part you want and choose No Spool from the right-click menu. The next time 
you right-click on the part, a check mark should appear beside the property No Spool.

OR

3. In the model drawing, display the AutoCAD Object Property Manager for the part and change the No Spool property.

OR

4. Click on the Set No Spool toolbar button in the Distributed Systems toolbar.

OR

5. Choose SC Pipe > Spools > Set No Spool (page 236) from the menu.

Note: You cannot set a pipe to No-Spool if the pipe is part of a locked spool.

6. The Select Hierarchy Window appears.
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7. Choose a valid hierarchy, and click OK.

Note: You cannot select the Project as a valid hierarchy. Typically, if the hierarchy is not known at modeling time, it 
should go into one of the Unassigned hierarchies so it is easier to find all the unassigned parts later.

Spool breaks will automatically be added at every connection the No-Spool item has.

To undefine no-spool items

There are six ways to undefine a no-spool part:

1. In the Spool Manager (SC Pipe > Spools > Spool Manager (page 235)), drag and drop a No Spool part to the 
Undefined Spools folder.

OR

2. In the Spool Manager (SC Pipe > Spools > Spool Manager (page 235)), select one or multiple No Spool parts and 
right-click on a No Spool part in the list and choose Undefine Part from the right-click menu.

OR

3. In the model drawing, right-click on the part you want and choose No Spool from the right-click menu. The next time 
you right-click on the part, no check mark should appear beside the property No Spool.

OR

4. In the model drawing, display the AutoCAD Object Property Manager for the part and change the No Spool property.

OR

5. Click on the Remove No Spool toolbar button in the Distributed Systems toolbar.

OR

6. Choose SC Pipe > Spools > Remove No Spool (page 236) from the menu.

To change the display properties of the no-spool icon

1. Choose SC Pipe > Pipe Options (page 244) to open the Pipe Options window in a Pipe drawing. See Display Options 
for Pipe (page 84).

2. In the Display tab, change the properties under Show No Spool.

3. Click OK.
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Add and Remove Spool Breaks
Spool breaks let you logically split up your system into distinct spools. Connections can be turned into spool breaks with 
the aid of the Spool Manager or by clicking on the corresponding toolbar icon.

By default, spool breaks are indicated with a disk of rays. You can turn on or off the display of spool break indicators and 
change their size and color.

To add a spool break to a spool

1. In the Spool Manager click Add (under Spool Break).

ShipConstructor minimizes the Spool Manager and prompts:
Please select a Connection to add a Spool Break:

2. Select the connection where you want to break the spool. Parts that are not connections are temporarily locked, to 
make selecting a connection easier. 

ShipConstructor inserts a spool break at the connection.

To add another spool break, select another connection.

Note: You can also window select. Window select will only select connections.

Tip: To make choosing a connection easier, use the OPM to see the properties of the connection. The properties 
list the part names of the connected parts.

To stop adding spool breaks, press Esc.

Note: There is also the menu command SC Pipe > Spools > Add Spool Break (page 236) and there is a toolbar 
button in the Distributed Systems Utilities toolbar.

3. If breaks are added that split defined spools, a prompt to select which section of the spool to remain spooled is 
displayed. Select a single part from each split spool.

Note: This step also is needed when deleting a connection in the middle of a defined spool.
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To remove a spool break from a spool

1. In the Spool Manager click Remove (under Spool Break).

ShipConstructor minimizes the Spool Manager and prompts:
Pick select a Connection to remove a Spool Break:

2. Select the Pipe connection that has the spool break you want to remove. Parts that are not connections are 
temporarily locked, to make selecting a connection easier.

To remove another spool break, select another connection.

Note: You can also window select. Window select will only select connections.

To stop removing spool breaks, press Esc.

Note: There is also the menu command SC Pipe > Spools > Remove Spool Break (page 237) and there is a 
toolbar button in the Distributed Systems Utilities toolbar.

3. If breaks were removed between defined spools a prompt to select which spool you wish to keep for this joined 
section is displayed. Select a single part from the section of the original spool that you wish to keep.

To change the display properties of the spool break icon

1. Choose SC Pipe > Pipe Options (page 244) to open the Pipe Options window. See Display Options for Pipe (page 84).

2. In the Display tab, change the properties under Show Spool Break.

3. Click OK.

Define and Undefine a Spool

Permission: Pipe Spools – Create/Delete

To define a selected spools

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Under the Undefined Spools category, select one or multiple spools and right-click on an undefined spool and choose 
Define Spool.

The Spool Properties window appears. (See Spool Properties Reference (page 333).)

3. Choose a hierarchy level for the spool, a name, finishes, insulation and click OK.

Note: You cannot select the Project as a valid hierarchy. Typically, if the hierarchy is not known at modeling time, it 
should go into one of the Unassigned hierarchies so it is easier to find all the unassigned parts later.

The spool now appears under the Modified Spools heading.

Note: When a spool is defined, the spool will be put on a layer of the same name as the spool.

To define all undefined spools

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Right-click on the Undefined Spools category heading and choose Define All.

The Spool Properties window appears. (See Spool Properties Reference (page 333).)

3. Choose a hierarchy level for the spools and click OK.

ShipConstructor minimizes the Spool Manager and displays a prompt:
Please Select 1/x Spool to define

4. Select any pipe from the first spool that you want to define.

Note: Spools are automatically named based on the order you select them.
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5. Continue to select parts from each spool that you want to define in the order that you want the spools to be named.

Note: To stop defining spools, press Esc. Spools that you have already defined will remain defined. Spools that 
you have not yet defined will remain undefined.

6. When you select a part from the last remaining undefined spool, the Spool Manager returns to normal.

Note: Initial defined spools appear in the Modified Spools category. Once a spool has been approved, it will move 
to the Defined category.

Tip: Use Override Color to change the color of the defined spools within the drawing. This makes it easier to see 
which spools you have not yet defined when using the Define All command.

Note: When a spool is defined, the spool will be put on a layer of the same name as the spool.

To undefine selected spools

Warning: You cannot undo this action, and all information related to the spool (database information) will be lost. If a 
spool drawing was associated with the spool, the drawing will be moved to the Deleted_Spool_Drawings folder under 
Pipe in the relevant unit.

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spools you wish to undefine and right-click on a defined spool in your selection and choose Undefine 
Spool.

Note: You cannot undefine a locked spool.

ShipConstructor moves the spool from the Defined Spools , Modified Spools, or Empty Spools category to the 
Undefined Spools category.

Note: Empty spools occur when all the parts from a defined or modified spool are deleted. They can be treated 
like a modified spool, and usually should just be undefined to free up the spool name.

To undefine all spools in a category

Warning: You cannot undo this action, and all information related to the spool (database information) will be lost. If a 
spool drawing was associated with the spool, the drawing will be moved to the Deleted_Spool_Drawings folder under 
Pipe in the relevant unit.

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Right-click on the Defined Spools header or the Modified Spools header and choose Undefine All.

Note: You cannot undefine a locked spool.

ShipConstructor moves the spools from the Defined Spools or the Modified Spools category to the Undefined Spools 
category.

Note: Empty spools occur when all the parts from a defined or modified spool are deleted. They can be treated 
like a modified spool, and usually should just be undefined to free up the spool name.

Approve a Spool
Spools that are in the Modified Spools category are spools that have just been either created or modified. These are the 
spools that can be approved. A spool must be approved before it can be moved to the Defined Spools category. 
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Permission: Pipe Spools - Approve

To approve selected spools

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spools in the Modified Spools category you wish it approve and right-click on a spool in your selection and 
chose Approve Spool from the right-click menu.

The spool automatically moves to the Defined Spools category.

To approve all spools

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Right-click on the Modified Spools category heading and select Approve All.

All the spools that were in the Modified Spools category now appear in the Defined Spools category.

Lock and Unlock Spools
You can lock a defined spool to prevent any editing of the parts in the spool that would change the spool (for example, 
erasing, moving, adding new parts to unconnected ends, or adding and removing breaks). Once a spool is finished, you 
should lock the spool to prevent a modeler from changing the spool without first checking with the project manager.

To lock selected spools

Permission: Pipe Spools - Lock

There are three methods available to lock a spool:

Open the Spool Manager. (See Creating Spools (page 127).)

1. Right-click on a selection of spools in the Defined Spools category and choose Lock Spool from the right-click menu.

OR

2. Click on the unlock icon beside a defined spool. The icon should change to a lock.

OR

3. Click on a defined spool. In the properties window at the bottom of the Spool Manager (see Spool Manager 
Reference (page 329)), click the unlock icon to change it to a lock icon.

To unlock a spool

Permission: PIpe Spools - Unlock

There are three methods available to unlock a spool:

Open the Spool Manager. (See Creating Spools (page 127).)

1. Right-click on a selection of spools in the Defined Spools category and choose Unlock Spool from the right-click 
menu.

OR

2. Click on the lock icon beside a defined spool. The icon should change to an unlocked icon.

OR

3. Click on a defined spool. In the properties window at the bottom of the Spool Manager (see Spool Manager 
Reference (page 329)), click the lock icon to change it to an unlocked icon.

Change Spool Properties
You can change the name, hierarchy level, and finishes of a defined spool.

Permission: Pipe Spools - Edit

To change the spool name

1. Open the Spool Manager. (See Creating Spools (page 127).)
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2. Select the spool.

3. Make sure the properties section of the Spool Manager is open. (See Spool Manager Reference (page 329).)

4. There are two methods to change a spool’s name: by changing the naming convention used by the spool, or by 
picking a different generated name, using the spool’s current naming convention.

5. Select the naming convention in the Properties section and change it via the dropdown control. The next available 
name of the new naming convention is used.

OR

6. Click the (…) button beside the spool name in the Properties section.

A list of available names appears.

7. Select a name you want and click OK. The current name will not appear in the list.

To change the hierarchy level

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spool.

3. Make sure the properties section of the Spool Manager is open. (See Spool Manager Reference (page 329).)

4. Click the (…) button beside the hierarchy name.
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A hierarchy tree appears.

5. Select a hierarchy level and click OK.

Note: If you change the hierarchy level of your spool and your naming convention has a hierarchy level item in it, 
the name will not be updated. This means that you will have to re-name your spool to reflect these changes.

To change the finishes of a spool

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spool.

3. Make sure the properties section of the Spool Manager is open. (See Spool Manager Reference (page 329).)

4. Click beside the finishes list.

The Select Finishes window appears.
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5. When you finish changing the finishes, click OK. See Finishes Reference (page 269) for more details.

To change the insulation of a spool

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spool.

3. Make sure the properties section of the Spool Manager is open. (See Spool Manager Reference (page 329).)

4. Click beside the insulation list.

The Select Insulation window appears.
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5. When you finish changing the insulation, click OK. See Insulation Reference (page 268) for more details.

View Spool History
Spool history is created for every spool. Before saving a system model drawing, the spool history is updated based on the 
actions you perform in the drawing so you can keep track of what you have done before you save. After the drawing is 
saved and re-opened, the spool history changes to reflect the time when your drawing was saved. For example, if you 
modify the spool a few times, before saving the drawing the spool history will show each modification, after saving and 
re-opening the spool history will show one modification at the time the drawing is saved.

To view spool history

1. Open the Spool Manager. (See Creating Spools (page 127).)

2. Select the spool.

3. Make sure the properties section of the Spool Manager is open. (See Spool Manager Reference (page 329).)

4. Click beside the revision history.

The Spool Revision History window appears.

Note: The Spool Revision History window will not appear if the spool has just been created. If a spool has just 
been created, the word Created will appear in the Revision History row in the Properties section of the Spool 
Manager.
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Click OK to close the window.

OPM
The Object Properties Manager (OPM) in AutoCAD is a very powerful tool when used with ShipConstructor entities. 

Each ShipConstructor entity has properties which can be seen in the OPM, many of which can be modified directly 
through the OPM without running separate commands.

In addition to the general OPM properties that all AutoCAD entities shared, ShipConstructor adds Solid LineType and Solid 
LineWeight. These properties allow you to set the line type and line weight of the solid separately from the centerline. The 
centerline line type and line weight will use the default LineType and LineWeight properties. As with all AutoCAD entity 
properties that aren’t ShipConstructor properties, they will not transfer between drawings such as when creating a 
production drawing or regenerating a model drawing from the database.
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In this example, the properties with the white background are the properties which are editable. There are general 
properties as well as part specific properties. User-defined attributes that are assigned to the stock or part, can be seen 
here. The part user-defined attributes can be edited through the OPM. The ShipConstructor entities have logically
categorized properties according to the specific part’s properties for easy navigation.

Weight
There are 4 different types of weight listed for pipes in the OPM and available in the BOM’s: water weight, fluid weight, dry

weight, and wet weight.

Water Weight – This is the weight of the water in the pipe if the pipe was completely filled.
Fluid Weight – This is the weight of the fluid actually in the pipe. It is calculated as the water weight * Fill Ratio * 
System Density. The fill ratio and the system density are defined in the system the part is in. 
Dry Weight – This is the weight of the pipe part with no fluid.
Wet Weight – This is the overall weight of the pipe. It is calculated as the dry weight + fluid weight.

Activate UCS from Parts
This is a ShipConstructor Utility function that is accessed through either the SC Utilities > Activate UCS… menu command 
or through the Utilities toolbar button. This utility behaves differently depending on what type of ShipConstructor parts are 
selected while using the command.

This document describes the command if you select a Distributed Systems part. For information on this command while 
selecting other ShipConstructor parts, please refer to the respective parts’ documentation.

To activate a UCS from a part

1. Choose SC Utilities > Activate UCS…

The Activate UCS window appears. For more information about the options in this window, please see the Structure 
manual.

2. Click on the Activate from Object button.

3. Select a Distributed Systems part such as Pipe.
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Note: Xref’d objects and dimensions are also selectable.

The Select UCS Options window appears. 

4. Select the options for the UCS and click OK. See Select UCS Options Reference (page 272) for more information.

The UCS will now be activated based on the options selected. To see a list of all the UCSs in your drawing, open up the 
Activate UCS window again and you should see the UCS that you just created.

Pipe-UCS Intersection
The UCS Intersection utility is useful when trying to place Elbows and other fittings at corner points with pipes that 
transcend the current UCS.

Add Pipe-UCS Intersection

To add a Pipe-UCS Intersection

1. Choose SC Pipe > Pipe-UCS Intersection > Add Pipe-UCS Intersection (page 240).

2. Select the end on the pipe part that you want to create an intersection for.

3. If the end direction intersects the current UCS a circle will be drawn at the intersection point and a dotted line will be 
drawn between the center of the circle and the selected end.
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Toggle UCS Intersection Line
To toggle displaying the dotted line drawn from the Pipe part to the intersection circle choose SC Pipe > Pipe-UCS 
Intersection > Toggle Highlight on all HEP-UCS Intersection (page 241).

Erase Pipe-UCS Intersection
The UCS intersection can be erased by modifying the pipe end that contains the intersection or by manually deleting the 
intersection.

To manually erase a Pipe-UCS Intersection

1. Choose SC Pipe > Pipe-UCS Intersection > Erase HEP-UCS Intersection (page 241).

2. Select the pipe end with the UCS intersection that you want to erase.

3. If an UCS intersection exists on the end it will be deleted.

Erase All Pipe-UCS Intersections
To erase all Pipe-UCS intersections in the current drawing choose SC Pipe > Pipe-UCS Intersection > Erase All HEP-UCS 
Intersection (page 241).

Hanger Modeling
This section of the manual explains how to use the tools provided in the hanger module to take the stocks you defined in 
the hanger library and place them in a model drawing to create a hanger model.

Hanger Drawings
You model hangers within hanger or pipe drawings.

For more information on drawings, see Drawings in the Structure manual.
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Create an Hanger Drawing

To create a Hanger drawing

1. Choose ShipConstructor > Navigator to open Navigator.

Note: To create a drawing for a unit other than the current unit, select the project at the top of the component list 
(for example, SC2009Demo), then select the unit in the Unit list.

2. Select Hanger in the component list.

3. Select the Hanger folder in the drawing list.

4. Click New Hanger.

The New Drawing window appears.

5. Enter a File name for the drawing.

Note: To open the new drawing, check the Open new drawing check box.

6. Click OK.

Upon Opening an Hanger Drawing
When opening a hanger model drawing, if connected to the database, synchronization occurs between the drawing and 
the database. If there are parts that are not in the database but are in the drawing they will be deleted from the drawing.

Note: This synchronization process does not happen with production drawings. For production drawings, you must 
choose to update it with the Update command in the respective production drawing menu.

Set Up Hanger Defaults, Display, and Performance

Display Options for Hangers

To change the hanger and support display options

1. Choose SC Supports & Hangers > Hanger And Support Drawing Options to open the Hanger & Support Drawing 
Options window. 

2. Set the display options. See Hanger & Support Drawing Options (page 275) for a description of each option.

3. Click OK to close the Hanger Options window.
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NavAid Options
When you are placing hangers that require directional input, a visual aid called the NavAid appears to help you orient the 
component. You can adjust the size and snap behavior of the NavAid. The NavAid settings are adjusted in the drawing 
options of the part type that is being hung.

To change the NavAid options

1. Choose SC Pipe > Pipe Options to open the Pipe Drawing Options window.

2. Click the NavAid tab.

3. Set the options. See The NavAid Tab (page 261) for details.

4. Click OK to save changes and close the Pipe Drawing Options window.

Insert Hangers
You create a hanger model by inserting hangers into a hanger drawing.

There are seventeen different types of distinctly modeled hangers that can be inserted into a hanger drawing. The 
different types of hangers are defined in the Hanger Stock Catalog in Manager. 
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Placing a hanger typically involves selecting a pipe part to place the hanger on and then providing geometric input that 
determines where the hanger is located and how it is oriented. You will provide geometric input by clicking points in the 
model and using the command line options.

Note: The hangable part types are pipe straights, pipe bents, and pipe elbows.

Information about the current stock that you are routing will appear on the command line. 

Selecting a Hanger Part to Place
To place a hanger you must first select the part that the hanger will hang. If this is the first hanger you are placing the 
Hanger Stock Selection window will be displayed to let you select a hanger stock to place. The Hanger Stock Selection 
window will let you select a hanger stock that you made in the Hanger Stocks Catalog.

To select a stock to insert

1. From the SC Supports & Hanger menu or the Hanger toolbar, choose the New Hanger command. Select the 
hangable parts you wish to place hangers on. The Hanger Stock Selection window will appear. See Hanger Stock 
Selection Window Reference (page 274) for more information.

Note: If there are no stocks shown clear all the filters and make sure that there are stocks of the type selected 
created and assigned to the nominal size and material of the selected hangable.

2. Select a hanger type and a stock and click OK.

3. If there are available accessory packages on the stock selected the Select Accessory Package window will be 
displayed, allowing you to pick an accessory package to assign to the hanger part.
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NavAid
The NavAid is a tool intended to help you with several aspects of hanger placing. It can be helpful for two things:

• Visualizing the current UCS

• Snapping input points to fixed angles

When visible, the NavAid is located at the current UCS origin, aligned to the UCS XY plane. The angle displayed by the 
NavAid is the polar angle of the current input point. The center of the NavAid is indicated by a small cross, with the longer
axis in the X direction (0° angle).

Place Hanger
To place a hanger, you will select a stock and then provide a position on the hangable part and an orientation point and 
rod height (if the hanger type has a rod).
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To place a hanger

1. Choose SC Supports & Hanger > New Hanger.

2. You are prompted to select parts to hang the hangers on. Select any number of hangable parts to place hangers on. 
The hangable parts can either be in the current drawing or MLinked into the current drawing.

3. If this is the first hanger you are placing on the selected type of hangable part, the Hanger Stock Selection Window 
will appear to select a stock. If you have placed hangers on the type of hangable part, the previous selection will be 
automatically selected.

4. You are prompted to pick the position of the hanger along the first hangable part selected. The hanger part will slide 
along the centerline of the hangable part to display where the hanger will be placed.
Please pick point along pipe for first hanger location : or [Change stock/Distance between 
hangers <0.00>]:
If desired, choose one of the available options:

5. Click anywhere along the hangable part where to select the position where the hanger will be placed.

6. You are prompted to pick an orientation and a rod length for the hanger.
Choose an orientation and rod length : or [ZRotate/Snap<on>/Distance between hanger <0.00>]
 If desired, choose one of the available options:

7. Click anywhere in the model to select the orientation for the hanger. If the hanger has a rod the rod length will be 
determined by the point specified or up to its maximum length specified when creating the stock.

8. Another hanger of the same stock will automatically start routing along the same hangable part once the previous 
hanger has been placed. Press Enter to stop placing hangers or if multiple hangable parts were selected to start 
hanging on the next hangable part.
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Hanger Routing Options
Several routing options are available in many different routing cases and serve more or less the same use in each case. 
To use the options, type their shortcuts (the letters that are capitalized when the options are displayed on the command 
line). Descriptions of each follow.

Hanger General options
• Change stock – Opens the Hanger Stock Selection window, allowing you select a different hanger stock.

• Distance between hangers <0.00> – Places hangers the distance specified apart in the direction specified.

The following options affect the The NavAid’ (page 91)s behavior or orientation.

• Snap – Toggles snapping of picked points to fixed angles (shown as spikes on the NavAid). The current setting is 
displayed in the command line in <angle brackets>.

• ZRotate –Rotates the NavAid (or equivalently, the current UCS) about the z-axis according to the right-hand rule.

Object Snaps
Hangers have several Object snap points that you may find useful when placing other parts in the drawing. The Object 
snaps can be enabled or disabled by clicking the OSNAP button on the AutoCAD status bar, by pressing F3, or by right 
clicking on the OSNAP button and clicking On or Off.  To enable or disable the Object snaps types, right click on the 
OSNAP button and click Settings.

Endpoint Object Snaps
The Endpoint OSNAPS will snap to the ends of the hanger. If the hanger has a rod the snap point will be at the top of the 
hanger. If the hanger does not have a rod the snap point will be at the edge of the hanger.
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Center Object Snaps
The center OSNAPS will snap to the point at the center of the hanger. This is the position on the centerline of the part the 
hanger is hung on where the hanger was placed.
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Nearest Object snap
The nearest OSNAP will snap to the nearest point along the 2d line used to define the hanger. The 2d line can be seen 
when the hanger is set to Show 2D Geom in the Hanger Drawing Options.



Hanger Modeling

153

Modify Hangers

Name Hangers
The Name Hangers command will rename the hangers that are selected in order based on their position on the parts they 
are hung on and order that the hangable parts are connected together. The hangers will be named using the current 
naming convention defined for hangers. 

Warning: This command cannot be undone once it has run.

To Rename Hangers

1. Choose SC Supports & Hangers > Name Hangers.

2. You are prompted to select the hangers you would like to rename.
Select hangers to rename [All/Pipe/Selection]:

• All – Will select all the hangers in the current drawing.

• Pipe – You will be prompted to select one or more pipes that have hangers and those hangers will be renamed.

• Selection – You will be prompted to select one or more hangers to be renamed.

3. You will be notified that the command cannot be undone. Click Yes to continue.

4. The selected hanger parts will be automatically renamed and the drawing will be automatically saved when it is 
finished.
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Move Hangers to Drawing
The Move Hangers to Drawing command will move the selected hangers to a drawing specified. The hangers being 
moved can be both hangers in the current drawing and hangers that have been MLinked in.

To Move Hangers to Drawing

1. Choose SC Supports & Hangers > Move Hangers to Drawing

2. Select the hangers that you wish to move to a different drawing.

3. You will be notified that the command cannot be undone. Click Yes to continue.

4. In the Select Single Drawing window select the drawing you want the hangers to move to.

5. A log file will be displayed showing which hangers were moved and which drawing they were originally in.

Move Attached Hangers to Current Drawing
The Move Attached Hangers to Current Drawing command will move all hangers that are hung on the selected hangable 
part to the current drawing. The hangers do not need to be MLinked in to bring them into the drawing. This command can 
be used if you want to modify the hangable part. The hangable part can only be modified if all the hangers are present in 
the current drawing so that they can be properly updated.

To Move Attached Hangers to Current Drawing

1. Choose SC Supports & Hangers > Move Attached Hangers to Current Drawing

2. Select one or more hangable parts that hangs the hangers you would like brought to the current drawing.

3. You will be notified that the command cannot be undone. Click Yes to continue.

4. A log file will be displayed showing which hangers were moved and which drawing they were originally in.

Grip-points
There are three different types of grips for hangers: slide, length and rotate. Slide grips are arrows that point along the 
same direction of the hangable part, rotate grips are square, and length grips are arrows that point up from the hanger 
and only exist on hangers with rods.  The slide grip points can be used to slide the hanger along the hangable part. The 
rotate grip points can be used to rotate the hanger around the hangable part, the rotate grip points will also change the 
length of the rod if the hanger has a rod. The length grips will change the length of the rod up to its maximum length.
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OPM
The Object Properties Manager (OPM) in AutoCAD is a very powerful tool when used with ShipConstructor entities. 

Each ShipConstructor entity has properties which can be seen in the OPM, many of which can be modified directly 
through the OPM without running separate commands.
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In this example, the properties with the white background are the properties which are editable. There are general 
properties as well as part-specific properties. User-defined attributes that are assigned to the stock or part can be seen 
here. The part user-defined attributes can be edited through the OPM. The ShipConstructor entities have logically 
categorized properties according to the specific part’s properties for easy navigation. 
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Support Modeling
This section of the manual explains how to use the tools provided in the support module to take the stocks you defined in 
the support library and place them in a model drawing to create a support model.

Support Drawings
You can model supports within support, pipe, or structure drawings.

For more information on drawings, see Drawings in the Structure manual.

Create a Support Drawing

To create a Support drawing

1. Choose ShipConstructor > Navigator to open Navigator

Note: To create a drawing for a unit other than the current unit, select the project at the top of the component list 
(for example, SC2009Demo), then select the unit in the Unit list.

2. Select Support in the component list.

3. Select the Distributed System Supports folder in the drawing list.

4. Click New

The New Drawing window appears

5. Enter a File name for the drawing

Note: To open the new drawing, check the Open new drawing check box.

6. Click OK.

Upon Opening a Support Drawing
If the project is connected to the database, and a model drawing is opened, the drawing will be automatically 
synchronized with the database. During the synchronization process, the database is considered to be a source of true 
information: modeled parts that exist in the drawing but don't have associated database records will be deleted from the 
drawing. At the same time, if there are database records that are not represented with modeled parts, new parts will 
appear in the drawing.

Note: The database synchronization doesn't apply to production drawings. To update a production drawing, one must 
open the drawing in ShipConstructor and manually run the Update Drawing command (SCUPDATEDWG) from the 
respective command menu.
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Set Up Support Defaults, Display, and Performance

Display Options for Supports

To change the display options

1. Choose SC Supports & Hangers > Hanger And Support Drawing Options to open the Hanger & Support Drawing 
Options window.

2. Set the display options. See Display Options for Hangers (page 145) for a description of each option.

3. Click OK to close the Hanger & Support Drawing Options window.

NavAid Options
1. Choose SC Supports & Hangers > Hanger And Support Drawing Options to open the Hanger and Support Drawing 

Options window.

2. Set the options. See The NavAid Tab (page 261) for details
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3. Click OK to save the changes and close the Hanger and Support Drawing Options window.

Insert Supports
You create a supports part by inserting supports into a drawing.

There are 7 different types of support templates that can be inserted into a drawing. The different types of supports are 
defined in the Pipe Support Template Catalog in Manager.

There are 2 distinct ways to insert a support part into a drawing.

Note: The hangable part types are pipe straights, pipe bents, and pipe elbows.

Bare Support
A bare support is placed in the drawing without being attached to any hangable parts. The support is only constrained by 
Support Template and can be placed anywhere in the drawing. This is useful for placing supports before placing the pipes 
that it will be supporting.

To insert a bare support:

1. Choose SC Supports & Hangers > Insert Bare Support.

If this is the first bares support that is being placed this session the Select Support Template window is displayed 
otherwise the last used support template is used again.

2. Select a Support Template Type and template and click OK. 

NavAid
The NavAid is a tool intended to help you with several aspects of placing the support. It can be helpful for two things:

• Visualizing the current UCS
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• Snapping input points to fixed angles

When visible, the NavAid is located at the current UCS origin, aligned to the UCS XY plane. The angle displayed by the 
NavAid is the polar angle of the current input point. The center of the NavAid is indicated by a small cross, with the longer
axis in the X direction (0° angle).

Place Bare Support
To place a bare support you will select a stock provide a position for the support, orient the support, provide a support 
height, and support width.
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To place a bare support

1. Choose SC Support & Hangers > Insert Bare Support.

2. If this is the first bare support you are placing the Support Template Selection window will appear to select a 
template. If you have previously placed a bare support the previous selection will be used.



Support Modeling

162

3. You are prompted to pick the position of the support.
Please pick point to place support : or  [Change stock/inTersection mode/Place by next 
Foot/pLace by next Level/Align to part/plaNE/XRotate/YRotate/ZRotate/SNap<on>/Mirror/Flip 
supporting profile]:
If desired, choose one of the available options (see General Options (page 103) for options not listed here):

• Change stock – Displays the Support Template Selection window to choose a new template to use.

• Intersection Mode – Changes the placement mode to intersection. Instead of placing by the corner of the profile 
it’s placed on the corner of flange and web of the profile. After placing a lap distance is entered. This option is 
only available if there is no base plate on the support template.

• Place by next foot – If the support template contains more than one vertical then the next vertical will be used 
for placing and orienting the support.

• Place by next level – If the support template contains any cross tiers then the next cross tier will be used for 
placing and orienting the support.

• Align to part – Ask you to select a part and displays the Select UCS Options window to define the UCS based off 
the selected part.

• Mirror – Mirrors the part causing the supporting directions to be reversed.

• Flip supporting profile – Flips the flange directions of the cross tier levels. This is useful if the support will be 
hanging from a part so that the supported pipes will sit on the support profiles. This option is only available if 
the supporting profile directions are opposite.

4. Click anywhere to place the support. If the support is being placed by a level other then the base of the support and 
the point picked is a snap point on a hangable part. You will be asked if you want to align the support to the part.

If desired, choose one of the available options (see General Options (page 103) for options not listed here):

5. Click anywhere in the model to select the orientation for the support.

6. Click anywhere to specify the height of the support. The height will be specified by the point picked or up to the 
maximum height specified in the support template.

7. If the support has multiple cross tiers click in the model to place the cross tier at the desired position.
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8. Click anywhere in the drawing to specify the width of the support. The width will be specified by the point picked or 
up to the maximum width specified in the support template.

9. If the support has more than 2 vertical levels click in the model to place the other vertical levels.

Auto Support
The auto support is used to place a support attached to a selection of hangable parts. To use the auto support you will 
select some hangable parts, a stock, and hangers for each type hangable stock. The Insert Auto Support command will 
allow you to insert any type of support; the specific auto support commands will allow you to insert only that type of 
support.

To place an auto support

1. Choose SC Support & Hangers > Insert Auto Support.

2. Select the hangable parts you would like to support.
Please select hangable objects to auto-support: or [Tolerance]:
If desired, choose one of the available options:

• Tolerance – The tolerance is the maximum allowable distance between the support and the hangable part. The 
initial tolerance value is specified in the Pipe to Support Distance Tolerance project setting. The tolerance can 
only be overridden if the user has the appropriate permission.

3. The Select Support Template window is displayed with support templates that can be used to support the selected 
hangable parts.

4. Select the support template you wish to use and the hangers and accessory packages for each type of hangable 
stock selected and click OK.

5. The support will slide along the available length of the hangable parts. Click anywhere to place the support on the 
hangable parts.
Please pick location of support: or [Next Section/Rotate/Mirror]:
If desired, choose one of the available options:
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• Next Section – Will move the support to the next section of the selected hangable parts.  This option is only 
available if multiple sections of the selected hangable parts can be used to place the selected support.

• Rotate – Will rotate the support around the hangable parts to the next available orientation.

• Mirror – Mirrors the part causing the supporting directions to be reversed.

6. Click anywhere to adjust the length of the support to the desired height.

Modify Hangers

Name Supports
The Name Supports command will rename the supports that are selected in order based on the hangers attached to the 
support and the position that the hangers are hung on the hangable parts. The supports will be renamed using the 
current naming convention defined for supports.

Warning: This command cannot be undone once it has run.

To Rename Supports

1. Choose SC Supports & Hangers > Name Supports in Order.

2. You are prompted to select the supports you would like to rename.
Select supports to rename [All/Selection]:

• All – Will select all the supports in the current drawing.

• Selection – You will be prompted to select one or more supports to be renamed.

3. You will be notified that the command cannot be undone. Click Yes to continue.

4. The selected support parts will be automatically renamed and the drawing will be automatically saved when the 
command was finished.

Move Supports to Drawing
The Move Supports to drawing command will move the selected supports to the specified drawing. The supports that are 
moved can be both supports in the current drawing and supports that have been MLinked in. If the supports being moved 
are attached to hangers the attached hangers will also be moved to the specified drawing.

To Move Supports to Drawing

1. Choose SC Supports & Hangers > Move Supports to Drawing.

2. Select the support that you wish to move to a different drawing.

3. You will be notified the command cannot be undone. Click Yes to continue.

4. In the Select Single Drawing window select the drawing you would like to move the supports to.

5. A log file will be displayed showing which supports were moved and which drawing they were originally in.

Attach Pipes to Supports
The Attach pipes to supports command will attach a selection of pipes to the specified supports with appropriate 
hangers. The selected pipes may be in the current drawing or have been MLinked in. The selected supports must be in the 
current drawing.

To Attach Pipes to Supports

1. Choose SC Supports & Hangers > Attach Pipes to Supports.

2. Select the hangable parts that you would like to attach to the supports.
Please select hangable objects to support: or [Tolerance]:
If desired, choose one of the available options:
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• Tolerance – The tolerance is the maximum allowable distance between the support and the hangable part. The 
initial tolerance value is specified in the Pipe to Support Distance Tolerance project setting. The tolerance can 
only be overridden if the user has the appropriate permission.

3. Select the support parts to attach the hangable parts to.

4. If the supports and hangable parts can be attached together the Hanger Stock Selection window will be displayed to 
select which hanger to use to attach the parts together. The Hanger Stock Selection window will be displayed once 
for each type of hangable stock being attached.

5. Select the appropriate hanger and accessory package and click OK.

Copy Supports along Supported Objects
The Copy supports along supported objects command will copy a selected support and you place the copied support 
along the same hangable that the original support was attached to.

To Copy Supports along supported objects

1. Choose SC Supports & Hangers > Copy Supports along Supported Objects.

2. Select the supports to copy.
Please pick location of support: or [Next Section]:
If desired, choose one of the available options:

• Next Section – Moves the support to the next available section on the hangable parts. 

3. Select the point on the hangable parts where to place the copied support.

Grip Points
The grip points for supports can be used to adjust the length and width of the support and to adjust the cross tier heights. 
The grip points to adjust the length of the support are the square grip points at the bottom of the vertical levels. The 
vertical levels will be adjusted individually. The arrow grip points on the cross tiers are used to adjust the height of the 
level. The cross tiers levels are restricted to be between the cross tiers above and below the cross tier. The cross tiers will 
only have grip points if that cross tier is not attached to a hangable part. The arrow grip points that point away from the 
support can be used to adjust the width of the support.
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OPM
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In this example, the properties with the white background are the properties which are editable. There are general 
properties as well as part-specific properties. User-defined attributes that are assigned to the stock or part can be seen 
here. The part user-defined attributes can be edited through the OPM. The ShipConstructor entities have logically 
categorized properties according to the specific part’s properties for easy navigation. 
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Distributed Systems Production Drawings
There are two different types of production output drawings that you can create using the Distributed Systems modules. 
You can create spool drawings and arrangement drawings. Spool drawings are created from HVAC or Pipe spools that are 
a series of interconnected ducts or pipes. Arrangement drawings can be created from Structure, Pipe, HVAC, and 
Equipment drawings and Pipe and HVAC systems as well as assemblies.

Creating a Spool Drawing
Several portions of ShipConstructor have to be configured correctly to produce spool drawings. The more time and effort
you put into setting up the required styles, templates, and settings, the better the resulting, automatically created spool 
drawings will look.

To create a spool drawing

Before you can create a spool drawing, you need five things:

1. A valid, active spool naming convention.

2. A defined and approved spool.

3. An HVAC or Pipe Spool Template drawing. Template drawings should have:

a. Dimension and text styles pre set.

b. A preformatted BOM inserted in the appropriate location.

c. Keywords inserted in the appropriate location.

d. Drawing options pre set.

4. Permission to create an HVAC or Pipe spool drawing.

5. A defined spool style or permission to define one.

Set Up Spool Naming Convention
One of the first steps in creating a spool is to define a spool naming convention. Spools cannot be defined without one.

To set up a spool naming convention

1. Choose ShipConstructor > Manager to open Manager.

2. Choose General > Naming Conventions to open the Naming Conventions window.
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3. Under Name Conventions, select HVAC > Spool or Pipe > Spool.

4. Click New.

5. Set up naming convention properties. For a spool naming convention, the database items that can be used are 
System and Assembly. For more information on how to set up these properties see the Naming Conventions section 
in the Structure manual.

Note: If the selected level of database item is lower than the actual parts level, no database item will be 
generated. For example, if you select an Assembly level of Panel, but your spool is joined to the Unit level, an 
empty string appears for that element in the generated spool name.

A check mark appears beside the naming convention in the Naming Conventions tree indicating that it is the active 
naming convention for that category.

Set an Active Naming Convention
You can have several spool naming conventions; however, only one spool naming convention can be the active naming 
convention that ShipConstructor uses.

To set a naming convention active

1. In the Naming Convention window, select the naming convention that you want to be active.

2. Click Set Active.

Set Up a Spool Template Drawing
One of the requirements to create a spool drawing is a spool template drawing. There must be a spool template defined 
for the type of spool drawing you want to create. For example, if you want to create an HVAC spool drawing, you must 
have an HVAC Spool Template defined.

To create a spool template drawing

1. Open Navigator (choose ShipConstructor > Navigator).
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2. Navigate to the Templates directory.

3. Select the HVACSpool folder and click New HVACSpool.

OR

4. Select the PipeSpool folder and click New PipeSpool.

5. Enter a name for the Spool Template drawing.

6. Click OK.

Set up the template drawing with the settings that you want to see in your generated spool drawing.

Customizing the Template Drawing
The template drawing controls how the final output drawing appears. By setting up viewports, styles, and layouts in a 
template drawing, all the production drawings that are generated with this template look generally the same. The 
template drawing selected when creating a production drawing, is used as a base for the drawing. This means that most 
AutoCAD options that are drawing specific and setup in the template drawing, will be in the production drawing created.

In order to help you customize the appearance of the template drawing, a number of layers are created and used:

• SCDimension – Dimensions are on this layer. Re-dimensioning a drawing will delete all objects on this layer. Change 
the color of this layer to control the color of the dimensions in the resulting spool drawings.

• Offset – Hatches and boxes for offsets are on this layer. Re-dimensioning a drawing will delete all objects on this 
layer. Change the color of this layer to control the color of the hatches and offsets in the resulting spool drawings.

• Spool Layer – All HVAC and Pipe entities are place on this layer. Change the color of this layer in combination with 
the Use Branch Color option in the Display Options to control the colors of the parts in the generated spool drawings.

Generally, the appearance of HVAC and Pipe parts in production drawings will adhere to the HVAC or Pipe options and 
native AutoCAD rendering options just as for model drawings.

Note: When plotting shaded viewports, part centerlines (if turned on) are projected in front of the part geometry such 
that they are easily visible. Furthermore, remember that AutoCAD allows you to override a viewport’s visual style 
when plotting (see AutoCAD’s SHADEPLOT setting for viewports).

Tip: The Pipe or HVAC drawing options you set in template drawing will be inherited in the final output drawing. We 
recommend that you disable all modeling aids such as free end arrows in order to produce the cleanest output 
drawings.
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A spool drawing as produced by ShipConstructor before any detail work has been done.  

Insert a New Empty Spool BOM Table

Note: In order to insert a spool BOM, there needs to be one defined in Manager. 

Bills of materials (BOM) in ShipConstructor are highly configurable. For the full functionality overview and for instructions 
on creating BOM definitions, see Bill of Materials (page 311).

ShipConstructor uses AutoCAD tables to present the BOM data. Tables created using the Insert Empty BOM Table
command have specific properties:

• They use the column headings specified by the BOM Definitions window. Column headers are updated every 
time the tables are updated.

• They are populated with data extracted from the database.

• They use the AutoCAD title, dimension, and table style specified by the BOM Definitions window.

• They are filled after the production drawings are updated and by running the SCUPDATEBOMS command.

• They reference one data master list per BOM definition.

• They reference the same item numbers regardless of layout.

To insert an empty BOM table

Note: You must be in paper space to insert a spool table.

1. Choose SC Spool Template > Insert BOM Table. The BOM Definition Wizard appears.
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2. Select the appropriate BOM definition and click Next. The settings particular to the BOM definition are displayed for 
reference after BOM selection.
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3. Various options available for BOM and labeling may be specified in step 2. See Insert Empty BOM Wizard (page 320).

4. Click Finish.

5. Depending on the Collectors included in the BOM definition, there may be additional attributes that can be selected.
If there are any such attributes, a window appears. The Pipe Part Collector that is normally included in a spool stock 
BOM contains such options.

6. Accept the default options to ensure that everything in the spool is listed and then click OK.

7. If the drawing is in model space it will automatically switch to paper space to place the BOM.

8. A sample table is created using the AutoCAD table style specified by the BOM Definition. Select the location for the 
table.

9. You may choose to prearrange more than one table if you anticipate table wrapping (BOMs with more items than 
specified by the Maximum number of rows property.

Spool Drawing Keywords
Spool drawing keywords consist of general keywords, spool related keywords, and module specific spool related 
keywords. Default keywords are updated when a spool drawing is generated to reflect each keyword’s current value. For 
example, if you have a <LAST UPDATE DATE> keyword, when the spool drawing is generated the < LAST UPDATE DATE > 
changes to the current date.

Keywords are not updated again until you manually update your spool drawing or choose Update from the right-click 
menu of the keyword. For example, if you had a < LAST UPDATE DATE > keyword in your spool drawing that reflected the 
current date, this date will not change until you manually choose Update from the right-click menu or choose SC Spool 
Drawing > Update Drawing.

Keywords are ShipConstructor entities. If you have previous keywords from a ShipConstructor2005 or earlier template, 
update your template using the update template command. (See Update a Previous Version of a Spool Template (page 
175).) Most of your keywords should be converted to the ShipConstructor keyword entities.

See Keywords Reference (page 336) for a list of available spool keywords and their description.

To insert keywords

Note: You must be in paper space to insert keywords.

1. Choose SC Spool Template > Insert Keywords.

The Spool Keyword window appears. (See Keywords Reference (page 336).)
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2. Select set up properties for the keywords.

3. Select the keywords that you want to include.

4. Click OK.

5. If the drawing is in model space it will automatically switch to paper space to place the keywords

6. ShipConstructor prompts you to select a location for each keyword you selected.
Please select a location for <LAST UPDATE DATE>

7. Select locations for all keywords.

To delete a keyword

1. Select the keyword.

2. Press Delete.

To change the properties of a keyword

1. Select the keyword.

2. Right-click and select properties to bring up AutoCAD’s OPM.

3. Change the properties in the OPM.

Note: In the OPM, you can change the text display properties as well as pre and post append text to a specific 
keyword. 

Update a Previous Version of a Spool Template
This command updates your keywords to the new ShipConstructor keyword entities. In most cases, the default keyword 
text has changed. You may want to re-position these keywords slightly to accommodate the new default text.
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This command also creates the three default layers used for ShipConstructor  Spool Drawings, and pre sets the drawing 
options with more Spool specific options. See Customizing the Template Drawing (page 171). 

To update a spool template

1. Copy your ShipConstructor2005 spool template into the ShipConstructor  spool templates folder.

2. The template should now appear in Navigator. Open the template using Navigator. Register the drawing if asked.

3. Choose SC Spool Drawing > Update.

4. All the keywords that can be updated are updated. Three default layers are created if not already there, drawing 
options are preset.

Generate Spool Drawings
Before being able to create a spool drawing, the following conditions must be met.

Prerequisites for creating a spool drawing

• Created a valid, active, naming convention for HVAC or Pipe spools.

• Defined and approved a spool.

• Created a Spool Template drawing.

• Obtained permission to create a spool drawing.

• Defined a spool style or have permission to define one.

Generating spool drawings is a multi-step process. To make this process easier, there is a Create Spool Drawing Wizard
(See Create Spool Drawing Wizard Reference (page 339)).

To generate a spool drawing

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select HVAC Spool or Pipe Spool in the component list.

3. Click on Create.
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The Create Spool Drawing Wizard appears. (See also Create Spool Drawing Wizard Reference (page 339)).

4. Select a spool template drawing and click Next.
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5. In the tree, select all the spools that you want to create a spool drawing for. You should see all the spools that you 
have selected on the right side of the wizard.

Note: Each spool that you select will generate its own drawing.

6. Click Next.
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7. Select a Spool Style and click Finish.  The last used Spool Style will be selected by default.

Note: There must be a spool style defined. If you have no spool style defined, click Edit under Spool Styles to 
create one. (This requires that you have permission to edit spool settings.) (See Spool Styles Reference (page 
341).)

Note: If a spool drawing with the same name exists already, you will be prompted to overwrite it. 

You will see your spool drawings being generated. If you are in MDI mode, all the spool drawings will open after 
generation. If you are in SDI mode, the last spool drawing generated will be open.

Edit Spool Drawings

Rotate a Dimension
The rotate dimension command provides you with an easy way to re-orient your aligned dimensions in 3D. The axis of 
rotation is defined by the two points that the dimension runs between. You can drag the dimension so that it is rotated 
about this axis while adjusting the length of its extension lines. You can also type an exact distance for the length of the 
extension lines.
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To re-orient a dimension

1. Choose SC Spool Drawing > Rotate Dimension.

2. You are prompted to pick an aligned dimension:
Select an aligned dimension to rotate:

3. Select one aligned dimension to rotate.

4. You are prompted to pick a point indicating the new location and orientation for the dimension.
Please pick point : [ZRotate/SNap<on>]:
If desired, do any of the following:

• ZRotate – To rotate the NavAid about the UCS Z axis (according to the right-hand rule), type ZR (for ZRotate) and 
press Enter.

• Snap – To turn on or off snapping of picked points to fixed angles (the current setting appears in the command 
line in <angle brackets>), type SN (for SNap) and press Enter.

5. Pick a point to set the location of the dimension. You can also type a length at the command line that will be used as 
the length of the dimensions extension lines while still using the rotation angle indicated by the mouse pointer.

Align Dimension Text to View
When changing the view angle of a spool viewport, you may still like the location of the dimensions but wish to re-align 
their text only. Choose  SC Spool Drawing > Align Dimension Text to Current View to do this.

Re-dimension a Spool Drawing
After the initial creation of a spool drawing, you may re-dimension your drawing with different settings or a different view-
angle.  

To re-dimension a spool drawing

1. Choose SC Spool Drawing > Re-dimension.
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2. If desired, click Override Spool Style Dimensions to make changes to the dimensioning options. (See Spool Styles 
Reference (page 341) for details on the dimensioning options).

3. Click OK.

Label Connecting Spool/Assembly
If the spool in the spool drawing is connected to one or more spools, labeling the connection ends where these spools 
connect is a good idea. By running the Label Connecting Spool/Assembly command, each end that connects a spool 
outside the drawing can be selected to have a label generated for it. The label just contains the name of the spool that 
the selected end connects to.

To show a connected spool

1. Choose SC Spool Drawing > Label Connecting Spool/Assembly (page 288)

2. If there are no spools which are connected to the current one, the command ends. If there are connected spools, the 
command will prompt to pick an end of the spool.

3. If the drawing is in paper space the largest viewport will automatically be made active.

4. Once an end is chosen that has a connected spool, a label is placed.

Update Spool Drawings
ShipConstructor spool drawings can be updated. Drawings that need updating can easily be identified in Navigator.

Identifying Drawings that Require Updating
Spool drawings that required updating because the parts contained in the spool drawing have changed are identified in 
Navigator.
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To identify out-of-date spool drawings

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select HVAC Spool or Pipe Spool in the component list.

3. Click the Show Out of Date button.

Out of date spool drawings can be identified by the exclamation mark icon ( ). 

Updating an Existing Spool Drawing
Spool drawings that are out of date can be updated instead of re-created. This lets you preserve all the customization 
work done on a spool drawing, as only the modified geometry of the spooled parts is modified.

Items that are affected during a drawing update include the following:

• All parts will be updated to reflect the latest geometry in the source model drawings.

• The Bill of Materials (BOM).

• All keywords.

• The automatically generated dimensions and offsets (optional).

Note: When ShipConstructor re-dimensions your spool drawing, it will delete all entities which reside on the dimension 
and offset layers. If you wish to preserve your custom dimensioning during an update, it is recommended that you 
place these dimensions on a different layer.

Note: You cannot update a spool drawing from a spool that is not approved.

To update a spool drawing

1. Choose SC Spool Drawing > Update Spool Drawing to start updating the drawing.

2. ShipConstructor determines all parts that need to be updated. 
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3. The Modified Part Information window appears. (See also Modified Part Information Reference (page 349)). 

4. You can use the Modified Part Information window to inspect parts that have changed during this update. Click OK to 
continue the update process.

5. The Bill of Materials (BOM) in this drawing will now be updated. Depending on the size of your drawing and the BOM 
definition, this may take some time.

6. A window appears asking if you want to re-dimension the drawing. If you choose No, the update process is now 
complete. If you choose Yes, continue with Step 7.

7. The Select Dimension Attributes window appears. (See also Spool Styles Reference (page 341)).
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8. You can choose to use the spool dimensioning style that was used to originally create the spool drawing or you can
override the settings. Click OK to finish the drawing updating.

Create Arrangement Drawings

Set Up an Arrangement Drawing Template
One of the requirements to create an arrangement drawing is an arrangement template drawing. There must be an 
arrangement template defined for the type of arrangement drawing you want to create. For example, if you want to 
create an HVAC arrangement drawing, you must have an HVAC arrangement template defined.

The template drawing controls how the final output drawing appears. By setting up viewports, styles, and layouts in a 
template drawing, all the production drawings that are generated with this template look generally the same. The 
template drawing selected when creating a production drawing, is used as a base for the drawing. This means that most 
AutoCAD options that are drawing specific and setup in the template drawing will be in the production drawing created.

To create an arrangement template drawing

1. Open Navigator (choose ShipConstructor > Navigator).

2. Navigate to the Templates directory.

3. Select the HVACArrangement folder and click New HVACArrangement.

OR

Select the PipeArrangement folder and click New PipeArrangement.

4. Enter a name for the Arrangement Template drawing.

5. Click OK.

Insert a New Empty Arrangement BOM Table

Note: In order to insert an arrangement BOM, there needs to be one defined in Manager. 

For a full functionality overview and instructions on creating BOM definitions, see Bill of Materials (page 311).

To insert an empty BOM table

Note: You must be in paper space to insert an arrangement table.

1. Choose SC Arrangement Template > Insert BOM Table. The BOM Definition Wizard appears.
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2. Select the appropriate BOM definition and click Next. The settings particular to the BOM definition are displayed for 
reference after BOM selection.
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3. Various options available for BOM and labeling are specified in Step 2 of the wizard. See Insert Empty BOM Wizard
(page 320).

4. Click Finish.

5. Depending on the Collectors included in the BOM Definition, there may be additional attributes that can be selected. 
If there are any such attributes, a window appears. The Pipe and HVAC Part Collectors that are normally included in a 
stock BOM contain such options.

6. Accept or modify the default options and then click OK.

7. If the drawing is in model space it will automatically switch to paper space to insert the BOM.

8. A sample table is created using the AutoCAD table style specified by the BOM Definition. Select the location for the 
table.

Arrangement Drawing Keywords
Arrangement drawing keywords consist of general keywords, arrangement related keywords, and module specific 
arrangement related keywords. Default keywords are updated when you generate an arrangement drawing to reflect 
each keyword’s current value. For example, if you have a <LAST UPDATE DATE> keyword, when the arrangement drawing 
is generated the <LAST UPDATE DATE> changes to the current date. 

Keywords are not updated again until you manually update your arrangement drawing. For example, if you had a <LAST 
UPDATE DATE> keyword in your arrangement drawing that reflected the current date, this date will not change until you 
manually call update from the menu.

Keywords are ShipConstructor entities. If you have previous keywords from a ShipConstructor2005 or earlier template, 
update your template using the update template command. See Update a Previous Version of an Arrangement Template
(page 187). Most of your keywords should be converted to the ShipConstructor keyword entities.

See Keywords Reference (page 336) for a list of available keywords and their description.

To insert keywords

Note: You must be in paper space to insert keywords.

1. Choose SC Arrangement Template > Insert Keywords.

The Insert Keyword window appears. 

2. Set up the properties as you want them for the keywords.
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3. Select the keywords that you want to include.

4. Click OK.

5. If the drawing is in model space it will automatically switch to paper space to insert the keywords.

6. ShipConstructor prompts you to select a location for each keyword you selected.
Please select a location for <LAST UPDATE DATE>

7. Select locations for all keywords.

To delete a keyword

1. Select the keyword.

2. Press Delete.

To change the properties of a keyword

1. Select the keyword.

2. Right-click and select properties to bring up AutoCAD’s OPM.

3. Change the properties in the OPM.

Note: In the OPM, you can change the text display properties as well as pre and post append text to a specific 
keyword. 

Update a Previous Version of an Arrangement Template
This command updates your keywords to the new ShipConstructor keyword entities. In most cases, the default keyword 
text has changed. You may want to re-position these keywords slightly to accommodate the new default text.

To update an arrangement template

1. Copy your ShipConstructor2005 arrangement template into the newer ShipConstructor arrangement templates 
folder.

2. The template should now appear in Navigator. Open the template using Navigator.

3. Choose SC Arrangement Template > Update from a previous version.

4. All the keywords that can be updated are updated.

Generate Arrangement Drawings
Generating arrangement drawings is a multi-step process. To make this process easier, there is a Create Arrangement
Drawing Wizard (See Create Arrangement Drawing Wizard Reference (page 344)).

To generate an arrangement drawing

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select HVAC or Pipe in the component list.

3. Select the Arrangement sub folder.
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4. Click New Arrangement.

5. The Create Arrangement Drawing Wizard appears. (See also Create Arrangement Drawing Wizard Reference (page 
344)).
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6. Enter a name for the Arrangement drawing and click Next.

Note: You will not be able to click the Next button if the name you entered already exists.
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7. Select an arrangement template drawing and click Next.
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8. Choose all sources and their destination layers that you want to generate your arrangement drawing from (see also 
Create Arrangement Drawing Wizard Reference (page 344)). There are four possible sources:

• Drawings

• Systems

• Assemblies

• Spools

Click on any sources you want to include in your drawing and select a layer from the drop down list or enter the 
destination layer in the text field of the drop down box. Any number of sources can be included in an Arrangement 
drawing. The items in the drop down box are the layers in the template drawing that was selected plus the default 
value of the source name, and you can also enter any text for a destination layer as well.  All selected sources and 
their layers appear on the right hand side of the window. You can later change these sources by updating the 
arrangement drawing (See Update Arrangement Drawings (page 193)).

Note: If you select different sources that include the same part, the part will only show up once in the 
arrangement drawing. This could happen if you include a system model drawing as well as the entire system that 
contains all parts in the selected system model drawing.  Layer conflicts may arise in this situation, but will be 
dealt with in a later step.

Note: You may also choose to retain the layers of the part from its model drawing source at this step. Choosing 
Retain Model Drawing Layers from the dropdown in the layer column will cause the layers from all model 
drawings containing parts in the current source to be copied into the arrangement drawing and the parts will be 
moved to the copy of the layer of their source. This brings in all layers from the source, not just ones used by 
parts in the given source.

Note: While selecting sources, if you hold down the Alt key while checking a box, that box’s children will not be 
checked; otherwise the children will be selected.
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Note: You can optionally not show spools as a source with the Show Spools check box. You can also force spools 
to override any possible layer conflicts caused by parts existing in multiple selected sources with the Spool 
Layers override conflicts check box

9. Click Next.

10. ShipConstructor automatically determines all the drawings that it must collect parts from to populate the 
arrangement drawing. In addition to ShipConstructor geometry, you may also import non-ShipConstructor entities.
You can later change these sources by updating the arrangement drawing (See Update Arrangement Drawings (page 
193)).  Select all drawings that you also want to import non-ShipConstructor geometry from and set destination 
layers for all non-ShipConstructor geometry. Click Finish.

11. The arrangement drawing will be generated and all Bill of Materials tables and keywords will be updated 
automatically. Depending on the number of sources selected and the contents of the selected sources, this process 
may take some time.

12. The Layer Conflict Resolution window appears if there are any conflicts between destination layers of any parts in the 
drawing.(see also Layer Conflict Resolution Reference (page 350)). 
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13. You can use the Layer Conflict Resolution window to sort out the destination layer for any conflicted parts.

Edit Arrangement Drawings

Insert a BOM into an Arrangement
You may at any time insert any extra BOM tables into one of the Arrangement Layouts. As explained in the reference 
section, one Master Bill of materials exists per BOM Definition, per Arrangement drawing. Each table, of a particular BOM 
definition, that is placed in the Arrangement, references one Master Bill of Materials. This way item numbering remains 
consistent across all sheets.

See section Insert a New Empty Arrangement BOM Table (page 184) for instructions in placing BOM tables.

Export a BOM from an Arrangement Drawing to a Text File
Use the AutoCAD command TABLEXPORT. This command outputs a csv file (comma separated value) to a location that 
you specify.

Update Arrangement Drawings
ShipConstructor arrangement drawings can be updated. Drawings that need updating can easily be identified in 
Navigator.

Note: Updating of a production drawing cannot be undone. 

Identifying Drawings that Require Updating
Arrangement drawings that contain parts that have been changed are identified in Navigator.
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To identify out of date arrangement drawings

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select HVAC or Pipe in the component list.

3. Click the Show Out of Date button.

Out-of-date arrangement drawings can be identified by the exclamation mark icon ( ). 

Updating an Existing Arrangement Drawing
Arrangement drawings can be updated in ShipConstructor. This lets you keep all the detail work done to an arrangement 
drawing while importing new parts and geometry, removing unneeded geometry or updating existing parts.

The following items are affected during a drawing update:

• All parts are updated to reflect the latest geometry in the source model drawings.

• The Bill of Materials (BOM).

• All keywords.

• The imported non ShipConstructor geometry

Note: When ShipConstructor updates the non-ShipConstructor entities, it only deletes and re-imports geometry that 
was brought in during the drawing creation to update process. Any additional geometry added by you to the 
arrangement drawing will be unaffected by a drawing update, regardless of which layer the geometry resides on.

Copied Parts in Arrangement Drawings

In an arrangement drawing, you can copy any number of production parts. During an update, the copies of the parts also 
are updated. The following rules apply while updating copied production parts.

• If the original part is deleted from the arrangement drawing by the update process, all its copies are also deleted.

• If the original part is moved or its geometry changes, the copies are also moves and have their geometry changed. 
They will move relative to the original part while updating.
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To update an arrangement drawing

1. Choose SC Arrangement > Update Drawing to start updating the drawing.

2. The Update Drawing Wizard appears (see also Update Arrangement Drawing Wizard Reference (page 351)).

3. All sources that currently make up the arrangement drawing are selected in the various source trees with the layers 
specified for those sources will be remembered from creation or the last time it was updated. In addition, a 
summary of all sources can be seen on the right side of the screen. Add or remove sources as necessary. You also 
set the destination layers for where new parts from these sources will be placed. Existing parts will stay on their 
current layer. Conflicts arising from parts being brought in from multiple sources with different layers will be resolved 
later.  Click Next.

Note: You can optionally not show spools as a source with the Show Spools check box. You can also force spools 
to override any possible layer conflicts caused by parts existing in multiple selected sources with the Spool 
Layers override conflicts check box
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4. ShipConstructor automatically determines all the drawings to collect parts from to populate the arrangement 
drawing. In addition to ShipConstructor parts, you can also import non-ShipConstructor geometry. All drawings that
you currently have imported non-ShipConstructor geometry from will be checked. Select all drawings that you also 
want to import non-ShipConstructor geometry from and set destination layers for all non-ShipConstructor geometry. 
Click Finish. 

5. The Modified Part Information window appears (see also Modified Part Information Reference (page 349)). 
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6. You can use the Modified Part Information window to inspect parts that have changed during this update. Click OK to 
continue the update process.

7. The Bill of Materials (BOM) in this drawing will now be updated. Depending on the size of your drawing and the BOM 
definition, this may take some time.

8. The Layer Conflict Resolution window appears if there are any conflicts between destination layers of any parts in the 
drawing.(see also Layer Conflict Resolution Reference (page 350)).

9. You can use the Layer Conflict Resolution window to sort out the destination layer for any conflicted parts.
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Labeling

Manual Labeling from BOM

To manual label from BOM

1. Choose SC Arrangement > Label > Manual label from BOM (page 282).

2. If there are multiple BOM tables on the current layout then you will be prompted to select a BOM table. Otherwise 
continue to step 3.
Select BOM table:

3. The command will switch to the last active model space viewport that is .has Label items in viewport set.
Select a part to label:

4. Select a part to label. The part must be one that is show in a BOM on the current layout. 
Specify label position (1 seg)[Multi-segment]:

5. If multi-segment option is selected, you will be prompted for more segments for the leader.

6. Select the position in paperspace to place the label. If you label a part that is already labeled then the original label 
is removed.

7. The command leaves you in a loop to be able to continue to manual label. 
Select part to label [Copy]:

8. If you select Copy then the you see
Select part to copy label [lAbel]: 

9. Select the next part you want to label and the label geometry will be identical to the previously placed label. You can 
switch back to manually placing each label by selecting lAbel.

Copy Label from BOM
To create a copy of a label for another part

1. Choose SC Arrangement > Label > Copy Label from BOM (page 282)
Select the source label: 

2. Select a label that you want to copy the style and geometry from.
Select a part:

3. A new label is placed.

Relabel All
This command re-labels all the parts from the BOM across all sheets and places the labels on the _ANNOTATION layer. 

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.

To re-label parts from BOMs

1. Choose SC Arrangement > Label > Relabel All (page 282) or SC Spool Drawing > Label > Relabel All (page 290).

Relabel from a selected BOM
This command only labels items from select tables and viewports. Labels are placed on the _ANNOTATION layer.

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.
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To re-label parts from BOMs

1. Choose SC Arrangement > Label > Relabel from BOM (page 283) or SC Spool Drawing > Label > Relabel from BOM
(page 291).

2. Select the BOM for which to generate labels from.

Relabel from Parts
This command will label all the parts selected by the user from the selected table.

To re-label parts

1. Choose SC Arrangement > Label > Relabel from Parts (page 283) or SC Spool Drawing > Label > Relabel from Parts
(page 291)

2. Select parts for which to generate labels from.

Label to part edges
This feature allows user to place labels on borders of parts instead of piece marks. Since there is only one piece 
mark on each part, it’s easy to find the location and lay the label arrow on it. It’s much more complicated to label on 
borders, because there could be none or many edges to be labelled on. A lot of times, it is hard to say where the best 
place is to put the label on. Several rules were setup in the searching algorism trying to get the best point on borders.

For detail explanation with diagrams, please refer to the Structure help file for Assembly drawings. 

Label on Visible Edge On/Off
If the value is true, all labels will be laid on HLR points (part centres), otherwise they will be on edges.

Type: Boolean.

Default: As in Project Settings

To run the command

1. Choose SC Arrangement > Label > Label on Visible Edge On/Off (page 283) or

SC Spool Drawing > Label > Label on Visible Edge On/Off

2. Set the value on command line

Adjacent Part Edge Tolerance
If the gap between a midpoint of a group edge to any other visible edge from any other objects is smaller than 
SCADVLABELADJACENTTOL, the midpoint will not be used as a label point. 

Type: A double number in current length units.

Default: As in Project Settings

If a label arrow points to an edge of an object that has other objects close to it, it is hard to tell which object the 
arrow is pointing to. This setting is trying to filter out those confusing cases. 

To run the command

1. Choose SC Arrangement > Label > Label on Visible Edge On/Off (page 283) or

SC Spool Drawing > Label > Label on Visible Edge On/Off

2. Set the value on command line

Curved Plates in Visible Edge Detection On/Off
If it is false, the frame of the curved plate will be used in HLR projection instead of the plate solid. As you can see, 
it is not very realistic since the frame won’t hide anything behind it. The advantage of this is that you will get a 
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much faster results because otherwise the surface will be used in HLR, which might bring in hundreds of thousands 
more points into the calculation.

Curve plates are represented in NURBS curves and surfaces. HLR 4 medium sized (300 x 100) curve plates on my 
machine with this setting on took about 5 minutes to finish. A complicated drawing from Austal took very long time 
to finish.

Type: Boolean.

Default: As in Project Settings

To run the command

1. Choose SC Arrangement > Label > Curved Plates in Visible Edge Detection On/Off (page 283) or

SC Spool Drawing > Label > Curved Plates in Visible Edge Detection On/Off

2. Set the value on command line

Edge Length Filter
It is a percentage value calculated by dividing the length of the testing edge with the length of the longest edge in the 
part. The testing edge will not be picked as a qualified labeling edge if its percentage is smaller than this setting.

Type: double number in percentage.

Default: As in Project Settings

To run the command

1. Choose SC Arrangement > Label > Edge Length Filter (page 284) or

SC Spool Drawing > Label > Edge Length Filter

2. Set the value on command line

Edge Determination Minimum Angle
When Hull points were caught from HLR, we’ll go through point to point with straight lines. If any 2 next lines form 
an angle that is bigger than this setting, the intersect point will be counted as a group line end point.

Value Type: A double number as an angle in degree.

Default: As in Project Settings

Group edge is used as the base element for a label to point. The length and the position of a group edge will be used 
to decide whether it can be used as a label edge.

To run the command

1. Choose SC Arrangement > Label > Edge Determination Minimum Angle (page 284) or

SC Spool Drawing > Label > Edge Determination Minimum Angle

2. Set the value on command line

Label Reset Automatic Settings
All label settings come originally from Project Settings in Manager. Once user changed a setting through a label 
command, the current value will be saved and used from current drawing. If you run this reset command and 
confirmed with a ‘yes’, all current label settings will be replaced back to the Project Settings again.

To run the command

1. Choose SC Arrangement > Label > Label Reset Automatic Settings (page 284) or

SC Spool Drawing > Label > Label Reset Automatic Settings

2. Confirm whether you want to reset on command line
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Common Production Drawing Functions

Insert an Orientation Icon
You can insert an orientation icon into your spool template drawings. (see Insert Orientation Icon into an Assembly 
Drawing in the Structure manual).

Viewport Options
These are options which are viewport specific. It is best to set these options in the production drawing template, but they 
can be changed in the production drawing as well.

To open the viewport options window

1. Choose Viewport Options from the production drawing menu.

2. Select the viewport(s) you would like to change the options for.

3. Press Enter. The viewport options window appears.

Currently, there is only the option to label the items in the viewport. The grayed out KeyMap option is for Assembly 
drawings.

Note: You can also set the BOM to label the items in the viewport through the BOM wizard when inserting a BOM.

4. Set your viewport options and click OK.

Note: For information on viewport specific display options see Viewport Display Options in the Structure manual.

Update BOMs
This updates the BOMs in your production drawing. You might want to update the BOM if you:

• Have set the BOM to list only those parts that are visible through the Toggle List Only Visible command and only have 
some parts showing in your viewport.

• Have recently inserted a BOM table and would like it populated.

• Altered items that are contained in the drawing and are referenced by the BOM.

To update the BOM table

1. Choose SC Arrangement > Update BOMs (page 281) or SC Spool Drawing > Update BOMs (page 289).
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Purge BOMs
This immediately purges erased BOMs from the drawing. Normally it takes opening and closing the drawing twice to 
permanently remove all references to BOMs after the last table has been erased for a BOM.

To purge erased BOMs

1. Type SCPURGEBOMS at the command line.

Clear All BOMs
This immediately erases all references to BOM definitions yet leaves the current BOM tables intact.

To remove all references to BOMs

1. Type SCCLEARALLBOMS at the command line.

Unlink All BOMS
Removes linked BOM references. Note that auto-linked BOMs will have their linkages reinstated the next time a BOM is 
inserted into the drawing.

To unlink all BOMs

1. Type SCCUNLINKBOMS at the command line.

To update the BOM table

1. Choose SC Arrangement > Update BOMs (page 281) or SC Spool Drawing > Update BOMs (page 289).

Edit BOM Collector Options
This command allows the user to alter a Bill of Materials Collector options. For example, the Pipe Collector allows the 
user to select which object types to include/exclude. By using this command you can quickly adjust the object types to 
suit your needs.

To change the BOM Collector options

1. Choose SC Arrangement > Edit Collector options (page 281) or SC Spool Drawing > Edit Collector options (page 289).

2. Select one representative Bill of Materials from the drawing.

3. Adjust the Collector options as necessary.

Note: you will be notified if the BOM that you selected has no configurable Collector options.

Update All Keywords
This command updates all the keywords in paper space in a production drawing.

To update only the keywords

1. Choose SC Arrangement > Update All Keywords (page 280) or SC Spool Drawing > Update All Keywords (page 288).

Viewport Display Options

List only Visible
There is smart functionality in the BOM which will either list only those parts which are visible to the user, or list all parts 
regardless if they are visible or not.

To toggle the list only visible variable in the BOM

1. Choose Toggle list only visible from the production drawing menu.
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2. Information on the command line will inform you whether the variable is set or not.

Note: You will want to run Update BOMs to see changes from this command in the BOM table. If all parts are visible, 
there will be no difference.

Viewport Clipping
ShipConstructor includes functionality to create precise viewport clipping planes. Unlike standard AutoCAD clip planes, 
ShipConstructor clipping lets you pick the front and back point to define the clip planes.

To clip a viewport

Note: Before running the command you need to switch to the viewport in which the clipping plane is to be applied.

1. Choose Clip current view from the SC Utilities menu.

2. If the drawing is in paper space it will prompt you to select the viewport to make active.

3. The command line prompts you to: Enter Point on Plane 1. Choose a point on one of the clipping planes to be used 
(whether it is the front or back clipping plane will be determined by ShipConstructor).
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Before clipping

After clipping
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4. The command line prompts you to enter a second point: Enter Point on plane 2. Choose a point on the second 
clipping plane (whether it is the front or back clipping plane will be determined by ShipConstructor). 

Note: If the clipping planes are not to your liking you can remove them with the command SC Utilities > Remove 
clip (see below).

Remove clip

To clear a viewport clip

1. Choose Remove clip from the SC Utilities menu.

2. Select the viewport to clear the clip.

Support Construction Drawings
Support construction drawings are the production drawings for constructing a single distributed systems support.

Before creating a support construction drawing, make sure you have done the following:

• At least one distributed systems support created.

• At least one support construction drawing template.
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Set Up Support Construction Drawings
Before creating support construction drawings, you must set up the support construction drawing template. 

Set Up a Support Construction Drawing Template
You can control the layout of support construction drawings using support construction drawing templates.

Note: There must be at least one support construction drawing template defined before you can create a support 
construction drawing.

Create a Support Construction Drawing Template

To create a support construction drawing template

1. Choose ShipConstructor > Navigator to open the Navigator.

2. Select the Templates page.

3. Select the DistributedSystemSupportConstruction folder.

4. Click New DistributedSystemSupportConstruction to open the New Drawing window.

5. Enter a name for the drawing and click OK.

6. Insert your company title block, or create one.

7. Set up as many viewports as you need.

8. Move and size each viewport individually.

9. Double-click on a viewport and choose View > Shade to select a shading style for the support in the view.

See Set Up Support Construction Drawing Template Viewports (page 206) and To insert keywords into an support 
construction drawing template

.

Set Up Support Construction Drawing Template Viewports
A viewport displays the support, and its dimensions. The layers of the support components and dimensions are 
determined by the support construction drawing options that can be configured in Manager > Piping.

To set up support construction drawing template viewports

1. In the support construction drawing template, activate paper space.

2. Click in the viewports that you want to set up.

3. Choose SC Support Const Template > Viewport Options (page 308) to open the Viewport Options window.
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4. To make the viewport contain automatic annotations, choose Label items in viewport.

5. Click OK.

6. Repeat Steps 2 through 5 for every viewport you want to set up.

Support Construction Drawing Keywords
You can insert various keywords into a support construction drawing template. When you generate a support construction 
drawing, ShipConstructor automatically replaces the keyword with the appropriate information.

To insert keywords into an support construction drawing template

1. In the support construction drawing template, activate paper space.

2. Choose SC Support Const Template > Insert Keywords (page 308) to open the Insert Keyword window.

3. Select the keywords to insert.

4. Change the text properties now in this window or later using AutoCAD. Keywords are based on AutoCAD text objects 
so all the properties of text objects are available.

5. Click OK.

6. Select the location for the keyword.

The keyword is created as a new ShipConstructor keyword object.

Note: To change the prefix or postfix text of the keyword, use AutoCAD’s property window. When a keyword is 
updated, the prefix and postfix text will not change.



Support Construction Drawings

208

Insert a Support Construction BOM Table
You can now predefine a BOM definition for use within a support construction drawing template. This enables you to 
format an empty BOM table to your specifications (correct text style, size, and so on) before creating a support 
construction drawing.

Note: To insert the BOM table, there must already be a support construction BOM definition defined. See Set Up a 
Support Construction Drawing BOM Style (page 208).

To insert a BOM table

1. In the support construction drawing template, activate paper space.

2. Choose Format > Table Styles to customize the table style to be used for the BOM table. Be sure that the name of 
the table style matches the Acad TableStyle name in the BOM Definition.

3. Choose SC Support Const Template > Insert BOM Table… (page 309)

4. Select a Support Construction BOM. 

5. Click Next.

6. Enter the options for the BOM table.

7. Click Finish.

8. Select the location of the empty BOM.

Set Up a Support Construction Drawing BOM Style
You can set up any number of BOM styles for use in support construction drawings, assembly drawings, plate nest 
drawings, arrangement drawings, and spool drawings.

To set up a BOM style

1. In Manager, choose General > Production Output > Bill of Materials to open the BOM Definitions window.

2. To create a new support construction BOM style, click on Support Construction in the left list and then click New.

3. Click Add/Remove to add fields to the BOM. See BOM Definitions Manager (page 313) for more details on BOM 
setup.

4. Include any relevant collectors. Make sure the collectors you want are listed under the Included list. See Collector 
Functionality (page 318) for more about collectors.
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5. Choose a label style for each collector. This is the style used to automatically annotate the drawing if this option is 
selected.

6. Click OK. 

Generate Support Construction Drawings

Generating Support Construction Drawings
Support Construction drawings are created for individual supports.

Once you have met the requirements outlined in Support Construction Drawings (page 205), you can create your support 
construction drawing. The support construction drawing will use the same name as the support that it is created for.

To create support construction drawings

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select Support Construction in the component list.

3. Click Create.

The Create Support Construction Drawing wizard appears.
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4. Select a support construction drawing template for all your drawings to use.

5. Click Next. Step 2 of the Create Support Construction Drawing Wizard appears.
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6. Place a check in the check box next to each support that will become a support construction drawing. The Drawing 
Exists column indicates if a support construction drawing already exists for that support.

7. Click Next. Step 3 of the Create Support Construction Drawing Wizard appears.
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Set up the settings for the dimensioning.

8. Click Finish.

ShipConstructor creates one support construction drawing for each support selected.

If you are in SDI mode, ShipConstructor will open the last support construction drawing it creates. Otherwise, all 
support construction drawings created will be open.

Edit Support Construction Drawings
The commands for editing support construction drawings are located in the SC Support Const Menu (page 299). Support 
Construction drawings are created using the same name as their support, but this is not a requirement. The support 
construction drawing’s name may be changed at any time, using the Rename command on the right-click menu, in 
Navigator.
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Update Support Construction Drawings

Identifying Drawings that Require Updating
ShipConstructor weld management drawings can be updated. Drawings that need updating can easily be identified in 
Navigator.

To identify out-of-date support construction drawings

1. Choose ShipConstructor > Navigator to open Navigator.

2. Select Support Construction in the component list.

3. Click Show Out of Date.

Out-of-date arrangement drawings can be identified by the exclamation mark icon ( ).

Warning: Show Out of Date may take some time depending on how many drawings and parts you have.

Note: If you switch to another page in Navigator and then go back to the support construction page, the support 
construction page is refreshed and you will not be able to see which drawings are out of date again until you click 
Show Out of Date.

4. If any support construction drawing’s name is different from its support’s name, then a log file will be created and 
display listing the support and the drawing names.
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Updating an Existing Support Construction Drawing
If changes are made to the support, or its component parts, after you have created support construction drawings, you 
must update your support construction drawings. When you update a support construction drawing, ShipConstructor 
automatically updates the support, parts, keywords, and dimensions, within the drawing, leaving all of your manual edits 
and annotations intact. Updating support construction drawings is much faster than re-creating them.

To update a support construction drawing

1. Choose SC Support Const > Update Drawing (page 299) to start updating the drawing.

2. ShipConstructor determines all parts that need to be updated. 

3. The Modified Part Information window appears (see also Modified Part Information Reference (page 349)). 

4. You can use the Modified Part Information window to inspect parts that have changed during this update. Click OK to 
continue the update process.

5. The Bill of Materials (BOM) in this drawing will now be updated. Depending on the size of your drawing and the BOM 
definition, this may take some time.

6. Click OK to finish the drawing updating.
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Insert Keywords in a Support Construction Drawing
Usually your support construction drawing template includes the keywords that you want included in support construction 
drawings. However, there may be certain keywords that you want to manually insert into a few support construction 
drawings. Once inserted, the keywords will remain as their default text until the support construction drawing is updated.

Inserting keywords into a support construction drawing is similar to inserting keywords into a support construction 
drawing template, except you use SC Support Const > Insert Keywords (page 299).

To insert keywords into a support construction drawing

1. In the support construction drawing, activate paper space.

2. Choose SC Support Const > Insert Keywords (page 299) to open the Insert Keyword window.

3. Select the keywords to insert.

4. You can change the default text settings now in this window or later using AutoCAD.

5. Click OK.

6. Select the location for each keyword selected.

Note: To change the prefix or postfix text of the keyword, use AutoCAD’s property window. When a keyword is 
updated, the prefix and postfix text will not change.

To update keywords

1. Choose SC Support Const > Update Drawing (page 299).

2. The keywords in the drawing update regardless of the status of the parts.

OR

1. Choose SC Support Const > Update All Keywords (page 299).

2. The keywords in the drawing update without updating the parts.

OR

1. Select keywords you wish to update.

2. Choose Update on the right-click menu.

Plot Support Construction Drawings

Plot a Support Construction Drawing

To plot a support construction drawing

1. In the support construction drawing, make sure you are in paper space. (If you are in model space, only the active 
viewport will be plotted.)

2. At the command line type MVIEW and Enter.
[ON/OFF/Fit/Shadeplot/Lock/Object/Polygonal/Restore/2/3/4] <Fit>:

3. Enter Shadeplot and press Enter.
Shade plot? [As displayed/Wireframe/Hidden/Rendered] <As displayed>

4. Enter Hidden and press Enter.
Select Objects:

5. Pick the viewport or viewports for which you want to hide lines.

6. PLOT the drawing.
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Inspect a Plotted Support Construction Drawing
After plotting a support construction drawing, visually inspect the plotted drawing for format and content.
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Appendix A: Pipe Command Reference

Manager Pipe Menu

Pipe > Pipe Benders
Opens the Pipe Bending/Cutting Machines window and lets you create, edit, and delete pipe bending and cutting 
machines.

Pipe Bending/Cutting Machines
Lists all pipe bending and cutting machines, and whether the machine can be used for bending, cutting, or both. Specific 
bending and cutting information for the selected machine is displayed in the Bending Information and Cutting 
Information sections of the window.

New – Shows the Edit Pipe Bending/Cutting Machine window. A new machine is created with the values set in this 
window.

Delete – Deletes the selected pipe bending or cutting machine.

Import – Shows the File Open window, allowing you to select which XML or PRO file you want to import bending or 
cutting machines from.

Export XML – Exports all of the bending and cutting machines in the Pipe Bending/Cutting Machines list that have 
their Export check box checked.
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Bending Information
Lists bending information for the selected Pipe Bending Machine. This information includes Nominal Size, Pressure 
Rating, Centerline Radius, Clamp Length, Maximum Bend Angle, Distance Between Bends, and Terminating Clamp 
Length for each pipe stock that the bending machine can be used with.

Edit – Shows the Machine Size Definition Bend Settings window where you set values for the currently selected item 
in the Bend Information list.

Add – Shows the Machine Size Definition Bend Settings window where you set values for a new Bend Information
entry that corresponds to the selected Pipe Bending/Cutting Machine and Size Definition.

Remove – Deletes the selected Bend Information entry.

Cutting Information
Lists cutting information for the selected pipe cutting machine. This information includes Nominal Size, Pressure Rating, 
and Kerf for each pipe stock that the bending machine can be used with.

Add – Creates a new entry in the Cutting Information list that corresponds to the selected Pipe Bending/Cutting 
Machine and Size Definition.

Remove – Deletes the selected Cutting Information entry.

Size Definitions
Lists all size definitions in a tree structure organized by nominal size and then by pressure rating. Selecting a nominal size 
or pressure rating from the tree will filter the Bending Information and Cutting Information lists to only show information 
matching the selected nominal size or the selected nominal size and pressure rating pair.

Show All – Shows all Bending Information and Cutting Information entries that correspond to the selected Pipe 
Bending/Cutting Machine. This lets you quickly undo any nominal size or size definition filtering that is selected in 
the Size Definition tree.

Pipe > Stock Catalog
Opens the Pipe Stock Catalog window and lets you create, edit, and delete pipe stocks and many of the items associated 
with the creation of a pipe stock.

Common Buttons and Tools
The Pipe Stock Catalog has four tabs, all of which share some buttons and tools.

Apply Changes – Saves any changes made to data in the current tab or the current tab’s sub-dialogs to the database.

Discard Changes – Discards any changes made to data in the current tab or the current tab’s sub-dialogs since the tab 
was opened or the tab’s Apply Changes button was clicked.

The Import and Export XML buttons are available with each tab, but import and export different things, depending on the 
tab you are in, as described below.

Stock Library Grid Toolbar
The Stock Library Grid Toolbar appears on the top of most major grids in the Pipe Stock Catalog. The toolbar has two 
groups of buttons, which may or may not be visible depending on the properties of the grid that the toolbar belongs to.

Expand All Button

If the grid that the Grid Toolbar is associated with has a tree structure, the Expand All button is visible. Clicking the 
Expand All button causes all nodes in the grid to be expanded at once.

Collapse All Button

If the grid that the Grid Toolbar is associated with has a tree structure, the Collapse All button is visible. Clicking the 
Collapse All button causes all nodes in the grid to be collapsed at once.

Apply Filter Button

If the grid that the Grid Toolbar is associated with contains a Filter Row, the Apply Filter button is visible. Clicking the 
Apply Filter button reapplies the current contents of the filter row to the visible rows in the grid. This is helpful if a 
filter has been set up and you want to apply that filter to the children of newly expanded items.
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Clear Filter Button

If the grid that the Grid Toolbar is associated with contains a Filter Row, the Clear Filter button is visible. Clicking the 
Clear Filter button clears all the columns in the grid’s filter row, removing any filters that may have been applied and 
showing all the children of the expanded items in the grid.

Filter Row
At the top of all major grids in the Pipe Stock Catalog is the yellow Filter Row. The filter row lets you apply a filter to the 
grid by supplying a filter to the desired column in the grid, making it quick and easy to find the desired information in a 
grid containing any number of rows. There are several important things to note about how the filter row works:

1. The filter row executes a contains filter. This means that if you filter using the string 13, the result of the filter will 
contain rows with 13, 133, Stock13, and any other string containing 13 in the column you are applying the filter 
against.

2. The filter is only applied to the expanded rows in the grid. If you create a filter and then expand a node and wish to 
apply the current filter to the newly expanded node’s children, use the Apply Filter button at the top of the grid to 
reapply the filter to the grid’s new contents.

Note: Filter values are saved between sessions, if a grid is not displaying the expected rows check that the filter row 
doesn’t contain any undesired values.

Filter Group
The Filter group has three options, Metric, Imperial, or Both. Metric causes the catalog to be filtered so that it only lists 
metric stocks, Imperial will filter for only imperial stocks, and Both will clear the filter showing all stocks in the project. 
Changes made to this group are applied to all tabs in the Pipe Stock Catalog. This can cause a change to the filter to take 
some time if there are a large number of stocks in the current project.

Property Units Group
The Property Units group lets you change how the units that properties are displayed, in metric or imperial. Changes to 
this setting are reflected in all tabs of the Pipe Stock Catalog.
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Size Definitions Tab

New – Create a new size definition. (See Create a Size Definition (page 7).)

New Next Size – Create a ‘New Next Size’ size definition. (See Create a ‘New Next Size’ Size Definition (page 7).)

Delete – Delete the selected size definition. (See Delete a Size Definition (page 8).)

Edit Nominal Sizes – Shows the Nominal Sizes window, where you can create, edit, and delete nominal sizes. (See 
Nominal Sizes (page 5).)

Edit Standards – Shows the Standards window, letting you create, edit, and delete international standards, geometric 
standards, and pressure ratings. (See Standards (page 2) or Standards Window (page 224).)

Import – Shows the File Open window, where you import size definitions from a .PRO or .XML file.

Export XML – Exports size definitions that have their Export check box checked to an .XML file.
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End Treatments Tab

New – Shows the Edit End Treatments window with a newly created end treatment using the currently selected size 
definition or the size definition of the currently selected end treatment. (See Create an End Treatment (page 12).)

New All Sizes... – Shows the Edit End Treatments window with a newly created end treatment for each of the size 
definitions defined in the Size Definitions tab.

New From Range... – Shows the End Treatment Range window, letting you enter a minimum and maximum value. Next 
the Edit End Treatments window shows a newly created end treatment for each size definition that has a nominal size 
within the entered range.

Edit – Shows the Edit End Treatments window with the currently selected end treatment or end treatments available for 
editing. (See Edit an End Treatment (page 13).)

Delete – Deletes the selected end treatment. (See Delete an End Treatment (page 14).)

Treatment Types... – Shows the Treatment Types window, where you can create, edit, and delete end treatment types.
(See Create an End Treatment Type (page 10).)

LineMode Icons... – Shows the LineMode Icon window, where you can create, edit, and delete linemode icons. (See Create 
a LineMode Icon (page 11).)

Edit Properties – Shows the End Treatment Properties window, where you can create, edit, and delete General, 
Descriptive, and Facing properties. (See Set Up End Treatment Properties (page 12).)

Usage Log – Generates a usage log file for the currently selected end treatment. This button is only enabled when a 
single valid end treatment is selected.

Import – Shows the Open File window, allowing you to import end treatments from a .PRO or .XML file.

Export XML – Exports end treatments that have their Export check box checked to an .XML file.
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Create/Edit Pipe Tab

New – Creates a new stock of the type selected in the Pipe Stocks list or of the type selected from the New button’s drop 
down list. (See Create a Stock (page 19).)

New Next Size – Creates a new stock, using the currently selected stock as a template and increasing the size definition 
to the next available size definition with the same geometric standard and pressure rating as the selected stock. (See 
Create a ‘New Next Size’ Stock (page 30).)

Edit – Shows the Stock Editor window for the currently selected stock. (See Edit a Pipe Stock (page 33).)

Delete – Deletes the currently selected stock.

Stock Usage – Shows the Drawings using stock window, allowing you to find what drawings, if any, contain instances of 
the selected stock. (See Stock Usage (page 34).)

End Types – Shows the End Types window, letting you specify what type of end treatments are available on a given 
straight, or bent, pipe stock. Currently disabled.

Assign To Spec – Shows the Assign To Spec window, letting you add or remove the currently selected stocks from any of 
the existing specs. (See Add or Remove Pipe Stocks To or From a Spec (page 33).)

Edit Specs – Shows the Pipe Specs window, letting you create, edit, and delete pipe specs. (See Specifications (page 16))

Assign To Cat. – Shows the Assign to Catalog window, letting you add or remove the currently selected stocks from any of 
the existing catalogs. (See Add or Remove Pipe Stocks To or From a Catalog (page 33).)

Edit Catalogs – Shows the Pipe Catalog window, letting you create, edit, and delete pipe catalogs. (See Catalogs (page 
17))

Valve Handles – Shows the Valve Handle Editor, letting you create, edit, and delete valve handles. (See Create a Valve 
Handle (page 30).)

Valve Types – Shows the Valve Types window, letting you edit existing valve types. (See Edit a Valve Type (page 31).)
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Connections Tab

New Type – Creates a new connection type in the Connections grid. (See Create a Connection Type (page 41))

New Connection – Creates a new connection under the selected connection type in the Connections grid. (See Create a 
Connection (page 41).)

New Next Size – Creates a new connection, using the currently selected connection as a template and increasing the 
nominal size of the new connection’s end treatments. The new end treatments will maintain the end treatment type and 
difference in size of the template stock’s end treatments. (See Create a ‘New Next Size’ Connection (page 42)).

Delete – Deletes the selected connection or connection type.

Import – Shows the File Open window, where you can select a .PRO or .XML file to import connections from.

Export XML – Exports the connections and connection types that have their Export check box checked to an .XML file.

Connection Accessories
The Connection Accessories grid displays all accessory packages that have been added to the connection selected in the 
Connections grid.

Add – Shows the Select Accessory Packages window, where you can select the accessory packages you want to add 
to the connection selected in the Connections grid. (See Add an Accessory Package To a Connection (page 43).)

Remove – Removes the selected accessory package from the selected connection.
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Standards Window

The Standards window (accessed from the Size Definitions Tab (page 220) of the Pipe Stock Catalog) lets you create, 
edit, and delete international standards, geometric standards, and pressure ratings. It also allows you to associate a 
given geometric standard with specific pipe stock types and with specific pressure ratings. The combination of an 
international standard, a geometric standard, and a pressure rating is what creates a schedule. The association of a 
geometric standard and specific pipe stock types allows you to control which schedules are available to stocks of a given 
type.

Standards
The Standards grid contains the international and geometric standards that have been defined for the project and lets 
you create, edit, and delete the standards as necessary.

New International – Creates a new international standard.

New Geometric – Creates a new geometric standard under the selected international standard.

Delete Standard – Deletes the selected geometric or international standard.

Edit Categories – Shows the Pipe Categories window, where you can create, edit, or delete pipe categories.

Pipe Stock Types
The Pipe Stock Types grid is a list of all the various types of pipe stock that has a check box for each type. The check box 
is used to add and remove associations between the stock type and the currently selected geometric standard in the 
Standards grid.

Pressure Ratings
The Pressure Ratings grid contains the pressure ratings that have been defined for the project. This is where you create, 
edit, and delete pressure ratings as necessary. This is also where you add and remove associations between pressure 
ratings and the currently selected geometric standard in the Standards grid.

New – Creates a new pressure rating.

Delete – Deletes the selected pressure rating.
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Toolbars
The most common commands are located on the Pipe toolbars.

Pipe Toolbar

Straight Pipe
See SC Pipe > Straight Pipe (page 228)

Bent Pipe
See SC Pipe > Bent Pipe (page 228)

Elbow
See SC Pipe > Elbow (page 229)

Reducer
See SC Pipe > Reducer (page 229)

Cap
See SC Pipe > Caps (page 229)

Cross
See SC Pipe > Cross (page 229)

Pipe Branch Flyout

Lateral

See SC Pipe > Branches > Lateral (page 230)

Tee

See SC Pipe > Branches > Tee (page 230)

Wye

See SC Pipe > Branches > Wye (page 230)

Misc.

See SC Pipe > Branches > Misc (page 230)

Pipe Connector Flyout

Union

See SC Pipe > Connectors > Union (page 231)

Flange

See SC Pipe > Connectors > Flange (page 231)

Coupling

See SC Pipe > Connectors > Coupling (page 231)

Weldolet
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See SC Pipe > Connectors > Weldolet (page 231)

Threadolet

See SC Pipe > Connectors > Threadolet (page 232)

Adapter

See SC Pipe > Connectors > Adapter (page 232)

Misc.

See SC Pipe > Connectors > Misc (page 232)

Pipe Valve Flyout

Ball

See SC Pipe > Valves > Ball (page 232)

Butterfly

See SC Pipe > Valves > Butterfly (page 233)

Check

See SC Pipe > Valves > Check (page 233)

Diaphragm

See SC Pipe > Valves > Diaphragm (page 233)

Gate

See SC Pipe > Valves > Gate (page 233)

Globe

See SC Pipe > Valves > Globe (page 234)

Plug

See SC Pipe > Valves > Plug (page 234)

Relief

See SC Pipe > Valves > Relief (page 234)

SDNR

See SC Pipe > Valves > SDNR (page 234)

Misc.

See SC Pipe > Valves > Misc (page 235)

Insert Connector Set

See SC Pipe > Insert Connector Set

Set System From Part

See SC Pipe > System > Set Current System From Pipe Part (page 237)
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Distributed Systems Utilities Toolbar

Connect Parts

See SC Pipe > Connect (page 241)

Disconnect Parts

See SC Pipe > Disconnect (page 242)

Extract Center Line

See SC Pipe > Utilities > Extract Center Line (page 240)

Anchor Part

See SC Pipe > Anchor Part (page 242)

Unanchor Part

See SC Pipe > Unanchor Part (page 242)

Toggle Transform Mode

See SC Pipe > Toggle Transform Mode (page 243)

Mark item as No-Spool

See SC Pipe > Spools > Set No-Spool (page 236)

Remove No-Spool status

See SC Pipe > Spools > Remove No-Spool (page 236)

Add Spool-break

See SC Pipe > Spools > Add Spool Break (page 236)

Remove Spool-break

See SC Pipe > Spools > Remove Spool Break (page 237)

Toggle Constrain Enforcement

See SC Pipe > Toggle Constrain Enforcement (page 243)

ShipConstructor Menu
See the Structure manual for general information on the ShipConstructor Menu.

ShipConstructor > Navigator

Button ...........
Ribbon ...........ShipConstructor tab > Navigation
Menu ............... ShipConstructor > Navigator

Toolbar............ ShipConstructor > 
Command ...... SCNAVIGATE
Permissions ... None
Procedure........See Pipe Navigator Page (page 251)

Opens the Navigator, letting you create and open drawings and perform other drawing related functions.



Appendix A: Pipe Command Reference

228

Note: You must use the Navigator to create, open, or move drawings so that ShipConstructor can keep track of them. 
Do not use Windows Explorer, or ShipConstructor will not be able to properly associate the drawings with the projects.

ShipConstructor > Export Pipe Bending Data

Menu ............... ShipConstructor > Export Pipe Bending Data
Toolbar............ None
Command ...... SCPIPEEXPORTBENDINGDATA
Permissions ... None
Details.............See Bending Data - XML Output (page 322)

Opens the select pipes window from which you can create pipe bending data XML.

SC Pipe Menu
The SC Pipe menu appears in Pipe drawings.

SC Pipe > Straight Pipe

Button ...........
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Straight Pipe

Toolbar............ Pipe > 
Command ...... SCSTRAIGHTPIPE
Permissions ... Pipe Models > Edit
Procedure....... Straight Pipe (page 93)

Inserts a straight pipe.

SC Pipe > Bent Pipe

Button ...........
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Bent Pipe

Toolbar............ Pipe > 
Command ...... SCBENTPIPE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Bent Pipe (page 94)

Inserts a bent pipe.
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SC Pipe > Elbow

Button ...........
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Elbow

Toolbar............ Pipe > 
Command ...... SCPIPELBOW
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a pipe elbow.

SC Pipe > Reducer

Button ...........
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Reducer

Toolbar............ Pipe > 
Command ...... SCPIPEREDUCER
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a pipe reducer.

SC Pipe > Caps

Button ...........
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Caps

Toolbar............ Pipe > 
Command ...... SCPIPECAP
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a pipe cap.

SC Pipe > Cross

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Cross

Toolbar............ Pipe > 
Command ...... SCPIPECROSS
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a pipe cross.
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SC Pipe > Branches > Lateral

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe

Menu ............... SC Pipe > Branches > Lateral

Toolbar............ Pipe > Pipe Branch Flyout > 
Command ...... SCPIPEBRANCH LATERAL
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a lateral branch.

SC Pipe > Branches > Tee

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Branches > Tee

Toolbar............ Pipe > Pipe Branch Flyout >
Command ...... SCPIPEBRANCH TEE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a tee branch.

SC Pipe > Branches > Wye

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Branches > Wye

Toolbar............ Pipe > Pipe Branch Flyout > 
Command ...... SCPIPEBRANCH WYE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a wye branch.

SC Pipe > Branches > Misc

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Branchs > Misc

Toolbar............ Pipe > Pipe Branch Flyout > 
Command ...... SCPIPEBRANCH MISC
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a miscellaneous branch.
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SC Pipe > Connectors > Union

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Union

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR UNION
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a union connector.

SC Pipe > Connectors > Flange

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Flange

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR FLANGE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a flange connector.

SC Pipe > Connectors > Coupling

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Coupling

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR COUPLING
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a coupling connector.

SC Pipe > Connectors > Weldolet

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Weldolet

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR WELDOLET
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a weldolet connector.
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SC Pipe > Connectors > Threadolet

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Threadolet

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR THREADOLET
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a threadolet connector.

SC Pipe > Connectors > Adapter

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Adapter

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR ADAPTER
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts an adapter connector.

SC Pipe > Connectors > Misc

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Connectors > Misc

Toolbar............ Pipe > Pipe Connector Flyout > 
Command ...... SCPIPECONNECTOR MISC
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a miscellaneous connector.

SC Pipe > Valves > Ball

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Ball

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE BALL
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a ball valve.
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SC Pipe > Valves > Butterfly

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Butterfly

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE BUTTERFLY
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a butterfly valve.

SC Pipe > Valves > Check

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Check

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE CHECK
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a check valve.

SC Pipe > Valves > Diaphragm

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Diaphragm

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE DIAPHRAGM
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a diaphragm valve.

SC Pipe > Valves > Gate

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Gate

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE GATE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a gate valve.
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SC Pipe > Valves > Globe

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Globe

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE GLOBE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a globe valve.

SC Pipe > Valves > Plug

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Plug

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE PLUG
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a plug valve.

SC Pipe > Valves > Relief

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Relief

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE RELIEF
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a relief valve.

SC Pipe > Valves > SDNR

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > SDNR

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE SDNR
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a SDNR valve.
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SC Pipe > Valves > Misc

Button ........... 
Ribbon ...........Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Valves > Misc

Toolbar............ Pipe > Pipe Valve Flyout > 
Command ...... SCPIPEVALVE MISC
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Fittings (page 96)

Inserts a miscellaneous valve.

SC Pipe > Insert Connector Set

Button ........... 
Ribbon ............ none
Menu ............... none

Toolbar............ SC Pipe > 
Command ...... SCPipeInsertConnectorSet 
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure........Insert Connector Set Command (page 103)

Inserts one or two connectors while retaining connections.

SC Pipe > Equipment

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Equipment

Toolbar............ Equipment > 
Command ...... SCINSEQUIPMENT
Permissions ... Equipment > Equipment Models - Edit
Procedure........See the Equipment Manual for details n Equipment Parts.

Inserts an equipment part.

SC Pipe > Spools > Spool Manager

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Spool
Menu ............... SC Pipe > Spools > Spool Manager…
Toolbar............ None
Command ...... SCPIPESPOOLMANAGER
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure........Spool Manager Reference (page 329)

Launches the Spool Manager for you to create, edit, and modify the spool breakdown for the current Pipe model.
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SC Pipe > Spools > Set No-Spool

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Spool
Menu ............... SC Pipe > Spools > Set No-Spool

Toolbar............ Distributed Systems Utilities > 
Command ...... SCDwgOptionsPipeNoSpool
Permissions ... Pipe > Modeling > Pipe Modeling - Edit
Procedure.......No-Spool Items (page 130)

Sets a part as a No-Spool item.

SC Pipe > Spools > Remove No-Spool

Button ...........
Ribbon ........... Pipe Modeling tab > Pipe Spool
Menu ............... SC Pipe > Spools > Remove No-Spool

Toolbar............ Distributed Systems Utilities > 
Command ...... SCRemoveNoSpool
Permissions ... Pipe > Modeling > Pipe Modeling - Edit
Procedure.......No-Spool Items (page 130)

Removes the No-Spool status.

SC Pipe > Spools > Add Spool Break

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Spool
Menu ............... SC Pipe > Spools > Add Spool Break

Toolbar............ Distributed Systems Utilities > 
Command ...... SCAddSpoolBrk
Permissions ... Pipe > Modeling > Pipe Modeling - Edit
Procedure.......Add and Remove Spool Breaks (page 132)

Adds a spool break to a connection. If a spool drawing already exists for the spool you are breaking then you have the 
possibility of making two new spools. If this is the case then the spool drawing is moved to Deleted_Spool_Drawings. You 
can reattach the spool drawing at a later date using the reattach command. See Reattaching a spool drawing in the 
Structure Manual. 
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SC Pipe > Spools > Remove Spool Break

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Spool
Menu ............... SC Pipe > Spools > Remove Spool Break

Toolbar............ Distributed Systems Utilities > 
Command ...... SCRemoveSpoolBrk
Permissions ... Pipe > Modeling > Pipe Modeling - Edit
Procedure.......Add and Remove Spool Breaks (page 132)

Removes a spool break from a connection.

SC Pipe > System > System Manager…

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > System > System Manager…

Toolbar............ SC Pipe > 
Command ...... SCPIPESYSMANAGER
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Set Up Pipe Systems (page 82)

Opens the System Manager, letting you create and edit Pipe systems. See System Manager (page 254).

SC Pipe > System > Set Current System From Pipe Part

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > System > Set Current System From Pipe Part

Toolbar............ Pipe > 
Command ...... SCPipeSetSystemFromPart
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Set the Current System for Pipes (page 83)

Set the current system of the model drawing by selecting a part that is assigned to the desired system.

SC Pipe > System > Set System…

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > System > Set System...

Toolbar............ Pipe > 
Command ...... SCDWGOPTIONSPIPEPIPESYSTEM
Permissions ... Pipe > Modeling > Pipe Models - Edit

Lets you assign a pipe to a different system branch.
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SC Pipe > Saddles > Create Saddle

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Saddles > Create Saddle
Toolbar............ None
Command ...... SCSADDLE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Create a Saddle (page 104)

Adds a saddle at the given location on the selected pipe.

SC Pipe > Saddles > Remove Saddle

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Saddles > Remove Saddle
Toolbar............ None
Command ...... SCREMOVESADDLE
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Remove Saddle (page 125)

Removes the selected saddle.

SC Pipe > Insulation and Finishes > Add Insulation

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Insulation and Finishes > Add Insulation
Toolbar............ None
Command ...... SCAPPLYINSULATION
Permissions ... Pipe > Modeling > Pipe Models - Edit

Opens the Select Insulation window, letting you apply insulation to the selected pipe. See Insulation Reference (page 
268).

SC Pipe > Insulation and Finishes > View Finishes

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Insulation and Finishes > View Finishes
Toolbar............ None
Command ...... SCVIEWFINISHES

Opens the Select Finishes window, letting you view the finishes for the selected pipe. See Finishes Reference (page 269).
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SC Pipe > Insulation and Finishes > Apply Finishes

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe
Menu ............... SC Pipe > Insulation and Finishes > Apply Finishes
Toolbar............ None
Command ...... SCAPPLYFINISHES
Permissions ... Pipe > Modeling > Pipe Models - Edit

Opens the Select Finishes window, letting you apply finishes to the selected pipe. See Finishes Reference (page 269).

SC Pipe > Utilities > Merge To Bent

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Utilities > Merge To Bent
Toolbar............ None
Command ...... SCPipeMergeToBent

Merges a selection of pipe parts into a single bent pipe.

SC Pipe > Utilities > Route on Polyline

Button ........... 
Ribbon ........... none
Menu ............... SC Pipe > Utilities > Route on Polyline
Toolbar............ Pipe > 
Command ...... SCPipePolyRoute

Creates a bent pipe and routes it along an existing AutoCAD polyline.

SC Pipe > Utilities > Cut to Max Length

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Utilities > Cut to Max Length
Toolbar............ None
Command ...... SCPipeCutToMaxLen
Permissions ... None
Procedure....... Cut to Maximum Length (page 125)

Automatically cuts all straights and bents to their maximum allowed length.



Appendix A: Pipe Command Reference

240

SC Pipe > Utilities > Extract Center Line

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Utilities > Extract Center Line

Toolbar............ Distributed Systems Utilities > 
Command ...... SCHEPEXTRACTCENTERLINE
Permissions ... None
Procedure....... Extract Center LIne (page 125)

Extracts the centerlines from the selected parts and creates block references containing the segments of the centerlines 
and dashed lines to the corner points. The segments are placed on the SCCENTERLINES layer and the corner lines use the 
line style ACAD_ISO02W100.

Bent duct with extracted centerline moved for display

SC Pipe > Pipe-UCS Intersection > Add Pipe-UCS Intersection

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Pipe-UCS Intersection > Add Pipe-UCS Intersection
Toolbar............ None
Command ...... SCPipeUCSIntersection
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Add Pipe-UCS Intersection (page 143)

Creates an intersection point where a selected pipe end and the current UCS intersect and draws a line between the 
intersection point and the pipe end.
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SC Pipe > Pipe-UCS Intersection > Toggle Highlight on all HEP-UCS Intersection

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Pipe-UCS Intersection > Toggle Highlight on all HEP-UCS Intersection
Toolbar............ None
Command ...... SCHepUCSIntersectionHighlight
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Toggle UCS Intersection Line (page 144)

Toggles displaying the dotted line between the UCS intersection point and the pipe end.

SC Pipe > Pipe-UCS Intersection > Erase HEP-UCS Intersection

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Pipe-UCS Intersection > Erase HEP-UCS Intersection
Toolbar............ None
Command ...... SCPipeUcsIntersectionDelete
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Erase Pipe-UCS Intersection (page 144)

Erases the UCS intersection on the selected end.

SC Pipe > Pipe-UCS Intersection > Erase All HEP-UCS Intersection

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Pipe-UCS Intersection > Erase All HEP-UCS Intersection
Toolbar............ None
Command ...... SCHepUCSIntersectionDeleteAll
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Erase all Pipe-UCS Intersections (page 144)

Erases all the UCS intersections in the current drawing.

SC Pipe > Connect

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Connect

Toolbar............ Distrubuted Systems Utilities > 
Command ...... SCHEPCONNECT
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure.......Connect Pipes (page 124)

Connects two pipes together. 
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SC Pipe > Disconnect

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Disconnect

Toolbar............ Distributed Systems Utilities > 
Command ...... SCHEPDisconnectAll
Permissions ... Pipe > Modeling > Pipe Models - Edit
Procedure....... Disconnect Pipes (page 124)

Disconnects two or more pipes. This command leaves the pipes at their current locations but removes the logical 
connection between them.

SC Pipe > Break Pipe at Point

Button ........... 
Ribbon ........... Pipe Modeling tab > Modeling Utilities
Menu ............... SC Pipe > Break Pipe at Point

Toolbar............ Utilies > 
Command ...... SCBAP or Break
Procedure....... Break a Pipe (page 124)

Anchors the selected part.

SC Pipe > Anchor Part

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Anchor Part

Toolbar............ Distributed Systems Utilities > 
Command ...... SCANCHOR
Procedure....... Anchor Pipes (page 113)

Anchors the selected part.

SC Pipe > Unanchor Part

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Unanchor Part

Toolbar............ Distributed Systems Utilities > 
Command ...... SCUNANCHOR
Procedure....... Unanchor a Pipe (page 114)

Unanchors the selected part.
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SC Pipe > Lock Part

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Lock Part

Toolbar............ Distrubuted Systems Utilities > 
Command ...... SCLOCK
Permissions ... Pipe > Modeling > Pipe Models – Lock/Unlock
Procedure........Lock a Pipe (page 114)

Locks a part.

SC Pipe > Toggle Constrain Enforcement

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Toggle Constrain Enforcement
Toolbar............ Distrubuted Systems Utilities > 
Command ...... SCCONSTRAINMODE
Permissions ... Allow bent pipe creation without bending machine
Procedure........Toggle Constraining Mode (page 124)

Toggles the Constrain Enforcement mode.

SC Pipe > Unlock Part

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Unlock Part

Toolbar............ Distributed Systems Utilities > 
Command ...... SCUNLOCK
Permissions ... Pipe > Modeling > Pipe Parts – Lock/Unlock
Procedure........Lock a Pipe (page 114)

Unlocks a part.

SC Pipe > Toggle Transform Mode

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe > Toggle Transform Mode

Toolbar............ Distributed Systems Utilities > 
Command ...... SCTRANSFORMMODE
Procedure....... Toggle Transform Mode (page 115)

Toggles the transform mode.
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SC Pipe > Pipe Options

Button ........... 
Ribbon ........... Pipe Modeling tab > Drawing Options
Menu ............... SC Pipe > Pipe Options...

Toolbar............ Pipe > 
Command ...... SCPIPEOPTIONS
Procedure....... Pipe Options (page 255)

Opens the Pipe Options window. See Pipe Options (page 255).

SC Pipe > Insert Penetration

Button ........... 
Ribbon ........... Pipe Modeling tab > Penetrations
Menu ............... SC Pipe >Insert Penetration

Toolbar............ Penetrations > 
Command ...... SCPENCREATE
Permissions ... Penetrations > Create Penetrations
Procedure........See the Penetrations manual for details on Penetrations.

Creates a Penetration.

SC Pipe > Change Connection Accessory Package

Button ........... 
Ribbon ........... Pipe Modeling tab > Pipe Modeling Utilities
Menu ............... SC Pipe >Change Connection Accessory Package
Toolbar............ None
Command ...... SCCHANGECONACCPKG
Permissions ... Pipe > Modeling > Pipe Modeling - Edit
Procedure........Change Connection Accessory Package (page 126)

Changes the accessory package associated with a particular connection.
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Individual Drawing Display Settings Commands
Set 'Centerline Color Index'
SCDwgOptionsPipeCenterlineColor

Set 'Show Centerline' [ 0: false, 1: true ]
SCDwgOptionsPipeShowCenterline

Set 'Show Thickness' [ 0: false, 1: true ]
SCDwgOptionsPipeShowWallThickness

Set 'Show Insulation' [ 0: false, 1: true ]
SCDwgOptionsPipeShowInsulation

Set 'Draw Part Using Branch Color' [ 0: false, 1: true ]
SCDwgOptionsPipeDrawPartUsingBranchColor

Set 'Draw Line Mode Icons' [ 0: false, 1: true ]
SCDwgOptionsPipeDrawLineModeIcons

Set 'Draw Line Edges Min Size'
SCDwgOptionsPipeDrawEdgesMinSize

Set 'Draw Line Edges' [ 0: always, 1: above min size only, 2: never ]
SCDwgOptionsPipeDrawEdges

Set 'Show Connections' [ 0: false, 1: true ]
SCDwgOptionsPipeShowConnections

Set 'Local Connection Color Index'
SCDwgOptionsPipeLocalConnectionColor

Set 'Local Connection Size'
SCDwgOptionsPipeLocalConnectionSize

Set 'Remote Connection Color Index'
SCDwgOptionsPipeRemoteConnectionColor

Set 'Remote Connection Size'
SCDwgOptionsPipeRemoteConnectionSize

Set 'Show Free End Arrows' [ 0: false, 1: true ]
SCDwgOptionsPipeShowFreeEndArrows

Set 'Free End Arrows Color Index'
SCDwgOptionsPipeFreeEndArrowsColor

Set 'Free End Arrows Size'
SCDwgOptionsPipeFreeEndArrowsSize

Set 'Show Spool Break' [ 0: false, 1: true ]
SCDwgOptionsPipeShowSpoolBreak

Set 'Spool Break Color Indescx'
SCDwgOptionsPipeSpoolBreakColor

Set 'Spool Break Size'
SCDwgOptionsPipeSpoolBreakSize
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Set 'Show No Spool Icon' [ 0: false, 1: true ]
SCDwgOptionsPipeShowNoSpoolIcon

Set 'No Spool Icon Color Index'
SCDwgOptionsPipeNoSpoolIconColor

Set 'No Spool Icon Size'
SCDwgOptionsPipeNoSpoolIconSize

Set 'End Numbers Mode' [ 0: Fixed Size, 1: Scaled Size, 2: None ]
SCDwgOptionsPipeEndNumbersMode

Set 'End Numbers Scaled To End Size'
SCDwgOptionsPipeEndNumbersScaledToEndSize

Set 'End Numbers Fixed Height On Screen'
SCDwgOptionsPipeEndNumbersFixedHeightOnScreen

Set ‘Show Elbow Icon’
Set 'Show Elbow Icon' [ 0: false, 1: true ]
SCDwgOptionsPipeSetShowElbowIcon

Set ‘Elbow Icon Color’
Set 'Elbow Icon Color Index'
SCDwgOptionsPipeSetElbowIconColor

Set ‘Elbow Icon Size’
Set 'Elbow Icon Size'
SCDwgOptionsPipeSetElbowIconSize

Set 'Show Green’
SCDwgOptionsPipeSetShowGreen

Set 'Green Color’
SCDwgOptionsPipeSetGreenColor

Shared HEP Commands

SCHEPTransferPartToDrawing

Button ........... 
Ribbon ........... none
Menu ............... SC Pipe >Transfer Parts

Toolbar............ Penetrations > 
Command ...... SCHEPTRANSFERPARTODRAWING
Permissions ... None
Procedure....... Transfer parts to another drawing / unit (page 127)

Transfers selected HEP parts from one drawing/unit to another drawing/unit. 
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SCHEPReplicateToDrawing

Ribbon ........... none
Menu ............... none
Toolbar............ none
Command ...... SCHEPREPLICATETODRAWING
Permissions ... None
Procedure....... Copy parts to another drawing / unit (page 127)

Copies selected HEP parts from one drawing/unit to another drawing/unit. 

Supports & Hanger Commands

SC Supports & Hangers > New Hanger

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > New Hanger

Toolbar............ Supports and Hangers > 
Command ...... SCHANG
Permissions ... Pipe > Hangers > Pipe Hangers – Insert/Edit
Procedure....... Inserts a new hanger

Inserts a new hanger onto the selected hangable part.

SC Supports & Hangers > Name Hangers

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Name Hangers

Toolbar............ Supports and Hangers > 
Command ...... SCNAMEHANGERS
Permissions ... Pipe > Hangers > Pipe Hangers – Insert/Edit
Procedure....... Renames hangers in order

Renames all the selected hangers in order based on the hangable parts they are attached to. 

SC Supports & Hangers > Move Hanger to Drawing

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Move Hangers to Drawing

Toolbar............ Supports and Hangers > 
Command ...... SCMOVEHANGERSTODWG
Permissions ... Pipe > Hangers > Pipe Hangers – Insert/Edit
Procedure....... Transfer hangers to another drawing / unit

Transfers selected hangers from one drawing/unit to another drawing/unit. 
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SC Supports & Hangers > Move Attached Hanger to Drawing

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Move Attached Hanger to Drawing

Toolbar............ Supports and Hangers > 
Command ...... SCMOVEATTACHEDHANGERSTODWG
Permissions ... Pipe > Hangers > Pipe Hanges – Insert/Edit
Procedure....... Transfer hangers to the current drawing

Transfers all the hangers attached to the selected hangable to the current drawing.

SC Supports & Hangers > Insert Bare Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert Bare Support

Toolbar............ Supports and Hangers > 
Command ...... SCBARESUPPORT
Permissions ... Supports – Insert/Edit
Procedure....... Inserts a new bare support

Inserts a new support that is not attached to any hangable parts

SC Supports & Hangers > Insert Auto Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert Auto Support

Toolbar............ Supports and Hangers > 
Command ...... SCAUTOSUPPORTT
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Creates a new T auto support part

Creates a new T type support attached to the selected hangable parts.

SC Supports & Hangers > Insert LF Auto Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert LF Auto Support

Toolbar............ Supports and Hangers > 
Command ...... SCAUTOSUPPORTLF
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Creates a new LF auto support part

Creates a new LF type support attached to the selected hangable parts.
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SC Supports & Hangers > Insert I Auto Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert I Auto Support

Toolbar............ Supports and Hangers > 
Command ...... SCAUTOSUPPORTI
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Creates a new I auto support part

Creates a new I type support attached to the selected hangable parts.

SC Supports & Hangers > Insert TN Auto Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert TN Auto Support

Toolbar............ Supports and Hangers > 
Command ...... SCAUTOSUPPORTTN
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Creates a new Two by N auto support part

Creates a new Two by N type support attached to the selected hangable parts.

SC Supports & Hangers > Insert MN Auto Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Insert MN Auto Support

Toolbar............ Supports and Hangers > 
Command ...... SCAUTOSUPPORT
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Creates a new M by N auto support part

Creates a new M by N type support attached to the selected hangable parts.

SC Supports & Hangers > Attach Pipes to Support

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Attach Pipes to Support

Toolbar............ Supports and Hangers > 
Command ...... SCATTACHPIPESTOSUPPORT
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Attaches pipes to supports

Attaches selected pipes to the selected supports with hangers.
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SC Supports & Hangers > Transfer Supports to Drawing

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Transfer Supports to Drawing

Toolbar............ Supports and Hangers > 
Command ...... SCMOVESUPPORTSTODWG
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Moves supports to a different drawing/unit

Moves the selected supports and attached hangers from one drawing/unit to another drawing/unit

SC Supports & Hangers > Name Supports In Order

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Name Supports In Order

Toolbar............ Supports and Hangers > 
Command ...... SCNAMESUPPORTS
Permissions ... Distributed Systems Supports > Supports – Insert/Edit
Procedure....... Name Hangers (page 153)

Renames the selected supports in order based on connected hangable parts.

SC Supports & Hangers > Copy Supports Along Supported Parts

Button ........... 
Ribbon ........... Pipe Modeling tab > Supports and Hangers
Menu ............... SC Supports & Hangers > Copy Supports Along Supported Parts

Toolbar............ Supports and Hangers > 
Command ...... SCCOPYSUPPORTSWITHSUPPORTEDOBJECTS
Permissions ... Distributed Systems Supports > Supports – Insert/Edit

Copies the selected support and places the new copied support to the selected point on the same hangable parts with the 
same hangers.

SC Supports & Hangers > Hanger and Support Drawing Options

Button ........... 
Ribbon ........... Pipe Modeling tab > Drawing Options
Menu ............... SC Supports & Hangers > Hanger and Support Drawing Options

Toolbar............ Supports and Hangers > 
Command ...... SCHANGDWGOPTIONS
Permissions ... None
Procedure....... Display Options for Hangers (page 145)

Displays the Support & Hanger Drawing Options.
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Appendix B: Pipe Modeling Reference

Pipe Navigator Page
The Pipe Navigator page lets you create, open, and modify Pipe model drawings and Pipe arrangement drawings 
belonging to the registered unit. From Navigator (ShipConstructor > Navigator), choose Pipe.

Open
Opens the selected Pipe model drawing or Pipe arrangement drawing. If you check the box Read Only, you will not be 
able to modify or save changes to the drawing.

New Piping

Permissions ... Pipe > Modeling > Pipe Models – Create/Delete

Creates a new Pipe model drawing as long as the Piping folder was selected.

New Arrangement

Permissions ... PIpe > Pipe Arrangement – Create/Delete

Creates a new Pipe arrangement drawing as long as the Arrangement folder was selected.
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Show Out of Date

Permissions ... None

Shows a warning icon beside all production drawings that are out of date. A production drawing becomes out of date 
when a part in a model drawing has been modified and that part is used in the production drawing.

Note: Clicking Show Out of Date may cause Navigator to take awhile to refresh the icons, as Navigator has to go 
through all the production drawings in your database. 

Right-Click Menu

Rename

Permissions ... Pipe > Modeling > Pipe Models - Edit

Lets you rename the selected Pipe drawing.

Delete

Permissions ... Pipe > Modeling > Pipe Models – Create/Delete

Deletes the selected Pipe drawing.

Pipe Spool Navigator Page
The Pipe Spool Navigator page lets you create, open, and modify Pipe spool drawings belonging to the registered unit.
From Navigator (ShipConstructor > Navigator), choose Pipe Spool.
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Open

Permissions ... Pipe > Spools > Spool Drawings – Edit

Opens the selected Pipe spool drawing. If you check the box Read Only, you will not be able to modify or save changes to 
the drawing.

Create

Permissions ... Pipe > Spools > Spool Drawings – Create/Delete

Creates one or more Pipe spool drawings based on the Pipe models defined in the current project.

Reattach Drawing

Permissions ... Pipe > Spools > Spool Drawings – Edit

Reattaches an existing drawing that was detached and moved to the Deleted_Spool_Drawings folder. This scenario can 
commonly happen as a result of adding spool breaks. The selected drawing is checked to ensure it is a Pipe spool 
drawing. The spool in the Navigator must not have a drawing to be able to use the Reattach drawing command (shown 

with the spool icon ).

Right-Click Menu
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Delete

Permissions ... Pipe > Spools > Spool Drawings – Create/Delete

Deletes the selected Pipe spool drawing.

Lock/Unlock Spool

Permissions ... Pipe > Spools> Pipe Spools – Lock / Unlock

Locks or unlocks the selected Pipe spool (and its drawing).

Model Drawing Right-Click Menu

Lock/Unlock Spools

Permissions ... Pipe > Spools> Pipe Spools – Lock / Unlock

Locks or unlocks all the approved Pipe spools (and their drawings) in the selected Pipe model drawing.

System Manager

Finish
The finishes that will be applied to pipes in the selected system.

Insulation
The insulation that will be applied to pipes in the selected system.

Color
The color that pipes belonging to this system will appear.

Class
The class field on a system provides a means of associating all pipes within the system to a certain classification.

Test Method
Enter a string field here based on what method you will use for testing.
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Test Pressure (kPa)
Enter a specific value in either pounds per square inch (psi) or kilopascals (kPa).

Density
The density of the pipe affects the wet weight (relative density multiplied by the weight of water). The density is entered 
based on each application and is entered on a branch or system level.

Pipe Options
SC Pipe > Pipe Options opens the Pipe Drawing Options window.

The Display Tab
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General Display

Show Centerline
When checked, displays a line along the center of each pipe.

• Color – You can change the color of the centerline.

Note: When plotting shaded viewports, centerlines are projected in front of the part geometry such that they are easily 
visible.

Show Wall Thickness
When this option is checked, the pipes will accurately show their wall thickness. Unchecking this option may improve 
display performance.

Show Insulation
When this option is checked, the pipes display all insulations that have been applied to them. Unchecking this option may 
improve display performance.

Draw Part Using Branch Color
Uses the pipe’s branch (system) color for display. If this option is unchecked, the pipe uses its AutoCAD color. If you want 
to organize your pipe colors by layer instead of system, uncheck this option, set all your pipes to use ByLayer coloring and 
apply the correct color to the layers that the pipes reside on. It is very useful to color parts by system in your model 
drawings and to color them by layer in production drawings.

End Numbers
End numbers can show up on a pipe when the mouse is hovering over the pipe. They label which end is which. This is very 
useful when trying to place a pipe.

• Scaled To End Size – When selected, will scale the end numbers relative to the size of the pipe’s end by the amount 
entered.

• Fixed Height On Screen – When selected, will show the end numbers at a fixed height according to the value entered.

• None – When selected, will not display the end numbers.

The same pipe showing scaled end numbers (left) and fixed height end numbers (right).

2D/3D Wireframe Display

Draw Line Mode Icons
When checked, will display the line mode icons that are associated with the pipe’s end treatments.



Appendix B: Pipe Modeling Reference

257

Override Stock
When checked the linemode icons displayed can be overridden by clicking the Edit Icon Sizes button. This checkbox is 
only available if the Draw Line Mode Icons is checked.

Edit Icon Sizes

When clicked the LineMode Icon dialog will be displayed and allow the user to select how they would like to override the 
linemode icons being displayed in the current drawing. This button is only available if the Draw Line Mode Icons is 
checked.

Double Line Display

Defines whether the solid is drawn for pipe parts. Parts with a profile smaller than the specified value if using the ‘For 
Profiles Smaller Than’ option or all parts if ‘Never’ is chosen will be drawn in a single line display and show in the part 
color, not the centerline color.

Note: Pipe and HVAC rendering has changed significantly since older versions of ShipConstructor 2006/2008. Instead 
of the old edge style options, edge style is now controlled by the AutoCAD system variables (similar to AutoCAD 
solids). See the ISOLINES and DISPSILH variables. Also, Pipe/HVAC models now obey AutoCAD’s adaptive 
degradation and level of detail settings (See the native AutoCAD display options).

Connections

These are options that are related to connections.

Show Connections
Displays geometry at all connected pipe ends. A small circle is used in 2D linemode, and a line surrounding the 
connection in combination with small mesh covering the connection gap is used in all other shademodes.
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Local Connection Color
Option to set the color and size of a local connection

• Color – You can change the color of the connection symbol.

• Size – You can change the size of the symbol. A default size of 0 indicates automatic sizing.

Remote Connection Color
Option to set the color and size of a remote connection.

• Color – You can change the color of the connection symbol.

• Size – You can change the size of the symbol. A default size of 0 indicates automatic sizing.

Show Free End Arrows
When checked, displays an arrow pointing at all free pipe ends. 

• Color – You can change the color of the free end arrow.

• Size – You can change the size of the arrow. A default size of 0 indicates automatic sizing.

Spool

Show Spool Break
When checked, displays a large spoked circle at each spool break.
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• Color – You can change the color of the spool break symbol.

• Size – You can change the size of the symbol. The default size of 0 indicates automatic sizing.

Show No-Spool Icon
When checked, displays a small cross at the center of each pipe that is a No Spool item.        

• Color – You can change the color of the no spool icon.

• Size – You can change the size of the icon. A default size of 0 indicates automatic sizing.

Show Elbow Corner Icon
When checked, displays a small elbow icon along the tangents of each elbow part.

• Color – You can change the color of the elbow corner icon.

• Size – You can change the size of the icon. A default size of 0 indicates automatic sizing.

Restore Defaults

The restore defaults button, when clicked, will change all the display settings back to the original default values.
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The NavAid Tab

Radius
Controls the size of the NavAid.

• 2x Pipe Diameter – The NavAid becomes twice the size of the pipe’s diameter.

• Static Radius – The NavAid’s radius is set to a constant value that you provide.

Snap
When checked, snaps the NavAid to angles based on the Tolerance and Increment settings.

• Tolerance – Controls the size of the snap zone. For example, if the Tolerance is 15 degrees, then the snap zone is 15 
degrees to either side of a snap point (as in the image below).
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• Increment – The angle between each successive snap point. Snap points appear as spikes on the NavAid. For 
example, if the Increment is 45 degrees, then the NavAid will have eight spikes (as in the image above).

Text
• Relative to Screen Size – NavAid text has a constant size relative to the screen, regardless of zoom level.

• 1/3 Pipe Dimension – NavAid text is 1/3 the size of the pipe’s diameter.

The Transform Tab
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Anchors

Show Anchors
When checked, will display the anchor symbol to indicate anchored pipes.

Color
The color of the anchor symbol.

Size
• Relative to Part – The size of the anchor symbol is relative to the part.

• Fixed – The size of the anchor symbol is statically defined by you, entered in the Size field.

Anchored Points

When performing a multipart transform, an octagon-like icon is displayed at points beyond which the transform cannot 
affect. For example the icon is drawn where the transform is restricted by an anchored or locked part, or a part on a 
locked layer, etc.

Color
The color of the anchored point symbol.

Size
• Relative to Part – The size of the anchored point symbol is relative to the part.

• Fixed – The size of the anchor symbol is statically defined by you, entered in the Size field.

Locks

Show Locks
When checked, will show the lock symbol for pipes that are locked.

Color
The color of the lock symbol.

Size
• Relative to Part – The size of the lock symbol is relative to the part.

• Fixed – The size of the lock symbol is statically defined by you, entered in the Size field.

Split and Merge

Override Color for Split Part
When checked, split pipes are drawn in the selected color instead of the default split color.
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The Routing Tab

Flow Direction

Show Flow Direction
When checked, will display the flow direction symbol on all bent pipes if their individual “Show Flow Direction” flag is set.

Show All
When checked, will display the flow direction symbol on all bent pipes regardless of whether or not their individual “Show 
Flow Direction” flag is set.

Color
The color of the flow direction symbol.

Size
The size of the flow direction symbol is statically defined by you, entered in the Size field.
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The Behavior Tab

Stock Length Enforcement

Automatically cut to stock length
When selected, automatically cuts parts that exceed their stock’s maximum length to that stock’s maximum length.

Ask before cutting to stock length
When selected, you will be prompted before a part is cut to its stock’s maximum length.

Never cut to stock length
When selected, parts will never be cut to their stock’s length.

Create warning labels for items exceeding stock length on drawing save
When checked, labels will be displayed on pipes that are greater than their max length, unless the “Don’t Show Max 
Length Warning” is set on the part.
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The Constraints Tab

Bender Constraints

Highlight Violating Segments
When checked, bent pipe segments that violate bender constraints will be highlighted with the specified color. This is a 
per-drawing setting and is on by default..

Stock Selection Window Reference
The Stock Selection window appears when:

• Trying to insert a part of a certain type for the first time

• You select ‘S’ while inserting a pipe

• Trying to connect one pipe to another and the pipe you are trying to connect to cannot connect.

This can happen if you have not defined a connection for the type of ends you are trying to connect.
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Apply Filter Button 
This will apply all filters that you have defined in the Filter Row and the ‘hidden’ filter that is created if you had selected a 
connection using the Connects To… button.

Clear Filter Button 
Will clear all filters that you have defined in the Filter Row, and it will temporarily disable the ‘hidden’ filter created if you 
had selected a connection using the Connects To… button.

The Filter Row
This is the empty row that is located just below the column headings. To use this filter, simply type in the string you would 
like to filter by under the correct column and click the Apply Filter button. The filter, when applied, will show only those 
stocks that match the string typed in for that specific column. The filter strings are remembered between sessions.

Connects To… Button
Click on this button when you want to filter all the stocks listed by an end that you could connect to. Once you click this 
button, you will be prompted to select an end. Once the end is selected, the list will be filtered based on if the stock 
shown can connect to the end selected.

Required Custom Attributes Reference
After routing the pipe if there are any required custom attributes or catalogs are assigned to the stock used the catalog 
and custom attributes for this part much be set. ShipConstructor will attempt to do this automatically. If there one 
catalog assigned to the stock it will be chosen for the part, and if all the stocks are set to be “Deferred by Default” or have 
been given a default value, they will be set to the default. If ShipConstructor cannot set all these values automatically the
dialog below will be shown. This dialog will allow users to enter in the custom attributes and will abort the parts routing if 
it is cancelled. Using the arrows to select items in a drop down and enter to move to the next non-deferred attribute and 
the OK button after all attributes have been entered, the user can quickly enter all the values using only the keyboard.
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Insulation Reference
Insulation on a pipe can be defined on a system, spool and on individual parts. 

While laying down a pipe, there is an option on the command line to select insulation (see Straight Pipe (page 93) or Bent
Pipe (page 94)), or while in a pipe drawing you can right-click on a part and choose Change Insulation.... This will bring up 
the Select Insulation window where you can select additional insulation to apply to the part or change the order of the 
selected insulation. By un-checking the box Inherit from System (or Inherit from Spool if your part is spooled), the existing
insulation will be pre-selected and you are free to change the insulation for the part.

Note: The stock’s insulation will not be shown in the insulation window while selecting insulation for a part or a 
system. 

When defining insulation for a pipe, order matters. Please double check the order of the selected insulation. The order of 
the insulation applied to the pipe may show up in reports or BOMs.

Available Insulations
A list that contains the available insulation that has been defined in the library setup.
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Selected Insulations
An ordered list that contains all the insulations that will be applied to the pipe.

Inherit from System (Inherit from Spool)
A box indicating whether to inherit the insulations from the system the part belongs to. 

To apply an insulation

1. Select an insulation from the available list.

2. Click the right arrow.

To unselect an insulation

1. Select an insulation from the selected list.

2. Click the left arrow.

To change the order of the selected insulation

1. Select an insulation from the selected list.

2. Click the up or down arrows as necessary.

Finishes Reference
Finishes on a pipe can be defined at many levels. Finishes can be applied to a system, a branch, a spool, a hierarchy, and 
a part.

When defining a system or a branch in a pipe drawing, you can select finishes to be applied to that system or branch in 
the System Manager. See Create a System (page 82) or Create a Branch (page 83) for more details on how to set up a 
system or branch. For example, when finishes are selected for a system, this means that all the parts belonging to the 
system will have these finishes applied.

Finishes selected for a hierarchy are last in the order of selected finishes for a part. This is so you can apply a finish to an 
entire hierarchy level of parts as a last step.

In a part, finishes from the system can be overridden. If you do not want your part to have any of the systems or branches 
finishes, simply uncheck the box Inherit from System and remove all the finishes.

At any time you can see which finishes are applied to a part by right-clicking on the part and choosing Change Finishes….
This brings up the Select Finishes window. 
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Available Finishes
A list that contains the available finishes that has been defined in the library setup.

Selected Finishes
An ordered list that contains all the finishes that will be applied to the pipe.

Inherit from System
A box indicating whether to inherit the finishes from the system the part belongs to. To override the finishes for a part, 
this box must be unchecked.

Inherit From Hierarchy
A box indicating whether the finishes from the hierarchy the part belongs to will be inherited.

To apply a finish

1. Select a finish from the available list.

2. Click the right arrow.

To unselect a finish

1. Select a finish from the selected list.

2. Click the left arrow.

To change the order of the selected finish

1. Select a finish from the selected list.

2. Click the up or down arrows as necessary.
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Pipe Part Right-Click Menu

Anchor
When selected, this option anchors the part. This means that the part stays where it is during a move command. This part 
will stay where it is even if it is connected to another part and all the parts are selected during a transformation. See 
Single-Part Transforms (page 115), Multi-Part Transforms (page 117) and Anchor Pipes (page 113) for more information.

Lock
When selected, will lock a part. This part will not be able to change.

Disconnect
This command disconnects the part from everything.

Change Stock…

Note: This command is not yet available in ShipConstructor.

This command lets you change the standard that the part belongs to.

Change Insulation…
Use this command to change the insulation on the part or to view the insulation that is applied to the part. See Insulation 
Reference (page 268) for more details.

Change Finish…
This command lets you change the finishes for the part, or the command lets you view all the finishes applied to the part. 
See Finishes Reference (page 269) for more details.

Extract Center Lines
This command will extract the center line from the selected part.
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Merge To Bent
This command will merge a selection of pipe parts into a single bent pipe.

Show Flow Direction
Use this command to toggle the visibility of the parts flow direction arrow.

Switch Flow Direction
Use this command to toggle the flow direction of the entire pipe run, up to a branch.

Rotate Line Mode Icon
This command will rotate the line mode icons of this part by 90 degrees.

Set Line Mode Icon Size
Running this command will give you command line options to change the size of the individual parts line mode icons.

Don’t Show Max Length Warning
This command will toggle the visibility of max length warnings if they are enabled in the pipe drawing options and the 
part is over the max length.

Select UCS Options Reference
The Select UCS Options window is an interactive window that will help you to see exactly how your new UCS will be. 

UCS Plane
Depending on the part selected, and what end you are currently on, there will be different choices for the UCS Plane. The 
choices for the UCS Plane that could show up are as follows:

• Deck Plane – Working plane will be in the Deck plane.

• Deck Like Plane – Working plane will be in a plane that is close to the Deck plane, but not exactly in the Deck plane. 
This is because the part end selected is not aligned exactly to the Deck plane.

• Frame Plane – Working plane will be in the Frame plane.

• Frame Like Plane – Working plane will be in a plane that is close to the Frame plane, but not exactly in the Frame 
Plane. This is because the part end selected is not aligned exactly to the Frame plane.

• LGBH Plane – Working plane will be in the LGBH plane.

• LGBH Like Plane – Working plane will be in a plane that is close to the LGBH plane, but not exactly in the LGBH 
Plane. This is because the part end selected is not aligned exactly to the LGBH plane.
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• Pick 3rd Point for Plane – This option enables you to create an arbitrary plane based on the alignment of the part and 
the point that you pick. When this option is selected, you will be prompted to pick a point.

UCS Origin Point

This option selects your UCS origin point.

• Part Point – Point on the part. The points are at the ends of the part. If there are multiple part points, you can click 
on the Toggle button to toggle through the list of points.

• Origin – Selecting this option will give you a UCS Origin at (0,0,0).

On the part itself, there is a mock plane to enable you to see where your working plane will be. You can use AutoCAD’s 
orbit command to adjust your view of the mock plane if need be. This working plane automatically adjusts as you select 
different planes or toggle through the different points.

Scenario Wizard Dialog
When new pipe parts need to be inserted when using any of the new functionality and there are multiples solutions 
for the simplest possible scenario then the Scenario Wizard dialog is shown. The wizard has 3 modes depending on 
how it was initialized; insert connectors, insert same size fitting, insert different size fitting. The image below shows 
an example where a user wanted to insert an 8” lateral into a 6” run of pipe.

The main grid initially shows you the partial solution made up of all the items that are the same in all possible 
solutions for the simplest scenario that has a solution. You can switch to any of the possible solutions by pressing 
the arrow buttons below the grid. The columns of this grid are described below:
• Name – The two bounding parts are the ones that are having the parts inserted between. The white rows list the 

stock name to be used. Selecting this cell will allow you select a stock for this item, if you are on the partial solution, 
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by clicking the ellipsis button. The green rows are the allowable connections. Selecting this cell will allow you select 
an allowable connection for this item, if you are on the partial solution, by clicking the ellipsis button.

• Switch Ends – This column shows the orientation of the item by end handle from left to right as shown in the preview 
at the top of the dialog. You can rotate the ends by pressing the ellipsis button if you are viewing the partial solution.

• End 1 – shows the end treatment on the left end of the stock or allowable connection.

• End 2– shows the end treatment on the right end of the stock or allowable connection.

• Gap – shows the connection gap for allowable connections.

• Accessory Package – shows the Accessory Package for allowable connections.

The top of the dialog shows a diagram laying out the current scenario type that is selected. 
The scenario type drop down allows you to switch to solutions that contain more parts. You can select simpler 
scenarios that the one that is initially selected, but they will not have any possible solutions.
The connector type drop down displays which connector type will be used when selecting a connector stock via the 
ellipsis button in the name column.
The clear button removes all stocks and allowable connections from partial solutions. If you are inserting a fitting 
then it will remain.
The solution selector, which is the number field and arrow buttons below the grid, allows you to switch between all 
the possible solutions and the partial solution. You can do this by pressing the buttons to move one forward or back, 
skipping to the first or last, or by entering a number in the field.
With a valid and complete solution shown in the grid you can press enter to apply it to the model.

Hanger Stock Selection Window Reference
The Hanger Stock Selection window appears when:

• Trying to insert a hanger  for the first time

• You select ‘C’ while inserting a hanger

• When hanging a pipe part that has a different nominal size or different material that what has been previously hung.
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The column on the left will display all the different types of hangers that have valid hangers based on the pipe that 
was selected to be hung. Selecting a hanger type in the left column will display all the valid hangers of the selected 
type in the right column. Select the appropriate hanger stock and click OK to place the hanger on the pipe.

Hanger & Support Drawing Options
The hanger drawing options controls how the hangers are displayed in the current drawing.

Hangers

Hanger Display

• Show Hanger 2D Geom – Displays the 2 dimensional representation of the hanger

• Show Hanger 3D Geom – Displays the 3 dimensional representation of the hanger
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Color

• Global Hanger Color – Displays all hangers using the selected color.

• Use Pipe System Color – The hangers are displayed using the same color as the system of the pipe they are attached 
to.

• Use Individual Colors – The hangers are displayed with the color specified in the OPM.

Supports

Support Display

• Show Support 2D Geom – Displays the 2 dimensional representation of the support.

• Show Support 3D Geom – Displays the 3 dimensional representation of the support.

Radius

Controls the size of the NavAid.

• 2x Profile Diameter – The NavAid becomes twice the size of the vertical profiles web length.

• Static Radius – The NavAid’s radius is set to a constant value that you provide.

Snap

When checked, snaps the NavAid to angles based on the Tolerance and Increment settings.

• Tolerance – Controls the size of the snap zone. For example, if the Tolerance is 15 degrees, then the snap zone is 15 
degrees to either side of a snap point (as in the image below).

• Increment – The angle between each successive snap point. Snap points appear as spikes on the NavAid. For 
example, if the Increment is 45 degrees, then the NavAid will have eight spikes (as in the image above).

Support Template Selection Window Reference
The Support Template Selection window appears when:

• Trying to insert a support  for the first time

• You select ‘C’ while inserting as support



Appendix B: Pipe Modeling Reference

277

The column on the left will display all the different types of supports that are valid based on the command run and the 
hangable parts selected.. Selecting a support type in the left column will display all the valid supports of the selected type 
in the right column. Select the appropriate support template stock, hangers and click OK to place the support.
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Appendix C: Pipe Production Command 
Reference

Toolbars
The most common commands are located on the Pipe toolbars.

Spool Toolbar
Rotate Dimension

See SC Spool Drawing > Rotate Dimension (page 287)

Re-dimension Spools

See SC Spool Drawing > Re-Dimension (page 287)

Insert Orientation Icon

See SC Spool Drawing > Orientation Icon (page 288)

SC Arrangement Menu
The SC Arrangement menu appears in arrangement drawings.

SC Arrangement > Update Drawing

Menu ............... SC Arrangement > Update Drawing
Toolbar............ None
Command ...... SCUPDATEDWG
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Update Arrangement Drawings (page 193)

Update an arrangement drawing with the latest geometry from the model drawings, or change the sources of which the 
arrangement drawing is composed of.

SC Arrangement > Silent Update Drawing

Menu ............... None
Toolbar............ None
Command ...... -SCUPDATEDWGSILENT
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Update Arrangement Drawings (page 193)

Update an arrangement drawing with the latest geometry from the model drawings without requesting user input.



Appendix C: Pipe Production Command Reference

280

SC Arrangement > Insert Keywords

Menu ............... SC Arrangement > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYWORD
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Arrangement Drawing Keywords (page 186)

Inserts keywords into the drawing.

SC Arrangement > Update All Keywords

Menu ............... SC Arrangement > Update All Keywords
Toolbar............ None
Command ...... SCUPDATEALLKEYWORDS
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Update All Keywords (page 202)

Updates all keywords in paper space in the drawing.

SC Arrangement > Pipe Drawing Options

Menu ............... SC Arrangement > Pipe Drawing Options

Toolbar............ Pipe > 
Command ...... SCDWGOPTIONSPIPE
Permissions ... None
Procedure....... Pipe Options (page 255)

Displays the pipe drawing options.

SC Arrangement > HVAC Drawing Options

Menu ............... SC Arrangement > HVAC Drawing Options

Toolbar............ HVAC > 
Command ...... SCDWGOPTIONSHVAC
Permissions ... None
Procedure....... See the HVAC manual for details.

Displays the HVAC drawing options.

SC Arrangement > Equipment Drawing Options

Menu ............... SC Arrangement > Equipment Drawing Options

Toolbar............ Equipment > 
Command ...... SCDWGOPTIONSEQUIP
Permissions ... None
Procedure....... See the Equipment manual for details.

Displays the Equipment drawing options.
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SC Arrangement > Viewport Options

Menu ............... SC Arrangement > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.

SC Arrangement > Set Viewport Display Options

Menu ............... SC Arrangement > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.

SC Arrangement > Insert BOM Table

Menu ............... SC Arrangement > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTBOM 
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Insert a New Empty Arrangement BOM Table (page 184)

Inserts a BOM table.

SC Arrangement > Update BOMs

Menu ............... SC Arrangement > Update BOMs
Toolbar............ None
Command ...... SCUPDATEBOMS
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Update BOMs (page 201)

Updates the BOM Table.

SC Arrangement > Edit Collector Options

Menu ............... SC Arrangement > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... Pipe > Arrangements - Edit
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.
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SC Arrangement > Toggle List Only Visible

Menu ............... SC Arrangement > Toggle List Only Visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.

SC Arrangement > Label > Manual Label from BOM

Menu ............... SC Arrangement > Label > Manual Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELMANUAL
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you manually label parts from a BOM. This is an alternative method to automatic labeling. The label style and text 
contents are used from the selected BOM. The selection of the leader arrow is the pickpoint where you selected the part. 
The number of leader segments follows the label style setting.

This command can be used in conjunction with Copy Label from BOM so complete the labeling. If you select a part that 
has been previously labeled then the previous label is removed.

SC Arrangement > Label > Copy Label from BOM

Menu ............... SC Arrangement > Label > Copy Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELCOPY
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of 
the selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label. 

SC Arrangement > Label > Relabel All

Menu ............... SC Arrangement > Label >Relabel All
Toolbar............ None
Command ...... SCRELABELALL
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Relabel All (page 198)

Generates labels for all new BOM items and places them on the _ANNOTATION layer. 

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.
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SC Arrangement > Label > Relabel from BOM

Menu ............... SC Arrangement > Label >Relabel from BOM
Toolbar............ None
Command ...... SCRELABELFROMBOM
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Relabel from a selected BOM (page 198)

Relabels parts from a selected BOM and places them on the _ANNOTATION layer.

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.

SC Arrangement > Label > Relabel from Parts

Menu ............... SC Arrangement > Label >Relabel from Parts
Toolbar............ None
Command ...... SCRELABELFROMPARTS
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Relabel from Parts (page 199)

Relabels selected parts from the BOMs.

SC Arrangement > Label > Label on Visible Edge On/Off

Button .............
Ribbon ............ Production tab > Labeling panel > Label on Visible Edge On/Off
Menu ............... SC Arrangement > Label > Label on Visible Edge On/Off
Toolbar............ None
Command ...... SCLABELONVISIBLEEDGE
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Label on Visible Edge On/Off (page 199)

Turns labels automatic label generation from label to piecemark to label on visible part edge.

SC Arrangement > Label > Curved Plates in Visible Edge Detection On/Off

Button .............
Ribbon ............ Production tab > Labeling panel > Curved Plates in Visible Edge Detection On/Off
Menu ............... SC Arrangement > Label > Curved Plates in Visible Edge Detection On/Off
Toolbar............ None
Command ...... SCLABELREMOVECURVEDPLATEHLR
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Curved Plates in Visible Edge Detection On/Off (page 199)

Turns on option to include curved plates in hidden line calculation when label on visible part edge is on.
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SC Arrangement > Label > Adjacent Part Edge Tolerance

Button .............
Ribbon ............ Production tab > Labeling panel > Adjacent Part Edge Tolerance
Menu ............... SC Arrangement > Label > Adjacent Part Edge Tolerance
Toolbar............ None
Command ...... SCLABELADJACENTTOL
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Adjacent Part Edge Tolerance (page 199)

Edges will be less likely to be labeled if they are closer than this distance to an edge of another part.

SC Arrangement > Label > Edge Length Filter

Button .............
Ribbon ............ Production tab > Labeling panel > Edge Length Filter
Menu ............... SC Arrangement > Label > Edge Length Filter
Toolbar............ None
Command ...... SCLABELEDGELENGTHFILTER
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Edge Length Filter (page 200)

Edges shorter than this percentage will be filtered out from consideration of being pointed to by the labe.

SC Arrangement > Label > Edge Determination Minimum Angle

Button .............
Ribbon ............ Production tab > Labeling panel > Edge Determination Minimum Angle
Menu ............... SC Arrangement > Label > Edge Determination Minimum Angle
Toolbar............ None
Command ...... SCLABELEDGEDETERMINATIONANGLE
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Edge Determination Minimum Angle (page 200)

Line segments will be considered part of the same edge if they are less than this angle away from tangent.

SC Arrangement > Label > Label Reset Automatic Settings

Button .............
Ribbon ............ Production tab > Labeling panel > Label Reset Automatic Settings
Menu ............... SC Arrangement > Label > Label Reset Automatic Settings
Toolbar............ None
Command ...... SCLABELRESETALL
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Label Reset Automatic Settings (page 200)

Resets the automatic label generation settings in the current drawing to use the project settings.
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SC Arrangement > BOM Revisions > New BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in Current Layout
Menu ............... SC Arrangement > BOM Revisions > New BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVNEW
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in the current layout.

SC Arrangement > BOM Revisions > New BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in All Layouts
Menu ............... SC Arrangement > BOM Revisions > New BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVNEWALL
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in all layouts.

SC Arrangement > BOM Revisions > Delete BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in Current Layout
Menu ............... SC Arrangement > BOM Revisions > Delete BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVDEL
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in the current layout.

SC Arrangement > BOM Revisions > Delete BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in All Layouts
Menu ............... SC Arrangement > BOM Revisions > Delete BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVDELALL
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in all layouts.
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SC Arrangement > BOM Revisions > Delete All BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in Current Layout
Menu ............... SC Arrangement > BOM Revisions > Delete All BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVCLEAR
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in the current layout.

SC Arrangement > BOM Revisions > Delete All BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in All Layouts
Menu ............... SC Arrangement > BOM Revisions > Delete All BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVCLEARALL
Permissions ... Pipe > Pipe Arrangement Drawing Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in all layouts.

SC Arrangement > BOM Revisions > List BOM Revisions

Button .............
Ribbon ............ Production tab > BOM Revisions panel > List BOM Revisions
Menu ............... SC Arrangement > BOM Revisions > List BOM Revisions
Toolbar............ None
Command ...... SCPRODREVLIST
Permissions ... None
Procedure....... List Revisions (page 357)

List the information about the revisions in the current layout.

SC Arrangement > Global Dimension to Point

Menu ............... SC Arrangement > Global Dimension to Point
Toolbar............ None
Command ...... SCDISTANCEFROMPOINT
Permissions ... Pipe > Pipe Arrangements - Edit
Procedure....... Global Dimension to Point (page 357)

Indicates the distance from a given point to a selected plane.

SC Spool Drawing Menu
The SC Spool Drawing menu appears in spool drawings.
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SC Spool Drawing > Update Spool Drawing

Menu ............... SC Spool Drawing > Update Spool Drawing
Toolbar............ None
Command ...... SCUPDATEDWG
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Updating an Existing Spool Drawing (page 182)

Update the spool drawing with the latest geometry from the model drawing.

SC Spool Drawing > Rotate Dimension

Menu ............... SC Spool Drawing > Rotate Dimension

Toolbar............ Spool > 
Command ...... SCROTATEDIM
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Rotate a Dimension (page 179)

Invoke a utility that aids in the fine-tuning of linear dimensions.

SC Spool Drawing > Align Dimension Text to Current View

Menu ............... SC Spool Drawing > Align Dimension Text to Curent View
Toolbar............ None
Command ...... SCALIGNDIMTEXT
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Align Dimension Text to View (page 180)

Rotate and orient all text labels in the drawing to face the user.

SC Spool Drawing > Re-Dimension

Menu ............... SC Spool Drawing > Re-Dimension

Toolbar............ Spool > 
Command ...... SCREDIM
Permissions ... Pipe > Spools > Pipe Spools – Edit
Procedure....... Re-dimension a Spool Drawing (page 180)

Automatically regenerates the dimensions for the spool.

SC Spool Drawing > CG Point

Menu ............... SC Spool Drawing > CG Point
Toolbar............ None
Command ...... SCINSERTCG
Permissions ... Pipe > Spools > Pipe Spools – Edit
Procedure.......

The command inserts a SConCGPoint object at a center of gravity (CG) position of the current assembly. The SConCGPoint 
is exactly like an AutoCAD POINT object except you cannot move it. The command also changes the current Point style to 

(34).  You can change the style of the CG point by using the point style options. The orientation of the point is based 
on the orientation of the current UCS. If a SConCGPoint already exists in drawing, it will be moved to the correct CG 
position. 



Appendix C: Pipe Production Command Reference

288

SC Spool Drawing > Orientation Icon

Menu ............... SC Spool Drawing > Orientatation Icon

Toolbar............ Spool > 
Command ...... SCASSORIENT
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Insert an Orientation Icon (page 201)

Insert an icon displaying the orientation of the ship.

SC Spool Drawing > Label Connecting Spool/Assembly

Menu ............... SC Spool Drawing > Connecting Spool
Toolbar............ None
Command ...... SCCONSPOOL
Permissions ... Pipe > Spools > Pipe Spools – Edit
Procedure....... Label Connecting Spool/Assembly (page 181)

Inserts a label where the spool connects to another spool not in the drawing.

SC Spool Drawing > Insert Keywords

Menu ............... SC Spool Drawing > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYWORD
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Spool Drawing Keywords (page 174)

Inserts keywords into the drawing.

SC Spool Drawing > Update All Keywords

Menu ............... SC Spool Drawing > Update All Keywords
Toolbar............ None
Command ...... SCUPDATEALLKEYWORDS
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Update All Keywords (page 202)

Updates all keywords in paper space in the drawing.

SC Spool Drawing > Drawing Options

Menu ............... SC Spool Drawing > Drawing Options
Toolbar............ None
Command ...... SCHEPDWGOPTIONS
Permissions ... None
Procedure....... Pipe Options (page 255)

Display the drawing options.
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SC Spool Drawing > Viewport Options

Menu ............... SC Spool Drawing > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.

SC Spool Drawing > Set Viewport Display Options

Menu ............... SC Spool Drawing > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.

SC Spool Drawing > Insert BOM Table

Menu ............... SC Spool Drawing > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTBOM 
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Insert a New Empty Spool BOM Table (page 172)

Inserts a BOM table.

SC Spool Drawing > Update BOMs

Menu ............... SC Spool Drawing > Update BOMs
Toolbar............ None
Command ...... SCUPDATEBOMS
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Update BOMs (page 201)

Updates the BOM Table.

SC Spool Drawing > Edit Collector Options

Menu ............... SC Spool Drawing > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.
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SC Spool Drawing > Toggle List Only Visible

Menu ............... SC Spool Drawing > Toggle List Only Visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.

SC Spool Drawing > Label > Manual Label from BOM

Menu ............... SC Spool Drawing > Label > Manual Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELMANUAL
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you manually label parts from a BOM. This is an alternative method to automatic labeling. The label style and text 
contents are used from the selected BOM. The selection of the leader arrow is the pickpoint where you selected the part. 
The number of leader segments follows the label style setting.

This command can be used in conjunction with Copy Label from BOM so complete the labeling. If you select a part that 
has been previously labeled then the previous label is removed.

SC Spool Drawing > Label > Copy Label from BOM

Menu ............... SC Spool Drawing > Label > Copy Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELCOPY
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of 
the selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label. 

SC Spool Drawing > Label > Relabel All

Menu ............... SC Spool Drawing > Label > Relabel All
Toolbar............ None
Command ...... SCRELABELALL
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Relabel All (page 198)

Generates labels for all new BOM items and places them on the _ANNOTATION layer.

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.
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SC Spool Drawing > Label > Relabel from BOM

Menu ............... SC Spool Drawing > Label > Relabel from BOM
Toolbar............ None
Command ...... SCRELABELFROMBOM
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Relabel from a selected BOM (page 198)

Relabels parts from a selected BOM and places them on the _ANNOTATION layer.

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.

SC Spool Drawing > Label > Relabel from Parts

Menu ............... SC Spool Drawing > Label > Relabel from Parts
Toolbar............ None
Command ...... SCRELABELFROMPARTS
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Relabel from Parts (page 199)

Relabels selected parts from the BOMs.

SC Spool Drawing > BOM Revisions > New BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in Current Layout
Menu ............... SC Spool Drawing > BOM Revisions > New BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVNEW
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in the current layout.

SC Spool Drawing > BOM Revisions > New BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in All Layouts
Menu ............... SC Spool Drawing > BOM Revisions > New BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVNEWALL
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in all layouts.
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SC Spool Drawing > BOM Revisions > Delete BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in Current Layout
Menu ............... SC Spool Drawing > BOM Revisions > Delete BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVDEL
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in the current layout.

SC Spool Drawing > BOM Revisions > Delete BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in All Layouts
Menu ............... SC Spool Drawing > BOM Revisions > Delete BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVDELALL
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in all layouts.

SC Spool Drawing > BOM Revisions > Delete All BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in Current Layout
Menu ............... SC Spool Drawing > BOM Revisions > Delete All BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVCLEAR
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in the current layout.

SC Spool Drawing > BOM Revisions > Delete All BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in All Layouts
Menu ............... SC Spool Drawing > BOM Revisions > Delete All BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVCLEARALL
Permissions ... Pipe > Spools > Pipe Spool Drawing Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in all layouts.



Appendix C: Pipe Production Command Reference

293

SC Spool Drawing > BOM Revisions > List BOM Revisions

Button .............
Ribbon ............ Production tab > BOM Revisions panel > List BOM Revisions
Menu ............... SC Spool Drawing > BOM Revisions > List BOM Revisions
Toolbar............ None
Command ...... SCPRODREVLIST
Permissions ... None
Procedure....... List Revisions (page 357)

List the information about the revisions in the current layout.

SC Spool Drawing > Global Dimension to Point

Menu ............... SC Spool Drawing > Global Dimension to Point
Toolbar............ None
Command ...... SCDISTANCEFROMPOINT
Permissions ... Pipe > Spools > Spool Drawings – Edit
Procedure....... Global Dimension to Point (page 357)

Indicates the distance from a given point to a selected plane.

SC Arrangement Template Menu
The SC Arrangement Template menu appears in arrangement drawing templates.

SC Arrangement Template > Orientation Icon

Menu ............... SC Arrangement Template > Orientatation Icon

Toolbar............ Spool > 
Command ...... SCASSORIENT
Permissions ... General - Edit Template Drawings
Procedure....... Insert an Orientation Icon (page 201)

Insert an icon displaying the orientation of the ship.

SC Arrangement Template > Insert Keywords

Menu ............... SC Arrangement Template > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYWORD
Permissions ... General - Edit Template Drawings
Procedure....... Arrangement Drawing Keywords (page 186)

Inserts keywords into the drawing.
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SC Arrangement Template > Pipe Drawing Options

Menu ............... SC Arrangement Template > Pipe Drawing Options

Toolbar............ Pipe > 
Command ...... SCDWGOPTIONSPIPE
Permissions ... None
Procedure....... Pipe Options (page 255)

Displays the pipe drawing options.

SC Arrangement Template > HVAC Drawing Options

Menu ............... SC Arrangement Template > HVAC Drawing Options

Toolbar............ HVAC > 
Command ...... SCDWGOPTIONSHVAC
Permissions ... None
Procedure....... See the HVAC manual for details.

Displays the HVAC drawing options.

SC Arrangement Template > Equipment Drawing Options

Menu ............... SC Arrangement Template > Equipment Drawing Options

Toolbar............ Equipment > 
Command ...... SCDWGOPTIONSEQUIP
Permissions ... None
Procedure....... See the Equipment manual for details.

Displays the Equipment drawing options.

SC Arrangement Template > Viewport Options

Menu ............... SC Arrangement Template > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.

SC Arrangement Template > Set Viewport Display Options

Menu ............... SC Arrangement Template > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.
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SC Arrangement Template > Insert BOM Table

Menu ............... SC Arrangement Template > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTBOM 
Permissions ... General - Edit Template Drawings
Procedure....... Insert a New Empty Arrangement BOM Table (page 184)

Inserts a BOM table.

SC Arrangement Template > Edit Collector Options

Menu ............... SC Arrangement Template > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... General - Edit Template Drawings
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.

SC Arrangement Template > Toggle List Only Visible

Menu ............... SC Arrangement Template > Toggle List Only Visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... General - Edit Template Drawings
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.

SC Arrangement Template > Update from a Previous Version

Menu ............... SC Arrangement Template > Update from a Previous Version
Toolbar............ None
Command ...... SCUPDATEPREVIOUSTEMP
Permissions ... None
Procedure....... Update a Previous Version of an Arrangement Template (page 187)

SC Spool Template Menu
The SC Spool Template menu appears in spool drawing templates.

SC Spool Template > Orientation Icon

Menu ............... SC Spool Template > Orientatation Icon

Toolbar............ Spool > 
Command ...... SCASSORIENT
Permissions ... General - Edit Template Drawings
Procedure....... Insert an Orientation Icon (page 201)

Insert an icon displaying the orientation of the ship.
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SC Spool Template > Insert Keywords

Menu ............... SC Spool Template > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYWORD
Permissions ... General - Edit Template Drawings
Procedure....... Spool Drawing Keywords (page 174)

Inserts keywords into the drawing.

SC Spool Template > Drawing Options

Menu ............... SC Spool Template > Drawing Options
Toolbar............ None
Command ...... SCHEPDWGOPTIONS
Permissions ... None
Procedure....... Pipe Options (page 255)

Displays the drawing options.

SC Spool Template > Viewport Options

Menu ............... SC Spool Template > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.

SC Spool Template > Set Viewport Display Options

Menu ............... SC Spool Template > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.

SC Spool Template > Insert BOM Table

Menu ............... SC Spool Template > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTBOM 
Permissions ... General - Edit Template Drawings
Procedure....... Insert a New Empty Spool BOM Table (page 172)

Inserts a BOM table.
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SC Spool Template > Edit Collector Options

Menu ............... SC Spool Template > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... General - Edit Template Drawings
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.

SC Spool Template > Toggle List Only Visible

Menu ............... SC Spool Template > Toggle List Only Visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... General - Edit Template Drawings
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.

SC Spool Template > Update from a Previous Version

Menu ............... SC Spool Template > Update from a Previous Version
Toolbar............ None
Command ...... SCUPDATEPREVIOUSTEMP
Permissions ... None
Procedure....... Update a Previous Version of a Spool Template (page 175)
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SC Support Const Menu
The SC Support Const menu appears in support construction drawings.

SC Support Const > Update Drawing

Menu ............... SC Support Const > Update Drawing
Toolbar............ None
Command ...... SCUPDATEDWG
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Update Support Construction Drawings (page 213)

Update a Support Construction drawing with the latest geometry from the model drawings.

SC Support Const > Silent Update Drawing

Menu ............... None
Toolbar............ None
Command ...... -SCUPDATEDWGSILENT
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Update Support Construction Drawings (page 213)

Update a Support Construction drawing with the latest geometry from the model drawings without any further user input.

SC Support Const > Insert Keywords

Menu ............... SC Support Const > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYWORD
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Support Construction Drawing Keywords (page 207)

Inserts keywords into the drawing.

SC Support Const > Update All Keywords

Menu ............... SC Support Const > Update All Keywords
Toolbar............ None
Command ...... SCUPDATEALLKEYWORDS
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Update All Keywords (page 202)

Updates all keywords in paper space in the drawing.



Appendix D: Distributed Systems Production Command Reference

300

SC Support Const > Re-Dimension

Menu ............... SC Support Const > Re-Dimension
Toolbar............ None
Command ...... SCREDIM
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Re-dimension a Support Construction Drawing

Automatically regenerates the dimensions for the support based on the support construction drawing options that can be 
editing in Manager.

Support Construction Drawing Options
The support construction drawing options control the dimensioning of the support construction drawing.

Dimension Style – The AutoCAD dimension style used to dimension the profiles of the support. The dimension styles 
come from General > Production Output > Dimension Styles in Manager.

Dimension Layer Name – A string that is appended of the layer name. The dimension is formed from Horizontal or 
Vertical Tier Layer Prefix + <index of the horizontal or vertical> + Dimension Layer Name + Dimension Direction (Eg. 
H_1_DIMZ)

The index of horizontals is top down with the top being 1.

The index of the verticals is left to right with the left being 1.

Horizontal Tier Dimension Layout – The type of dimension to use.
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Layout Appearance

Continue

Baseline

Ordinate

Horizontal Tier Datum Point Position – The position of the origin of the dimensions for the horizontal tiers.

Horizontal Dimension Offset – The distance from the top of the geometry to the first dimension.

Vertical Tier Dimension Layout – The type of dimension to use.

Vertical Tier Datum Point Position – The position of the origin of the dimensions for the horizontal tiers.

Vertical Dimension Offset – The distance from the top of the geometry to the first dimension.

Horizontal Tier Layer Prefix – The prefix to all horizontal related layers.

Vertical Tier Layer Prefix – The prefix to all horizontal related layers.

Hanger Layer Name – The postfix for the hanger layers. Hangers on the top horizontal profile would be on the Horizontal 
Tier Layer Prefix + 1 + Hanger Layer Name
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SC Support Const > Structure Drawing Options

Menu ............... SC Support Const > Structure Drawing Options

Toolbar............ Structure Display > 
Command ...... SCSTRUCTDISPLAY
Permissions ... None
Procedure....... Structure Options

Displays the structure drawing options.

SC Support Const > Hanger Drawing Options

Menu ............... SC Support Const > Hanger Drawing Options

Toolbar............ Hangers > 
Command ...... SCHANGDWGOPTIONS
Permissions ... None
Procedure....... Display Options for Hangers (page 145)

Displays the hanger drawing options.

SC Support Const > Viewport Options

Menu ............... SC Support Const > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.

SC Support Const > Set Viewport Display Options

Menu ............... SC Support Const > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.

SC Support Const > Insert BOM Table

Menu ............... SC Support Const > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTBOM
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Insert a Support Construction BOM Table (page 208)

Inserts a BOM table.
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SC Support Const > Update BOMs

Menu ............... SC Support Const > Update BOMs
Toolbar............ None
Command ...... SCUPDATEBOMS
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Update BOMs (page 201)

Updates the BOM Table(s).

SC Support Const > Edit Collector Options

Menu ............... SC Support Const > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.

SC Support Const > Toggle list only visible

Menu ............... SC Support Const > Toggle list only visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.

SC Support Const > Label > Manual Label from BOM

Menu ............... SC Assembly > Label > Manual Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELMANUAL
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you manually label parts from a BOM. This is an alternative method to automatic labeling. The label style and text 
contents are used from the selected BOM. The selection of the leader arrow is the pickpoint where you selected the part. 
The number of leader segments follows the label style setting.

This command can be used in conjunction with Copy Label from BOM so complete the labeling. If you select a part that 
has been previously labeled then the previous label is removed.

SC Support Const > Label > Copy Label from BOM

Menu ............... SC Assembly > Label > Copy Label from BOM

Toolbar............ Assembly > 
Command ...... SCLABELCOPY
Permissions ... None
Procedure....... Manual Labeling from BOM (page 198)

Let’s you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of 
the selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label. 
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SC Support Const > Label > Relabel All

Button .............
Ribbon ............ Production tab > Labeling panel > Relabel All
Menu ............... SC Arrangement > Label >Relabel All
Toolbar............ None
Command ...... SCRELABELALL
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Relabel All (page 198)

Generates labels for all new BOM items and places them on the _ANNOTATION layer. 

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.

SC Support Const > Label > Relabel from BOM

Button .............
Ribbon ............ Production tab > Labeling panel > Relabel from BOM
Menu ............... SC Arrangement > Label >Relabel from BOM
Toolbar............ None
Command ...... SCRELABELFROMBOM
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Relabel from a selected BOM (page 198)

Relabels parts from a selected BOM and places them on the _ANNOTATION layer.

Labels are generated only once. Subsequent commands only update the label text to reflect the Bill of Materials.

Even though labels are placed in Paper Space, they now track the objects in Model Space so that if the user pans, zooms, 
or orbits in the viewport, the labels track accordingly and remain synchronized to the objects that they represent.

SC Support Const > Label > Relabel from Parts

Button .............
Ribbon ............ Production tab > Labeling panel > Relabel from Parts
Menu ............... SC Arrangement > Label >Relabel from Parts
Toolbar............ None
Command ...... SCRELABELFROMPARTS
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Relabel from Parts (page 199)

Relabels selected parts from the BOMs.

SC Support Const > Label > Label on Visible Edge On/Off

Button .............
Ribbon ............ Production tab > Labeling panel > Label on Visible Edge On/Off
Menu ............... SC Arrangement > Label > Label on Visible Edge On/Off
Toolbar............ None
Command ...... SCLABELONVISIBLEEDGE
Permissions ... Distributed System Supports > Construction Drawings - Edit 
Procedure....... Label on Visible Edge On/Off (page 199)

Turns labels automatic label generation from label to piecemark to label on visible part edge.
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SC Support Const > Label > Curved Plates in Visible Edge Detection On/Off

Button .............
Ribbon ............ Production tab > Labeling panel > Curved Plates in Visible Edge Detection On/Off
Menu ............... SC Arrangement > Label > Curved Plates in Visible Edge Detection On/Off
Toolbar............ None
Command ...... SCLABELREMOVECURVEDPLATEHLR
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Curved Plates in Visible Edge Detection On/Off (page 199)

Turns on option to include curved plates in hidden line calculation when label on visible part edge is on.

SC Support Const > Label > Adjacent Part Edge Tolerance

Button .............
Ribbon ............ Production tab > Labeling panel > Adjacent Part Edge Tolerance
Menu ............... SC Arrangement > Label > Adjacent Part Edge Tolerance
Toolbar............ None
Command ...... SCLABELADJACENTTOL
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Adjacent Part Edge Tolerance (page 199)

Edges will be less likely to be labeled if they are closer than this distance to an edge of another part.

SC Support Const > Label > Edge Length Filter

Button .............
Ribbon ............ Production tab > Labeling panel > Edge Length Filter
Menu ............... SC Arrangement > Label > Edge Length Filter
Toolbar............ None
Command ...... SCLABELEDGELENGTHFILTER
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Edge Length Filter (page 200)

Edges shorter than this percentage will be filtered out from consideration of being pointed to by the labe.

SC Support Const > Label > Edge Determination Minimum Angle

Button .............
Ribbon ............ Production tab > Labeling panel > Edge Determination Minimum Angle
Menu ............... SC Arrangement > Label > Edge Determination Minimum Angle
Toolbar............ None
Command ...... SCLABELEDGEDETERMINATIONANGLE
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Edge Determination Minimum Angle (page 200)

Line segments will be considered part of the same edge if they are less than this angle away from tangent.
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SC Support Const > Label > Label Reset Automatic Settings

Button .............
Ribbon ............ Production tab > Labeling panel > Label Reset Automatic Settings
Menu ............... SC Arrangement > Label > Label Reset Automatic Settings
Toolbar............ None
Command ...... SCLABELRESETALL
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Label Reset Automatic Settings (page 200)

Resets the automatic label generation settings in the current drawing to use the project settings.

SC Support Const > BOM Revisions > New BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in Current Layout
Menu ............... SC Support Const > BOM Revisions > New BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVNEW
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in the current layout.

SC Support Const > BOM Revisions > New BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > New BOM Revision in All Layouts
Menu ............... SC Support Const > BOM Revisions > New BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVNEWALL
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Add/Edit
Procedure....... New Revision (page 356)

Creates a revision in all layouts.

SC Support Const > BOM Revisions > Delete BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in Current Layout
Menu ............... SC Support Const > BOM Revisions > Delete BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVDEL
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in the current layout.
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SC Support Const > BOM Revisions > Delete BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete BOM Revision in All Layouts
Menu ............... SC Support Const > BOM Revisions > Delete BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVDELALL
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Remove
Procedure....... Delete Revision (page 356)

Deletes the current revision in all layouts.

SC Support Const > BOM Revisions > Delete All BOM Revision in Current Layout

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in Current Layout
Menu ............... SC Support Const > BOM Revisions > Delete All BOM Revision in Current Layout
Toolbar............ None
Command ...... SCPRODREVCLEAR
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in the current layout.

SC Support Const > BOM Revisions > Delete All BOM Revision in All Layouts

Button .............
Ribbon ............ Production tab > BOM Revisions panel > Delete All BOM Revision in All Layouts
Menu ............... SC Support Const > BOM Revisions > Delete All BOM Revision in All Layouts
Toolbar............ None
Command ...... SCPRODREVCLEARALL
Permissions ... Distributed System Supports > DS Support Construction Dwg Revisions – Remove
Procedure....... Delete All Revisions (page 357)

Deletes all revisions in all layouts.

SC Support Const > BOM Revisions > List BOM Revisions

Button .............
Ribbon ............ Production tab > BOM Revisions panel > List BOM Revisions
Menu ............... SC Support Const > BOM Revisions > List BOM Revisions
Toolbar............ None
Command ...... SCPRODREVLIST
Permissions ... None
Procedure....... List Revisions (page 357)

List the information about the revisions in the current layout.
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SC Support Const > Global Dimension to Point

Menu ............... SC Support Const > Global Dimension to Point
Toolbar............ None
Command ...... SCDISTANCEFROMPOINT
Permissions ... Distributed System Supports > Construction Drawings - Edit
Procedure....... Global Dimension to Point (page 357)

Indicates the distance from a given point to a selected plane.

SC Support Const Template Menu
The SC Support Const Template menu appears in Support Construction drawing templates.

SC Support Const Template > Insert Keywords

Menu ............... SC Support Const Template > Insert Keywords
Toolbar............ None
Command ...... SCINSERTKEYW
Permissions ... General - Edit Template Drawings
Procedure....... Support Construction Drawing Keywords (page 207)

Inserts keywords into the drawing.

SC Support Const Template > Structure Drawing Options

Menu ............... SC Support Const Template > Structure Drawing Options

Toolbar............ Structure Display > 
Command ...... SCSTRUCTDISPLAY
Permissions ... None
Procedure....... Structure Options

Displays the structure drawing options.

SC Support Const Template > Hanger Drawing Options

Menu ............... SC Support Const Template > Hanger Drawing Options

Toolbar............ Hangers > 
Command ...... SCHANGDWGOPTIONS
Permissions ... None
Procedure....... Display Options for Hangers (page 145)

Displays the hanger drawing options.

SC Support Const Template > Viewport Options

Menu ............... SC Support Const Template > Viewport Options
Toolbar............ None
Command ...... SCVPORTOPTIONS
Permissions ... None
Procedure....... Viewport Options (page 201)

Display the options for a specific viewport.
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SC Support Const Template > Set Viewport Display Options

Menu ............... SC Support Const Template > Set Viewport Display Options
Toolbar............ None
Command ...... SCVIEWPORTDISPOPTIONS
Permissions ... None
Procedure....... Viewport Display Options (page 202)

Configure the viewport specific display options for a specific viewport.

SC Support Const Template > Insert BOM Table

Menu ............... SC Support Const Template > Insert BOM Table
Toolbar............ None
Command ...... SCINSERTEMPTYBOM
Permissions ... General - Edit Template Drawings
Procedure....... Insert a Support Construction BOM Table (page 208)

Inserts a BOM table.

SC Support Const Template > Edit Collector Options

Menu ............... SC Support Const Template > Edit Collector Options
Toolbar............ None
Command ...... SCTWEAKBOMOPTIONS
Permissions ... General - Edit Template Drawings
Procedure....... Edit BOM Collector Options (page 202)

Allows the user to change the BOM Collector options.

SC Support Const Template > Toggle list only visible

Menu ............... SC Support Const Template > Toggle list only visible
Toolbar............ None
Command ...... SCTOGGLELISTVISIBLE
Permissions ... General - Edit Template Drawings
Procedure....... List only Visible (page 202)

Toggles the variable in the BOM to list only those parts visible or not.
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Appendix E: Distributed Systems Production
Reference

Bill of Materials
The ShipConstructor  Bill of Materials (BOM) includes customizable and convenient functions:

• Management of all production drawing BOMs is performed through a unified interface, the BOM Definitions
manager.

• BOMs have full merging, sorting, and grouping capability – even on hidden columns.

• You have control of object listing order in tables.

• Column heading aliasing. 

• BOM tables use standard AutoCAD tables.

• BOM Functionality is identical regardless of drawing type.

• Consistent item numbering across all sheets.

• Updating without losing formatting.

BOM Functionality Overview
ShipConstructor projects can have any number of user-customizable BOM definitions available for use in target 
production drawing types. As shown in the following diagram, multiple tables can be inserted in a production drawing, 
each referencing a master list.
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One master list exists per BOM definition. The first time a BOM table is inserted in a drawing, its master list is created. 
Subsequent table insertions all reference the initial master list.

BOM content is determined at the time of BOM update. Collectors, specified by the BOM definition, organize the objects in 
the drawing into relevant groups (for example, Pipe, Accessories, and Spools) and process the BOM data into data blocks. 
The data blocks are then compiled into the master list with the tables being updated to reflect the master list data.

The order of the items listed in the BOM depends on primary and secondary factors. The primary order is determined by 
the collector. Each collector provides its own formatted data block. Within each data block, the row order is determined 
by the field sort order specified of the BOM definition.

Collectors process the data for their respective objects according to the format specified by the BOM definition. Therefore, 
each block of collector data is sorted according to the field sort order specified by the BOM definition.

Item numbering is performed on the master list at the time of BOM update. Tables inserted with the List Only Visible
option retrieve their item numbering from the master list to ensure consistent numbering across all sheets. Item numbers 
can have user-defined prefix text (for example, SP–001).

To understand how collector use works, we will use an example: You have a Pipe arrangement drawing that contains 
structure, pipe, and HVAC, and you need two different bills of materials: a pipe stock BOM and spool list.

The pipe stock BOM must list all pipe items, HVAC items, and connection accessories, but not structure. This can be 
achieved by creating two BOM definitions, one for the stocks and one for the spool list.

The stock BOM should list the objects in a specific order: Pipe objects, HVAC objects, Pipe connection accessories, and 
then HVAC connection accessories.
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To create a stock BOM that accomplishes the requirement, a BOM definition is created that includes the following 
collectors: Pipe Part, HVAC Part, Pipe Connection Accessories, and HVAC Connection Accessories. Order them as 
specified above; the BOM lists the items in the order specified

To create the spool list, another BOM definition is created that only includes the pipe spool collector.

Both of these BOMs can exist in the same drawing.

Virtually all other aspects of a BOM can be customized, including the following:

• Items included and their order.

• User-defined column header text.

• Each field can be sorted ascending or descending, in user-defined sequence.

• Rows can be merged dependent or independent of equivalent field data.

• Field properties such as units, display format (decimals or fractions), and rounding can be edited individually.

BOM Definitions Manager
ShipConstructor  integrates all Bill of Materials management through the BOM Definitions manager. The BOM Definitions
manager lets you create and edit existing BOMs for all production drawing types.

Access the BOM Definitions manager through Manager > General > Production Output > Bill of Materials.

Properties and Functions Explained
Broken down into production drawing categories, the BOM Definitions area lets you create and delete definitions and
editing characteristics specific to a BOM.

• Style Name – Name of the BOM definition.

• Title – Title to display on AutoCAD tables.

Note: Only tables using table styles that contain the Title section will display the Title text.

• Acad TableStyle – AutoCAD tablestyle to use for BOM instances. If the specified tablestyle is not found at the time of 
insertion, then the STANDARD style is used.

• Label Style – ShipConstructor label style to use for the BOM. This style can be overridden by the Collector Label Style.
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• Row # prefix text – Precedes item number with text in both table and label.

New
Creates new BOM definitions. 

Default Collectors – If selected, the BOM definition includes reasonable collectors for the current production drawing type. 
You can modify the collectors and their order after creation.

Delete
Deletes the selected BOM definition. If the BOM definition is in use, it cannot be deleted.

Moves selected fields up in the listing order

Moves selected fields down in the listing order.

BOM Fields
Lets you customize aspects of the fields that appear in your BOM:

• Choose which fields to include in the BOM.

• Alias the field names to something appropriate for your company.

• List the order the fields will be displayed in.

• Specify sorting, merging, and visibility of the included fields.

• Specify properties specific to the type of field included, be it a decimal, length, weight, or other type of value. 
Fields with manageable properties are indicated by a white background in the Field Props column.

Add/Remove – Adds or removes production fields or user attribute fields. Production fields are those provided by 
ShipConstructor and that exist in every project. Attribute fields are special fields that are defined by the user for the 
project. All attribute fields are listed, regardless of whether they logically make sense for the BOM definition.

Note: The BOM Labeling procedure extracts the text contained in the first column of the table. (Typically the Item # 
field would be the first field but you could for instance use a field such as ‘Spool Name’, etc.) 

Production Field Description Module Numeric Type

Angle Angle of the stock elbow HVAC, Pipe Angle

Arc Length Length of arc on Bent pipe. Specific to Bending BOM 
only

Pipe Length

Area Area of one side of the part Structure Area

Area with Green Area of the part, including green Structure Area

Assembly The name of the assembly where the part resides HVAC, Pipe, 
Structure

Bend Angle Angle of arc in bent pipe. Specific to Bending BOM only Pipe Length

Bend Radius Radius of bend in bent pipe. Specific to Bending BOM 
only

Pipe Length

Branch The name of the system branch HVAC, Pipe

Catalogs The name of the catalog HVAC, Pipe

Common Name Same as part name for Structural parts, Spools, and 
Assemblies, same as stock for everything else

HVAC, Pipe, 
Structure

Connection The connected item HVAC, Pipe

CPC Catalog 
Number

The catalog number of the part in the Common Parts 
Catalog

HVAC, Pipe, 
Structure

CPC Company CAGE 
Code

The company cage code of the part in the Common 
Parts Catalog

HVAC, Pipe, 
Structure
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Cutback Angle The angle of the elbow fitting, less the 'cutback' 
amount on each end.

Pipe

Drawing The drawing the part is modeled in HVAC, Pipe, 
Structure

End The end treatments for the part HVAC, Pipe

End 1 / Start Green The green length on the first end of the part Pipe, Structure Length

End 2 / End Green The green length on the second end of the part Pipe, Structure Length

End Profiles The end profiles for the part HVAC

Endcut End The name of the endcut standard applied to the 
second end of the part

Structure

Endcut Start The name of the endcut standard applied to the 
starting end of the part

Structure

Finishes All the finishes applied to the part. HVAC, Pipe, 
Structure

Flange Direction The direction in which the flange is facing.  For twisted 
profiles, it is the facing direction at the profile start 
point.

Structure

Fluid Weight The fluid weight of the part. Based on the relative 
density of the system fluid.

Pipe Weight

Full Assembly 
Name

The full path of the assembly in which the part resides HVAC, Pipe, 
Structure

Inner Length Length of straight section on bent pipe. Applies to 
Bending Data BOMs only

Pipe

Insulations All insulation applied to the part HVAC, Pipe

Item # Corresponds to the numbered label in the production 
drawing

HVAC, Pipe, 
Structure

Integer

Item # (alpha-
numeric)

Corresponds to the label in the production drawing HVAC, Pipe, 
Structure

LCG The location of the longitudinal center of gravity HVAC, Pipe, 
Structure

Length

Length The length of the part. This does not include green 
length

HVAC, Pipe, 
Structure

Length

Length with Green The length of the part including green Pipe, Structure

Manufacturer The name of the manufacturer HVAC, Pipe, 
Structure

Mark Side The mark side determines which side of the plate will 
face up when the part is in a nest drawing. The 
displayed directions are determined by the orientation 
of the plate in the model

Structure

Material The primary material the part is composed of. This is 
used for density calculations

HVAC, Pipe, 
Structure

Maximum Extent 
Long

The maximum extent in the longitudinal direction HVAC, Pipe, 
Structure

Length

Maximum Extent 
Trans

The maximum extent in the transverse direction HVAC, Pipe, 
Structure

Length

Maximum Extent 
Vert

The maximum extent in the vertical direction HVAC, Pipe, 
Structure

Length

Minimum Extent 
Long

The minimum extent in the longitudinal direction HVAC, Pipe, 
Structure

Length

Minimum Extent The minimum extent in the transverse direction HVAC, Pipe, Length
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Trans Structure

Minimum Extent 
Vert

The minimum extent in the vertical direction HVAC, Pipe, 
Structure

Length

Mirror Part Name The name of the mirrored part nested on a mirrored 
nest.

Structure

Nest The nest the structure part is in Structure

Nominal Size The name of the nominal size for the pipe part Pipe

Num Vanes The number of vanes for the HVAC part HVAC Integer

OD The outer diameter of the pipe part Pipe Length

Outer Length The outer length of the bend (straight length + tangent 
to corners). Specific to Bending Data BOMs.

Pipe Length

Parent Assembly 
Name

The name of the parent assembly for the assembly in 
which the part resides

HVAC, Pipe, 
Structure

Part Name The name of the part HVAC, Pipe, 
Structure

Part Side The side of the ship in which the structure part lies (P, 
S, C)

Structure

Piece Type The type of part HVAC, Pipe, 
Structure

Pipe/Duct Length Same as ‘Length’ field, but N/A for all other parts other 
than HVAC and Pipe

HVAC, Pipe Length

Plot Dwg The drawing in which the profile is plotted. Structure

Plot Sheet The sheet on which the profile is plotted. Structure

Position The position on the line. Pipe

Profile Chord 
Length

The chord length for the profile part Structure Length

Quantity The number of parts HVAC, Pipe, 
Structure

Integer

Radius The radius of the HVAC or Pipe part elbow curvature HVAC, Pipe Length

Rank The Rank (Assembly level) of the part HVAC, Pipe, 
Structure

Rotation The rotation about centerline of the pipe. Specific to 
Bending Data BOMs

Pipe

Schedule The schedule of the pipe Pipe

Sheet Stock The name of the sheet stock used for the part HVAC

Short Assembly 
Name

The name of the assembly and parent assembly in 
which the part resides

HVAC, Pipe, 
Structure

Spec Name The name of the specification Pipe

Spool Name The name of the spool HVAC, Pipe

Spool UDA User Defined Attributes of the spool HVAC, Pipe

Stock Description The description of the stock HVAC, Pipe, 
Structure

Stock Name The name of the stock HVAC, Pipe, 
Structure

Surface Area The total surface area of the part Structure Area

System The name of the system HVAC, Pipe

TCG The location of the transverse center of gravity HVAC, Pipe, Length
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Structure

Merging Rows 
Rows with common field values can be merged. There are only two requirement for two rows to be merged:

1. The rows must be produced by the same Collector.

2. For each field where Merge Identical has been set to Yes, the row must have the same value as the one above. 

Fields that are not marked as Merge Identical are merged appropriately e.g. Total Length is summed, quantities are 
summed, etc. Where values differ in merged cells, the value “Varies” will be displayed.

There is one exception to the rule of summation however, and this is for the ‘Length’ field. It is not summed so that the 
BOM can produce output like:

Item # Quantity Length Stock Name

4 6 48-5/16” P-SM-CS_00.75_40_A53-B

Where each of the six pipes is 48-5/16” long. Use the “Total Length” field (and Alias the name to your company 
standards) if you need to sum the lengths of the objects.

Merging Columns
It is sometimes necessary to show information that is contained in different locations within objects, in the same cell. For 
instance,  an Assembly Bill of Materials may list assemblies, spools, structure parts, pipe parts, etc.. Rather than 
displaying multiple columns to display the relevant name information, you can merge the data into the same column, 
thereby reducing the total number of columns displayed in the BOM table.

In order to merge the columns, the columns must:

• Have the same Field Alias. Rename the field alias from the default to the required name.

• Be consecutively ordered within the BOM definition

• Contain mutually exclusive data. i.e. only one of the fields will return data. If more than one field returns values, 
then ‘varies’ will be displayed in the cell.

Collectors
Collectors are responsible for gathering objects in a drawing to be included in a BOM and then processing the object data 
for display in the BOM.

Note: Collector order is important because each collector returns information specific to the objects it collects. 
Resultant information for each collector is then compiled in the order specified by the BOM definition.

Collectors are specific for each production drawing type. The following table lists the collectors available per drawing type.

Collector Availability per Drawing Type
Module Production Drawing Type Collectors
General Assembly Assembly, Standard Assembly, Structure Part, Equipment Part, Pipe 

Spool, Pipe Part, HVAC Spool, HVAC Part, Penetration Component, 
Pipe Hanger, Distributed System Supports, General Part, Pipe 
Connection Accessories, HVAC Connection Accessories, Pipe 
Hanger Accessories, Penetration Accessories, All Accessories

Structure Approval To be determined

Nest Plate Nest

Profile Plot Profile Plot
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Pipe Pipe Spool Pipe Part, Pipe Cutlist, Penetration Component, Global Point, 
Corner Point, Pipe Connection Accessories, Penetration 
Accessories, All Accessories

Bending Tables Bending Info

Pipe Arrangement Assembly, Standard Assembly, Structure Part, Equipment Part, Pipe 
Spool, Pipe Part, HVAC Spool, HVAC Part, Penetration Component, 
Pipe Hanger, Distributed System Supports, General Part, Pipe 
Connection Accessories, HVAC Connection Accessories, Pipe 
Hanger Accessories, Penetration Accessories, All Accessories

Support Construction Structure Part, Pipe Hanger, Pipe Hanger Accessories, All 
Accessories

HVAC HVAC Spool HVAC Part, HVAC Cutlist, Penetration Component, HVAC Connection 
Accessories, Penetration Accessories, All Accessories

HVAC Arrangement Assembly, Standard Assembly, Structure Part, Equipment Part, Pipe 
Spool, Pipe Part, HVAC Spool, HVAC Part, Penetration Component, 
Pipe Hanger, Distributed System Supports, General Part, Pipe 
Connection Accessories, HVAC Connection Accessories, Pipe 
Hanger Accessories, Penetration Accessories, All Accessories

Equipment Equipment Arrangement Assembly, Standard Assembly, Structure Part, Equipment Part, Pipe 
Spool, Pipe Part, HVAC Spool, HVAC Part, Penetration Component, 
Pipe Hanger, Distributed System Supports, General Part, Pipe 
Connection Accessories, HVAC Connection Accessories, Pipe 
Hanger Accessories, Penetration Accessories, All Accessories

Collector Functionality
The following table lists the collectors and their functions. 

Collector Description Additional Functionality
Assembly Organizes objects into primary production 

strategy assemblies. 

Returns information for each of the first level 
subassemblies. Main assembly and children of 
the subassemblies are not reported.

Include Standard Assemblies – if checked 
this will collect parts in standard 
assemblies 

Filter Only – Allows the collector to collect, 
but not display the items in the BOM. 
Useful if you want to only include items 
directly within the Assembly and not from 
sub assemblies.

Standard Assembly Collects all parts that are part of standard 
assemblies.

Structure Part Finds and returns information for all structure 
parts.

Collector Options let you select the Part 
Types to collect.

CorrugatedPlate, CurvedPlate, Extrusion, 
Penetration Components, Plank, Plate, 
TwistedExtrusion

Equipment Part Finds and returns information for all equipment 
parts.

Pipe Part Finds and returns information for all pipe parts. Lets you specify the type and spool status 
of the objects listed in the BOM.

Pipe Connection 
Accessories

Queries all pipe-pipe connections and retrieves 
accessory package information from them.

Pipe Spool Gathers all Pipe objects and organizes them into 
their spools. Returns information for each spool.

HVAC Part Finds and returns information for all HVAC parts. Lets you specify the type and spool status 
of the objects listed in the BOM.
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HVAC Connection 
Accessories

Queries all HVAC- HVAC connections and 
retrieves accessory package information from 
them.

HVAC Spool Gathers all HVAC objects and organizes them 
into their spools. Returns information for each 
spool.

Penetration 
Accessories

Queries all penetrations in the drawing and 
retrieves accessory package information from 
them.

Penetration 
Component

Gathers all Penetration component parts and 
reports information for the items contained in 
each.

Pipe Hanger Find and returns information for all Pipe Hanger 
parts.

Lets you choose from all the hanger part 
types

Pipe Hanger 
Accessories

Queries all Pipe Hangers and retrieves accessory 
package information from them.

General Part Collects all parts and returns part level 
information for each.

Warning: The general part collector can take 
a significant amount of time to process data 
on larger projects.

Nest Finds and returns all objects in a Nest drawing 
specific to a particular nest.

Profile Plot Collects all objects in a Profile Plot drawing 
specific to a particular nest.

Global Point Collects free ends of Piping for listing: the 
distance to nearest planar group in the three 
primary directions, and the connectivity of the 
free end.

Cannot currently: include other fields or 
change column ordering. Typically links* to 
Corner Point BOM in order to maintain 
consistent item numbering.

Corner Point Lists the end positions and change of direction 
points within a run of pipe in pipe coordinates.

Cannot currently: include other fields or 
change column ordering. Typically links* to 
Global Point BOM in order to maintain 
consistent item numbering.

Bending Info Lists information necessary to cut and bend pipe Typically links* to Cutlist BOM in order to 
maintain consistent item numbering.

Distributed System
Supports

Collects all parts that are part of supports. This 
only included profiles and plates and not the pipe 
hangers.

All Accessories Collects all the different types of accessories

* Linked BOMs are BOMs that are placed independently yet share a common set of item numbering. See Linked BOMs 
section for more information.

Creating a New BOM Definition
Utilizing the BOM Definition Manager, you can manage all the Bill of Material for your project. To create a new BOM:

1. Select the drawing type for which the BOM is intended.

2. Optionally, check the Default Collectors checkbox so that a reasonable subset of Collectors (page 317) is included in 
when you create your BOM.

3. Press the New button.

4. Set the properties for the BOM in the BOM definition grid. 
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5. Choose and order the Collectors (page 317) that are appropriate for your BOM.

6. Add BOM Fields (page 314) by pressing the Add/Remove button. You can choose from a predefined set of 
production fields or choose from any of the user-defined attributes that have been added to your project.

Note: You can modify BOM definitions after they are in use and they will be updated the next time a BOM update is 
performed. 

Insert Empty BOM Wizard
The BOM Definition Wizard is used for inserting instances of a particular BOM into a drawing. Multiple tables can be 
inserted into a single drawing.

1. Step 1 of the wizard lets you specify which BOM definition you want to insert in the BOM. The interface is similar to 
the BOM Definitions window; however, it is a read-only view for selection purposes. Select a BOM definition to 
advance to the next page.

2. Step 2 lets you select BOM types. BOM functionality depends on the production drawing type. All drawing types 
except for Nest and Profile plots require that the BOM be inserted in paper space only. Nest and Profile Plots are 
inserted in model space only.
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Table Options
Specify the physical table properties:

• Column width – the initial column width of the table. You can easily adjust the widths afterwards.

• Row height – Default number of lines per row of table. Actual height varies with table style and text style.

• Maximum number of rows per table – any non-zero value will cause additional tables to be populated in the direction 
specified by the wrap property below. 

Column width
All rows generated by the collectors are compiled into the BOM data master set. You can control the items listed in the 
BOM by choosing one of the two options:

• List All – Lists all items in the compiled master BOM.

• List Only Visible – Items displayed in the BOM will be based on objects’ viewport visibility. Items that are visible in 
any of the viewports within the layout will be listed. Object layer visibility and viewport clipping are respected.

The numbering of items remains consistent across all layouts regardless of whether List All or List only visible is chosen.

Wrap Properties – Choices are enabled when a value greater than zero is entered in the Maximum number of rows per 
table field.

• Table wrap direction – Direction that new tables should be added.

• Spacing – Space between newly created tables.

Label Options

The labeling procedure works in conjunction with the BOM. Only objects that are referenced by a particular BOM are 
labeled. Label text is retrieved from the column specified by the BOM definition.

The label style used for labeling is defined in the BOM definition. You can specify one main one for the BOM definition 
and one for each collector. The collector label style overrides the BOM definition label style if one is specified.
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ShipConstructor marks viewports that you select with AutoCAD xdata. Once selected, the objects in the viewport will be 
labeled every time the SCRELABELALL,  SCRELABEL, SCRELABELFROMBOM command is run. You can manage selected 
viewports in two ways:

• Using the BOM Definitions Wizard

a. Select viewports – choose the viewports that you want to be labeled.

b. Highlight selected – Highlights  viewports currently selected for labeling.

• Using the SCVPORTOPTIONS command

• Min leader length -The minimum leader length used when labeling in the layout’s paper units. This value is stored on 
a per layout basis. 

Manual Label from BOM
Let’s you manually label parts from a BOM. This is an alternative method to automatic labeling. The label style and text 
contents are used from the selected BOM. The selection of the leader arrow is the pickpoint where you selected the part. 
The number of leader segments follows the label style setting.

This command can be used in conjunction with Copy Label from BOM so complete the labeling. If you select a part that 
has been previously labeled then the previous label is removed.

Copy Label from BOM
Lets you create labels that are copies of an existing label with the contents changed to reflect the first BOM column of the 
selected part. The copied label will be created with the label text and styles from the BOM table and geometry 
information from the source label. 

Bending Data – XML Output
ShipConstructor can export XML bending data for pipes. XML was chosen as the primary intermediary for export because 
its format can be verified against a schema, the ability of translation through XSLT, and simply because there are a great 
number of readers that are able to parse XML (such as Excel).

Two target formats are currently supported for Bending information: Raw, and Formatted. The information that is 
contained within the files is listed as follows:  Part name, 

Raw
Raw indicates that the information is in its most native form. The information is highly normalized and is presented in 
millimeter length units and degrees angular units. The information is prepared and validated against schema that is 
installed in the install directory in the following path: \XMLSchemas\Output\Piping\ SC_PipeBendingDataV2011.1.xsd.

The following diagram shows the primary schema definition for the Raw bending data:



Appendix E: Distributed Systems Production Reference

323

Pipe Bending Data schema outline
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Schema - Arc segment node Schema - Straight segment node

Formatted
This form of XML is different than the Raw format in that the information is flattened, and therefore imports easier into 
programs such Microsoft Excel. The data is also converted into the destination units of choice by editing a settings XML 
file.

The schema file is located in the install directory in the following path: \XMLSchemas\Output\Piping\
SC_PipeBendingData_FlattenedV2011.1.xsd. The formatted xml is the result of an XSLT transformation that is applied by 
MappingSC_PipeBendingData_FlattenedV2011_1.xslt and the input file SC_PipeBendingData_FormattingV2011.1.xml.

The following shows the schema diagram for the Formatted (flattened) file:
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Excel Import
The information from the flattened file can be imported into Excel easily by using the Data import feature. The following 
example uses Excel 2007 to import a sample flattened file into Excel.
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1. From the Data ribbon, choose the “From Other Sources” droplist and then select the “From XML Data Import” 
option.

2. Select the sheet and cell for the origin of the top left most portion of the tabular data.

3. The data is imported in columnar fashion however it is likely randomly ordered. To order the data you will 
specify a custom sort based on at least two columns. For this example, the data will be ordered on Name and 
Segment number, in that order. The order is important because the data must first be grouped a field that 
unites all segments from one item. Then an ascending sort is applied to the Segment Number field.

The data should now be ordered according to pipe name and the segment number.

Choosing Pipes for XML Data Generation
To choose the pipes that are required for XML data generation, run the SCPIPEEXPORTBENDINGDATA command.

The select pipes window is presented where you can choose pipes based on drawing, system, and assembly. Choose the 
output type: raw or formatted, and also choose the file location. The file name is automatically generated and a 
time/date stamp is appended to the name. 
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Once you are satisfied with the selected pipes, the file name, and the output type, choose OK and the XML file will be 
generated.

Bend Information and Location Tables
The information available in Spool drawings for bending tables consists of Bending Information, End/Corner Point 
Locations, and Global Point/Connectivity. The latter two BOMs comprise what is termed Location Tables.

The following diagram shows the arrangement in the Spool location of the BOM Definition Manager

The BOMs that define these created almost like others except the fields and Collectors are not selectable, but are chosen 
automatically when the BOM Definition is first created. In the above image, each of the items with the icon is a BOM 
definition and the other nodes are just grouping nodes.

Corner Point
The Corner Point BOM is comprised of the Corner Point Collector and two fields: Item # (alpha numeric) and Position. The 
position field is broken out as X, Y, and Z coordinates in the BOM table. 

The X, Y, and Z values are converted to a spool coordinate system that is defined as follows: the first pipe is aligned with 
the x-axis, and the z-axis is as close to the WCS z-axis as possible, while maintaining an orthogonal coordinate system.

The origin is determined to be closest to the ship coordinate system origin sorted first by x distance, then y, and then z.
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There is always one main run labeled “Main A-B” and any branch lines are labeled “Br 1”, “Br 2”, etc 

Points listed are: end points, corner points, and branch points.

Global Position
The Global Position BOM is comprised of the Global Point collector and three fields: Item # (alpha numeric), Location and 
Connection. Location lists the distance to the closest planar groups, similar to the Global Distance to point function. There
are currently no options to override this behavior. Connection lists the spool name of the connected item.

The Global Position BOM is automatically linked to the Corner Point BOM so that the item numbers coincide.

Bending Tables
The Bending Information BOM is comprised of Bending Info Collector and six fields: Item # (alpha numeric), Outer Length, 
Inner Length, Rotation, Bend Radius, and Bend Angle.

The Bending Info Collector only collects straight and bent pipes, just like the Cutlist Collector. In fact since the items in
both the Cutlist BOM and the Bending Info BOM are identical, the BOMs are automatically linked so that the item 
numbers coincide. The ordering is determined by that specified in the Cutlist BOM. 

The bending fields are defined as follows:

Inner Length - the length of any straight section of pipe

Outer Length – the length from end to corner (bent end-axis intersection point) or corner to corner

Rotation – the rotation, about the previous straight run axis, that is required before the next bend can be applied.

Bend Radius – The centerline radius of the bend

Bend Angle – The angle of the bend.

Bending and Location Tables Example
The bent pipe in the following image produces the tables that follow:
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Spool Manager Reference
In ShipConstructor, you no longer need to click a refresh button to refresh all lists. Spool Manager dynamically refreshes. 
If you have the Spool Manager open while modeling and you add a part to the drawing, it appears in the Spool Manager
as soon as you finish adding it. If you are in an HVAC drawing, choosing SC HVAC > Spools > Spool Manager opens the 
HVAC Spool Manager. If you are in a Pipe drawing, choosing SC Pipe > Spools > Spool Manager opens the Pipe Spool 
Manager. You must save the drawing first in order to open the spool manager.
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Undefined Spools 
This is where groups of interconnected parts reside that are waiting to be defined. Each grouping of parts will list all the 
individual parts that are contained within the grouping.



Appendix E: Distributed Systems Production Reference

331

Defined Spools 
This is where defined and approved spools reside.

• Lock Icon – Appears next to a spool when the spool is locked against modification.

• Unlock Icon – Appears when a spool is unlocked.

• Spool Icon – Appears when the spool does not have a drawing associated with it.

• Drawing Icon – Appears when the spool has a drawing associated with it.

No Spool 
This is where all parts that are defined as No Spool in the drawing reside.

Modified Spools 
This is where all the modified spools that are pending approval reside. When a spool is just created, it resides in the 
modified spools category because it still needs approval.

Empty Spools
This is where all the spools that have been create and had all the parts in it deleted. They are separated for ease of 
viewing. These can be treated much the same as modified spools, but are usually just undefined to free up the spool 
name.

Spool Break
A spool break is a break in the logical grouping of a run of ducts. This makes it possible for you to spool pieces of a 
system that are still connected together. 

• Add – Adds a spool break. When clicked, the Spool Manager minimizes and lets you select all the connections that
you want a spool break added for.

• Remove – Removes a spool break. When clicked, the Spool Manager minimizes and lets you select all the 
connections that you want a spool break removed from.

Override Colors
This is where you can override the color settings while the Spool Manager is open. Changing color settings helps you 
visualize which parts are Undefined, Defined, Locked, No Spool, and Modified. 

To override the colors

1. Check the Override Colors check box.

2. Select a category from the drop-down list. For example, select Modified.

3. Click on the color picker (…) directly below the drop-down list and select a color. For example, if you selected 
Modified in the previous step, the color selected here will change the color of all parts that are in the Modified Spools
category.

4. Repeat Steps 2 and 3 for all the categories you want to override colors for.

View
When any of these options are checked, if you double-click on a spool, an undefined spool group, or any part, the view will 
change according to the options checked and what was double-clicked on. For example, if the Zoom and Center view 
options are checked and you double-click on a spool, the view in the model drawing will be zoomed and centered on that 
spool.

Done
Closes the Spool Manager.

Properties
This button lets you toggle whether you see the properties or not. The properties will dynamically update depending on 
what you have selected in the tree above.

Spool Properties:
1. Naming Convention – The naming convention used to generate the spool’s current name. To change the naming 

convention, click on the dropdown control and select a new naming convention in the list. The first available 
name using the new naming convention will be assigned to the spool.
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2. Spool Name – The name of the spool. To change the spool name, click on the button (…) beside the spool name. 
(You may have to click on the spool name itself in order to see the button.) A list appears with some possible 
names. Select a new name and click OK. 

3. Is Locked – The icon that appears here tells you whether or not the spool is locked. To change the lock status 
here, click on the button (…) beside the icon. (You may have to click on the icon to see the button.)

4. Hierarchy – The hierarchy level of the spool. To change the hierarchy level of the spool, click on the button (…) 
beside the hierarchy level. (You may have to click on the hierarchy level to see the button.) A hierarchy tree 
appears. Select a new hierarchy level and click OK. If your spool name depends on your spool’s hierarchy level, 
you may want to re-name your spool.

5. Finishes – All the finishes that are applied to the spool. To change the finishes for the spool, click on the (…) 
button beside the finishes list. (You may have to click on the finishes list to see the button.) The select finishes 
window appears. Change the finishes for the spool and click OK. See Finishes Reference (page 269).

6. Insulation – All the insulation that are applied to the spool. To change the insulation for the spool, click on the 
(…) button beside the insulation list. (You may have to click on the insulation list to see the button.) The select 
insulation window appears. Change the insulation for the spool and click OK. See Insulation Reference (page 
268).

7. Revision History – Shows the last revision made to the spool. To see all the revisions made to the spool click the 
(…) button beside the last revision. (You may have to click on the last revision in order to see the button.) A 
window appears showing all the revisions made to the spool in descending order. If a spool has recently been 
created, the last revision in the properties shows Created and the revision list window does not appear.

8. User Defined Attributes – Any user defined attributes that have been assigned to this spool type, will show up 
after the Revision History property. To change the value, simply click inside the cell and change the text.

Part Properties:
1. Part Name – The name of the part.

2. Stock Name – The name of the stock that the part was created from.

3. Stock Description – A description of the stock that the part was created from.

Right-Click Menu for the Spool Manager
There are many small right-click menus for the Spool Manager that are each based on what you have selected.

Undefined Spools Category Menu
1. Define All – Changes all the undefined spool groups into defined spools (see Define and Undefine a Spool (page 

133)).

2. Expand All – Expands all the nodes in the tree beneath this category.

3. Collapse All – Collapses all the nodes to the undefined spool group level.

Undefined Spool Menu
1. Define Spool – Defines the spool (see Define and Undefine a Spool (page 133)).

Undefined Part Menu
1. Set No Spool Part – Sets the undefined part to a no-spool part (see No-Spool Items (page 130)).

Defined Spools Category Menu
1. Expand All – Expands all the nodes in the tree beneath this category.

2. Collapse All – Collapses all the nodes to the defined spool level.

Defined Spool Menu
1. Lock Spool (Only available if spool is unlocked.) – Locks the spool (see Lock and Unlock Spools (page 135)).

2. Unlock Spool (Only available if spool is locked.) – Unlocks the spool (see Lock and Unlock Spools (page 135)).

3. Undefine Spool (Only available if spool is unlocked.) – Undefines this spool (see Define and Undefine a Spool (page 
133)).
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Defined Part Menu
1. Set No Spool Part (Only available if spool is unlocked.) – Sets the part to a no-spool part (see No-Spool Items (page 

130)).

No Spool Category Menu
1. Expand All – Expands all the nodes in the tree beneath this category.

2. Collapse All – Collapses all the nodes to the part category level.

No Spool Part Menu
1. Undefine Part – Undefines the no-spool part. That is, make the part a normal, undefined part (see No-Spool Items

(page 130)).

Modified Spools Category Menu
1. Approve All – Approves all the modified spools (see Approve a Spool (page 134)).

2. Expand All – Expands all the nodes in the tree beneath this category.

3. Collapse All – Collapses all the nodes to the spool level.

Modified Spool Menu
1. Approve Spool – Approves the spool (see Approve a Spool (page 134)).

2. Undefine Spool – Undefines the spool (see Define and Undefine a Spool (page 133)).

Modified Part Menu
1. Set No Spool Part – Sets the part to a no-spool part (see No-Spool Items (page 130)).

Empty Spool Menu 
1. Approve Spool – Approves the spool (see Approve a Spool (page 134)).

2. Undefine Spool – Undefines the spool (see Define and Undefine a Spool (page 133)).

Drag and Drop Feature for the Spool Manager
The Spool Manager has a drag-and-drop feature for defining, undefining, and setting no-spool parts. 

To define a spool

Drag an undefined spool into the Defined Spools category box.

To undefine a spool

Drag a spool into the Undefined Spools category box.

To set a no-spool part

Drag a part into the No Spool category box.

To undefine a no-spool part

Drag a no-spool part into the Undefined Spools category box.

Spool Properties Reference
The Spool Properties window appears when you are defining one or more spools.
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Hierarchy Tree
On the left hand side of the window is a hierarchy tree. This is where you pick which hierarchy level you want the spool to 
go to.

Spool Name
The list of naming conventions defined for spools are listed. If the selected naming convention uses a hierarchy level as 
one of its elements, the first available name will update for you when you select different hierarchy levels. If you un-check 
the Use next available starting at… check box, the Pick Name… button is enabled. By clicking Pick Name…, you can 
choose from a list of available names. The name that you select appears in the spool name label. If you leave the Use 
next available starting at… check box then you may chose the number to be used when generating the spool name.
Changing the selected naming convention will update the preview name.
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The dialog that appears after clicking the Pick Name… button give you a list of available spool names to select.  You can 
alter the range of the displayed spool names by entering values in the text boxes. The Start At field allows you to chose 
where the list starts. If the number chosen is not available, then the list will start at the next available spool after the 
number chosen. The Number of Names field allows the user to specify the length of the displayed list. After those values 
are chosen click the Get Names button to generate the names from the entered fields. After highlighting a name in the 
list, you can click OK to use that name. Checking the Remember Range check box and clicking OK will save the value of 
the fields for the next time the dialog is shown. 

Note: Remember Range is an option because generating a list of names with a high starting value or high number of 
names can take a long time.

Spool Finishes
This is a list of finishes that will be applied to the spool. To change the finishes for the spool, click the ‘…’ button that 
appears when in the cell. The Select Finishes window appears letting you select finishes for the spool. See Finishes 
Reference (page 269). 

Spool Insulation
This is a list of insulation that will be applied to the spool. To change the insulation for the spool, click the ‘…’ button that 
appears when inside the cell. The Select Insulation window appears letting you select insulation for the spool. See 
Insulation Reference (page 268). 

User Defined Attributes
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Every user defined attribute that is assigned to this spool type is listed here. If the user defined attribute is required, a ‘*’ 
will appear next to the attribute name to indicate that it is required to have a value. Edit the values simply by clicking 
inside the cell and typing.

Set From Part
This button allows the user to assign where in the product hierarchy the spool goes by choosing any part or structure 
that’s already assigned to an assembly from within the drawing.

Keywords Reference
Depending on the type of drawing, depends on which lists of keywords are available. For instance, the HVAC Spool 
Drawing keyword list is made up of general ShipConstructor keywords, general spool keywords, and HVAC spool specific
keywords.

Below is a table listing the keywords available, where they are available, and a short description of what they are.

Keyword Name Type Description

<COMPANY NAME> General The name of the company setup in Project Settings

<FILE NAME> General The name of the current file.

<FILEPATH> General The path of the current drawing.

<HULL NUMBER> General The Hull number setup in Project Settings.

<JOB NUMBER> General The Job Number setup in Project Settings.

<LAST UPDATE DATE AND TIME> General The date and time when the keyword was last updated.

<LAST UPDATE DATE> General The date when the keyword was last updated.

<PROJECT DESCRIPTION> General The Project Description setup in the Project Settings.

<PROJECT NAME> General The Project Name setup in the Project Settings.

<USER> General The User logged in that either created or updated the 
drawing.

<SPOOL ASSEMBLY> Spool The immediate assembly level of the spool

<SPOOL BRANCH> Spool The Branch of the system the spool belongs to.

<SPOOL CG> Spool The Center of Gravity point of the spool.

<SPOOL FINISHES> Spool The finishes assigned to the spool.

<SPOOL FULL ASSEMBLY NAME> Spool The entire assembly chain from the project down to the 
spool’s assembly.

<SPOOL FULL SYSTEM> Spool The Spec / System / Branch of the spool.

<SPOOL LCG> Spool The longitudinal component of the Center of Gravity point of 
the spool.

<SPOOL NAME> Spool The Name of the spool.

<SPOOL PROPERTIES> Spool The Rank, immediate assembly, weight, center of gravity 
point, and finishes.

<SPOOL SHORT ASSEMBLY NAME> Spool The spool assembly and it’s direct parent assembly.
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<SPOOL SYSTEM> Spool The System that the spool belongs to. See Spool Branch 
keyword for the Systems’ branch.

<SPOOL TCG> Spool The Transversal component of the Center of Gravity point of 
the spool.

<SPOOL VCG> Spool The Vertical component of the Center of Gravity point of the 
spool.

<SPOOL WEIGHT> Spool The total weight of the spool.

<SPOOL UDA> Spool User Defined Attributes of the spool, one keyword for each 
UDA

<HVAC SPOOL AIR FLOW> HVAC Spool The air flow of the system that the spool belongs to.

<PIPE SPOOL CLASS> Pipe Spool The class of the system that the spool belongs to.

<PIPE SPOOL RELATIVE DENSITY> Pipe Spool The relative density of the system that the spool belongs to.

<PIPE SPOOL TEST METHOD> Pipe Spool The Test method of the system that the spool belongs to.

<PIPE SPOOL TEST PRESSURE> Pipe Spool The Test pressure of the system that the system belongs to.

<ASSEMBLY CG> Assembly The Center of Gravity of the assembly.

<ASSEMBLY DESCRIPTION 1> Assembly The Description1 User Defined Attribute of the assembly.

<ASSEMBLY DESCRIPTION 2> Assembly The Description1 User Defined Attribute of the assembly

<ASSEMBLY LCG> Assembly The Longitudinal component of the Center of Gravity point 
of the assembly.

<ASSEMBLY LEVEL> Assembly The rank(level) name of the assembly.

<ASSEMBLY NAME> Assembly The name of the assembly.

<ASSEMBLY PROPERTIES> Assembly The rank name, weight, center of gravity point, and finishes 
of the assembly.

<ASSEMBLY TCG> Assembly The Transversal component of the Center of Gravity point of 
the assembly.

<ASSEMBLY VCG> Assembly The Vertical component of the Center of Gravity point of the 
assembly.

<ASSEMBLY WEIGHT> Assembly The total weight of the assembly.

<FULL ASSEMBLY NAME> Assembly The full path of the assembly tree that this assembly 
belongs to.

<LEVEL X ASSEMBLY NAME> Assembly X represents each rank level. These keywords produce an 
assembly name at the assigned level based on the path of 
the current assembly. As an example, a rank named UNIT 
would produce the keyword called <LEVEL UNIT ASSEMBLY 
NAME>. If an assembly was part of U01 which had a rank 
level of UNIT, the keyword would produce U01.

<SHORT ASSEMBLY NAME> Assembly The name of the assembly and it’s direct parent.

<ASSEMBLY UDA> Assembly User Defined Attributes of the Assembly, one keyword for 
each UDA

<Support CG> Support 
Construction

The Center of Gravity of the support.

<Support Full Assembly Name> Support 
Construction

The full name of the assembly that the support is assigned 
to, in the primary product hierarchy.
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<Support LCG> Support 
Construction

The Longitudinal component of the Center of Gravity point 
of the support.

<Support Name> Support 
Construction

The name of the support.

<Support TCG> Support 
Construction

The Transversal component of the Center of Gravity point of 
the support.

<Support Template Type> Support 
Construction

The template type of the support.

<Support Template> Support 
Construction

The template name of the support.

<Support VCG> Support 
Construction

The Vertical component of the Center of Gravity point of the 
support.

<Support Weight> Support 
Construction

The combined weight of all the component parts for a 
support.

To insert keywords, you must be in paper space.

Keywords
The list of available keywords to place in the HVAC spool template drawing.

Text Style
The selected text style for the keywords selected under Keywords. This is a list of available text styles from within the 
drawing. If you created more text styles using AutoCAD for this drawing, the text styles you created appear in this list.
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Text Size
The size of the text. 

Rotation
The rotation of the text.

Note: If a keyword does not seem to update when you have created your spool drawing, your project settings may not 
be fully set up. For example, if you chose <JOB NUMBER> as one of your keywords, and this keyword still shows the 
same text as the template in your generated spool drawing, this means that the project settings for the job number 
have not yet been set. To complete the settings, go to Manager > General > Project Settings.

You can update specific keywords manually by selecting a keyword, right-clicking, and selecting Update from the right-
click menu. 

There are numerous options associated with keywords that are accessible through the OPM. You can now pre and post 
append text to a keyword, and change the display properties of  keyword with ease.

Create Spool Drawing Wizard Reference
The Create Spool Drawing wizard is a tool for generating spool drawings.



Appendix E: Distributed Systems Production Reference

340

The first page of the wizard is where you select your HVAC spool template drawing.

The second page of the wizard is where you select all the spools that you want to generate spool drawings for. You can 
select spools by navigating through your HVAC drawing, systems, or assemblies. A list of all the spools selected is shown 
on the right side under Selected Sources. 
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The last page of the wizard is where you select which spool style to use. Select a spool style under Spool Styles. When a 
spool style is selected, the properties of the style are shown under Spool Style Properties.

If there are no spool styles defined and you have permission to create one, click on the Edit Styles button to create a 
spool style. See Spool Styles Reference (page 341) for more details.

Note: Baseline Dimensioning is not yet implemented in ShipConstructor.

Spool Styles Reference
Spool styles are used in the dimensioning and labeling of spools.

Note: If you do not have permission to edit spool settings, the window controls are disabled, and the title bar displays
READ ONLY.
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Spool Styles
The list of spool styles. When you click on a spool style in the list, the properties are updated to reflect the properties of 
the selected spool style. 

New
Click this button to create a new spool style.

Delete
Click this button to delete the selected spool style.

ARS and Penetration Label Style
• Label Offset – The label offset in millimeters used for penetration labels and ARS labels.

• Label Style – The label style used for penetration labels and ARS labels. This list is generated from the label styles 
set up in Manager.

ARS Label
• Angle – When checked the ARS label will display the angle of the corner.

• Radius – When checked the ARS label will display the radius of the corner.

• Arc Length – When checked the ARS label will display the arc length of the corner

• Label Non-Cutback Elbows – When checked the ARS label will display the arc length of the corner

Penetrations
• Show Penetrations – When checked penetrations will be marked in the drawing. 

Note: All penetrations will be marked in the spool drawing if selected but only watertight component parts will be 
displayed in the drawing and BOM’s.

Note: For watertight penetrations with component parts, the penetration mark will be placed on the penetrator 
where the component part and the penetrator intersect.

CG Point 
• Display CG Point – When checked a point will be drawn indicating the center of gravity for the spool.
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Dimensioning
• Baseline Dimensioning – Not used at this time.

• Break Dimension at Branches – When checked, will break the dimensions at branch points of fittings.

• Break Dimension at Connections – When checked, will break the dimensions at connections.

• Break Dimension at Saddles – When checked, will break connections at saddles.

• Dimension Offset – The offset of the dimension from the part’s centerline.

Dimensions generated along a run of Pipe. The offset as well as each break type are shown. 

• Dimension Style – The style of the dimension used. This list is generated from the dimension style names that are 
set up in Manager. If you have set up a dimension style in your template drawing that you want to use, make sure 
the name is set up in Manager under Dimension Styles.

• Orientation – The orientation selection of the dimensions.

• Ship Coordinate System – Aligned to the world coordinate system.

• Best Fit – ShipConstructor determines the most appropriate coordinate system to align the dimensions to.

• UCS – Orients the dimensions to the coordinate system stored in the named UCS Spool. When you originally
create the spool drawing, you have not yet had an opportunity to customize this UCS; thus this option is usually 
only useful for re-dimensioning.

In addition to the AutoCAD dimensions created based the above settings, ShipConstructor will also create AutoCAD text 
objects showing the length of straight segments of bent pipes.
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Straight segment text labels generated in addition to the normal dimensions (bent pipes only).

Create Arrangement Drawing Wizard Reference
The Create Arrangement Drawing wizard is a tool for generating arrangement drawings.
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The first page of the wizard is for entering a drawing name. The Next button will be disabled until a valid drawing name is 
entered. 

The second page of the wizard is where you select your arrangement template drawing.
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The third page of the wizard is where you select the various sources that you want to include in your arrangement drawing
and the layers of where to put them. You can select an arbitrary number of sources to include in your arrangement 
drawing. A summary of all selected sources and their layers appears on the right side of the screen under Selected 
Sources.

While choosing sources for your drawing, selecting a root node in the tree will also select anything underneath that node.
So if you want to create an arrangement drawing containing an entire system with all its branches, simply click on the 
system.

You may also choose to retain the layers of the part from its model drawing source at this step. Choosing Retain Model 
Drawing Layers from the dropdown in the layer column will cause the layers from all model drawings containing parts in 
the current source to be copied into the arrangement drawing and the parts will be moved to the copy of the layer of their 
source. This brings in all layers from the source, not just ones used by parts in the given source.  If multiple model 
drawings to bring layers in from have layers with the same name, the first one encountered will be taken and further 
layers of that name will be ignored.  
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The last page of the arrangement drawing creation wizard lets you choose which drawings non-ShipConstructor geometry 
will obtained from and the layers to put them on. The drawings presented in this tree are computed based on the sources 
you have selected during Step 3 of the arrangement drawing creation process.  The layer column behaves similar to that 
of the previous step.

Note: Any geometry imported using this mechanism has a special tag attached to it for the purpose of identifying it. 
When the drawing is updated, only the non-ShipConstructor entities brought into the drawing with this process are 
updated. Any custom geometry you manually add to the arrangement drawing will be unaffected during a drawing 
update.
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Modified Part Information Reference
The Modified Part Information window is used while updating existing production drawings. It helps you to inspect parts 
that will change during this update process.

The main table shows you a list of parts that are affected by updating this drawing. The parts are split into several 
categories. You can multi-select any of the parts in this list, and, depending on the View options, the parts will be 
highlighted, centered, and zoomed to.

Note: If you are in one of the Paper space layouts and you do not have a viewport selected, the largest viewport will be 
automatically chosen to highlight entities in. If you want to use a different viewport, simply activate it.

Reasons why parts are being updated

• New Parts – If an existing source (such as a system) has had parts added to it, the parts will show up here. Or, 
because you selected new sources in the drawing creation wizard.

• Removed Parts – These are parts that will be removed for any reason, including the source being removed entirely or 
the part being deleted out of the source.

• Modified Parts – Any parts that have had any of their attributes changed will show up here.

• User Deleted Parts – Parts that have been manually deleted out of the production drawing. Select the parts using the 
checkbox beside them to re-insert them. To re-insert multiple parts, select all the parts that are to be re-inserted. 
Click the checkbox for one of the selected parts, the checkboxes for all the selected parts will be checked. Deleted 
parts can be previewed using both the Show/Preview Checked Parts and the Refresh Preview controls.

View

The view options control what happens when you click on a part in the updating part list. 

• Center – Centers on all selected parts.

• Highlight – Highlights all selected parts.

• Zoom – Zooms to all selected parts.

Part Color overrides

To visually aid in identifying parts, all parts that are not affected by the update process are temporarily displayed in a light 
grey color. All affected parts have custom color overrides that control how the parts appear while the Modified Part 
Information window is visible.

• New – Set the color of the parts that have been newly added to this drawing.

• Modified – Set the color of the parts that are being updated because any of their attributes or their geometry has 
changed.

• Removed – Set the color of the parts that are being removed from this drawing
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• Deleted – Set the color of the parts that have been deleted by the user from this drawing. This corresponds to the list 
of User Deleted Parts from the modified parts table.

• Unchanged – Set the color of the parts that are unaffected by the update of the drawing

Show Removed Parts - If you do want to see parts that are being removed from this drawing. This is useful if you have 
removed an entire source and do need to know exactly what is being removed.

Show/Preview Checked Parts - If you do want to see parts that you deleted intentionally from this drawing. When 
enabled, all the parts with their checkboxes checked with appear in the drawing, using the User Deleted color. 
Unchecking will hide all checked parts.

Refresh Preview – If the list of checked parts has changed and you want to preview any parts added to that list.

Layer Conflict Resolution Reference

The Layer Conflict Resolution window is used when creating or updating arrangement or assembly drawings.  It allows 
you to easily move any parts that were given multiple layers to go to in source selection.

The window will appear when creating or updating production drawings where layers are defined with sources if there are 
any parts with multiple source layers defined. The list labeled Layer Conflicts shows all the sources that contain conflicted 
parts, and a status icon for each conflict.  You can select any of the conflict in this list, and, depending on the View
options, the conflicted parts from the selected conflict will be highlighted, centered, and zoomed to. The list labeled 
Layers shows the possible layers for the currently selected conflict on the Layer Conflicts list. The Use for all button will 
assign the checked layer in the Layers list to all conflicts where that layer is an option.

Status Icons
The X icon signifies that the conflict hasn’t been resolved.

The Check Mark icon signifies that it has been resolved.

The Exclamation Mark icon signifies that it is resolved but was changed by the Use for all button.
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Once all conflicts are resolved the OK button will be enabled and you can press it to move the conflicted parts to the 
selected layers.

Update Arrangement Drawing Wizard Reference
The Update Arrangement Drawing Wizard appears when an arrangement drawing is updated. It lets you add and remove 
sources for ShipConstructor parts as well as sources for non-ShipConstructor geometry. 

All sources that are currently used to populate this drawing are summarized under the Selected Sources heading. In 
addition, the sources are also pre-selected in the main source trees with the layer specified entered in the Layer column, 
and the appropriate nodes expanded for easy visual identification.

To add or remove sources from this arrangement drawing, use the check boxes in the source trees. You may add any 
number of sources to one drawing. The Layers column works the same here as it does for creation of an arrangement 
drawing, except that parts for each source that are already in the arrangement drawing will remain on their current layer.
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The second page of the wizard shows you all drawings that ShipConstructor entities will be obtained from to create the 
arrangement drawing. If you want to also bring in non-ShipConstructor geometry, such as lines and solids from those 
drawings, select them here. Any drawings that you have already obtained non-ShipConstructor entities from will be pre-
selected. The Layers column behaves similar to that of the previous step.

Note: While updating non-ShipConstructor entities, only entities that were brought into the drawing with this process 
will be affected. If you have custom annotations or any other geometry in the arrangement drawing, it will not be 
affected during updating.
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Label Styles
Labels are defined in Manager under General and in the Production Output fly-out.

Bubble Style 
The type of outline that will be around the text of the label. 

Bubble Size 
Determines the size of the bubble. Generally the bubble will be sized by text + bubble size.

Leader
Whether or not the label has a leader pointing to the object that is labeled.

Acad Dimension Style
The AutoCAD dimension style to use for various aspects of the label.

Text Height
The height of the text in the label. Uses the value in the text style if it is not 0, otherwise it uses the value in the 

dimension style

Arrow Size
The size of the arrow for the leader.

Shown above are the various types of bubble styles for labels. They’re shown with a bubble size of 8mm and a text size of 0.18 . The size 
of each bubble style is described below.

Circle Diameter = Text Height + Bubble Size
Square Length = Bubble Size
Triangle Height = Base Length = Bubble Size
Octagon Width = Height = Bubble Size
Rectangle Height = Text height + 2 * Bubble Size

Width = 2 * Text Width + Bubble Size
Bubble Height = Text Height + Bubble Size * 1.5 * Number of Lines

Width  = Text Height + Text Width + Bubble Size * 1.5 * Number of Lines
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BOM Revisions
When BOM tables are updated, they are rebuilt each time to reflect the current state of the drawing. This does not allow 
the user to see how the drawing changes affected the BOM tables. It also may renumber the items, causing existing 
labels to be incorrect.

BOM Revisions allow the user to save the current state of the Bills of Material in the drawing (or layout), so that when the 
BOM tables are updated, they will be able to compare the new BOM data with the old BOM data and display those 
changes to the user.

To prevent the original BOM tables appearance from changing, new items in the BOM are appended to the end of the 
table, and removed items have their text changed to use strikeout. Any changes to existing items are simply updated into 
their rows. This allows the items to maintain their original item numbering, preventing the user from having to relabel 
everything.

To use BOM revisions best, a Revision column should be added to the BOM definitions. This column will display one of 
three possible values:

- nothing, for when no revisions exist

- the current revision, such as “Rev.0”

- the “modified” state, which is the current revision prepended with “*”, such as “*Rev.0”. This state indicated 
that something in this row was modified during an update.

BOM Revisions can be defined for any paperspace layout in production drawings. Alternatively, the user can define a 
revision for the entire drawing (all layouts), instead of for just the current layout.

An example of how the BOM table evolves is shown:

This is a BOM table in a Pipe Arrangement drawing after creation. The user defines a revision called “A”. The empty 
Revision column is filled with this name.

Then they update the drawing. Some parts have been added, and others have been removed. The result looks like this:
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The changed parts have the “*A” identifier. The removed parts used strikeout text. New rows are appended to the end, 
continuing the item numbering, and not re-ordering it.

The commands to add and remove revisions are the same for Assembly, Arrangement, Spool, and Support Construction 
production drawings.

New Revision
Revisions can be created at any time: the user simply needs to provide a name, and an optional description. The new 
revision name must not be used in the layout (or drawing, if creating a revision for all layouts). The revision saves the 
current user and the date and time of creation.

If this is the first revision in the drawing, the empty Revision column for all BOM tables in the layout (or drawing) are 
changed to the revision name.  If it’s not the first revision, then all the rows with in the “*” identifier are changed to the 
new revision. This way, only items that have changed during the BOM updating are tagged as belonging to the new 
revision.

To create a revision

1. Choose SC Arrangement > BOM Revisions > New BOM Revision in Current Layout (page 285) or SC Arrangement > 
BOM Revisions > New BOM Revision in All Layouts (page 285)

2. Provide a name for the revision
Enter a name for the new revision:

3. Provide a description for the revision (this can be left blank)
Enter a description for the new revision <none>:

4. The revision is created in the specified layouts
Revision 'Rev.A' created in layout 'Master BOM'
Or
Revision 'Rev.A' created in 2 layouts

Delete Revision
When deleting revisions, only the current revision can be deleted.  Any BOM item with the current revision is changed to 
be the previous revision with the “*” identifier. If no previous revision exists, then the Revision column is left blank.

Using the “all layouts” command to delete revision requires that the current revision in all those layouts have the same 
name.

To delete a revision

1. Choose SC Arrangement > BOM Revisions > Delete BOM Revision in Current Layout (page 285) or SC Arrangement > 
BOM Revisions > Delete BOM Revision in All Layouts (page 285)

2. The current revision is deleted
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Revision 'Rev.A' deleted in layout 'Master BOM'
Or
Revision 'Rev.A' deleted in 2 layouts

Delete All Revisions
Instead of deleting each revision one by one, the user can simply delete all revisions. The BOM tables will not be restored 
to the original state, but will be left as they currently appear (except that all Revision columns are reset to a blank value)

To delete a revision

1. Choose SC Arrangement > BOM Revisions > Delete All BOM Revision in Current Layout (page 286) or SC 
Arrangement > BOM Revisions > Delete All BOM Revision in All Layouts (page 286)

2. All revisions are deleted
3 revisions deleted in layout 'Master BOM'
Or
3 revisions deleted in 2 layouts

List Revisions
Information about the revisions in the current layout can be printed to the command line. Revisions are listed with their 
name, description, user and date/time of creation.

To list revisions

1. Choose SC Arrangement > BOM Revisions > List BOM Revisions (page 286)

2. Choose R (or enter) to display the revisions
Select what to list [Revisions/Operations/All]<Revisions>:

3. Choose N (or enter) to avoid seeing a long list of parts changed per revision.
List parts? [No/Yes]<No>:

4. The revisions are then listed at the command line

Global Dimension to Point
Global Dimension to Points are used to indicate the distances from a given point to selected planes. The global 
dimension to points can be displayed either as dimensions or as labels.  The text displayed in the dimensions and labels 
can be customized to display the information in any format specified by the user. 
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The main grid will display all the available UCS’s in the project, or if Current Unit Only is selected it will display all 
available UCS’s in the current unit. Up to 3 different UCS’s can be selected one in each direction X, Y, Z.  If a UCS is 
selected that is in the same direction as an already selected UCS the previously selected UCS will be unchecked. The 
preview window will be updated with the newly selected UCS to indicate what will be displayed. The top yellow row can be 
used to filter through the grid to find the appropriate UCS.
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Global Dimension to Point
To create a global dimension to point, select the Dimension or Label button. This will change the preview to display the 
text that will be used for the global dimension. If creating a dimension, enter the dimension offset. This value is the 
length of the extension line for the dimension. Select a style to be used for the global dimension. The dimension and label 
styles are defined in Manager. Select the UCS’s to mark the dimensions to. If necessary edit the display text to display the 
appropriate keywords. Click OK. If a label is created, select a point for where to place the label text.

Editing the Text
The text displayed for the Global dimensions can be customized to display words or specific keywords.  
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The available keywords are:

• Distance – The distance in the current units between the selected point and the plane.

• Direction To – The direction from the point to the plane.

• Direction From – The direction from the plane to the point.

• +/- To – Positive if the plane point is greater than the picked point in the given direction, otherwise negative.

• +- From - Negative if the plane point is greater than the picked point in the given direction, otherwise positive.

• UCS Name – The name of the UCS being used.

To edit the text for a global dimension first select the global dimension type Dimension or Label. The preview window will 
update to display the appropriate text. Then click the edit button. The preview window will change to display the keywords 
and text used to generate the global dimensions and a box with the available keywords will appear on the side. To add a 
keyword to the text place the cursor where the keyword should be inserted and then double click on the keyword in the 
list. Regular text can also be placed anywhere in the text. To delete a keyword, highlight the keyword and press the 
backspace button. To finish editing press the edit button again. This will close the keyword list and the preview will 
change to display the appropriate text.

The default button will place a default text in the preview box; the default text is Distance DirectTo UCSName.
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To allow for multiple types of keywords to be used; the global dimension styles can be saved out. The style will save the 
global dimension type, the label or dimension style, and the keywords used. To save a style, click the Save Global 
Dimension Style button. Enter a name for the style in the dialog that is displayed and click OK. To load the style back, 
click the Load Global Dimension Style button. The list of stored styles will appear on the right side of the dialog. Double 
click on the appropriate style and the stored values will be loaded. To delete a saved style, click the Delete Global 
Dimension Style button. The list of available styles will be displayed, select the style to delete and click the Delete Global 
Dimension Style button. Click OK to confirm the deletion of the style.

To select the planes closest to the selected point click the Select Closest Planes button. The planes closest to the point 
will be selected and all other previously selected ones will be unselected.

The UCS’s called also be saved as datum planes. These datum planes are used to store a UCS in each direction so that 
they can be easily reloaded and used for other global dimensions. To store a UCS as a datum plane, check the plane in 
the grid to use as datum planes, right click on the grid and select Save as Datum Plane. To reload the datum planes click 
the Select Datum Planes button.

Cut Length Dimensions
A cut length dimension uses a text style to define its appearance in a spool drawing. 

The style that the cut length dimension uses is chosen by the dimension style used in the spool style for that drawing.

Elbow Radius Dimension
An elbow radius dimension’s appearance is defined by the label style used in the spool style for that drawing. The 
information displayed in the label can be selected in the spool styles. The label can be set to display any of the 3 parts 
angle, radius, and arc length. To not display the label, uncheck all 3 check boxes in the spool settings when creating or 
updating the spool drawing, or uncheck the boxes in Select Dimension Attributes dialog when re-dimensioning the spool.



Appendix E: Distributed Systems Production Reference

362

Flange Rotation Angles
If the end part of a spool is a flange which is connected to a valve outside of the spool, a rotation angle is calculated. If 
the end part is a flange but it is not connected to a valve, a rotation angle will be calculated if the dimension orientation 
used is not Ship Coordinate System. The rotation angle indicates the angle the flange needs to be rotated so that the bolt 
holes will be aligned when the spool is produced.
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Spool Drawings – Valves Icons
The valve icons are used to represent valves in 2D line mode for spool drawings. The valve icons are made up of 3 parts:
valve ends, body icons, and valve handles.

Valve Ends
The valve ends are drawn as triangles. The base of the triangle is drawn at the end of the valve with the tip pointing to the 
center of the valve.  The plane the triangles are drawn in will adjust based on the current view direction.  When the valve 
ends are drawn on end the ends will be drawn as a circle with an S in it. 

Body Icons
The body icons will draw a 2D representation of the selected body icon used for the valve. The body icons can either be an 
arrow, sphere, or cone.  The plane the body icons are drawn in will adjust based on the current view.

Valve Handles
The geometry used to draw the valve handles is defined by the user, see Create a Valve Handle 2D drawing (page 31). 
The 2D valve handles will be scaled to the same length as the valve handle.
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Spool Drawings – Penetrations
Penetrations will be displayed in the spool drawing if the show penetrations option is selected in the spool styles, see 
Spool Styles Reference (page 341). The penetrations will be marked using an X and placed on the Pens layer. If the 
penetration is a watertight penetration and contains component parts the component parts will be displayed in the spool 
drawing the BOM’s. 
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The penetration component parts will be included in the BOM’s if either the penetration collector is added to the BOM or 
if the pipe collector and/or the structure collector options are edited to include penetration component parts. 

The penetrations will be dimensioned from the penetration mark to the end of the pipe run to the end or to the break 
point selected in the spool styles. The baseline dimension height in the specified dimension style will be used to stack the 
overlapping dimension lines.
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