ShipConstructor 2008 R2.5 Update

ShipConstructor 2008 R2.5 Update
Posted: August 19, 2008

This update can only be applied to SC2008 R2 or later. This update uses database version

  • You must install ShipConstructor 2008 R2.5 before installing R2.5.1.
  • Your database must be updated using Administrator if you are updating from R2.4.3 or lower.
  • If you are updating from 2.1.7 or lower then this update must be applied to your license server.
  • ShipConstructor 2008 currently does NOT support AutoCAD 2009.
  • If you are updating from R2.3 or earlier, please read the following Knowledge Base article: