ShipConstructor2005 Hotfix 1.28.3

ShipConstructor2005 Hotfix 1.28.3
Posted: April 26, 2007

Update Details

  • Addresses a licensing issue.
  • This update allows ShipConstructor 2005 to work with the new SConLicenseServer developed as part of the ShipConstructor 2006 suite. It provides compatibility for running ShipConstructor 2006 concurrently with ShipConstructor 2005.
  • The 1.28 update must be applied to the 1.27.6 version of ShipConstructor 2005, so if you are not yet running this version you must first update to 1.27.6.

Issue Addressed
ShipConstructor 2005 versions 1.27.6 and older run the ARLLicenseServer service to host licenses, this service cannot be run concurrently with the SConLicenseServer service introduced by ShipConstructor 2006 R2 release.
To resolve this issue support has been added to ShipConstructor 2005 with update 1.28 that allows ShipConstructor 2005 to use the new SConLicenseServer service and which removes the ARLLicenseServer Service.

The ShipConstructor 2005 1.28 update can be applied to ShipConstructor 2005 installations, but it is recommended that it be installed only if the client is intending to run ShipConstructor 2005 and ShipConstructor 2006 R2 concurrently.

This update must be applied to ShipConstructor 2005 AFTER ShipConstructor 2006 R2 has been installed to prevent conflicts with the license server installation.

Recommended Update Steps

  1. Check your current version of ShipConstructor 2005
    *You can see the current version of SC2005 in the About dialog (menu ShipConstructor->About ShipConstructor, the Release Version indicates your current installed version)
  2. If you are not running version 1.27.6; Download and install the 1.27.6 update
  3. Install ShipConstructor 2006 R2 from the R2 installation CD
  4. Download and install the 1.28 update