SSI-Nexus-Hero2
ShipConstructor-Overview-Hero

更新

ShipConstructor 2008 R4.1.4 Update


ShipConstructor 2008 R4.1.4 Update
(139MB/exe)
Posted: June 9, 2009

Important! Please read the following carefully before running R4.1.4: ShipConstructor R4.1.4 allows users to solve a serious error with plate nests that contain remnants. For full instructions on how to use R4.1.4 to solve this problem, please read the following KnowledgeBase Article. This update also contains a fixed SQL update script from R3.1 to R4 allowing users who have not updated to R4 yet to avoid this problem when they update their databases.

This update can only be applied to ShipConstructor 2008 R3 or later. This update uses the same database version as R4.1.1 (1.4.3.4) and therefore you do not have to update your databases.

ShipConstructor 2008 R4.0.1 Full Install


ShipConstructor 2008 R4.0.1 Full Install
(343MB/zip)
Posted: February 20, 2009

Please contact SSI Support  for the download link. For more information, please see the R4 What's New document.

  • Important! ShipConstructor 2008 R4.0.1 requires 1200 level lock licenses. Do not download this release until you have contacted your local sales representative to update your locks.

ShipConstructor 2008 R4.0.1 Update


ShipConstructor 2008 R4.0.1 Update
(126MB/exe)
Posted: February 20, 2009

This update can only be applied to ShipConstructor 2008 R3 or later. This update uses a new database version (1.4.1.0) and therefore you will have to update your databases. R4.0.1 contains many new features and improvements which are described in the R4 What's New document.

ShipConstructor 2008 R3 Update


ShipConstructor 2008 R3 Update
 
(173MB/exe)
Posted: October 27, 2008

This update can be applied to any version of ShipConstructor 2008. This update uses database version 1.3.3.2. This major update for ShipConstructor 2008 includes numerous bug fixes and features. For more information, please see the R3 What's New document.

  • IMPORTANT: Updating a project from 2.x to R3 can sometimes take a very long time - depending on your data, it could take up to 24 hours. Your project will not be usable while it is updating, so it is recommended that you allow for 24 hours where the project cannot be used before starting the update.
  • Your database must be updated using Administrator if you are updating from R2.5.2 or lower.
  • If you are updating from R2.5.2 or lower then this update must be applied to your license server.
  • Due to significant changes to the ShipConstructor 2008 CUI, any AutoCAD profile customizations will be lost when R3 is first run. However, it is possible to migrate your pre-R3 profile over to R3 by following the steps in this KB article: How to migrate your old ShipConstructor AutoCAD Profile to R3
  • ShipConstructor 2008 currently does NOT support AutoCAD 2009.
  • ShipConstructor 2008 currently does NOT support Windows Vista.
  • Additional R3 related Knowledge Base articles:

If you are updating from R2.3 or earlier, please read the following Knowledge Base article:
http://www.shipconstructor.com/kb/questions.php?questionid=1739

ShipConstructor 2008 R3 Full Install


ShipConstructor 2008 R3 Full Install 
(217MB/zip)
Posted: October 29th, 2008

Please contact SSI Support  for the download link. This major update for ShipConstructor 2008 includes numerous bug fixes and features. For more information, please see the R3 What's New document.

  • ShipConstructor 2008 requires 1100 level lock licenses

ShipConstructor 2008 R2.5.2 Update


ShipConstructor 2008 R2.5.2 Update
(13MB/exe)
You must install ShipConstructor 2008 R2.5 before installing R2.5.2.

Posted: October 17, 2008

This update can only be applied to SC2008 R2.5 or later. This update uses database version 1.2.38.2.

ShipConstructor 2008 R2.5 Update


ShipConstructor 2008 R2.5 Update
(155MB/exe)
Posted: August 19, 2008

This update can only be applied to SC2008 R2 or later. This update uses database version 1.2.38.2.

  • You must install ShipConstructor 2008 R2.5 before installing R2.5.1.
  • Your database must be updated using Administrator if you are updating from R2.4.3 or lower.
  • If you are updating from 2.1.7 or lower then this update must be applied to your license server.
  • ShipConstructor 2008 currently does NOT support AutoCAD 2009.
  • If you are updating from R2.3 or earlier, please read the following Knowledge Base article:
    http://kb.shipconstructor.com/x/vgwF

ShipConstructor 2008 R2 Update


ShipConstructor 2008 R2 Update
(85MB/exe)
Posted: December 21, 2007

ShipConstructor 2008 R2 has arrived! This major update for ShipConstructor 2008 includes numerous bug fixes and features. For more information, please see the R2 What's New document.

  • This update uses database version 1.2.23.0. Your database must be updated using Administrator if you are updating from R1.3.4 or lower. Note: Updating your database to R2 may take 30 minutes or longer depending on the size of your project.

ShipConstructor 2008 R2 Full Install


ShipConstructor 2008 R2 Full Install
(193MB/zip)
Posted: January 7, 2008

Please contact SSI Support for the download link.

  • ShipConstructor 2008 requires 1100 level lock licenses

ShipConstructor2006 1.03.6 Update


ShipConstructor2006 1.03.6 Update
(35.3MB/exe)
Posted: July 3, 2007

Fixes an issue with approval drawings. Fixes an issue with endcuts on certain curves. Addresses some penetration issues. This update is compatible with ShipConstructor 2006 1.01 or later. It is a cumulative update that includes the functionality of all updates released since ShipConstructor 2006 1.01.

IMPORTANT: If you are still using ShipConstructor 2006, we strongly encourage you to upgrade to ShipConstructor 2008 as soon as possible. ShipConstructor 2008 is far superior to ShipConstructor 2006 and contains many significant new features and bug fixes. ShipConstructor 2006 is no longer being developed and we will not be releasing any more patches for it.

Upgrading to ShipConstructor 2008 is a very simple process and many customers have already upgraded with no problems. Projects can be updated to 2008 using Administrator and the process is as simple as updating a 2006 project from one database version to another. Please contact このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。 for 2008 download instructions or if you have any questions about ShipConstructor 2008.

ShipConstructor compatibility with AutoCAD 2006/2007

Please be aware that ShipConstructor 2005 and ShipConstructor 2006 are NOT compatible with AutoCAD 2007. If you are thinking of upgrading your AutoCAD version, please wait until the release of ShipConstructor 2008 this summer. This new version of our software will be compatible with both AutoCAD 2007 and AutoCAD 2008.

There may be a problem for ShipConstructor users wishing to purchase a new AutoCAD license. Fewer and fewer AutoCAD dealers are selling AutoCAD 2006, as AutoCAD 2007 is now their primary product.

For now, after discussion with Autodesk, we recommend the following procedure for purchasing AutoCAD 2006:

  1. purchase AutoCAD 2007 with the normal subscription
  2. submit a formal request to Autodesk to additionally receive AutoCAD 2006

This is a straightforward process within Autodesk, and because you have purchased a subscription you will be able to update to AutoCAD 2007 without hassle when ShipConstructor 2008 is released.

We apologize if this causes any inconvenience. ShipConstructor and Autodesk are working hard to better synchronize future software releases.

Updating ShipConstructor 2005 Projects to ShipConstructor 2006

Due to the greatly increased capabilities of ShipConstructor 2006 over its predecessor, updating existing projects from ShipConstructor 2005 is a complex undertaking. If you are interested in updating one of your projects to ShipConstructor 2006, please contact our Support team, who will be happy to make an assessment.

ShipConstructor 2005 v1.30


ShipConstructor2005 1.30 Full Install
(292MB/zip)
Posted: April 15, 2009

Please contact SSI Support for the download link.

  • Universal Licensing is now supported in SC2005 1.30. For more information on Universal Licensing, please contact your dealer.
  • This version is compatible with SC2008. It is recommended you use this full install when running SC2005 side-by-side with SC2008. It is recommended you read this KB article before installing.
  • If you are running alongside SC2008, it is recommended you use SC2008 R3 or later. If you wish to use an earlier version than R3, please contact your dealer for assistance.
  • This version uses the same database version as 1.27.6, 1.28.3 and 1.29.